FirebirdSql.Data.Firebird

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FirebirdSql.Data.Firebird Namespace

Namespace hierarchy

Classes

Class | Description
FbCommand | Represents an SQL statement or stored procedure to execute against a data source. This class cannot be inherited.
FbCommandBuilder | Automatically generates single-table commands used to reconcile changes made to a DataSet with the associated data source. This class cannot be inherited.
FbConnection | Represents an open connection to a Firebird database. This class cannot be inherited.
FbConnectionStringBuilder | Allows handling of the connection strings. See ConnectionString
FbDataAdapter | Represents a set of data commands and a connection to a data source that are used to fill the DataSet and update the data source. This class cannot be inherited.
FbDatabaseInfo | Reports requested information about a attached database. This class cannot be inherited.
FbDataReader | Provides a Way for reading a forward-only stream of rows. This class cannot be inherited.
FbError | Collects information relevant to a error returned by Firebird. This class cannot be inherited.
FbErrorCollection | Collects all errors generated by the Firebird .NET Data Provider. This class cannot be inherited.
FbException | The exception that is thrown when Firebird Server returns a warning or error. This class cannot be inherited.
FbInfoMessageEventArgs | Provides data for the InfoMessage event. This class cannot be inherited.
FbParameter | Represents a parameter of a FbCommand, and optionally, its mapping to DataSet columns. This class cannot be inherited.
FbParameterCollection | A collection of parameters associated to a FbCommand. This class cannot be inherited.
FbRemoteEvent | Represents a Firebird Event. This class cannot be inherited.
FbRemoteEventEventArgs | Provides data for the RemoteEventCounts event. This class cannot be inherited.
FbRowUpdatedEventArgs | Provides data for the RowUpdated event. This class cannot be inherited.
FbRowUpdatingEventArgs | Provides data for the RowUpdating event. This class cannot be inherited.
FbTransaction | Represents a Firebird transaction. This class cannot be inherited.

Delegates

Delegate | Description
FbInfoMessageEventHandler | Represents the method that will handle the InfoMessage event of an FbConnection.
FbRemoteEventEventHandler |
FbRowUpdatedEventHandler | Represents the method that will handle the RowUpdated event of an FbDataAdapter.
FbRowUpdatingEventHandler | Represents the method that will handle the RowUpdating event of an FbDataAdapter.

Enumerations

Enumeration | Description
FbCharset | Specifies the character set of FbParameter.
FbCommandBuilderBehavior | Provides a description of how FbCommandBuilder will do the generation of the WHERE clausule of UPDATE and DELETE commands
FbDbSchemaType | Obsolete. Retrieves the the type of schema table that can be used with the GetDbSchemaTable method.
FbDbType | Specifies the data type of a field, property, or FbParameter.
FbTransactionOptions | Specifies Firebird transactions specific options that can be used with BeginTransaction.

Copyright (C) 2002-2006 Carlos Guzman Alvarez


FbCharset Enumeration

Specifies the character set of FbParameter.

[Visual Basic]
<Serializable, _ Serializable>
Public Enum FbCharset
[C#]
[Serializable]
[Serializable]
public enum FbCharset

Members

Member Name | Description
Default | Use the connection character set.
None | No specific character set usage.
Octets |
Ascii | American Standard Code for Information Interchange.
UnicodeFss | Eight-bit Unicode Transformation Format.
ShiftJis0208 | Shift-JIS, Japanese.
EucJapanese0208 | JIS X 0201, 0208, 0212, EUC encoding, Japanese.
Iso2022Japanese | Windows Japanese.
Dos437 | MS-DOS United States, Australia, New Zealand, South Africa.
Dos850 | MS-DOS Latin-1.
Dos865 | MS-DOS Nordic.
Dos860 | MS-DOS Portuguese.
Dos863 | MS-DOS Canadian French.
Iso8859_1 | ISO 8859-1, Latin alphabet No. 1.
Iso8859_2 | ISO 8859-2, Latin alphabet No. 2.
Ksc5601 | Windows Korean.
Dos861 | MS-DOS Icelandic.
Windows1250 | Windows Eastern European.
Windows1251 | Windows Cyrillic.
Windows1252 | Windows Latin-1.
Windows1253 | Windows Greek.
Windows1254 | Windows Turkish.
Big5 | Big5, Traditional Chinese.
Gb2312 | GB2312, EUC encoding, Simplified Chinese.
Windows1255 | Windows Hebrew.
Windows1256 | Windows Arabic.
Windows1257 | Windows Baltic.

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird Namespace


FbCommand Class

Represents an SQL statement or stored procedure to execute against a data source. This class cannot be inherited.

For a list of all members of this type, see FbCommand Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
FirebirdSql.Data.Firebird.FbCommand

[Visual Basic]
<ToolboxBitmap, _ ToolboxItem(ToolboxItemType:=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName:="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"), _ Designer(DesignerBaseTypeName:="System.ComponentModel.Design.IDesigner, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", DesignerTypeName:="FirebirdSql.Data.Firebird.Design.FbCommandDesigner, FirebirdSql.Data.Firebird, Version=1.7.1.0, Culture=neutral, PublicKeyToken=fa843d180294369d"), _ DesignerCategory(Category:="Component")>
NotInheritable Public Class FbCommand
Inherits Component
Implements IDbCommand, ICloneable
[C#]
[ToolboxBitmap]
[ToolboxItem(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[Designer(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", DesignerTypeName="FirebirdSql.Data.Firebird.Design.FbCommandDesigner, FirebirdSql.Data.Firebird, Version=1.7.1.0, Culture=neutral, PublicKeyToken=fa843d180294369d")]
[DesignerCategory(Category="Component")]
public sealed class FbCommand : Component, IDbCommand, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

It's strongly recommend to call Dispose method for free the memory allocated by the Firebird Server, when the command is no more needed.

The FbCommand class provides the following methods for executing commands against a Firebird database:

Method | Description
ExecuteReader | Executes commands that return rows.
ExecuteNonQuery | Executes commands such as SQL INSERT, DELETE, UPDATE, and SET statements.
ExecuteScalar | Retrieves a single value (for example, an aggregate value) from a database.

Example

FbConnection connection = new FbConnection(myConnString);
FbTransaction transaction = connection.BeginTransaction()
FbCommand command = new FbCommand("SELECT * FROM employee", connection);

connection.Open();
FbDataReader reader = command.ExecuteReader();

try
{
    while (reader.Read())
    {
        Console.WriteLine(myReader.GetValue(0));
    }
}
finally
{
    // always call Close when done reading.
    reader.Close();
    // always call Close when done with connection.
    connection.Close();
}

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbCommand Members | FirebirdSql.Data.Firebird Namespace


FbCommand Members

FbCommand overview

Public Instance Constructors

FbCommand Overloaded. Initializes a new instance of the FbCommand class.

Public Instance Properties

CommandPlan | Gets the plan used by the server for the command.
CommandText | Gets or sets the SQL statement or stored procedure to execute.
CommandType | Gets or sets how the CommandText property is interpreted.
Connection | Gets or sets the FbConnection associated with the current command.
Container (inherited from Component) | Gets the IContainer that contains the Component.
DesignTimeVisible | Gets or sets whether the command object should be visible in a Windows Forms Designer control.
FetchSize |
Parameters | Gets the FbParameterCollection.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Transaction | Gets or sets the FbTransaction within which the FbCommand will be used.
UpdatedRowSource | Gets or sets how the Update method should apply command results to the DataRow.

Public Instance Methods

Cancel | Try to cancel command execution.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
CreateParameter | Creates a new instance of an FbParameter class.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExecuteNonQuery | Executes an the query and returns the number of rows affected.
ExecuteReader | Overloaded. Executes the query and builds an FbDataReader object.
ExecuteScalar | Executes the query, and returns the first column of the first row in the resultset returned by the query. Extra columns or rows are ignored.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Prepare | Creates a prepared (or compiled) version of the command.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


FbCommand Constructor

Creates a new instance of the FbCommand class.

Overload List

Creates a new instance of the FbCommand class.

public FbCommand();

Creates a new instance of the FbCommand class with the text of the query.

public FbCommand(string);

public FbCommand(string,FbConnection);

public FbCommand(string,FbConnection,FbTransaction);

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


FbCommand Constructor ()

Creates a new instance of the FbCommand class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FbCommand();

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace | FbCommand Constructor Overload List


FbCommand Constructor (String)

Creates a new instance of the FbCommand class with the text of the query.

[Visual Basic]
Overloads Public Sub New( _
ByVal cmdText As String _
)
[C#]
public FbCommand(
string cmdText
);

Parameters

cmdText
The text of the query.

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace | FbCommand Constructor Overload List


FbCommand Constructor (String, FbConnection)

[Visual Basic]
Overloads Public Sub New( _
ByVal cmdText As String, _
ByVal connection As FbConnection _
)
[C#]
public FbCommand(
string cmdText,
FbConnection connection
);

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace | FbCommand Constructor Overload List


FbCommand Constructor (String, FbConnection, FbTransaction)

[Visual Basic]
Overloads Public Sub New( _
ByVal cmdText As String, _
ByVal connection As FbConnection, _
ByVal transaction As FbTransaction _
)
[C#]
public FbCommand(
string cmdText,
FbConnection connection,
FbTransaction transaction
);

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace | FbCommand Constructor Overload List


FbCommand Properties

The properties of the FbCommand class are listed below. For a complete list of FbCommand class members, see the FbCommand Members topic.

Public Instance Properties

CommandPlan | Gets the plan used by the server for the command.
CommandText | Gets or sets the SQL statement or stored procedure to execute.
CommandType | Gets or sets how the CommandText property is interpreted.
Connection | Gets or sets the FbConnection associated with the current command.
Container (inherited from Component) | Gets the IContainer that contains the Component.
DesignTimeVisible | Gets or sets whether the command object should be visible in a Windows Forms Designer control.
FetchSize |
Parameters | Gets the FbParameterCollection.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Transaction | Gets or sets the FbTransaction within which the FbCommand will be used.
UpdatedRowSource | Gets or sets how the Update method should apply command results to the DataRow.

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


CommandPlan Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbCommand.CommandPlan Property

Gets the plan used by the server for the command.

[Visual Basic]
<Browsable(Browsable:=False)>
Public ReadOnly Property CommandPlan As String
[C#]
[Browsable(Browsable=False)]
public string CommandPlan {get;}

Property Value

The plan used for the Firebird server for the current command. The default is an empty string.

Remarks

It's needed that the command was prepared to retrieve the command plan. It will return null if the commplan cannot be determined.

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


CommandText Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbCommand.CommandText Property

Gets or sets the SQL statement or stored procedure to execute.

[Visual Basic]
<Editor(EditorBaseTypeName:="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName:="FirebirdSql.Data.Firebird.Design.FbCommandTextUIEditor, FirebirdSql.Data.Firebird, Version=1.7.1.0, Culture=neutral, PublicKeyToken=fa843d180294369d"), _ Category(Category:="Data"), _ DefaultValue, _ RefreshProperties(RefreshProperties:=RefreshProperties.All)>
NotOverridable Public Property CommandText As String _
Implements IDbCommand.CommandText
[C#]
[Editor(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="FirebirdSql.Data.Firebird.Design.FbCommandTextUIEditor, FirebirdSql.Data.Firebird, Version=1.7.1.0, Culture=neutral, PublicKeyToken=fa843d180294369d")]
[Category(Category="Data")]
[DefaultValue]
[RefreshProperties(RefreshProperties=RefreshProperties.All)]
public string CommandText {get; set;}

Property Value

The SQL statement or stored procedure to execute. The default value is an empty string ("").

Implements

IDbCommand.CommandText

Remarks

When the CommandType property is set to StoredProcedure, the CommandText property should be set to the name of the stored procedure. The user may be required to use escape character syntax if the stored procedure name contains any special characters. The command executes this stored procedure when you call one of the Execute methods.

The Firebird .NET Data Provider support the question mark (?) placeholder and named parameters for passing parameters to a SQL Statement or a stored procedure.

For example you can do:

SELECT * FROM Customers WHERE CustomerID = @CustomerID
or
SELECT * FROM Customers WHERE CustomerID = ?

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


CommandType Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbCommand.CommandType Property

Gets or sets how the CommandText property is interpreted.

[Visual Basic]
<Category(Category:="Data"), _
 RefreshProperties(RefreshProperties:=RefreshProperties.All), _
 DefaultValue(Value:=CommandType.Text)>
NotOverridable Public Property CommandType As CommandType _
Implements IDbCommand.CommandType
[C#]
[Category(Category="Data")]
[RefreshProperties(RefreshProperties=RefreshProperties.All)]
[DefaultValue(Value=CommandType.Text)]
public System.Data.CommandType CommandType {get; set;}

Property Value

One of the CommandType values. The default is Text.

Implements

IDbCommand.CommandType

Exceptions

Exception Type | Condition
ArgumentException | The value was not a valid CommandType.

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


Connection Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbCommand.Connection Property

Gets or sets the FbConnection associated with the current command.

[Visual Basic]
<Category(Category:="Behavior"), _ DefaultValue(Value:=null)>
Public Property Connection As FbConnection
[C#]
[Category(Category="Behavior")]
[DefaultValue(Value=null)]
public FbConnection Connection {get; set;}

Property Value

The connection to a data source. The default is a null value.

Remarks

You cannot set the Connection, CommandType, and CommandText properties if the current connection is performing an execute or fetch operation.

Exceptions

Exception Type | Condition
InvalidOperationException | The Connection property was changed while a transaction was in progress.

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


DesignTimeVisible Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbCommand.DesignTimeVisible Property

Gets or sets whether the command object should be visible in a Windows Forms Designer control.

[Visual Basic]
<DefaultValue(Value:=True), _ DesignOnly(IsDesignOnly:=True), _ Browsable(Browsable:=False)>
Public Property DesignTimeVisible As Boolean
[C#]
[DefaultValue(Value=True)]
[DesignOnly(IsDesignOnly=True)]
[Browsable(Browsable=False)]
public bool DesignTimeVisible {get; set;}

Property Value

Whether the command object should be visible in a control. The default is true.

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


FetchSize Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbCommand.FetchSize Property

[Visual Basic]
<DefaultValue(Value:=200), _ Category(Category:="Behavior")>
Public Property FetchSize As Integer
[C#]
[DefaultValue(Value=200)]
[Category(Category="Behavior")]
public int FetchSize {get; set;}

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


Parameters Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbCommand.Parameters Property

Gets the FbParameterCollection.

[Visual Basic]
<Category(Category:="Data"), _ DesignerSerializationVisibility(Visibility:=DesignerSerializationVisibility.Content)>
Public ReadOnly Property Parameters As FbParameterCollection
[C#]
[Category(Category="Data")]
[DesignerSerializationVisibility(Visibility=DesignerSerializationVisibility.Content)]
public FbParameterCollection Parameters {get;}

Property Value

The parameters of the DSQL statement or stored procedure. The default is an empty collection.

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


Transaction Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbCommand.Transaction Property

Gets or sets the FbTransaction within which the FbCommand will be used.

[Visual Basic]
<Browsable(Browsable:=False), _ DesignerSerializationVisibility(Visibility:=DesignerSerializationVisibility.Hidden)>
Public Property Transaction As FbTransaction
[C#]
[Browsable(Browsable=False)]
[DesignerSerializationVisibility(Visibility=DesignerSerializationVisibility.Hidden)]
public FbTransaction Transaction {get; set;}

Property Value

An FbTransaction object. The default is a null value.

Remarks

You cannot set the Transaction property if it is already set to a specific value, and the command is in the process of executing. If you set the transaction property to an FbTransaction object that is different of the FbConnection of the FbCommand object, an exception will be thrown the next time you attempt to execute or prepare the command.

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


UpdatedRowSource Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbCommand.UpdatedRowSource Property

Gets or sets how the Update method should apply command results to the DataRow.

[Visual Basic]
<Category(Category:="Behavior"), _ DefaultValue(Value:=UpdateRowSource.Both)>
NotOverridable Public Property UpdatedRowSource As UpdateRowSource _
Implements IDbCommand.UpdatedRowSource
[C#]
[Category(Category="Behavior")]
[DefaultValue(Value=UpdateRowSource.Both)]
public System.Data.UpdateRowSource UpdatedRowSource {get; set;}

Property Value

One of the System.Data.UpdateRowSource values.

Implements

IDbCommand.UpdatedRowSource

Remarks

The default UpdateRowSource value is Both unless the command is automatically generated, for example using the FbCommandBuilder), in which case the default will be None.

Exceptions

Exception Type | Condition
ArgumentException | The value entered was not one of the UpdateRowSource values.

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


FbCommand Methods

The methods of the FbCommand class are listed below. For a complete list of FbCommand class members, see the FbCommand Members topic.

Public Instance Methods

Cancel | Try to cancel command execution.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
CreateParameter | Creates a new instance of an FbParameter class.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExecuteNonQuery | Executes an the query and returns the number of rows affected.
ExecuteReader | Overloaded. Executes the query and builds an FbDataReader object.
ExecuteScalar | Executes the query, and returns the first column of the first row in the resultset returned by the query. Extra columns or rows are ignored.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Prepare | Creates a prepared (or compiled) version of the command.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


FbCommand.Cancel Method

Try to cancel command execution.

[Visual Basic]
NotOverridable Public Sub Cancel() _
Implements IDbCommand.Cancel
[C#]
public void Cancel();

Implements

IDbCommand.Cancel

Remarks

Not currently supported.

Exceptions

Exception Type | Condition
NotSupportedException | Always.

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


FbCommand.CreateParameter Method

Creates a new instance of an FbParameter class.

[Visual Basic]
Public Function CreateParameter() As FbParameter
[C#]
public FbParameter CreateParameter();

Return Value

An FbParameter object.

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


FbCommand.ExecuteNonQuery Method

Executes an the query and returns the number of rows affected.

[Visual Basic]
NotOverridable Public Function ExecuteNonQuery() As Integer _
Implements IDbCommand.ExecuteNonQuery
[C#]
public int ExecuteNonQuery();

Return Value

For UPDATE, INSERT, and DELETE statements, the return value is the number of rows affected by the command. For all other types of statements, the return value is -1.

Implements

IDbCommand.ExecuteNonQuery

Remarks

Although ExecuteNonQuery does not return any rows, any output parameters or return values mapped to parameters are populated with data.

IMPORTANT: To execute this method you need to have a FbTransaction associated to the command.

Exceptions

Exception Type | Condition
InvalidOperationException | The connection does not exist. -or- The connection is not open. -or- The transaction is not valid.

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


ExecuteReader Method

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbCommand.ExecuteReader Method

Executes the query and builds an FbDataReader object.

Overload List

Executes the query and builds an FbDataReader object.

public FbDataReader ExecuteReader();

Executes the query and builds an FbDataReader using one of the CommandBehavior values.

public FbDataReader ExecuteReader(CommandBehavior);

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


FbCommand.ExecuteReader Method ()

Executes the query and builds an FbDataReader object.

[Visual Basic]
Overloads Public Function ExecuteReader() As FbDataReader
[C#]
public FbDataReader ExecuteReader();

Return Value

An FbDataReader object.

Exceptions

Exception Type | Condition
InvalidOperationException | The connection does not exist. -or- The connection is not open. -or- The transaction is not valid.

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace | FbCommand.ExecuteReader Overload List


FbCommand.ExecuteReader Method (CommandBehavior)

Executes the query and builds an FbDataReader using one of the CommandBehavior values.

[Visual Basic]
Overloads Public Function ExecuteReader( _
ByVal behavior As CommandBehavior _
) As FbDataReader
[C#]
public FbDataReader ExecuteReader(
CommandBehavior behavior
);

Parameters

behavior
One of the CommandBehavior values.

Return Value

An FbDataReader object.

Exceptions

Exception Type | Condition
InvalidOperationException | The connection does not exist. -or- The connection is not open. -or- The transaction is not valid.

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace | FbCommand.ExecuteReader Overload List


FbCommand.ExecuteScalar Method

Executes the query, and returns the first column of the first row in the resultset returned by the query. Extra columns or rows are ignored.

[Visual Basic]
NotOverridable Public Function ExecuteScalar() As Object _
Implements IDbCommand.ExecuteScalar
[C#]
public object ExecuteScalar();

Return Value

The first column of the first row in the resultset.

Implements

IDbCommand.ExecuteScalar

Exceptions

Exception Type | Condition
InvalidOperationException | The connection does not exist. -or- The connection is not open. -or- The transaction is not valid.

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


FbCommand.Prepare Method

Creates a prepared (or compiled) version of the command.

[Visual Basic]
NotOverridable Public Sub Prepare() _
Implements IDbCommand.Prepare
[C#]
public void Prepare();

Implements

IDbCommand.Prepare

Remarks

Prepare is automatically called when the command is executed using ExecuteNonQuery, ExecuteReader, ExecuteReader or ExecuteScalar methods.

Exceptions

Exception Type | Condition
InvalidOperationException | The connection does not exist. -or- The connection is not open. -or- The transaction is not valid.

See Also

FbCommand Class | FirebirdSql.Data.Firebird Namespace


FbCommandBuilder Class

Automatically generates single-table commands used to reconcile changes made to a DataSet with the associated data source. This class cannot be inherited.

For a list of all members of this type, see FbCommandBuilder Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
FirebirdSql.Data.Firebird.FbCommandBuilder

[Visual Basic]
<DesignerCategory(Category:="Component")>
NotInheritable Public Class FbCommandBuilder
Inherits Component
[C#]
[DesignerCategory(Category="Component")]
public sealed class FbCommandBuilder : Component

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The FbDataAdapter does not automatically generate the SQL statements required to reconcile changes made to a DataSet associated with the data source. However, you can create an FbCommandBuilder object that generates SQL statements for single-table updates by setting the SelectCommand property of the FbDataAdapter. Then, the FbCommandBuilder generates any additional SQL statements that you do not set.

To generate INSERT, UPDATE, or DELETE statements, the FbCommandBuilder uses the SelectCommand property to retrieve a required set of metadata. If you change the value of SelectCommand after the metadata has been retrieved (for example, after the first update), you then should call the RefreshSchema method to update the metadata.

Example

public DataSet SelectRows(DataSet myDataSet,string myConnection,string mySelectQuery,string myTableName)
{
    FbConnection  myConn     = new FbConnection(myConnection);
    FbDataAdapter myDataAdapter = new FbDataAdapter();
    FbTransaction myTxn         = myConn.BeginTransaction();

    myDataAdapter.SelectCommand = new FbCommand(mySelectQuery, myConn, myTxn);
    FbCommandBuilder custCB     = new FbCommandBuilder(myDataAdapter);

    myConn.Open();

    DataSet custDS = new DataSet();
    myDataAdapter.Fill(custDS, "Employee");

    //code to modify data in dataset here

    //Without the FbCommandBuilder this line would fail
    myDataAdapter.Update(custDS, "Employee");

    myConn.Close();

    return custDS;
 }

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbCommandBuilder Members | FirebirdSql.Data.Firebird Namespace


FbCommandBuilder Members

FbCommandBuilder overview

Public Static (Shared) Methods

DeriveParameters

Public Instance Constructors

FbCommandBuilder Overloaded. Initializes a new instance of the FbCommandBuilder class.

Public Instance Properties

CommandBuilderBehavior | One of the FbCommandBuilderBehavior values.
Container (inherited from Component) | Gets the IContainer that contains the Component.
DataAdapter | Gets or sets an FbDataAdapter object for which this FbCommandBuilder object will generate SQL statements.
QuotePrefix | Gets or sets the beginning character or characters to use when working with database objects (for example, tables or columns) whose names contain characters such as spaces or reserved tokens.
QuoteSuffix | Gets or sets the ending character or characters to use when working with database objects, (for example, tables or columns), whose names contain characters such as spaces or reserved tokens.
Site (inherited from Component) | Gets or sets the ISite of the Component.
TimestampColumnName |

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDeleteCommand | Gets the automatically generated FbCommand object required to perform deletions at the data source.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInsertCommand | Gets the automatically generated FbCommand object required to perform insertions at the data source.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUpdateCommand | Gets the automatically generated FbCommand object required to perform updates at the data source.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
RefreshSchema | Refreshes the database schema information used to generate INSERT, UPDATE, or DELETE statements.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

FbCommandBuilder Class | FirebirdSql.Data.Firebird Namespace


FbCommandBuilder Constructor

Creates a new instance of the FbCommandBuilder class.

Overload List

Creates a new instance of the FbCommandBuilder class.

public FbCommandBuilder();

public FbCommandBuilder(FbDataAdapter);

See Also

FbCommandBuilder Class | FirebirdSql.Data.Firebird Namespace


FbCommandBuilder Constructor ()

Creates a new instance of the FbCommandBuilder class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FbCommandBuilder();

See Also

FbCommandBuilder Class | FirebirdSql.Data.Firebird Namespace | FbCommandBuilder Constructor Overload List


FbCommandBuilder Constructor (FbDataAdapter)

[Visual Basic]
Overloads Public Sub New( _
ByVal adapter As FbDataAdapter _
)
[C#]
public FbCommandBuilder(
FbDataAdapter adapter
);

See Also

FbCommandBuilder Class | FirebirdSql.Data.Firebird Namespace | FbCommandBuilder Constructor Overload List


FbCommandBuilder Properties

The properties of the FbCommandBuilder class are listed below. For a complete list of FbCommandBuilder class members, see the FbCommandBuilder Members topic.

Public Instance Properties

CommandBuilderBehavior | One of the FbCommandBuilderBehavior values.
Container (inherited from Component) | Gets the IContainer that contains the Component.
DataAdapter | Gets or sets an FbDataAdapter object for which this FbCommandBuilder object will generate SQL statements.
QuotePrefix | Gets or sets the beginning character or characters to use when working with database objects (for example, tables or columns) whose names contain characters such as spaces or reserved tokens.
QuoteSuffix | Gets or sets the ending character or characters to use when working with database objects, (for example, tables or columns), whose names contain characters such as spaces or reserved tokens.
Site (inherited from Component) | Gets or sets the ISite of the Component.
TimestampColumnName |

See Also

FbCommandBuilder Class | FirebirdSql.Data.Firebird Namespace


CommandBuilderBehavior Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbCommandBuilder.CommandBuilderBehavior Property

One of the FbCommandBuilderBehavior values.

[Visual Basic]
<DefaultValue(Value:=FbCommandBuilderBehavior.Default)>
Public Property CommandBuilderBehavior As FbCommandBuilderBehavior
[C#]
[DefaultValue(Value=FbCommandBuilderBehavior.Default)]
public FbCommandBuilderBehavior CommandBuilderBehavior {get; set;}

See Also

FbCommandBuilder Class | FirebirdSql.Data.Firebird Namespace


DataAdapter Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbCommandBuilder.DataAdapter Property

Gets or sets an FbDataAdapter object for which this FbCommandBuilder object will generate SQL statements.

[Visual Basic]
<DefaultValue(Value:=null)>
Public Property DataAdapter As FbDataAdapter
[C#]
[DefaultValue(Value=null)]
public FbDataAdapter DataAdapter {get; set;}

Remarks

The FbCommandBuilder registers itself as a listener for RowUpdating events that are generated by the FbDataAdapter specified in this property.

See Also

FbCommandBuilder Class | FirebirdSql.Data.Firebird Namespace


QuotePrefix Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbCommandBuilder.QuotePrefix Property

Gets or sets the beginning character or characters to use when working with database objects (for example, tables or columns) whose names contain characters such as spaces or reserved tokens.

[Visual Basic]
Public Property QuotePrefix As String
[C#]
public string QuotePrefix {get; set;}

Remarks

Some data sources may contain objects whose names include characters such as spaces, commas, and semicolons. To accommodate this, use the QuotePrefix and QuoteSuffix properties to specify delimiters, such as a left and right bracket, that will encapsulate the object name.

Note:

Although you cannot change the QuotePrefix or QuoteSuffix properties after an insert, update, or delete command has been generated, you can change their settings after calling the Update method of an FbDataAdapter.

Exceptions

Exception Type | Condition
InvalidOperationException | This property cannot be changed after an insert, update, or delete command has been generated.

See Also

FbCommandBuilder Class | FirebirdSql.Data.Firebird Namespace


QuoteSuffix Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbCommandBuilder.QuoteSuffix Property

Gets or sets the ending character or characters to use when working with database objects, (for example, tables or columns), whose names contain characters such as spaces or reserved tokens.

[Visual Basic]
Public Property QuoteSuffix As String
[C#]
public string QuoteSuffix {get; set;}

Remarks

Some data sources may contain objects whose names include characters such as spaces, commas, and semicolons. To accommodate this, use the QuotePrefix and QuoteSuffix properties to specify delimiters, such as a left and right bracket, that will encapsulate the object name.

Note:

Although you cannot change the QuotePrefix or QuoteSuffix properties after an insert, update, or delete command has been generated, you can change their settings after calling the Update method of an FbDataAdapter.

Exceptions

Exception Type | Condition
InvalidOperationException | This property cannot be changed after an insert, update, or delete command has been generated.

See Also

FbCommandBuilder Class | FirebirdSql.Data.Firebird Namespace


TimestampColumnName Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbCommandBuilder.TimestampColumnName Property

[Visual Basic]
<DefaultValue>
Public Property TimestampColumnName As String
[C#]
[DefaultValue]
public string TimestampColumnName {get; set;}

See Also

FbCommandBuilder Class | FirebirdSql.Data.Firebird Namespace


FbCommandBuilder Methods

The methods of the FbCommandBuilder class are listed below. For a complete list of FbCommandBuilder class members, see the FbCommandBuilder Members topic.

Public Static (Shared) Methods

DeriveParameters

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDeleteCommand | Gets the automatically generated FbCommand object required to perform deletions at the data source.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInsertCommand | Gets the automatically generated FbCommand object required to perform insertions at the data source.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUpdateCommand | Gets the automatically generated FbCommand object required to perform updates at the data source.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
RefreshSchema | Refreshes the database schema information used to generate INSERT, UPDATE, or DELETE statements.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

See Also

FbCommandBuilder Class | FirebirdSql.Data.Firebird Namespace


FbCommandBuilder.DeriveParameters Method

[Visual Basic]
Public Shared Sub DeriveParameters( _
ByVal command As FbCommand _
)
[C#]
public static void DeriveParameters(
FbCommand command
);

See Also

FbCommandBuilder Class | FirebirdSql.Data.Firebird Namespace


FbCommandBuilder.GetDeleteCommand Method

Gets the automatically generated FbCommand object required to perform deletions at the data source.

[Visual Basic]
Public Function GetDeleteCommand() As FbCommand
[C#]
public FbCommand GetDeleteCommand();

Return Value

The automatically generated FbCommand object required to perform deletions.

Remarks

You can use the GetDeleteCommand method for informational or troubleshooting purposes because it returns the FbCommand object to be executed.

You can also use GetDeleteCommand as the basis of a modified command.

After the SQL statement is first generated, you must explicitly call RefreshSchema if it changes the statement in any way. Otherwise, the GetDeleteCommand still will be using information from the previous statement, which might not be correct. The SQL statements are first generated when the application calls either Update or GetDeleteCommand.

See Also

FbCommandBuilder Class | FirebirdSql.Data.Firebird Namespace


FbCommandBuilder.GetInsertCommand Method

Gets the automatically generated FbCommand object required to perform insertions at the data source.

[Visual Basic]
Public Function GetInsertCommand() As FbCommand
[C#]
public FbCommand GetInsertCommand();

Return Value

The automatically generated FbCommand object required to perform insertions.

Remarks

You can use the GetInsertCommand method for informational or troubleshooting purposes because it returns the FbCommand object to be executed. You can also use GetInsertCommand as the basis of a modified command.

After the SQL statement is first generated, you must explicitly call RefreshSchema if it changes the statement in any way. Otherwise, the GetInsertCommand still will be using information from the previous statement, which might not be correct. The SQL statements are first generated when the application calls either Update or GetInsertCommand.

See Also

FbCommandBuilder Class | FirebirdSql.Data.Firebird Namespace


FbCommandBuilder.GetUpdateCommand Method

Gets the automatically generated FbCommand object required to perform updates at the data source.

[Visual Basic]
Public Function GetUpdateCommand() As FbCommand
[C#]
public FbCommand GetUpdateCommand();

Return Value

The automatically generated FbCommand object required to perform updates.

Remarks

You can use the GetUpdateCommand method for informational or troubleshooting purposes because it returns the FbCommand object to be executed. You can also use GetUpdateCommand as the basis of a modified command.

After the SQL statement is first generated, you must explicitly call RefreshSchema if it changes the statement in any way. Otherwise, the GetUpdateCommand still will be using information from the previous statement, which might not be correct. The SQL statements are first generated when the application calls either Update or GetUpdateCommand.

See Also

FbCommandBuilder Class | FirebirdSql.Data.Firebird Namespace


FbCommandBuilder.RefreshSchema Method

Refreshes the database schema information used to generate INSERT, UPDATE, or DELETE statements.

[Visual Basic]
Public Sub RefreshSchema()
[C#]
public void RefreshSchema();

Remarks

You should call RefreshSchema whenever the SelectCommand value of the FbDataAdapter changes.

See Also

FbCommandBuilder Class | FirebirdSql.Data.Firebird Namespace


FbCommandBuilderBehavior Enumeration

Provides a description of how FbCommandBuilder will do the generation of the WHERE clausule of UPDATE and DELETE commands

[Visual Basic]
<Serializable, _ Serializable>
Public Enum FbCommandBuilderBehavior
[C#]
[Serializable]
[Serializable]
public enum FbCommandBuilderBehavior

Members

Member Name | Description
Default | AllFields
AllFields | The FbCommandBuilder class will do the generation of the WHERE clausule of UPDATE and DELETE commands using all fields.
KeyFields | The FbCommandBuilder class will do the generation of the WHERE clausule of UPDATE and DELETE commands using only the key fields.
KeyAndTimestampFields | The FbCommandBuilder class will do the generation of the WHERE clausule of UPDATE and DELETE commands using only the key fields and the timestamp column specified in TimestampColumnName.

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird Namespace


FbConnection Class

Represents an open connection to a Firebird database. This class cannot be inherited.

For a list of all members of this type, see FbConnection Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
FirebirdSql.Data.Firebird.FbConnection

[Visual Basic]
<ToolboxBitmap, _
 DefaultEvent(Name:="InfoMessage"), _
 ToolboxItem(ToolboxItemType:=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName:="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"), _
 DesignerCategory(Category:="Component")>
NotInheritable Public Class FbConnection
Inherits Component
Implements IDbConnection, ICloneable
[C#]
[ToolboxBitmap]
[DefaultEvent(Name="InfoMessage")]
[ToolboxItem(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignerCategory(Category="Component")]
public sealed class FbConnection : Component, IDbConnection, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

A FbConnection object represents a individual connection to Firebird server.

If a FbConnection object goes out of scope, it is not closed, you must explicitly close the the connection by calling Close or Dispose.

Example

public void InsertRow(string connectionString)
{
    //    If the connection string is null, use a default.
    if(connectionString == "")
    {
        FbConnectionStringBuilder cs = new FbConnectionStringBuilder();

        cs.DataSource = "localhost";
        cs.Database = "C:\\PROGRAM FILES\\FIREBIRD\\EXAMPLES\\EMPLOYEE.FDB";
        cs.UserID = "SYSDBA";
        cs.Password = "masterkey";
        cs.Dialect = 3;

        connectionString = cs.ToString();
    }

    FbConnection connection = new FbConnection(connectionString);
    connection.Open();
    FbTransaction transaction = connection.BeginTransaction();

    string insertQuery = "INSERT INTO PROJECT(proj_id, proj_name, product) Values('FBNP', '.NET Provider', 'N/A')";
    FbCommand command = new FbCommand(insertQuery, myConn, myTxn);

    command.ExecuteNonQuery();

    transaction.Commit();

    connection.Close();
}

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbConnection Members | FirebirdSql.Data.Firebird Namespace


FbConnection Members

FbConnection overview

Public Static (Shared) Properties

ConnectionPoolsCount Gets the number of active connection pools.

Public Static (Shared) Methods

ClearAllPools | Clears all active connection pools, closing all active connections.
ClearPool | Clear the connection pool that owns the specified connection, closing all active connections.
CreateDatabase | Overloaded. Creates a new database using the given connection string information.
DropDatabase | Overloaded. Drops a existent database using the given connection string information.
GetPooledConnectionCount | Gets the number of active connections in the connection pool that owns the spcified connection.

Public Instance Constructors

FbConnection Overloaded. Initializes a new instance of the FbConnection class.

Public Instance Properties

ConnectionString | Gets or sets the string used to open a connection to a Firebird database.
ConnectionTimeout | Gets the time to wait while trying to establish a connection before terminating the attempt and generating an error.
Container (inherited from Component) | Gets the IContainer that contains the Component.
Database | Gets the name of the actual database or the database to be used when a connection is open.
DataSource | Gets the name of the Firebird Server to which to connect.
PacketSize | Gets the size (in bytes) of network packets used to communicate with an instance of Firebird Server.
ServerVersion | Gets a string containing the version of the Firebird Server to which the client is connected.
Site (inherited from Component) | Gets or sets the ISite of the Component.
State | Gets the current state of the connection.

Public Instance Methods

BeginTransaction | Overloaded. Begins a new transaction with the default isolation level IsolationLevel.ReadCommitted.
ChangeDatabase |
Close | Closes the connection to the database. This is the preferred method of closing any open connection.
CreateCommand | Creates and returns a new FbCommand object associated with the current FbConnection object.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDbSchemaTable | Obsolete.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetSchema | Overloaded. Returns information about the MetaDataCollections schema.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Open | Opens a new connection to a database with the property settings specified by the ConnectionString.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

Public Instance Events

Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
InfoMessage | Occurs when the Firebird Server sends a warning message.
StateChange | Occurs when the state of the connection changes.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


FbConnection Constructor

Creates a new instance of the FbConnection class.

Overload List

Creates a new instance of the FbConnection class.

public FbConnection();

Creates a new instance of the FbConnection class with the specified connection string.

public FbConnection(string);

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


FbConnection Constructor ()

Creates a new instance of the FbConnection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FbConnection();

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace | FbConnection Constructor Overload List


FbConnection Constructor (String)

Creates a new instance of the FbConnection class with the specified connection string.

[Visual Basic]
Overloads Public Sub New( _
ByVal connectionString As String _
)
[C#]
public FbConnection(
string connectionString
);

Parameters

connectionString
Connection string.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace | FbConnection Constructor Overload List


FbConnection Properties

The properties of the FbConnection class are listed below. For a complete list of FbConnection class members, see the FbConnection Members topic.

Public Static (Shared) Properties

ConnectionPoolsCount Gets the number of active connection pools.

Public Instance Properties

ConnectionString | Gets or sets the string used to open a connection to a Firebird database.
ConnectionTimeout | Gets the time to wait while trying to establish a connection before terminating the attempt and generating an error.
Container (inherited from Component) | Gets the IContainer that contains the Component.
Database | Gets the name of the actual database or the database to be used when a connection is open.
DataSource | Gets the name of the Firebird Server to which to connect.
PacketSize | Gets the size (in bytes) of network packets used to communicate with an instance of Firebird Server.
ServerVersion | Gets a string containing the version of the Firebird Server to which the client is connected.
Site (inherited from Component) | Gets or sets the ISite of the Component.
State | Gets the current state of the connection.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


ConnectionPoolsCount Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnection.ConnectionPoolsCount Property

Gets the number of active connection pools.

[Visual Basic]
Public Shared ReadOnly Property ConnectionPoolsCount As Integer
[C#]
public static int ConnectionPoolsCount {get;}

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


ConnectionString Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnection.ConnectionString Property

Gets or sets the string used to open a connection to a Firebird database.

[Visual Basic]
<RecommendedAsConfigurable(RecommendedAsConfigurable:=True), _ Category(Category:="Data"), _ Editor(EditorBaseTypeName:="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName:="FirebirdSql.Data.Firebird.Design.FbConnectionStringUIEditor, FirebirdSql.Data.Firebird, Version=1.7.1.0, Culture=neutral, PublicKeyToken=fa843d180294369d"), _ RefreshProperties(RefreshProperties:=RefreshProperties.All), _ DefaultValue>
NotOverridable Public Property ConnectionString As String _
Implements IDbConnection.ConnectionString
[C#]
[RecommendedAsConfigurable(RecommendedAsConfigurable=True)]
[Category(Category="Data")]
[Editor(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="FirebirdSql.Data.Firebird.Design.FbConnectionStringUIEditor, FirebirdSql.Data.Firebird, Version=1.7.1.0, Culture=neutral, PublicKeyToken=fa843d180294369d")]
[RefreshProperties(RefreshProperties=RefreshProperties.All)]
[DefaultValue]
public string ConnectionString {get; set;}

Property Value

The connection string that includes the source database path and name, and other parameters needed to establish the initial connection. The default value is an empty string.

Implements

IDbConnection.ConnectionString

Remarks

The following table lists the valid names for keyword values for ConnectionString property.

Name | Description | Default
Database | Database path to establish the connection. |
User | Firebird User account for login. |
Password | Password for the Firebird user account. |
Dialect | Database dialect. | 3
Server or Data Source. | Server name for establish the connection. |
Port | Port number in the server for establish the connection. | 3050
Charset | Database Character Set. | NONE
Role | User Role. |
Packet Size | Size (in bytes) of network packets used to communicate with an instance of Firebird Server. | 8192
Connection Lifetime | When a connection is returned to the pool, its creation time is compared with the current time, and the connection is destroyed if that time span (in seconds) exceeds the value specified by connection lifetime. | 0
MinPoolSize | The minimun number of connections allowed in the pool. | 0
MaxPoolSize | The maximun number of connections allowed in the pool. | 100
Pooling | When true, the FbConnection object is drawn from the appropriate pool, or if necessary, is created and added to the appropriate pool. Recognized values are true, false, yes, and no. | true
Fetch Size | Indicates the number of rows that will be fetched at the same time on Read calls into the internal row buffer.
ServerType | When 0 the provider will use the GDS implementation used for connections to Firebird Super or Classic servers, when 1 the provider will use the GDS implementation used for connections to the Firebird embedded server. | 0

The following table lists the valid names for the Charset keyword of the ConnectionString:

Firebird Charset | Description
ASCII | American Standard Code for Information Interchange.
BIG_5 | Big5, Traditional Chinese.
DOS437 | MS-DOS United States, Australia, New Zealand, South Africa.
DOS850 | MS-DOS Latin-1.
DOS860 | MS-DOS Portugues.
DOS861 | MS-DOS Icelandic.
DOS863 | MS-DOS Canadian French.
DOS865 | MS-DOS Nordic.
EUCJ_0208 | JIS X 0201, 0208, 0212, EUC encoding, Japanese.
GB_2312 | GB2312, EUC encoding, Simplified Chinese.
ISO8859_1 | ISO 8859-1, Latin alphabet No. 1.
ISO8859_2 | ISO 8859-2, Latin alphabet No. 2.
KSC_5601 | Windows Korean.
ISO2022-JP | Windows Japanese.
SJIS_0208 | Japanese (Shift-JIS)
UNICODE_FSS | Eight-bit Unicode Transformation Format.
WIN1250 | Windows Eastern European.
WIN1251 | Windows Cyrillic.
WIN1252 | Windows Latin-1.
WIN1253 | Windows Greek.
WIN1254 | Windows Turkish.
WIN1254 | Windows Hebrew.
Arabic | Windows Turkish.
WIN1257 | Windows Baltic.

Exceptions

Exception Type | Condition
ArgumentException | An invalid connection string argument has been supplied or a required connection string argument has not been supplied.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


ConnectionTimeout Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnection.ConnectionTimeout Property

Gets the time to wait while trying to establish a connection before terminating the attempt and generating an error.

[Visual Basic]
<DesignerSerializationVisibility(Visibility:=DesignerSerializationVisibility.Hidden)>
NotOverridable Public ReadOnly Property ConnectionTimeout As Integer _
Implements IDbConnection.ConnectionTimeout
[C#]
[DesignerSerializationVisibility(Visibility=DesignerSerializationVisibility.Hidden)]
public int ConnectionTimeout {get;}

Property Value

The time (in seconds) to wait for a connection to open. The default value is 0 seconds.

Implements

IDbConnection.ConnectionTimeout

Remarks

A value of 0 indicates no limit.

Not currently supported.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


Database Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnection.Database Property

Gets the name of the actual database or the database to be used when a connection is open.

[Visual Basic]
<DesignerSerializationVisibility(Visibility:=DesignerSerializationVisibility.Hidden)>
NotOverridable Public ReadOnly Property Database As String _
Implements IDbConnection.Database
[C#]
[DesignerSerializationVisibility(Visibility=DesignerSerializationVisibility.Hidden)]
public string Database {get;}

Property Value

The name of the actual database or the database to be used when a connection is open. The default value is an empty string.

Implements

IDbConnection.Database

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


DataSource Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnection.DataSource Property

Gets the name of the Firebird Server to which to connect.

[Visual Basic]
<DesignerSerializationVisibility(Visibility:=DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property DataSource As String
[C#]
[DesignerSerializationVisibility(Visibility=DesignerSerializationVisibility.Hidden)]
public string DataSource {get;}

Property Value

The name of the Firebird Server to which to connect. The default value is an empty string.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


PacketSize Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnection.PacketSize Property

Gets the size (in bytes) of network packets used to communicate with an instance of Firebird Server.

[Visual Basic]
<DesignerSerializationVisibility(Visibility:=DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property PacketSize As Integer
[C#]
[DesignerSerializationVisibility(Visibility=DesignerSerializationVisibility.Hidden)]
public int PacketSize {get;}

Property Value

The size (in bytes) of network packets. The default value is 8192.

Remarks

PacketSize may be in the rane 512-32767 bytes. An exception is generated if the value is outside of this range.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


ServerVersion Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnection.ServerVersion Property

Gets a string containing the version of the Firebird Server to which the client is connected.

[Visual Basic]
<DesignerSerializationVisibility(Visibility:=DesignerSerializationVisibility.Hidden), _ Browsable(Browsable:=False)>
Public ReadOnly Property ServerVersion As String
[C#]
[DesignerSerializationVisibility(Visibility=DesignerSerializationVisibility.Hidden)]
[Browsable(Browsable=False)]
public string ServerVersion {get;}

Property Value

The version of the Firebird Server to which the client is connected.

Exceptions

Exception Type | Condition
InvalidOperationException | The connection is closed.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


State Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnection.State Property

Gets the current state of the connection.

[Visual Basic]
<Browsable(Browsable:=False), _ DesignerSerializationVisibility(Visibility:=DesignerSerializationVisibility.Hidden)>
NotOverridable Public ReadOnly Property State As ConnectionState _
Implements IDbConnection.State
[C#]
[Browsable(Browsable=False)]
[DesignerSerializationVisibility(Visibility=DesignerSerializationVisibility.Hidden)]
public System.Data.ConnectionState State {get;}

Property Value

One of the System.Data.ConnectionState values. The default is Closed.

Implements

IDbConnection.State

Remarks

The allowed state changes are:

  • From Closed to Open, using the Open method.
  • From Open to Closed, using the Close method or the Dispose method.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


FbConnection Methods

The methods of the FbConnection class are listed below. For a complete list of FbConnection class members, see the FbConnection Members topic.

Public Static (Shared) Methods

ClearAllPools | Clears all active connection pools, closing all active connections.
ClearPool | Clear the connection pool that owns the specified connection, closing all active connections.
CreateDatabase | Overloaded. Creates a new database using the given connection string information.
DropDatabase | Overloaded. Drops a existent database using the given connection string information.
GetPooledConnectionCount | Gets the number of active connections in the connection pool that owns the spcified connection.

Public Instance Methods

BeginTransaction | Overloaded. Begins a new transaction with the default isolation level IsolationLevel.ReadCommitted.
ChangeDatabase |
Close | Closes the connection to the database. This is the preferred method of closing any open connection.
CreateCommand | Creates and returns a new FbCommand object associated with the current FbConnection object.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDbSchemaTable | Obsolete.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetSchema | Overloaded. Returns information about the MetaDataCollections schema.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Open | Opens a new connection to a database with the property settings specified by the ConnectionString.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


BeginTransaction Method

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnection.BeginTransaction Method

Begins a new transaction with the default isolation level IsolationLevel.ReadCommitted.

Overload List

Begins a new transaction with the default isolation level IsolationLevel.ReadCommitted.

public FbTransaction BeginTransaction();

Begins a new transaction using the specified options.

public FbTransaction BeginTransaction(FbTransactionOptions);

Begins a new transaction using the specified options and transaction name.

public FbTransaction BeginTransaction(FbTransactionOptions,string);

Begins a new transaction with the specified isolation level.

public FbTransaction BeginTransaction(IsolationLevel);

Begins a new transaction with the specified isolation level and transaction name.

public FbTransaction BeginTransaction(IsolationLevel,string);

Begins a new transaction with the specified name.

public FbTransaction BeginTransaction(string);

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


FbConnection.BeginTransaction Method ()

Begins a new transaction with the default isolation level IsolationLevel.ReadCommitted.

[Visual Basic]
Overloads Public Function BeginTransaction() As FbTransaction
[C#]
public FbTransaction BeginTransaction();

Return Value

An FbTransaction object.

Remarks

To commit or rollback the transaction, you must explicitly use the Commit or Rollback methods.

Exceptions

Exception Type | Condition
InvalidOperationException | A transaction is currently active. Parallel transactions are not supported. Or the connection is not valid and Open.

Example

public void RunFirebirdTransaction(string connectionString)
{
    FbConnection connection = new FbConnection(connectionString);
    connection.Open();

    // Start a new transaction
    FbTransaction transaction = connection.BeginTransaction();;

    // Creates a new FbCommand object
    FbCommand command = new FbCommand();
    command.Connection = connection;
    command.Transaction = transaction;

    try
    {
        command.CommandText = "Insert into Region (RegionID, RegionDescription) VALUES (100, 'Description')";
        command.ExecuteNonQuery();
        command.CommandText = "Insert into Region (RegionID, RegionDescription) VALUES (101, 'Description')";
        command.ExecuteNonQuery();

        transaction.Commit();

        Console.WriteLine("Both records are written to database.");
    }
    catch(Exception e)
    {
        myTrans.Rollback();
        Console.WriteLine(e.ToString());
        Console.WriteLine("Neither record was written to database.");
    }
    finally
    {
        myConnection.Close();
    }
}

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace | FbConnection.BeginTransaction Overload List


FbConnection.BeginTransaction Method (FbTransactionOptions)

Begins a new transaction using the specified options.

[Visual Basic]
Overloads Public Function BeginTransaction( _
ByVal options As FbTransactionOptions _
) As FbTransaction
[C#]
public FbTransaction BeginTransaction(
FbTransactionOptions options
);

Parameters

options
A FbTransactionOptions value.

Return Value

An FbTransaction object.

Remarks

To commit or rollback the transaction, you must explicitly use the Commit or Rollback methods.

Exceptions

Exception Type | Condition
InvalidOperationException | A transaction is currently active. Parallel transactions are not supported. Or the connection is not valid and Open.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace | FbConnection.BeginTransaction Overload List


FbConnection.BeginTransaction Method (FbTransactionOptions, String)

Begins a new transaction using the specified options and transaction name.

[Visual Basic]
Overloads Public Function BeginTransaction( _
ByVal options As FbTransactionOptions, _
ByVal transactionName As String _
) As FbTransaction
[C#]
public FbTransaction BeginTransaction(
FbTransactionOptions options,
string transactionName
);

Parameters

options
A FbTransactionOptions value.
transactionName
The name of the transaction.

Return Value

An FbTransaction object.

Remarks

To commit or rollback the transaction, you must explicitly use the Commit or Rollback methods.

Exceptions

Exception Type | Condition
InvalidOperationException | A transaction is currently active. Parallel transactions are not supported. Or the connection is not valid and Open.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace | FbConnection.BeginTransaction Overload List


FbConnection.BeginTransaction Method (IsolationLevel)

Begins a new transaction with the specified isolation level.

[Visual Basic]
Overloads Public Function BeginTransaction( _
ByVal level As IsolationLevel _
) As FbTransaction
[C#]
public FbTransaction BeginTransaction(
IsolationLevel level
);

Parameters

level
The isolation level for the transaction.

Return Value

An FbTransaction object.

Remarks

To commit or rollback the transaction, you must explicitly use the Commit or Rollback methods.

Exceptions

Exception Type | Condition
InvalidOperationException | A transaction is currently active. Parallel transactions are not supported. Or the connection is not valid and Open.

Example

FbConnection connection = new FbConnection(connectionString);
connection.Open();

FbConnection connection = new FbConnection(connectionString);
connection.Open();

// Start a new transaction
FbTransaction transaction = myConnection.BeginTransaction();

// Creates a new FbCommand object
FbCommand command = new FbCommand();
command.Connection = connection;
command.Transaction = transaction;

try
{
    command.CommandText = "Insert into Region (RegionID, RegionDescription) VALUES (100, 'Description')";
    command.ExecuteNonQuery();

    command.CommandText = "Insert into Region (RegionID, RegionDescription) VALUES (101, 'Description')";
    command.ExecuteNonQuery();

    transaction.Commit();

    Console.WriteLine("Both records are written to database.");
}
catch(Exception e)
{
    transaction.Rollback();

    Console.WriteLine(e.ToString());
    Console.WriteLine("Neither record was written to database.");
}
finally
{
    connection.Close();
}

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace | FbConnection.BeginTransaction Overload List


FbConnection.BeginTransaction Method (IsolationLevel, String)

Begins a new transaction with the specified isolation level and transaction name.

[Visual Basic]
Overloads Public Function BeginTransaction( _
ByVal level As IsolationLevel, _
ByVal transactionName As String _
) As FbTransaction
[C#]
public FbTransaction BeginTransaction(
IsolationLevel level,
string transactionName
);

Parameters

level
The isolation for the transaction.
transactionName
The name of the transaction.

Return Value

An object representing the new transaction.

Remarks

To commit or rollback the transaction, you must explicitly use the Commit or Rollback methods.

Exceptions

Exception Type | Condition
InvalidOperationException | A transaction is currently active. Parallel transactions are not supported. Or the connection is not valid and Open.

Example

FbConnection connection = new FbConnection(connectionString);
connection.Open();

// Start a new transaction
FbTransaction transaction = myConnection.BeginTransaction();

// Creates a new FbCommand object
FbCommand command = new FbCommand();
command.Connection = connection;
command.Transaction = transaction;

try
{
    command.CommandText = "INSERT INTO PROJECT(proj_id, proj_name, product) Values('FBNP', '.Net Provider', 'N/A')";
    command.ExecuteNonQuery();

    transaction.Save("SampleTransaction");

    command.CommandText = "INSERT INTO PROJECT(proj_id, proj_name, product) Values('FBN1', '.Net Provider1.', 'N/A')";
    command.ExecuteNonQuery();

    transaction.Commit();
    Console.WriteLine("Both records are written to database.");
}
catch(Exception e)
{
    try
    {
        transaction.Rollback("SampleTransaction");
    }
    catch (FbException ex)
    {
        if (transaction.Connection != null)
        {
            Console.WriteLine("An exception of type " + ex.GetType() + " was encountered while attempting to roll back the transaction.");
        }
    }

    Console.WriteLine("An exception of type " + e.GetType() + " was encountered while inserting the data.");
    Console.WriteLine("Neither record was written to database.");
}
finally
{
    connection.Close();
}

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace | FbConnection.BeginTransaction Overload List


FbConnection.BeginTransaction Method (String)

Begins a new transaction with the specified name.

[Visual Basic]
Overloads Public Function BeginTransaction( _
ByVal transactionName As String _
) As FbTransaction
[C#]
public FbTransaction BeginTransaction(
string transactionName
);

Parameters

transactionName
The name of the transaction.

Return Value

An FbTransaction object.

Remarks

To commit or rollback the transaction, you must explicitly use the Commit or Rollback methods.

Exceptions

Exception Type | Condition
InvalidOperationException | A transaction is currently active. Parallel transactions are not supported. Or the connection is not valid and Open.

Example

FbConnection connection = new FbConnection(connectionString);
connection.Open();

// Start a new transaction
FbTransaction transaction = myConnection.BeginTransaction();

// Creates a new FbCommand object
FbCommand command = new FbCommand();
command.Connection = connection;
command.Transaction = transaction;

try
{
    command.CommandText = "INSERT INTO PROJECT(proj_id, proj_name, product) Values('FBNP', '.Net Provider', 'N/A')";
    command.ExecuteNonQuery();

    transaction.Save("SampleTransaction");

    command.CommandText = "INSERT INTO PROJECT(proj_id, proj_name, product) Values('FBN1', '.Net Provider1.', 'N/A')";
    command.ExecuteNonQuery();

    transaction.Commit();

    Console.WriteLine("Both records are written to database.");
}
catch(Exception e)
{
    try
    {
        transaction.Rollback("SampleTransaction");
    }
    catch (FbException ex)
    {
        if (transaction.Connection != null)
        {
            Console.WriteLine("An exception of type " + ex.GetType() +
                " was encountered while attempting to roll back the transaction.");
        }
    }

    Console.WriteLine("An exception of type " + e.GetType() + " was encountered while inserting the data.");
    Console.WriteLine("Neither record was written to database.");
}
finally
{
    connection.Close();
}

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace | FbConnection.BeginTransaction Overload List


FbConnection.ChangeDatabase Method

[Visual Basic]
NotOverridable Public Sub ChangeDatabase( _
ByVal db As String _
) _
Implements IDbConnection.ChangeDatabase
[C#]
public void ChangeDatabase(
string db
);

Implements

IDbConnection.ChangeDatabase

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


FbConnection.ClearAllPools Method

Clears all active connection pools, closing all active connections.

[Visual Basic]
Public Shared Sub ClearAllPools()
[C#]
public static void ClearAllPools();

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


FbConnection.ClearPool Method

Clear the connection pool that owns the specified connection, closing all active connections.

[Visual Basic]
Public Shared Sub ClearPool( _
ByVal connection As FbConnection _
)
[C#]
public static void ClearPool(
FbConnection connection
);

Parameters

connection
A FbConnection instance.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


FbConnection.Close Method

Closes the connection to the database. This is the preferred method of closing any open connection.

[Visual Basic]
NotOverridable Public Sub Close() _
Implements IDbConnection.Close
[C#]
public void Close();

Implements

IDbConnection.Close

Remarks

The Close method rolls back any pending transactions and drops active statments. It then releases the connection to the connection pool, or closes the connection if connection pooling is disabled. If Close is called while handling a StateChange event, no additional StateChange events are fired.

Close can be called more than one time without generating an exception.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


FbConnection.CreateCommand Method

Creates and returns a new FbCommand object associated with the current FbConnection object.

[Visual Basic]
Public Function CreateCommand() As FbCommand
[C#]
public FbCommand CreateCommand();

Return Value

A new FbCommand object.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


CreateDatabase Method

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnection.CreateDatabase Method

NOTE: This method is now obsolete.

Use CreateDatabase(string connectionString) instead

Creates a new database.

Overload List

Obsolete. Creates a new database.

public static void CreateDatabase(Hashtable);

Creates a new database using the given connection string information.

public static void CreateDatabase(string);

Creates a new database using the given connection string information.

public static void CreateDatabase(string,bool);

Creates a new database using the given connection string information, create parameters.

public static void CreateDatabase(string,int,bool,bool);

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


FbConnection.CreateDatabase Method (Hashtable)

NOTE: This method is now obsolete.

Use CreateDatabase(string connectionString) instead

Creates a new database.

[Visual Basic]
<Obsolete(Message:="Use CreateDatabase(string connectionString) instead", IsError:=False)>
Overloads Public Shared Sub CreateDatabase( _
ByVal values As Hashtable _
)
[C#]
[Obsolete(Message="Use CreateDatabase(string connectionString) instead", IsError=False)]
public static void CreateDatabase(
Hashtable values
);

Parameters

values
Collection of valid keys and values.

Remarks

List of valid keys:

Name | Description
Database | Database path.
User | User name.
Password | User Password.
Dialect | Database dialect.
DataSource. | Server name.
Port | Port number.
Charset | Database Character Set.
PageSize | Database page size.
ForcedWrite | Create database using froced writes mode.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace | FbConnection.CreateDatabase Overload List


FbConnection.CreateDatabase Method (String)

Creates a new database using the given connection string information.

[Visual Basic]
Overloads Public Shared Sub CreateDatabase( _
ByVal connectionString As String _
)
[C#]
public static void CreateDatabase(
string connectionString
);

Parameters

connectionString
A valid connection string.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace | FbConnection.CreateDatabase Overload List


FbConnection.CreateDatabase Method (String, Boolean)

Creates a new database using the given connection string information.

[Visual Basic]
Overloads Public Shared Sub CreateDatabase( _
ByVal connectionString As String, _
ByVal overwrite As Boolean _
)
[C#]
public static void CreateDatabase(
string connectionString,
bool overwrite
);

Parameters

connectionString
A valid connection string.
overwrite
Specfifies if an existing database should be overwritten or not.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace | FbConnection.CreateDatabase Overload List


FbConnection.CreateDatabase Method (String, Int32, Boolean, Boolean)

Creates a new database using the given connection string information, create parameters.

[Visual Basic]
Overloads Public Shared Sub CreateDatabase( _
ByVal connectionString As String, _
ByVal pageSize As Integer, _
ByVal forcedWrites As Boolean, _
ByVal overwrite As Boolean _
)
[C#]
public static void CreateDatabase(
string connectionString,
int pageSize,
bool forcedWrites,
bool overwrite
);

Parameters

connectionString
A valid connection string.
pageSize
Database page size.
forcedWrites
Indicates wheter the database should be created using the Forced Writes mode. true to create the database in Forced writes mode; or false if not.
overwrite
Indicates if the database should overwrite an existing database.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace | FbConnection.CreateDatabase Overload List


DropDatabase Method

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnection.DropDatabase Method

NOTE: This method is now obsolete.

Use DropDatabase(string connectionString) instead

Drop a existing database.

Overload List

Obsolete. Drop a existing database.

public static void DropDatabase(Hashtable);

Drops a existent database using the given connection string information.

public static void DropDatabase(string);

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


FbConnection.DropDatabase Method (Hashtable)

NOTE: This method is now obsolete.

Use DropDatabase(string connectionString) instead

Drop a existing database.

[Visual Basic]
<Obsolete(Message:="Use DropDatabase(string connectionString) instead", IsError:=False)>
Overloads Public Shared Sub DropDatabase( _
ByVal values As Hashtable _
)
[C#]
[Obsolete(Message="Use DropDatabase(string connectionString) instead", IsError=False)]
public static void DropDatabase(
Hashtable values
);

Parameters

values
Collection of valid keys and values.

Remarks

List of valid keys:

Name | Description
Database | Database path.
User | User name.
Password | User Password.
DataSource. | Server name.
Port | Port number.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace | FbConnection.DropDatabase Overload List


FbConnection.DropDatabase Method (String)

Drops a existent database using the given connection string information.

[Visual Basic]
Overloads Public Shared Sub DropDatabase( _
ByVal connectionString As String _
)
[C#]
public static void DropDatabase(
string connectionString
);

Parameters

connectionString
A valid connection string.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace | FbConnection.DropDatabase Overload List


FbConnection.GetDbSchemaTable Method

NOTE: This method is now obsolete.

Use GetSchema methods instead

[Visual Basic]
<Obsolete(Message:="Use GetSchema methods instead", IsError:=False)>
Public Function GetDbSchemaTable( _
ByVal schema As FbDbSchemaType, _
ByVal restrictions As Object() _
) As DataTable
[C#]
[Obsolete(Message="Use GetSchema methods instead", IsError=False)]
public DataTable GetDbSchemaTable(
FbDbSchemaType schema,
object[] restrictions
);

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


FbConnection.GetPooledConnectionCount Method

Gets the number of active connections in the connection pool that owns the spcified connection.

[Visual Basic]
Public Shared Function GetPooledConnectionCount( _
ByVal connection As FbConnection _
) As Integer
[C#]
public static int GetPooledConnectionCount(
FbConnection connection
);

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


GetSchema Method

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnection.GetSchema Method

Returns information about the MetaDataCollections schema.

Overload List

Returns information about the MetaDataCollections schema.

public DataTable GetSchema();

Returns information about a specific metadata collection.

public DataTable GetSchema(string);

public DataTable GetSchema(string,string[]);

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


FbConnection.GetSchema Method ()

Returns information about the MetaDataCollections schema.

[Visual Basic]
Overloads Public Function GetSchema() As DataTable
[C#]
public DataTable GetSchema();

Return Value

DataTable with the MetaDataCollections information.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace | FbConnection.GetSchema Overload List


FbConnection.GetSchema Method (String)

Returns information about a specific metadata collection.

[Visual Basic]
Overloads Public Function GetSchema( _
ByVal collectionName As String _
) As DataTable
[C#]
public DataTable GetSchema(
string collectionName
);

Return Value

DataTable with the speficied schema information.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace | FbConnection.GetSchema Overload List


FbConnection.GetSchema Method (String, String[])

[Visual Basic]
Overloads Public Function GetSchema( _
ByVal collectionName As String, _
ByVal restrictions As String() _
) As DataTable
[C#]
public DataTable GetSchema(
string collectionName,
string[] restrictions
);

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace | FbConnection.GetSchema Overload List


FbConnection.Open Method

Opens a new connection to a database with the property settings specified by the ConnectionString.

[Visual Basic]
NotOverridable Public Sub Open() _
Implements IDbConnection.Open
[C#]
public void Open();

Implements

IDbConnection.Open

Remarks

The FbConnection draws an open connection from the connection pool if one is available. Otherwise, it establishes a new connection to the database.

Note:

If a FbConnection object goes out of scope, the connection it represents does not close automatically, you need to explicitly close the connection by calling Close or Dispose methods.

Exceptions

Exception Type | Condition
InvalidOperationException | The connection is already open.
ArgumentException | If Connection string is not valid.
FbException | A connection-level error occurred while opening the connection.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


FbConnection Events

The events of the FbConnection class are listed below. For a complete list of FbConnection class members, see the FbConnection Members topic.

Public Instance Events

Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
InfoMessage | Occurs when the Firebird Server sends a warning message.
StateChange | Occurs when the state of the connection changes.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


FbConnection.InfoMessage Event

Occurs when the Firebird Server sends a warning message.

[Visual Basic]
Public Event InfoMessage As FbInfoMessageEventHandler
[C#]
public event FbInfoMessageEventHandler InfoMessage;

Event Data

The event handler receives an argument of type FbInfoMessageEventArgs containing data related to this event. The following FbInfoMessageEventArgs properties provide information specific to this event.

Property | Description
Errors | Gets the collection of warnings sent from the Firebird Server.
Message | Gets a value representing the complete error message sent from the Firebird Server.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


FbConnection.StateChange Event

Occurs when the state of the connection changes.

[Visual Basic]
Public Event StateChange As StateChangeEventHandler
[C#]
public event StateChangeEventHandler StateChange;

Remarks

The StateChange event is raised when the connection state changes from Closed to Opened, or from Opened to Closed.

See Also

FbConnection Class | FirebirdSql.Data.Firebird Namespace


FbConnectionStringBuilder Class

Allows handling of the connection strings. See ConnectionString

For a list of all members of this type, see FbConnectionStringBuilder Members.

System.Object
FirebirdSql.Data.Firebird.FbConnectionStringBuilder

[Visual Basic]
NotInheritable Public Class FbConnectionStringBuilder
[C#]
public sealed class FbConnectionStringBuilder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

The following example builds a connection string and prints it in the console.

FbConnectionStringBuilder cs = new FbConnectionStringBuilder();

cs.DataSource = "localhost";
cs.UserID     = "SYSDBA";
cs.Password     = "masterkey";
cs.Database     = "nunit_testdb";
cs.Port         = 3050;
cs.Charset     = "UNICODE_FSS";
cs.Pooling     = true;
cs.ConnectionLifeTime = 30;
// To use the embedded server set the ServerType to 1
cs.ServerType = 0;

Console.WriteLine(cs.ToString());

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbConnectionStringBuilder Members | FirebirdSql.Data.Firebird Namespace


FbConnectionStringBuilder Members

FbConnectionStringBuilder overview

Public Instance Constructors

FbConnectionStringBuilder Overloaded. Initializes a new instance of the FbConnectionStringBuilder class.

Public Instance Properties

Charset | Gets or sets the connection character set.
ConnectionLifeTime | Gets or sets the lifetime of a connection in the pool.
ConnectionString | Gets or sets the connection string.
ConnectionTimeout | Gets the time to wait while trying to establish a connection before terminating the attempt and generating an error.
Database | Gets the name of the actual database or the database to be used when a connection is open.
DataSource | Gets the name of the Firebird Server to which to connect.
Dialect | Gets or sets the database dialect.
FetchSize | Indicates the number of rows that will be fetched at the same time on Read calls into the internal row buffer.
IsolationLevel | Gets or sets the default Isolation Leve for implicit transactions.
MaxPoolSize | Gets or sets the maximun pool size.
MinPoolSize | Gets or sets the minumun pool size.
PacketSize | Gets or sets the size (in bytes) of network packets used to communicate with an instance of Firebird Server.
Password | Gets ort sets the password for the Firebird user account.
Pooling | Gets or sets the status of the connection pooling (enabled/disabled).
Port | Gets or sets the port number in the server for establish the connection
Role | Gets or sets the suer role name.
ServerType | Gets or sets the server type to wich we want to connect.
UserID | Gets or sets the firebird User account for login.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Overrided method, returns the Firebird connection string.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


FbConnectionStringBuilder Constructor

Creates a new instance of the FbConnectionStringBuilder class.

Overload List

Creates a new instance of the FbConnectionStringBuilder class.

public FbConnectionStringBuilder();

Creates a new instance of the FbConnectionStringBuilder class with the specified connection string.

public FbConnectionStringBuilder(string);

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


FbConnectionStringBuilder Constructor ()

Creates a new instance of the FbConnectionStringBuilder class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FbConnectionStringBuilder();

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace | FbConnectionStringBuilder Constructor Overload List


FbConnectionStringBuilder Constructor (String)

Creates a new instance of the FbConnectionStringBuilder class with the specified connection string.

[Visual Basic]
Overloads Public Sub New( _
ByVal connectionString As String _
)
[C#]
public FbConnectionStringBuilder(
string connectionString
);

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace | FbConnectionStringBuilder Constructor Overload List


FbConnectionStringBuilder Properties

The properties of the FbConnectionStringBuilder class are listed below. For a complete list of FbConnectionStringBuilder class members, see the FbConnectionStringBuilder Members topic.

Public Instance Properties

Charset | Gets or sets the connection character set.
ConnectionLifeTime | Gets or sets the lifetime of a connection in the pool.
ConnectionString | Gets or sets the connection string.
ConnectionTimeout | Gets the time to wait while trying to establish a connection before terminating the attempt and generating an error.
Database | Gets the name of the actual database or the database to be used when a connection is open.
DataSource | Gets the name of the Firebird Server to which to connect.
Dialect | Gets or sets the database dialect.
FetchSize | Indicates the number of rows that will be fetched at the same time on Read calls into the internal row buffer.
IsolationLevel | Gets or sets the default Isolation Leve for implicit transactions.
MaxPoolSize | Gets or sets the maximun pool size.
MinPoolSize | Gets or sets the minumun pool size.
PacketSize | Gets or sets the size (in bytes) of network packets used to communicate with an instance of Firebird Server.
Password | Gets ort sets the password for the Firebird user account.
Pooling | Gets or sets the status of the connection pooling (enabled/disabled).
Port | Gets or sets the port number in the server for establish the connection
Role | Gets or sets the suer role name.
ServerType | Gets or sets the server type to wich we want to connect.
UserID | Gets or sets the firebird User account for login.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


Charset Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnectionStringBuilder.Charset Property

Gets or sets the connection character set.

[Visual Basic]
Public Property Charset As String
[C#]
public string Charset {get; set;}

Property Value

The connection character set

Remarks

Firebird Charset | Description
ASCII | American Standard Code for Information Interchange.
BIG_5 | Big5, Traditional Chinese.
DOS437 | MS-DOS United States, Australia, New Zealand, South Africa.
DOS850 | MS-DOS Latin-1.
DOS860 | MS-DOS Portugues.
DOS861 | MS-DOS Icelandic.
DOS863 | MS-DOS Canadian French.
DOS865 | MS-DOS Nordic.
EUCJ_0208 | JIS X 0201, 0208, 0212, EUC encoding, Japanese.
GB_2312 | GB2312, EUC encoding, Simplified Chinese.
ISO8859_1 | ISO 8859-1, Latin alphabet No. 1.
ISO8859_2 | ISO 8859-2, Latin alphabet No. 2.
KSC_5601 | Windows Korean.
ISO2022-JP | Windows Japanese.
SJIS_0208 | Japanese (Shift-JIS)
UNICODE_FSS | Eight-bit Unicode Transformation Format.
WIN1250 | Windows Eastern European.
WIN1251 | Windows Cyrillic.
WIN1252 | Windows Latin-1.
WIN1253 | Windows Greek.
WIN1254 | Windows Turkish.
WIN1254 | Windows Hebrew.
Arabic | Windows Turkish.
WIN1257 | Windows Baltic.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


ConnectionLifeTime Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnectionStringBuilder.ConnectionLifeTime Property

Gets or sets the lifetime of a connection in the pool.

[Visual Basic]
Public Property ConnectionLifeTime As Long
[C#]
public long ConnectionLifeTime {get; set;}

Property Value

When a connection is returned to the pool, its creation time is compared with the current time, and the connection is destroyed if that time span (in seconds) exceeds the value specified by connection lifetime.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


ConnectionString Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnectionStringBuilder.ConnectionString Property

Gets or sets the connection string.

[Visual Basic]
Public Property ConnectionString As String
[C#]
public string ConnectionString {get; set;}

Property Value

The connection string.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


ConnectionTimeout Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnectionStringBuilder.ConnectionTimeout Property

Gets the time to wait while trying to establish a connection before terminating the attempt and generating an error.

[Visual Basic]
Public Property ConnectionTimeout As Integer
[C#]
public int ConnectionTimeout {get; set;}

Property Value

The time (in seconds) to wait for a connection to open. The default value is 0 seconds.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


Database Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnectionStringBuilder.Database Property

Gets the name of the actual database or the database to be used when a connection is open.

[Visual Basic]
Public Property Database As String
[C#]
public string Database {get; set;}

Property Value

The name of the actual database or the database to be used when a connection is open. The default value is an empty string.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


DataSource Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnectionStringBuilder.DataSource Property

Gets the name of the Firebird Server to which to connect.

[Visual Basic]
Public Property DataSource As String
[C#]
public string DataSource {get; set;}

Property Value

The name of the Firebird Server to which to connect. The default value is an empty string.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


Dialect Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnectionStringBuilder.Dialect Property

Gets or sets the database dialect.

[Visual Basic]
Public Property Dialect As Byte
[C#]
public byte Dialect {get; set;}

Property Value

The database dialect. Default value is 3.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


FetchSize Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnectionStringBuilder.FetchSize Property

Indicates the number of rows that will be fetched at the same time on Read calls into the internal row buffer.

[Visual Basic]
Public Property FetchSize As Integer
[C#]
public int FetchSize {get; set;}

Property Value

The maximun number of rows to be fetched in a single call to Read into the internal row buffer.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


IsolationLevel Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnectionStringBuilder.IsolationLevel Property

Gets or sets the default Isolation Leve for implicit transactions.

[Visual Basic]
Public Property IsolationLevel As IsolationLevel
[C#]
public System.Data.IsolationLevel IsolationLevel {get; set;}

Property Value

An IsolationLevel.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


MaxPoolSize Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnectionStringBuilder.MaxPoolSize Property

Gets or sets the maximun pool size.

[Visual Basic]
Public Property MaxPoolSize As Integer
[C#]
public int MaxPoolSize {get; set;}

Property Value

The maximun number of connections allowed in the pool. Default is 100.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


MinPoolSize Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnectionStringBuilder.MinPoolSize Property

Gets or sets the minumun pool size.

[Visual Basic]
Public Property MinPoolSize As Integer
[C#]
public int MinPoolSize {get; set;}

Property Value

The minimun number of connections allowed in the pool. Default is 0.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


PacketSize Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnectionStringBuilder.PacketSize Property

Gets or sets the size (in bytes) of network packets used to communicate with an instance of Firebird Server.

[Visual Basic]
Public Property PacketSize As Short
[C#]
public short PacketSize {get; set;}

Property Value

The size (in bytes) of network packets. The default value is 8192.

Remarks

PacketSize may be in the rane 512-32767 bytes. An exception is generated if the value is outside of this range.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


Password Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnectionStringBuilder.Password Property

Gets ort sets the password for the Firebird user account.

[Visual Basic]
Public Property Password As String
[C#]
public string Password {get; set;}

Property Value

The user password.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


Pooling Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnectionStringBuilder.Pooling Property

Gets or sets the status of the connection pooling (enabled/disabled).

[Visual Basic]
Public Property Pooling As Boolean
[C#]
public bool Pooling {get; set;}

Property Value

When true, the FbConnection object is drawn from the appropriate pool, or if necessary, is created and added to the appropriate pool. Recognized values are true, false, yes, and no.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


Port Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnectionStringBuilder.Port Property

Gets or sets the port number in the server for establish the connection

[Visual Basic]
Public Property Port As Integer
[C#]
public int Port {get; set;}

Property Value

The port number.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


Role Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnectionStringBuilder.Role Property

Gets or sets the suer role name.

[Visual Basic]
Public Property Role As String
[C#]
public string Role {get; set;}

Property Value

The user role

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


ServerType Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnectionStringBuilder.ServerType Property

Gets or sets the server type to wich we want to connect.

[Visual Basic]
Public Property ServerType As Integer
[C#]
public int ServerType {get; set;}

Property Value

The default value is 0.

Remarks

When 0 the provider will use the GDS implementation used for connections to Firebird Super or Classic servers, when 1 the provider will use the GDS implementation used for connections to the Firebird embedded server.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


UserID Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbConnectionStringBuilder.UserID Property

Gets or sets the firebird User account for login.

[Visual Basic]
Public Property UserID As String
[C#]
public string UserID {get; set;}

Property Value

The user name.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


FbConnectionStringBuilder Methods

The methods of the FbConnectionStringBuilder class are listed below. For a complete list of FbConnectionStringBuilder class members, see the FbConnectionStringBuilder Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Overrided method, returns the Firebird connection string.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


FbConnectionStringBuilder.ToString Method

Overrided method, returns the Firebird connection string.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The Firebird connection string.

See Also

FbConnectionStringBuilder Class | FirebirdSql.Data.Firebird Namespace


FbDataAdapter Class

Represents a set of data commands and a connection to a data source that are used to fill the DataSet and update the data source. This class cannot be inherited.

For a list of all members of this type, see FbDataAdapter Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Data.Common.DataAdapter
System.Data.Common.DbDataAdapter
FirebirdSql.Data.Firebird.FbDataAdapter

[Visual Basic]
<DefaultEvent(Name:="RowUpdated"), _ ToolboxItem(ToolboxItemType:=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName:="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"), _ ToolboxBitmap, _ Designer(DesignerBaseTypeName:="System.ComponentModel.Design.IDesigner, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", DesignerTypeName:="FirebirdSql.Data.Firebird.Design.FbDataAdapterDesigner, FirebirdSql.Data.Firebird, Version=1.7.1.0, Culture=neutral, PublicKeyToken=fa843d180294369d"), _ DesignerCategory(Category:="Component")>
NotInheritable Public Class FbDataAdapter
Inherits DbDataAdapter
[C#]
[DefaultEvent(Name="RowUpdated")]
[ToolboxItem(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmap]
[Designer(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", DesignerTypeName="FirebirdSql.Data.Firebird.Design.FbDataAdapterDesigner, FirebirdSql.Data.Firebird, Version=1.7.1.0, Culture=neutral, PublicKeyToken=fa843d180294369d")]
[DesignerCategory(Category="Component")]
public sealed class FbDataAdapter : DbDataAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The FbDataAdapter, serves as a bridge between a DataSet and FirebirdSQL for retrieving and saving data. The FbDataAdapter provides this bridge by mapping Fill, which changes the data in the DataSet to match the data in the data source, and Update, which changes the data in the data source to match the data in the DataSet, using the appropriate DSQL statements against the data source.

FbDataAdapter is used in conjunction with FbConnection and FbCommand to increase performance when connecting to a FirebirdSQL Server database.

The FbDataAdapter also includes the SelectCommand, InsertCommand, DeleteCommand, UpdateCommand, and TableMappings properties to facilitate the loading and updating of data.

When an instance of FbDataAdapter is created, the read/write properties are set to initial values.

Example

public static void CreateFbDataAdapter()
{
    FbConnection    conn = new FbConnection("Database=C:\\PROGRAM FILES\\FIREBIRD\\EXAMPLES\\EMPLOYEE.GDB;User=SYSDBA;Password=masterkey;Dialect=3;Server=localhost");
    FbDataAdapter    custDA = new FbDataAdapter();
    FbTransaction    txn     = conn.BeginTransaction();

    custDA.MissingSchemaAction = MissingSchemaAction.AddWithKey;

    custDA.SelectCommand = new FbCommand("SELECT custno, customer FROM CUSTOMER", conn, txn);
    custDA.InsertCommand = new FbCommand("INSERT INTO customer (CustomerID, customer) " +
                                            "VALUES (?, ?)", conn, txn);
    custDA.UpdateCommand = new FbCommand("UPDATE customer SET custno = ?, customer = ? " +
                                            "WHERE custno = ?", conn, txn);
    custDA.DeleteCommand = new FbCommand("DELETE FROM customer WHERE custno = ?", conn, txn);

    custDA.InsertCommand.Parameters.Add("@custno", FbDbType.Int32, 4, "custno");
    custDA.InsertCommand.Parameters.Add("@customer", FbDbType.VarChar, 25, "customer");

    custDA.UpdateCommand.Parameters.Add("@custno", FbDbType.Int32, 4, "custno");
    custDA.UpdateCommand.Parameters.Add("@customer", FbDbType.VarChar, 25, "customer");
    custDA.UpdateCommand.Parameters.Add("@oldcustno", FbDbType.Int32, 4, "custno").SourceVersion = DataRowVersion.Original;

    custDA.DeleteCommand.Parameters.Add("@oldcustno", FbDbType.Int32, 4, "custno").SourceVersion = DataRowVersion.Original;
}

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbDataAdapter Members | FirebirdSql.Data.Firebird Namespace


FbDataAdapter Members

FbDataAdapter overview

Public Instance Constructors

FbDataAdapter Overloaded. Initializes a new instance of the FbDataAdapter class.

Public Instance Properties

AcceptChangesDuringFill (inherited from DataAdapter) | Gets or sets a value indicating whether AcceptChanges is called on a DataRow after it is added to the DataTable during any of the Fill operations.
AcceptChangesDuringUpdate (inherited from DataAdapter) | Gets or sets whether AcceptChanges is called during a Update.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContinueUpdateOnError (inherited from DataAdapter) | Gets or sets a value that specifies whether to generate an exception when an error is encountered during a row update.
DeleteCommand | Overloaded.
FillLoadOption (inherited from DataAdapter) | Gets or sets the LoadOption that determines how the adapter fills the DataTable from the DbDataReader.
InsertCommand | Overloaded. Gets or sets an SQL statement or stored procedure used to insert new records into the data source.
MissingMappingAction (inherited from DataAdapter) | Determines the action to take when incoming data does not have a matching table or column.
MissingSchemaAction (inherited from DataAdapter) | Determines the action to take when existing DataSet schema does not match incoming data.
ReturnProviderSpecificTypes (inherited from DataAdapter) | Gets or sets whether the Fill method should return provider-specific values or common CLS-compliant values.
SelectCommand | Overloaded. Gets or sets an SQL statement or stored procedure used to select records in the data source.
Site (inherited from Component) | Gets or sets the ISite of the Component.
TableMappings (inherited from DataAdapter) | Gets a collection that provides the master mapping between a source table and a DataTable.
UpdateBatchSize (inherited from DbDataAdapter) | Gets or sets a value that enables or disables batch processing support, and specifies the number of commands that can be executed in a batch.
UpdateCommand | Overloaded. Gets or sets an SQL statement or stored procedure used to update records in the data source.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Fill (inherited from DbDataAdapter) | Overloaded. Adds or refreshes rows in the DataSet to match those in the data source using the DataSet name, and creates a DataTable named "Table."
FillSchema (inherited from DbDataAdapter) | Overloaded. Configures the schema of the specified DataTable based on the specified SchemaType.
GetFillParameters (inherited from DbDataAdapter) | Gets the parameters set by the user when executing an SQL SELECT statement.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ResetFillLoadOption (inherited from DataAdapter) | Resets FillLoadOption to its default state and causes Fill to honor AcceptChangesDuringFill.
ShouldSerializeAcceptChangesDuringFill (inherited from DataAdapter) | Determines whether the AcceptChangesDuringFill property should be persisted.
ShouldSerializeFillLoadOption (inherited from DataAdapter) | Determines whether the FillLoadOption property should be persisted.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from DbDataAdapter) | Overloaded. Calls the respective INSERT, UPDATE, or DELETE statements for each inserted, updated, or deleted row in the specified DataSet.

Public Instance Events

Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
FillError (inherited from DataAdapter) | Returned when an error occurs during a fill operation.
RowUpdated | Occurs during an Update operation after a command is executed against the data source.
RowUpdating | Occurs during an Update operation before a command is executed against the data source.

Protected Internal Instance Properties

FillCommandBehavior (inherited from DbDataAdapter) Gets or sets the behavior of the command used to fill the data adapter.

See Also

FbDataAdapter Class | FirebirdSql.Data.Firebird Namespace


FbDataAdapter Constructor

Creates a new instance of the FbDataAdapter class.

Overload List

Creates a new instance of the FbDataAdapter class.

public FbDataAdapter();

Creates a new instance of the FbDataAdapter class with the specified SQL SELECT statement.

public FbDataAdapter(FbCommand);

public FbDataAdapter(string,FbConnection);

Creates a new instance of the FbDataAdapter class with an SQL SELECT statement and a connection string.

public FbDataAdapter(string,string);

See Also

FbDataAdapter Class | FirebirdSql.Data.Firebird Namespace


FbDataAdapter Constructor ()

Creates a new instance of the FbDataAdapter class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FbDataAdapter();

Remarks

When you create an instance of FbDataAdapter, the following read/write properties are set to their default values, as shown in the table.

Properties | Default Value
MissingMappingAction | MissingMappingAction.Passthrough
MissingSchemaAction | MissingSchemaAction.Add

See Also

FbDataAdapter Class | FirebirdSql.Data.Firebird Namespace | FbDataAdapter Constructor Overload List


FbDataAdapter Constructor (FbCommand)

Creates a new instance of the FbDataAdapter class with the specified SQL SELECT statement.

[Visual Basic]
Overloads Public Sub New( _
ByVal selectCommand As FbCommand _
)
[C#]
public FbDataAdapter(
FbCommand selectCommand
);

Parameters

selectCommand
An FbCommand that is an SQL SELECT statement or stored procedure, and is set as the SelectCommand property of the FbDataAdapter.

Remarks

When you create an instance of FbDataAdapter, the following read/write properties are set to their default values, as shown in the table.

Properties | Default Value
MissingMappingAction | MissingMappingAction.Passthrough
MissingSchemaAction | MissingSchemaAction.Add

See Also

FbDataAdapter Class | FirebirdSql.Data.Firebird Namespace | FbDataAdapter Constructor Overload List


FbDataAdapter Constructor (String, FbConnection)

[Visual Basic]
Overloads Public Sub New( _
ByVal selectCommandText As String, _
ByVal selectConnection As FbConnection _
)
[C#]
public FbDataAdapter(
string selectCommandText,
FbConnection selectConnection
);

See Also

FbDataAdapter Class | FirebirdSql.Data.Firebird Namespace | FbDataAdapter Constructor Overload List


FbDataAdapter Constructor (String, String)

Creates a new instance of the FbDataAdapter class with an SQL SELECT statement and a connection string.

[Visual Basic]
Overloads Public Sub New( _
ByVal selectCommandText As String, _
ByVal selectConnectionString As String _
)
[C#]
public FbDataAdapter(
string selectCommandText,
string selectConnectionString
);

Parameters

selectCommandText
A string that is a SQL SELECT statement or stored procedure to be used by the SelectCommand property of the FbDataAdapter.
selectConnectionString
The connection string.

Remarks

When you create an instance of FbDataAdapter, the following read/write properties are set to their default values, as shown in the table.

Properties | Default Value
MissingMappingAction | MissingMappingAction.Passthrough
MissingSchemaAction | MissingSchemaAction.Add

See Also

FbDataAdapter Class | FirebirdSql.Data.Firebird Namespace | FbDataAdapter Constructor Overload List


FbDataAdapter Properties

The properties of the FbDataAdapter class are listed below. For a complete list of FbDataAdapter class members, see the FbDataAdapter Members topic.

Public Instance Properties

AcceptChangesDuringFill (inherited from DataAdapter) | Gets or sets a value indicating whether AcceptChanges is called on a DataRow after it is added to the DataTable during any of the Fill operations.
AcceptChangesDuringUpdate (inherited from DataAdapter) | Gets or sets whether AcceptChanges is called during a Update.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContinueUpdateOnError (inherited from DataAdapter) | Gets or sets a value that specifies whether to generate an exception when an error is encountered during a row update.
DeleteCommand | Overloaded.
FillLoadOption (inherited from DataAdapter) | Gets or sets the LoadOption that determines how the adapter fills the DataTable from the DbDataReader.
InsertCommand | Overloaded. Gets or sets an SQL statement or stored procedure used to insert new records into the data source.
MissingMappingAction (inherited from DataAdapter) | Determines the action to take when incoming data does not have a matching table or column.
MissingSchemaAction (inherited from DataAdapter) | Determines the action to take when existing DataSet schema does not match incoming data.
ReturnProviderSpecificTypes (inherited from DataAdapter) | Gets or sets whether the Fill method should return provider-specific values or common CLS-compliant values.
SelectCommand | Overloaded. Gets or sets an SQL statement or stored procedure used to select records in the data source.
Site (inherited from Component) | Gets or sets the ISite of the Component.
TableMappings (inherited from DataAdapter) | Gets a collection that provides the master mapping between a source table and a DataTable.
UpdateBatchSize (inherited from DbDataAdapter) | Gets or sets a value that enables or disables batch processing support, and specifies the number of commands that can be executed in a batch.
UpdateCommand | Overloaded. Gets or sets an SQL statement or stored procedure used to update records in the data source.

Protected Internal Instance Properties

FillCommandBehavior (inherited from DbDataAdapter) Gets or sets the behavior of the command used to fill the data adapter.

See Also

FbDataAdapter Class | FirebirdSql.Data.Firebird Namespace


DeleteCommand Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDataAdapter.DeleteCommand Property

[Visual Basic]
<DefaultValue(Value:=null), _ Category(Category:="Update")>
Overloads Public Property DeleteCommand As FbCommand
[C#]
[DefaultValue(Value=null)]
[Category(Category="Update")]
new public FbCommand DeleteCommand {get; set;}

See Also

FbDataAdapter Class | FirebirdSql.Data.Firebird Namespace


InsertCommand Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDataAdapter.InsertCommand Property

Gets or sets an SQL statement or stored procedure used to insert new records into the data source.

[Visual Basic]
<DefaultValue(Value:=null), _ Category(Category:="Update")>
Overloads Public Property InsertCommand As FbCommand
[C#]
[DefaultValue(Value=null)]
[Category(Category="Update")]
new public FbCommand InsertCommand {get; set;}

Property Value

An FbCommand used during an update operation to insert records in the data source that correspond to new rows in the DataSet.

Remarks

During Update, if this property is not set and primary key information is present in the DataSet, the InsertCommand can be generated automatically if you set the SelectCommand property and use the FbCommandBuilder. Then, any additional commands that you do not set are generated by the FbCommandBuilder. This generation logic requires key column information to be present in the DataSet.

When InsertCommand is assigned to a previously created FbCommand, the FbCommand is not cloned. The InsertCommand maintains a reference to the previously created FbCommand object.

See Also

FbDataAdapter Class | FirebirdSql.Data.Firebird Namespace


SelectCommand Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDataAdapter.SelectCommand Property

Gets or sets an SQL statement or stored procedure used to select records in the data source.

[Visual Basic]
<Category(Category:="Fill"), _ DefaultValue(Value:=null)>
Overloads Public Property SelectCommand As FbCommand
[C#]
[Category(Category="Fill")]
[DefaultValue(Value=null)]
new public FbCommand SelectCommand {get; set;}

Property Value

An FbCommand that is used during a fill operation to select records from data source for placement in the DataSet.

Remarks

When SelectCommand is assigned to a previously created FbCommand, the FbCommand is not cloned. The SelectCommand maintains a reference to the previously created FbCommand object.

If the SelectCommand does not return any rows, no tables are added to the DataSet, and no exception is raised.

See Also

FbDataAdapter Class | FirebirdSql.Data.Firebird Namespace


UpdateCommand Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDataAdapter.UpdateCommand Property

Gets or sets an SQL statement or stored procedure used to update records in the data source.

[Visual Basic]
<Category(Category:="Update"), _ DefaultValue(Value:=null)>
Overloads Public Property UpdateCommand As FbCommand
[C#]
[Category(Category="Update")]
[DefaultValue(Value=null)]
new public FbCommand UpdateCommand {get; set;}

Property Value

An FbCommand used during an update operation to update records in the data source that correspond to modified rows in the DataSet.

Remarks

During Update, if this property is not set and primary key information is present in the DataSet, the UpdateCommand can be generated automatically if you set the SelectCommand property and use the FbCommandBuilder. Then, any additional commands that you do not set are generated by the FbCommandBuilder. This generation logic requires key column information to be present in the DataSet.

When UpdateCommand is assigned to a previously created FbCommand, the FbCommand is not cloned. The UpdateCommand maintains a reference to the previously created FbCommand object.

See Also

FbDataAdapter Class | FirebirdSql.Data.Firebird Namespace


FbDataAdapter Events

The events of the FbDataAdapter class are listed below. For a complete list of FbDataAdapter class members, see the FbDataAdapter Members topic.

Public Instance Events

Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
FillError (inherited from DataAdapter) | Returned when an error occurs during a fill operation.
RowUpdated | Occurs during an Update operation after a command is executed against the data source.
RowUpdating | Occurs during an Update operation before a command is executed against the data source.

See Also

FbDataAdapter Class | FirebirdSql.Data.Firebird Namespace


FbDataAdapter.RowUpdated Event

Occurs during an Update operation after a command is executed against the data source.

[Visual Basic]
Public Event RowUpdated As FbRowUpdatedEventHandler
[C#]
public event FbRowUpdatedEventHandler RowUpdated;

Event Data

The event handler receives an argument of type FbRowUpdatedEventArgs containing data related to this event. The following FbRowUpdatedEventArgs properties provide information specific to this event.

Property | Description
Command | Gets the FbCommand executed when Update is called.
Errors | Gets any errors generated by the .NET Framework data provider when the Command was executed.
RecordsAffected | Gets the number of rows changed, inserted, or deleted by execution of the SQL statement.
Row | Gets the DataRow sent through an Update.
RowCount | Gets the number of rows processed in a batch of updated records.
StatementType | Gets the type of SQL statement executed.
Status | Gets the UpdateStatus of the Command property.
TableMapping | Gets the DataTableMapping sent through an Update.

See Also

FbDataAdapter Class | FirebirdSql.Data.Firebird Namespace


FbDataAdapter.RowUpdating Event

Occurs during an Update operation before a command is executed against the data source.

[Visual Basic]
Public Event RowUpdating As FbRowUpdatingEventHandler
[C#]
public event FbRowUpdatingEventHandler RowUpdating;

Event Data

The event handler receives an argument of type FbRowUpdatingEventArgs containing data related to this event. The following FbRowUpdatingEventArgs properties provide information specific to this event.

Property | Description
Command | Gets the FbCommand executed when Update is called.
Errors | Gets any errors generated by the .NET Framework data provider when the Command executes.
Row | Gets the DataRow that will be sent to the server as part of an insert, update, or delete operation.
StatementType | Gets the type of SQL statement to execute.
Status | Gets or sets the UpdateStatus of the Command property.
TableMapping | Gets the DataTableMapping to send through the Update.

See Also

FbDataAdapter Class | FirebirdSql.Data.Firebird Namespace


FbDatabaseInfo Class

Reports requested information about a attached database. This class cannot be inherited.

For a list of all members of this type, see FbDatabaseInfo Members.

System.Object
FirebirdSql.Data.Firebird.FbDatabaseInfo

[Visual Basic]
NotInheritable Public Class FbDatabaseInfo
[C#]
public sealed class FbDatabaseInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbDatabaseInfo Members | FirebirdSql.Data.Firebird Namespace


FbDatabaseInfo Members

FbDatabaseInfo overview

Public Instance Constructors

FbDatabaseInfo Overloaded. Initializes a new instance of the FbDatabaseInfo class.

Public Instance Properties

ActiveTransactions | Gets the number of active transction.
ActiveUsers |
AllocationPages | Gets the number of database pages allocated.
BackoutCount | Gets the number of removals of a version of a record.
BaseLevel | Gets the database version (level) number.
Connection | Gets or sets the FbConnection used by this instance of the FbDataseInfo.
CurrentMemory | Gets the Amount of server memory (in bytes) currently in use.
DatabaseSizeInPages | Gets the database size in pages.
DbId | Gets the database file name and site name.
DeleteCount | Gets the number of database deletes since the database was last attached.
ExpungeCount | Gets the number of removals of a record and all of its ancestors, for records hose deletions have been committed.
Fetches | Gets the number of reads from the memory buffer cache.
ForcedWrites | Gets the mode in which database writes are performed.
Implementation | Gets the database implementation number.
InsertCount | Gets the number of inserts into the database since the database was last attached.
IscVersion | Gets the version identification string of the database implementation.
Marks | Gets the number of writes to the memory buffer cache.
MaxMemory | Gets the Maximum amount of memory (in bytes) used at one time since the first process attached to the database.
NextTransaction | Gets the number of the next transction.
NoReserve | Gets the indicates if space is reserved on each database page for holding.
NumBuffers | Gets the number of memory buffers currently allocated.
OdsMinorVersion | Gets the On-disk structure (ODS) minor version number.
OdsVersion | Gets the ODS major version number.
OldestActiveSnapshot | Gets the number of the oldest snapshot transaction.
OldestActiveTransaction | Gets the number of the oldest active transaction.
OldestTransaction | Gets the number of the oldest transaction.
PageSize | Gets the page size of the database.
PurgeCount | Gets the number of removals of old versions of fully mature records.
ReadIdxCount | Gets the number of reads done via an index since the database was last attached.
ReadOnly | Gets wheter database is in readonly mode.
Reads | Gets the number of page reads.
ReadSeqCount | Gets the number of sequential sequential table scans (row reads) done on each table since the database was last attached.
ServerClass | Gets wheter Firebird Server is a Super or Classic server.
ServerVersion | Gets the version identification string of the Firebird Server.
SweepInterval | Gets the number of transactions that are committed between “sweeps” to remove database record versions that are no longer needed.
UpdateCount | Gets the number of database updates since the database was last attached.
Writes | Gets the number of page writes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


FbDatabaseInfo Constructor

Creates a new instance of the FbDatabaseInfo class.

Overload List

Creates a new instance of the FbDatabaseInfo class.

public FbDatabaseInfo();

Creates a new instance of the FbDatabaseInfo class with an FbConnection object.

public FbDatabaseInfo(FbConnection);

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


FbDatabaseInfo Constructor ()

Creates a new instance of the FbDatabaseInfo class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FbDatabaseInfo();

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace | FbDatabaseInfo Constructor Overload List


FbDatabaseInfo Constructor (FbConnection)

Creates a new instance of the FbDatabaseInfo class with an FbConnection object.

[Visual Basic]
Overloads Public Sub New( _
ByVal connection As FbConnection _
)
[C#]
public FbDatabaseInfo(
FbConnection connection
);

Parameters

connection
An FbConnection object.

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace | FbDatabaseInfo Constructor Overload List


FbDatabaseInfo Properties

The properties of the FbDatabaseInfo class are listed below. For a complete list of FbDatabaseInfo class members, see the FbDatabaseInfo Members topic.

Public Instance Properties

ActiveTransactions | Gets the number of active transction.
ActiveUsers |
AllocationPages | Gets the number of database pages allocated.
BackoutCount | Gets the number of removals of a version of a record.
BaseLevel | Gets the database version (level) number.
Connection | Gets or sets the FbConnection used by this instance of the FbDataseInfo.
CurrentMemory | Gets the Amount of server memory (in bytes) currently in use.
DatabaseSizeInPages | Gets the database size in pages.
DbId | Gets the database file name and site name.
DeleteCount | Gets the number of database deletes since the database was last attached.
ExpungeCount | Gets the number of removals of a record and all of its ancestors, for records hose deletions have been committed.
Fetches | Gets the number of reads from the memory buffer cache.
ForcedWrites | Gets the mode in which database writes are performed.
Implementation | Gets the database implementation number.
InsertCount | Gets the number of inserts into the database since the database was last attached.
IscVersion | Gets the version identification string of the database implementation.
Marks | Gets the number of writes to the memory buffer cache.
MaxMemory | Gets the Maximum amount of memory (in bytes) used at one time since the first process attached to the database.
NextTransaction | Gets the number of the next transction.
NoReserve | Gets the indicates if space is reserved on each database page for holding.
NumBuffers | Gets the number of memory buffers currently allocated.
OdsMinorVersion | Gets the On-disk structure (ODS) minor version number.
OdsVersion | Gets the ODS major version number.
OldestActiveSnapshot | Gets the number of the oldest snapshot transaction.
OldestActiveTransaction | Gets the number of the oldest active transaction.
OldestTransaction | Gets the number of the oldest transaction.
PageSize | Gets the page size of the database.
PurgeCount | Gets the number of removals of old versions of fully mature records.
ReadIdxCount | Gets the number of reads done via an index since the database was last attached.
ReadOnly | Gets wheter database is in readonly mode.
Reads | Gets the number of page reads.
ReadSeqCount | Gets the number of sequential sequential table scans (row reads) done on each table since the database was last attached.
ServerClass | Gets wheter Firebird Server is a Super or Classic server.
ServerVersion | Gets the version identification string of the Firebird Server.
SweepInterval | Gets the number of transactions that are committed between “sweeps” to remove database record versions that are no longer needed.
UpdateCount | Gets the number of database updates since the database was last attached.
Writes | Gets the number of page writes.

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


ActiveTransactions Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.ActiveTransactions Property

Gets the number of active transction.

[Visual Basic]
Public ReadOnly Property ActiveTransactions As Integer
[C#]
public int ActiveTransactions {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


ActiveUsers Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.ActiveUsers Property

[Visual Basic]
Public ReadOnly Property ActiveUsers As ArrayList
[C#]
public System.Collections.ArrayList ActiveUsers {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


AllocationPages Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.AllocationPages Property

Gets the number of database pages allocated.

[Visual Basic]
Public ReadOnly Property AllocationPages As Integer
[C#]
public int AllocationPages {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


BackoutCount Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.BackoutCount Property

Gets the number of removals of a version of a record.

[Visual Basic]
Public ReadOnly Property BackoutCount As Integer
[C#]
public int BackoutCount {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


BaseLevel Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.BaseLevel Property

Gets the database version (level) number.

[Visual Basic]
Public ReadOnly Property BaseLevel As String
[C#]
public string BaseLevel {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


Connection Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.Connection Property

Gets or sets the FbConnection used by this instance of the FbDataseInfo.

[Visual Basic]
Public Property Connection As FbConnection
[C#]
public FbConnection Connection {get; set;}

Property Value

The connection to a data source. The default is a null value.

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


CurrentMemory Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.CurrentMemory Property

Gets the Amount of server memory (in bytes) currently in use.

[Visual Basic]
Public ReadOnly Property CurrentMemory As Integer
[C#]
public int CurrentMemory {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


DatabaseSizeInPages Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.DatabaseSizeInPages Property

Gets the database size in pages.

[Visual Basic]
Public ReadOnly Property DatabaseSizeInPages As Integer
[C#]
public int DatabaseSizeInPages {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


DbId Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.DbId Property

Gets the database file name and site name.

[Visual Basic]
Public ReadOnly Property DbId As String
[C#]
public string DbId {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


DeleteCount Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.DeleteCount Property

Gets the number of database deletes since the database was last attached.

[Visual Basic]
Public ReadOnly Property DeleteCount As Integer
[C#]
public int DeleteCount {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


ExpungeCount Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.ExpungeCount Property

Gets the number of removals of a record and all of its ancestors, for records hose deletions have been committed.

[Visual Basic]
Public ReadOnly Property ExpungeCount As Integer
[C#]
public int ExpungeCount {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


Fetches Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.Fetches Property

Gets the number of reads from the memory buffer cache.

[Visual Basic]
Public ReadOnly Property Fetches As Integer
[C#]
public int Fetches {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


ForcedWrites Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.ForcedWrites Property

Gets the mode in which database writes are performed.

[Visual Basic]
Public ReadOnly Property ForcedWrites As Boolean
[C#]
public bool ForcedWrites {get;}

Property Value

true if database is in forced writes mode; false if not.

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


Implementation Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.Implementation Property

Gets the database implementation number.

[Visual Basic]
Public ReadOnly Property Implementation As String
[C#]
public string Implementation {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


InsertCount Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.InsertCount Property

Gets the number of inserts into the database since the database was last attached.

[Visual Basic]
Public ReadOnly Property InsertCount As Integer
[C#]
public int InsertCount {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


IscVersion Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.IscVersion Property

Gets the version identification string of the database implementation.

[Visual Basic]
Public ReadOnly Property IscVersion As String
[C#]
public string IscVersion {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


Marks Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.Marks Property

Gets the number of writes to the memory buffer cache.

[Visual Basic]
Public ReadOnly Property Marks As Integer
[C#]
public int Marks {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


MaxMemory Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.MaxMemory Property

Gets the Maximum amount of memory (in bytes) used at one time since the first process attached to the database.

[Visual Basic]
Public ReadOnly Property MaxMemory As Integer
[C#]
public int MaxMemory {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


NextTransaction Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.NextTransaction Property

Gets the number of the next transction.

[Visual Basic]
Public ReadOnly Property NextTransaction As Integer
[C#]
public int NextTransaction {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


NoReserve Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.NoReserve Property

Gets the indicates if space is reserved on each database page for holding.

[Visual Basic]
Public ReadOnly Property NoReserve As Boolean
[C#]
public bool NoReserve {get;}

Property Value

true if the space is reserved; false if not.

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


NumBuffers Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.NumBuffers Property

Gets the number of memory buffers currently allocated.

[Visual Basic]
Public ReadOnly Property NumBuffers As Integer
[C#]
public int NumBuffers {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


OdsMinorVersion Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.OdsMinorVersion Property

Gets the On-disk structure (ODS) minor version number.

[Visual Basic]
Public ReadOnly Property OdsMinorVersion As Integer
[C#]
public int OdsMinorVersion {get;}

Remarks

An increase in a minor version number indicates a non-structural change, one that still allows the database to be accessed by database engines with the same major version number but possibly different minor version numbers.

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


OdsVersion Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.OdsVersion Property

Gets the ODS major version number.

[Visual Basic]
Public ReadOnly Property OdsVersion As Integer
[C#]
public int OdsVersion {get;}

Remarks

• Databases with different major version numbers have different physical layouts; a database engine can only access databases with a particular ODS major version number.

• Trying to attach to a database with a different ODS number results in an error.

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


OldestActiveSnapshot Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.OldestActiveSnapshot Property

Gets the number of the oldest snapshot transaction.

[Visual Basic]
Public ReadOnly Property OldestActiveSnapshot As Integer
[C#]
public int OldestActiveSnapshot {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


OldestActiveTransaction Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.OldestActiveTransaction Property

Gets the number of the oldest active transaction.

[Visual Basic]
Public ReadOnly Property OldestActiveTransaction As Integer
[C#]
public int OldestActiveTransaction {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


OldestTransaction Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.OldestTransaction Property

Gets the number of the oldest transaction.

[Visual Basic]
Public ReadOnly Property OldestTransaction As Integer
[C#]
public int OldestTransaction {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


PageSize Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.PageSize Property

Gets the page size of the database.

[Visual Basic]
Public ReadOnly Property PageSize As Integer
[C#]
public int PageSize {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


PurgeCount Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.PurgeCount Property

Gets the number of removals of old versions of fully mature records.

[Visual Basic]
Public ReadOnly Property PurgeCount As Integer
[C#]
public int PurgeCount {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


ReadIdxCount Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.ReadIdxCount Property

Gets the number of reads done via an index since the database was last attached.

[Visual Basic]
Public ReadOnly Property ReadIdxCount As Integer
[C#]
public int ReadIdxCount {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


ReadOnly Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.ReadOnly Property

Gets wheter database is in readonly mode.

[Visual Basic]
Public ReadOnly Property ReadOnly As Boolean
[C#]
public bool ReadOnly {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


Reads Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.Reads Property

Gets the number of page reads.

[Visual Basic]
Public ReadOnly Property Reads As Integer
[C#]
public int Reads {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


ReadSeqCount Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.ReadSeqCount Property

Gets the number of sequential sequential table scans (row reads) done on each table since the database was last attached.

[Visual Basic]
Public ReadOnly Property ReadSeqCount As Integer
[C#]
public int ReadSeqCount {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


ServerClass Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.ServerClass Property

Gets wheter Firebird Server is a Super or Classic server.

[Visual Basic]
Public ReadOnly Property ServerClass As String
[C#]
public string ServerClass {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


ServerVersion Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.ServerVersion Property

Gets the version identification string of the Firebird Server.

[Visual Basic]
Public ReadOnly Property ServerVersion As String
[C#]
public string ServerVersion {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


SweepInterval Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.SweepInterval Property

Gets the number of transactions that are committed between “sweeps” to remove database record versions that are no longer needed.

[Visual Basic]
Public ReadOnly Property SweepInterval As Integer
[C#]
public int SweepInterval {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


UpdateCount Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.UpdateCount Property

Gets the number of database updates since the database was last attached.

[Visual Basic]
Public ReadOnly Property UpdateCount As Integer
[C#]
public int UpdateCount {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


Writes Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabaseInfo.Writes Property

Gets the number of page writes.

[Visual Basic]
Public ReadOnly Property Writes As Integer
[C#]
public int Writes {get;}

See Also

FbDatabaseInfo Class | FirebirdSql.Data.Firebird Namespace


FbDataReader Class

Provides a Way for reading a forward-only stream of rows. This class cannot be inherited.

For a list of all members of this type, see FbDataReader Members.

System.Object
System.MarshalByRefObject
FirebirdSql.Data.Firebird.FbDataReader

[Visual Basic]
<DefaultMember(MemberName:="Item")>
NotInheritable Public Class FbDataReader
Inherits MarshalByRefObject
Implements IDataReader, IDisposable, IDataRecord, IEnumerable
[C#]
[DefaultMember(MemberName="Item")]
public sealed class FbDataReader : MarshalByRefObject, IDataReader, IDisposable, IDataRecord, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This class cannot be instatiated directly, to create a FbDataReader, you need to call the ExecuteReader method of a FbCommand object.

Until the FbDataReader is closed using the Close method of of the FbDataReader, the associated FbConnection is busy busy serving the FbDataReader, and no other operations can be performed on the FbConnection other than closing it. This is the case until the Close method is called.

To retrieve output parameters you must close the FbDataReader.

IsClosed and RecordsAffected are the only properties that you can call after the FbDataReader is closed.

Example

public void ReadMyData(string myConnString)
{
    string mySelectQuery = "SELECT dept_no, departament FROM departament";

    FbConnection    myConnection = new FblConnection(myConnString);
    myConnection.Open();

    FbTransaction    myTxn         = myConnection.BeginTransaction();
    FbCommand        myCommand    = new FbCommand(mySelectQuery, myConnection, myTxn);

    FbDataReader myReader;
    myReader = myCommand.ExecuteReader();

    // Always call Read before accessing data.
    while (myReader.Read())
    {
    Console.WriteLine(myReader.GetInt32(0) + ", " + myReader.GetString(1));
    }

    // always call Close when done reading.
    myReader.Close();

    // Close the connection when done with it.
    myConnection.Close();
}

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbDataReader Members | FirebirdSql.Data.Firebird Namespace


FbDataReader Members

FbDataReader overview

Public Instance Properties

Depth | Gets the depth of nesting for the current row.
FieldCount | Gets the number of columns in the current row.
HasRows | Gets whether the FbDataReader contains one or more rows.
IsClosed | Gets a value indicating whether the data reader is closed.
Item | Overloaded. Gets the value of the specified column in its native format given the column ordinal.
RecordsAffected | Gets the number of rows changed, inserted, or deleted by execution of the DSQL statement.

Public Instance Methods

Close | Closes the FbDataReader object.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoolean | Gets the value of the specified column as a Boolean.
GetByte | Gets the value of the specified column as a byte.
GetBytes | Reads a stream of bytes from the specified column offset into the buffer as an array, starting at the given buffer offset.
GetChar | Gets the value of the specified column as a character.
GetChars | Reads a stream of characters from the specified column offset into the buffer as an array, starting at the given buffer offset.
GetData | NOT SUPPORTED.
GetDataTypeName | Gets the name of the source data type.
GetDateTime | Gets the value of the specified column as a DateTime object.
GetDecimal | Gets the value of the specified column as a Decimal object.
GetDouble | Gets the value of the specified column as a double-precision floating point number.
GetFieldType | Gets the Type that is the data type of the column.
GetFloat | Gets the value of the specified column as a single-precision floating-point number.
GetGuid | NOT SUPPORTED
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt16 | Gets the value of the specified column as a 16-bit signed integer.
GetInt32 | Gets the value of the specified column as a 32-bit signed integer.
GetInt64 | Gets the value of the specified column as a 64-bit signed integer.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetName | Gets the name of the specified column.
GetOrdinal | Gets the column ordinal, given the name of the column.
GetSchemaTable | Returns a DataTable that describes the column metadata of the FbDataReader.
GetString | Gets the value of the specified column as a string.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Gets the value of the specified column in its native format.
GetValues |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
IsDBNull | Gets a whether the column contains non-existent or missing values.
NextResult | Advances to the next result, when reading the results of batch DSQL statements.
Read | Advances the FbDataReader to the next record.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader Properties

The properties of the FbDataReader class are listed below. For a complete list of FbDataReader class members, see the FbDataReader Members topic.

Public Instance Properties

Depth | Gets the depth of nesting for the current row.
FieldCount | Gets the number of columns in the current row.
HasRows | Gets whether the FbDataReader contains one or more rows.
IsClosed | Gets a value indicating whether the data reader is closed.
Item | Overloaded. Gets the value of the specified column in its native format given the column ordinal.
RecordsAffected | Gets the number of rows changed, inserted, or deleted by execution of the DSQL statement.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


Depth Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDataReader.Depth Property

Gets the depth of nesting for the current row.

[Visual Basic]
NotOverridable Public ReadOnly Property Depth As Integer _
Implements IDataReader.Depth
[C#]
public int Depth {get;}

Property Value

The depth of nesting for the current row.

Implements

IDataReader.Depth

Remarks

The outermost table has a depth of zero. The Firebird .NET Data Provider does not support nesting and always returns zero.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FieldCount Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDataReader.FieldCount Property

Gets the number of columns in the current row.

[Visual Basic]
NotOverridable Public ReadOnly Property FieldCount As Integer _
Implements IDataRecord.FieldCount
[C#]
public int FieldCount {get;}

Property Value

When not positioned in a valid recordset, 0; otherwise the number of columns in the current row. The default is -1.

Implements

IDataRecord.FieldCount

Remarks

After executing a query that does not return rows, FieldCount returns 0.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


HasRows Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDataReader.HasRows Property

Gets whether the FbDataReader contains one or more rows.

[Visual Basic]
Public ReadOnly Property HasRows As Boolean
[C#]
public bool HasRows {get;}

Property Value

True if the FbDataReader contains one or more rows; otherwise false.

Remarks

This property returns always true.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


IsClosed Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDataReader.IsClosed Property

Gets a value indicating whether the data reader is closed.

[Visual Basic]
NotOverridable Public ReadOnly Property IsClosed As Boolean _
Implements IDataReader.IsClosed
[C#]
public bool IsClosed {get;}

Property Value

True if the FbDataReader is closed; otherwise, false.

Implements

IDataReader.IsClosed

Remarks

IsClosed and RecordsAffected are the only properties that you can call after the FbDataReader is closed.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


Item Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDataReader.Item Property

Gets the value of the specified column in its native format given the column ordinal.

Overload List

Gets the value of the specified column in its native format given the column ordinal.

public object this[int] {get;}

Gets the value of the specified column in its native format given the column name.

public object this[string] {get;}

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


Item Property (Int32)

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDataReader.Item Property (Int32)

Gets the value of the specified column in its native format given the column ordinal.

[Visual Basic]
NotOverridable Overloads Public Default ReadOnly Property Item( _
ByVal i As Integer _
) _
Implements IDataRecord.Item
As Object _
Implements IDataRecord.Item
[C#]
public object this[
int i
] {get;}

Parameters

i
The zero-based column ordinal.

Property Value

The value of the specified column in its native format.

Implements

IDataRecord.Item

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The index passed was outside the range of 0 through FieldCount.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace | FbDataReader.Item Overload List


Item Property (String)

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDataReader.Item Property (String)

Gets the value of the specified column in its native format given the column name.

[Visual Basic]
NotOverridable Overloads Public Default ReadOnly Property Item( _
ByVal name As String _
) _
Implements IDataRecord.Item
As Object _
Implements IDataRecord.Item
[C#]
public object this[
string name
] {get;}

Parameters

name
The column name.

Property Value

The value of the specified column in its native format.

Implements

IDataRecord.Item

Exceptions

Exception Type | Condition
IndexOutOfRangeException | No column with the specified name was found.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace | FbDataReader.Item Overload List


RecordsAffected Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDataReader.RecordsAffected Property

Gets the number of rows changed, inserted, or deleted by execution of the DSQL statement.

[Visual Basic]
NotOverridable Public ReadOnly Property RecordsAffected As Integer _
Implements IDataReader.RecordsAffected
[C#]
public int RecordsAffected {get;}

Property Value

The number of rows changed, inserted, or deleted; 0 if no rows were affected or the statement failed; and -1 for SELECT statements.

Implements

IDataReader.RecordsAffected

Remarks

The value of this property is cumulative. For example, if two records are inserted in batch mode, the value of RecordsAffected will be two.

IsClosed and RecordsAffected are the only properties that you can call after the FbDataReader is closed.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader Methods

The methods of the FbDataReader class are listed below. For a complete list of FbDataReader class members, see the FbDataReader Members topic.

Public Instance Methods

Close | Closes the FbDataReader object.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoolean | Gets the value of the specified column as a Boolean.
GetByte | Gets the value of the specified column as a byte.
GetBytes | Reads a stream of bytes from the specified column offset into the buffer as an array, starting at the given buffer offset.
GetChar | Gets the value of the specified column as a character.
GetChars | Reads a stream of characters from the specified column offset into the buffer as an array, starting at the given buffer offset.
GetData | NOT SUPPORTED.
GetDataTypeName | Gets the name of the source data type.
GetDateTime | Gets the value of the specified column as a DateTime object.
GetDecimal | Gets the value of the specified column as a Decimal object.
GetDouble | Gets the value of the specified column as a double-precision floating point number.
GetFieldType | Gets the Type that is the data type of the column.
GetFloat | Gets the value of the specified column as a single-precision floating-point number.
GetGuid | NOT SUPPORTED
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt16 | Gets the value of the specified column as a 16-bit signed integer.
GetInt32 | Gets the value of the specified column as a 32-bit signed integer.
GetInt64 | Gets the value of the specified column as a 64-bit signed integer.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetName | Gets the name of the specified column.
GetOrdinal | Gets the column ordinal, given the name of the column.
GetSchemaTable | Returns a DataTable that describes the column metadata of the FbDataReader.
GetString | Gets the value of the specified column as a string.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Gets the value of the specified column in its native format.
GetValues |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
IsDBNull | Gets a whether the column contains non-existent or missing values.
NextResult | Advances to the next result, when reading the results of batch DSQL statements.
Read | Advances the FbDataReader to the next record.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.Close Method

Closes the FbDataReader object.

[Visual Basic]
NotOverridable Public Sub Close() _
Implements IDataReader.Close
[C#]
public void Close();

Implements

IDataReader.Close

Remarks

You must explicitly call the Close method when you are using the FbDataReader to use the associated FbConnection for any other purpose.

The Close method fills in the values for output parameters, return values, increasing the amount of time it takes to close a FbDataReader.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetBoolean Method

Gets the value of the specified column as a Boolean.

[Visual Basic]
NotOverridable Public Function GetBoolean( _
ByVal i As Integer _
) As Boolean _
Implements IDataRecord.GetBoolean
[C#]
public bool GetBoolean(
int i
);

Parameters

i
The zero-based column ordinal.

Return Value

A Boolean that is the value of the column.

Implements

IDataRecord.GetBoolean

Remarks

Call IsDBNull to check for null values before calling this method.

Exceptions

Exception Type | Condition
InvalidCastException | The specified cast is not valid.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetByte Method

Gets the value of the specified column as a byte.

[Visual Basic]
NotOverridable Public Function GetByte( _
ByVal i As Integer _
) As Byte _
Implements IDataRecord.GetByte
[C#]
public byte GetByte(
int i
);

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as a byte.

Implements

IDataRecord.GetByte

Exceptions

Exception Type | Condition
InvalidCastException | The specified cast is not valid.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetBytes Method

Reads a stream of bytes from the specified column offset into the buffer as an array, starting at the given buffer offset.

[Visual Basic]
NotOverridable Public Function GetBytes( _
ByVal i As Integer, _
ByVal dataIndex As Long, _
ByVal buffer As Byte(), _
ByVal bufferIndex As Integer, _
ByVal length As Integer _
) As Long _
Implements IDataRecord.GetBytes
[C#]
public long GetBytes(
int i,
long dataIndex,
byte[] buffer,
int bufferIndex,
int length
);

Parameters

i
The zero-based column ordinal.
dataIndex
The index within the field where the read operation is to begin.
buffer
The buffer into which to read the stream of bytes.
bufferIndex
The index where buffer is to begin the write operation.
length
The number of bytes to read.

Return Value

The actual number of bytes read.

Implements

IDataRecord.GetBytes

Remarks

If you pass a buffer that is a null reference, GetBytes returns the length of the field in bytes.

No conversions are performed, therefore the data retrieved must already be a byte array.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetChar Method

Gets the value of the specified column as a character.

[Visual Basic]
<EditorBrowsable(State:=EditorBrowsableState.Never)>
NotOverridable Public Function GetChar( _
ByVal i As Integer _
) As Char _
Implements IDataRecord.GetChar
[C#]
[EditorBrowsable(State=EditorBrowsableState.Never)]
public char GetChar(
int i
);

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as a character.

Implements

IDataRecord.GetChar

Exceptions

Exception Type | Condition
InvalidCastException | The specified cast is not valid.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetChars Method

Reads a stream of characters from the specified column offset into the buffer as an array, starting at the given buffer offset.

[Visual Basic]
NotOverridable Public Function GetChars( _
ByVal i As Integer, _
ByVal dataIndex As Long, _
ByVal buffer As Char(), _
ByVal bufferIndex As Integer, _
ByVal length As Integer _
) As Long _
Implements IDataRecord.GetChars
[C#]
public long GetChars(
int i,
long dataIndex,
char[] buffer,
int bufferIndex,
int length
);

Parameters

i
The zero-based column ordinal.
dataIndex
The index within the field where the read operation is to begin.
buffer
The buffer into which to read the stream of bytes.
bufferIndex
The index where buffer is to begin the write operation.
length
The number of bytes to read.

Return Value

The actual number of characters read.

Implements

IDataRecord.GetChars

Remarks

If you pass a buffer that is a null reference, GetChars returns the length of the field in characters.

No conversions are performed, therefore the data retrieved must already be a character array.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace | GetBytes


FbDataReader.GetData Method

NOT SUPPORTED.

[Visual Basic]
<EditorBrowsable(State:=EditorBrowsableState.Never)>
NotOverridable Public Function GetData( _
ByVal i As Integer _
) As IDataReader _
Implements IDataRecord.GetData
[C#]
[EditorBrowsable(State=EditorBrowsableState.Never)]
public IDataReader GetData(
int i
);

Parameters

i
The zero-based column ordinal.

Return Value

Implements

IDataRecord.GetData

Exceptions

Exception Type | Condition
NotSupportedException | Always.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetDataTypeName Method

Gets the name of the source data type.

[Visual Basic]
NotOverridable Public Function GetDataTypeName( _
ByVal i As Integer _
) As String _
Implements IDataRecord.GetDataTypeName
[C#]
public string GetDataTypeName(
int i
);

Parameters

i
The zero-based column ordinal.

Return Value

The name of the back-end Data Type

Implements

IDataRecord.GetDataTypeName

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetDateTime Method

Gets the value of the specified column as a DateTime object.

[Visual Basic]
NotOverridable Public Function GetDateTime( _
ByVal i As Integer _
) As Date _
Implements IDataRecord.GetDateTime
[C#]
public DateTime GetDateTime(
int i
);

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as a DateTime object.

Implements

IDataRecord.GetDateTime

Exceptions

Exception Type | Condition
InvalidCastException | The specified cast is not valid.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetDecimal Method

Gets the value of the specified column as a Decimal object.

[Visual Basic]
NotOverridable Public Function GetDecimal( _
ByVal i As Integer _
) As Decimal _
Implements IDataRecord.GetDecimal
[C#]
public decimal GetDecimal(
int i
);

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as a Decimal object.

Implements

IDataRecord.GetDecimal

Exceptions

Exception Type | Condition
InvalidCastException | The specified cast is not valid.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetDouble Method

Gets the value of the specified column as a double-precision floating point number.

[Visual Basic]
NotOverridable Public Function GetDouble( _
ByVal i As Integer _
) As Double _
Implements IDataRecord.GetDouble
[C#]
public double GetDouble(
int i
);

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as a double-precision floating point number.

Implements

IDataRecord.GetDouble

Exceptions

Exception Type | Condition
InvalidCastException | The specified cast is not valid.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetFieldType Method

Gets the Type that is the data type of the column.

[Visual Basic]
NotOverridable Public Function GetFieldType( _
ByVal i As Integer _
) As Type _
Implements IDataRecord.GetFieldType
[C#]
public Type GetFieldType(
int i
);

Parameters

i
The zero-based column ordinal.

Return Value

The Type that is the data type of the object.

Implements

IDataRecord.GetFieldType

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetFloat Method

Gets the value of the specified column as a single-precision floating-point number.

[Visual Basic]
NotOverridable Public Function GetFloat( _
ByVal i As Integer _
) As Single _
Implements IDataRecord.GetFloat
[C#]
public float GetFloat(
int i
);

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as a single-precision floating-point number.

Implements

IDataRecord.GetFloat

Exceptions

Exception Type | Condition
InvalidCastException | The specified cast is not valid.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetGuid Method

NOT SUPPORTED

[Visual Basic]
NotOverridable Public Function GetGuid( _
ByVal i As Integer _
) As Guid _
Implements IDataRecord.GetGuid
[C#]
public Guid GetGuid(
int i
);

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as a GUID.

Implements

IDataRecord.GetGuid

Exceptions

Exception Type | Condition
NotSupportedException | Always.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetInt16 Method

Gets the value of the specified column as a 16-bit signed integer.

[Visual Basic]
NotOverridable Public Function GetInt16( _
ByVal i As Integer _
) As Short _
Implements IDataRecord.GetInt16
[C#]
public short GetInt16(
int i
);

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as a 16-bit signed integer.

Implements

IDataRecord.GetInt16

Exceptions

Exception Type | Condition
InvalidCastException | The specified cast is not valid.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetInt32 Method

Gets the value of the specified column as a 32-bit signed integer.

[Visual Basic]
NotOverridable Public Function GetInt32( _
ByVal i As Integer _
) As Integer _
Implements IDataRecord.GetInt32
[C#]
public int GetInt32(
int i
);

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as a 32-bit signed integer.

Implements

IDataRecord.GetInt32

Exceptions

Exception Type | Condition
InvalidCastException | The specified cast is not valid.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetInt64 Method

Gets the value of the specified column as a 64-bit signed integer.

[Visual Basic]
NotOverridable Public Function GetInt64( _
ByVal i As Integer _
) As Long _
Implements IDataRecord.GetInt64
[C#]
public long GetInt64(
int i
);

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as a 64-bit signed integer.

Implements

IDataRecord.GetInt64

Exceptions

Exception Type | Condition
InvalidCastException | The specified cast is not valid.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetName Method

Gets the name of the specified column.

[Visual Basic]
NotOverridable Public Function GetName( _
ByVal i As Integer _
) As String _
Implements IDataRecord.GetName
[C#]
public string GetName(
int i
);

Parameters

i
The zero-based column ordinal.

Return Value

The name of the column.

Implements

IDataRecord.GetName

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetOrdinal Method

Gets the column ordinal, given the name of the column.

[Visual Basic]
NotOverridable Public Function GetOrdinal( _
ByVal name As String _
) As Integer _
Implements IDataRecord.GetOrdinal
[C#]
public int GetOrdinal(
string name
);

Parameters

name
The name of teh column.

Return Value

The zero-based column ordinal.

Implements

IDataRecord.GetOrdinal

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetSchemaTable Method

Returns a DataTable that describes the column metadata of the FbDataReader.

[Visual Basic]
NotOverridable Public Function GetSchemaTable() As DataTable _
Implements IDataReader.GetSchemaTable
[C#]
public DataTable GetSchemaTable();

Return Value

A DataTable that describes the column metadata.

Implements

IDataReader.GetSchemaTable

Remarks

DataReader Column | Description
ColumnName | The name of the column; this might not be unique. If this cannot be determined, a null value is returned. This name always reflects the most recent renaming of the column in the current view or command text.
ColumnOrdinal | The ordinal of the column. Columns are numbered starting with one. This column cannot contain a null value.
ColumnSize | The maximum possible length of a value in the column. For columns that use a fixed-length data type, this is the size of the data type.
NumericPrecision | If ProviderType is a numeric data type, this is the maximum precision of the column. The precision depends on the definition of the column. If ProviderType is not a numeric data type, this is a null value.
NumericScale | If ProviderType is is DECIMAL or NUMERIC data type, the number of digits to the right of the decimal point. Otherwise, this is a null value.
DataType | Maps to the .NET Framework type of the column.
ProviderType | The indicator of the column's data type. If the data type of the column varies from row to row, this must be Object. This column cannot contain a null value.
IsLong | True if the column contains a BLOB that contains very long data; otherwise false.
AllowDbNull | True if the column allows null values; otherwise false.
IsReadOnly | True if the column cannot be modified; otherwise false.
IsRowVersion | Set if the column contains a persistent row identifier that cannot be written to, and has no meaningful value except to identity the row.
IsUnique | true if the the column is one of a set of columns of a unique key.
IsKey | true if the the column is one of a set of columns of a primary key.
IsAutoIncrement | true if the column assigns values to new rows in fixed increments; otherwise false. The default of this column is false.
IsAliased | True if the column name is an alias; otherwise false.
IsExpression | True if the column is an expression; otherwise false.
BaseSchemaName | As Firebird doesn't support Schemas this column will be always NULL.
BaseCatalogName | As Firebird doesn't support Catalogs this column will be always NULL.
BaseTableName | The name of the table or view in the data store that contains the column. A null value if the base table name cannot be determined. The default of this column is a null value.
BaseColumnName | The name of the column in the data store. This might be different than the column name returned in the ColumnName column if an alias was used. A null value if the base column name cannot be determined or if the rowset column is derived, but not identical to, a column in the data store. The default of this column is a null value.

Exceptions

Exception Type | Condition
InvalidOperationException | The FbDataReader is closed.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetString Method

Gets the value of the specified column as a string.

[Visual Basic]
NotOverridable Public Function GetString( _
ByVal i As Integer _
) As String _
Implements IDataRecord.GetString
[C#]
public string GetString(
int i
);

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as a string.

Implements

IDataRecord.GetString

Exceptions

Exception Type | Condition
InvalidCastException | The specified cast is not valid.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetValue Method

Gets the value of the specified column in its native format.

[Visual Basic]
NotOverridable Public Function GetValue( _
ByVal i As Integer _
) As Object _
Implements IDataRecord.GetValue
[C#]
public object GetValue(
int i
);

Parameters

i
The zero-based column ordinal.

Return Value

The value to return.

Implements

IDataRecord.GetValue

Remarks

This method returns null valus as DBNull.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.GetValues Method

[Visual Basic]
NotOverridable Public Function GetValues( _
ByVal values As Object() _
) As Integer _
Implements IDataRecord.GetValues
[C#]
public int GetValues(
object[] values
);

Implements

IDataRecord.GetValues

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.IsDBNull Method

Gets a whether the column contains non-existent or missing values.

[Visual Basic]
NotOverridable Public Function IsDBNull( _
ByVal i As Integer _
) As Boolean _
Implements IDataRecord.IsDBNull
[C#]
public bool IsDBNull(
int i
);

Parameters

i
The zero-based column ordinal.

Return Value

true if the specified column value is equivalent to DBNull; otherwise, false.

Implements

IDataRecord.IsDBNull

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.NextResult Method

Advances to the next result, when reading the results of batch DSQL statements.

[Visual Basic]
NotOverridable Public Function NextResult() As Boolean _
Implements IDataReader.NextResult
[C#]
public bool NextResult();

Return Value

true if there are more result sets; otherwise, false.

Implements

IDataReader.NextResult

Remarks

Used to process execution of batch DSQL statements.

By default, the data reader is positioned on the first result.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDataReader.Read Method

Advances the FbDataReader to the next record.

[Visual Basic]
NotOverridable Public Function Read() As Boolean _
Implements IDataReader.Read
[C#]
public bool Read();

Return Value

true if there are more rows; otherwise, false.

Implements

IDataReader.Read

Remarks

The default position of the FbDataReader is prior to the first record. Therefore, you must call Read to begin accessing any data.

Only one FbDataReader per FbConnection can be open at a time, and any attempt to open another will fail until the first one is closed. Similarly, while the FbDataReader is in use, the associated FbConnection is busy serving it until you close the FbDataReader by call Close method.

See Also

FbDataReader Class | FirebirdSql.Data.Firebird Namespace


FbDbSchemaType Enumeration

NOTE: This enumeration is now obsolete.

Use the FbConnection.GetSchema() methods.

Retrieves the the type of schema table that can be used with the GetDbSchemaTable method.

[Visual Basic]
<Serializable, _ Serializable, _ Obsolete(Message:="Use the FbConnection.GetSchema() methods.", IsError:=False)>
Public Enum FbDbSchemaType
[C#]
[Serializable]
[Serializable]
[Obsolete(Message="Use the FbConnection.GetSchema() methods.", IsError=False)]
public enum FbDbSchemaType

Members

Member Name Description
CharacterSets

Retrieves the character sets defined in the database.

The list of returned columns for this schema type is:

Column | Description | *
CHARACTER_SET_CATALOG |  | 0
CHARACTER_SET_SCHEMA |  | 1
CHARACTER_SET_NAME | The name of the character set. | 2
CHARACTER_SET_ID | The id of the character set. |
DEFAULT_COLLATION | The default collation of the character set. |
BYTES_PER_CHARACTER | The number of bytes per character. |
DESCRIPTION | The character set description |

CheckConstraints

Retrieves the check constraints defined in the database.

The list of returned columns for this schema type is:

Column | Description | *
CONSTRAINT_CATALOG |  | 0
CONSTRAINT_SCHEMA |  | 1
CONSTRAINT_NAME | The name of the constraint. | 2
CHECK_CLAUSULE | The chek clausule of the constraint. |
DESCRIPTION | The description of the check constraint |

CheckConstraintsByTable

Retrieves the check constraints, by table,defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
CONSTRAINT_CATALOG |  | 0
CONSTRAINT_SCHEMA |  | 1
CONSTRAINT_NAME | The name of the constraint. | 2
TABLE_NAME | The name of the table. |
CHECK_CLAUSULE | The clausule of the check constraint. |
DESCRIPTION | The description of the check constraint |

Collations

Retrieves the collations defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
COLLATION_CATALOG |  | 0
COLLATION_SCHEMA |  | 1
COLLATION_NAME | The name of the collation. | 1
CHARACTER_SET_NAME | The name of the character set. |
DESCRIPTION | The description of the collation. |

Columns

Retrieves the columns of tables ( including views ) defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
TABLE_CATALOG |  | 0
TABLE_SCHEMA |  | 1
TABLE_NAME | The name of the table. | 2
COLUMN_NAME | The name of the column. | 3
COLUMN_DATA_TYPE | The data type name of the column. |
COLUMN_SUB_TYPE | The sub type of the column. |
COLUMN_SIZE | The maximum possible length of a value in the column. |
NUMERIC_PRECISION | The maximum precision of the column for numeric data types. |
NUMERIC_SCALE | The maximum scale of the column for decimal and numeric data types. |
CHARACTER_OCTET_LENGTH | For char and varchar columns the maximun number of bytes in the column. |
ORDINAL_POSITION | The ordinal of the column. |
COLUMN_DEFAULT | The default value of the column. |
IS_NULLABLE | True if the column allows null values; otherwise false. |
IS_READONLY | True if the column cannot be modified; otherwise false. |
IS_ARRAY | True if the column has array data type; otherwise false. |
CHARACTER_SET_NAME | The caracter set name of the column. |
COLLATION_NAME | The collation name of the column. |
DESCRIPTION | Column description. |

ColumnPrivileges Retrieves the columns Privileges defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
TABLE_CATALOG |  | 0
TABLE_SCHEMA |  | 1
TABLE_NAME | The name of the table. | 1
COLUMN_NAME | The name of the column. | 2
GRANTEE | User name to who the privilege has been granted. |
GRANTOR | User who granted the privileges on the table. |
PRIVILEGE | Privilege type. |
WITH_GRANT | Privilege set with the grant option. |

DataTypes Retrieves the data types supported by Firebird Server.

The list of returned columns for this schema type is:

Column name Description *

Domains Retrieves the domains defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
DOMAIN_CATALOG |  | 0
DOMAIN_SCHEMA |  | 1
DOMAIN_NAME | The name of the domain. | 2
DOMAIN_DATA_TYPE | The data type name of the domain. |
DOMAIN_SUB_TYPE | The sub type of the domain. |
DOMAIN_SIZE | The maximum possible length of a value in the domain. |
NUMERIC_PRECISION | The maximum precision of the domain for numeric data types. |
NUMERIC_SCALE | The maximum scale of the domain for decimal and numeric data types. |
CHARACTER_OCTET_LENGTH | For char and varchar columns the maximun number of bytes in the column. |
IS_NULLABLE | True if the domain allows null values; otherwise false. |
ARRAY_DIMENSIONS | If the data type of the domain is an array type, the number of dimensions of the array. |
DESCRIPTION | Domain description. |

ForeignKeys Retrieves the foreign keys defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
PK_TABLE_CATALOG |  | 0
PK_TABLE_SCHEMA |  | 1
PK_TABLE_NAME | The name of the primary key table. | 2
FK_TABLE_CATALOG |  | 3
FK_TABLE_SCHEMA |  | 4
FK_TABLE_NAME | The name of the foreign key table. | 5
PK_COLUMN_NAME | The name of the primary key column. |
FK_COLUMN_NAME | The name of the foreign key column. |
FK_NAME | The name of the foreign key. |
ORDINAL_POSITION | The ordinal of the column. |
MATCH_OPTION |  |
UPDATE_RULE | Update rule. |
DELETE_RULE | Delete rule. |
IS_DEFERRABLE |  |
DEFERRABLITY |  |

Functions Retrieves the external Functions defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
FUNCTION_CATALOG |  | 0
FUNCTION_SCHEMA |  | 1
FUNCTION_NAME | The name of the function. | 2
IS_SYSTEM_FUNCTION | Indicates wheter the function is a system function. | 1
FUNCTION_TYPE | The type of the function. |
QUERY_NAME |  |
FUNCTION_MODULE_NAME | The name of the function module. |
FUNCTION_ENTRY_POINT | Entry point. |
RETURN_ARGUMENT |  |
DESCRIPTION | The description of the function. |

Generators Retrieves the generators defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
GENERATOR_CATALOG |  | 0
GENERATOR_SCHEMA |  | 1
GENERATOR_NAME | The name of the generator. | 2
IS_SYSTEM_GENERATOR | Indcates wheter the genaror is a system generator. | 1
GENERATOR_ID | The id of the generator. |

Indexes Retrieves the indexes defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
TABLE_CATALOG |  | 0
TABLE_SCHEMA |  | 1
TABLE_NAME | The name of the table. | 2
INDEX_NAME | The name of the index. | 3
INDEX_TYPE | The type of the index |
COLUMN_NAME | The name of the column. |
ORDINAL_POSITION | The ordinal of the column. |
IS_INACTIVE | Indicates wheter the index is inactive. |
IS_SYSTEM_INDEX | Indicates wheter the index is a system index. |
IS_UNIQUE | Indicates wheter the index is aunique index. |
INDEX_STATISTICS | The statistics of the index. |
DESCRIPTION | The description of the index. |

MetaDataCollections Retrieves the supported metadata collections (schemas).

The list of returned columns for this schema type is:

Column name | Description | *
CollectionName | Metadata collection name. |
NumberOfRestrictions | Max number of restrictions allowed for the metadata collection. |
NumberOfIdentifierParts | Max number of restrictions allowed for the metadata collection. |

PrimaryKeys Retrieves the primary key columns defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
TABLE_CATALOG
TABLE_SCHEMA
TABLE_NAME | The name of the table. | 0
COLUMN_NAME | The name of the column. |
ORDINAL_POSITION | The ordinal of the column. |
PK_NAME | The name of the primary key. |

ProcedureParameters Retrieves the parameters of stored procedures defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
PROCEDURE_CATALOG |  | 0
PROCEDURE_SCHEMA |  | 1
PROCEDURE_NAME | The name of the stored procedure. | 2
PARAMETER_NAME | The of the stored procedure parameter |
ORDINAL_POSITION | The ordinal of the parameter. |
PARAMETER_DIRECTION | The direction of the stored procedure parameter (input/output) |
PARAMETER_DATA_TYPE | The data type name of the stored procedure parameter. |
PARAMETER_SUB_TYPE | The sub type of the stored procedure parameter. |
PARAMETER_SIZE | The maximum possible length of a value in the paremeter. |
NUMERIC_PRECISION | The maximum precision of the parameter for numeric data types. |
NUMERIC_SCALE | The maximum scale of the parameter for decimal and numeric data types. |
CHARACTER_OCTET_LENGTH | For char and varchar columns the maximun number of bytes in the column. |
CHARACTER_SET_NAME | Character set of the parameter. |
COLLATION_NAME | Collation of the parameter. |
DESCRIPTION | The description of the stored procedure parameter. |

ProcedurePrivileges Retrieves the privileges of stored procedures defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
PROCEDURE_CATALOG |  | 0
PROCEDURE_SCHEMA |  | 1
PROCEDURE_NAME | The name of the stored procedure. | 2
GRANTEE | User name to who the privilege has been granted. |
GRANTOR | User who granted the privileges on the table. |
PRIVILEGE | Privilege type. |
WITH_GRANT | Privilege set with the grant option. |

Procedures Retrieves the stored procedures defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
PROCEDURE_CATALOG |  | 0
PROCEDURE_SCHEMA |  | 1
PROCEDURE_NAME | The name of the stored procedure. | 2
INPUTS | The number of input parameters of the stored procedure. |
OUTPUTS | The number of output parameters of the stored procedure. |
DESCRIPTION | The description of the stored procedure. |

Restrictions Retrieves the list of restrictions supported by each metadata collection.

The list of returned columns for this collection is:

Column name | Description | *
RestrictionName | Metadata collection name. |
RestrictionDefault |  |
RestrictionNumber | Ordinal of the colelction srestriction. |

Roles Retrieves the user roles defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
ROLE_NAME | The name of the role. | 0
OWNER |  |

TableConstraints
TablePrivileges Retrieves the table privileges defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
TABLE_CATALOG |  | 0
TABLE_SCHEMA |  | 1
TABLE_NAME | The name of the table. | 2
GRANTEE | User name to who the privilege has been granted. |
GRANTOR | User who granted the privileges on the table. |
PRIVILEGE | Privilege type. |
WITH_GRANT | Privilege set with the grant option. |

Tables Retrieves the tables defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
TABLE_CATALOG |  | 0
TABLE_SCHEMA |  | 1
TABLE_NAME | The name of the table. | 2
TABLE_TYPE | The type of the table. | 3
IS_SYSTEM_TABLE | Indicates wheter the table is a system table. |
OWNER_NAME |  |
DESCRIPTION | The description of the table. |

Triggers Retrieves the triggers defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
TABLE_CATALOG |  | 0
TABLE_SCHEMA |  | 1
TABLE_NAME | The name of the table. | 2
TRIGGER_NAME | The name of the trigger. | 3
IS_SYSTEM_TRIGGER | Indicates wheter the trigger is a system trigger. |
IS_INACTIVE | Indicates wheter the trigger is inactive. |
SEQUENCE | Execution sequence number. |
SOURCE | The source of the trigger. |
DESCRIPTION | The description of the trigger. |

UniqueKeys Retrieves the unique key columns defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
_CATALOG |  | 0
TABLE_SCHEMA |  | 1
TABLE_NAME | The name of the table. | 2
COLUMN_NAME | The name of the column. |
ORDINAL_POSITION | The ordinal of the column. |
UK_NAME | The name of the unique key. |

ViewColumnUsage Retrieves the view column usage information defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
VIEW_CATALOG |  | 0
VIEW_SCHEMA |  | 1
VIEW_NAME | The name of the view. | 2
COLUMN_NAME | The name of the column. | 3
COLUMN_DATA_TYPE | The data type name of the column. |
COLUMN_SUB_TYPE | The sub type of the column. |
COLUMN_SIZE | The maximum possible length of a value in the column. |
NUMERIC_PRECISION | The maximum precision of the column for numeric data types. |
NUMERIC_SCALE | The maximum scale of the column for decimal and numeric data types. |
CHARACTER_OCTET_LENGTH | For char and varchar columns the maximun number of bytes in the column. |
ORDINAL_POSITION | The ordinal of the column. |
COLUMN_DEFAULT | The default value of the column. |
IS_ARRAY | True if the column has array data type; otherwise false. |
IS_NULLABLE | True if the column allows null values; otherwise false. |
DESCRIPTION | The description of the column. |

ViewPrivileges Retrieves the view privileges defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
VIEW_CATALOG |  | 0
VIEW_SCHEMA |  | 1
VIEW_NAME | The name of the view. | 2
GRANTEE | User name to who the privilege has been granted. |
GRANTOR | User who granted the privileges on the table. |
PRIVILEGE | Privilege type. |
WITH_GRANT | Privilege set with the grant option. |

Views Retrieves the views defined in the database.

The list of returned columns for this schema type is:

Column name | Description | *
VIEW_CATALOG |  | 0
VIEW_SCHEMA |  | 1
VIEW_NAME | The name of the view. | 2
DEFINITION | The SQL definition of the view. |
DESCRIPTION | The description of the view. |

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird Namespace


FbDbType Enumeration

Specifies the data type of a field, property, or FbParameter.

[Visual Basic]
<Serializable, _ Serializable>
Public Enum FbDbType
[C#]
[Serializable]
[Serializable]
public enum FbDbType

Members

Member Name | Description
Array | Array values. This maps to System.Array.
BigInt | Exact numeric value (SQL_INT64). This maps to Int64.
Binary | A stream of binary data (SQL_BLOB). This maps to an Array of type Byte.
Char | A fixed-length character string (SQL_CHAR). This maps to String.
Date | Date data (SQL_TYPE_DATE). This maps to DateTime.
Decimal | Signed, exact, numeric value with a precision of at least p and scale s, The maximum precision is 18 (SQL_DECIMAL). This maps to Decimal.
Double | Signed, approximate, numeric value with a binary precision 53 (SQL_DOUBLE). This maps to Double.
Float | Signed, approximate, numeric value with a binary precision 24 (SQL_FLOAT). This maps to Single.
Guid | Globally unique identifier.
Integer | Exact numeric value with precision 10 and scale 0 (SQL_LONG). This maps to Int32.
Numeric | Signed, exact, numeric value with a precision p and scale s (SQL_DECIMAL). This maps to Decimal.
SmallInt | Exact numeric value with precision 5 and scale 0 (SQL_SHORT). This maps to Int16.
Text | Variable length character data. Maximum length is data source–dependent (SQL_TEXT). This maps to String.
Time | Time data (SQL_TYPE_TIME). This maps to DateTime.
TimeStamp | Date data (SQL_TIMESTAMP). This maps to DateTime.
VarChar | A variable-length character string (SQL_TEXT). This maps to String.

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird Namespace


FbError Class

Collects information relevant to a error returned by Firebird. This class cannot be inherited.

For a list of all members of this type, see FbError Members.

System.Object
FirebirdSql.Data.Firebird.FbError

[Visual Basic]
<Serializable, _ Serializable>
NotInheritable Public Class FbError
[C#]
[Serializable]
[Serializable]
public sealed class FbError

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This class is instantiated by the Firebird .NET Data Provider when an error occurs. An instance of FbError is created and managed by the FbException class.

Example

public void DisplayFbErrors(FbException myException)
{
    for (int i=0; i < myException.Errors.Count; i++)
    {
       MessageBox.Show("Index #" + i + "\n" +
            "Error: " + myException.Errors[i].ToString() + "\n");
    }
}

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbError Members | FirebirdSql.Data.Firebird Namespace


FbError Members

FbError overview

Public Instance Properties

Class | Gets the severity level of the error returned from Firebird.
LineNumber | Gets the line number within the DSQL command batch or stored procedure that contains the error.
Message | Gets the text describing the error.
Number | Gets a number that identifies the type of error.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbError Class | FirebirdSql.Data.Firebird Namespace


FbError Properties

The properties of the FbError class are listed below. For a complete list of FbError class members, see the FbError Members topic.

Public Instance Properties

Class | Gets the severity level of the error returned from Firebird.
LineNumber | Gets the line number within the DSQL command batch or stored procedure that contains the error.
Message | Gets the text describing the error.
Number | Gets a number that identifies the type of error.

See Also

FbError Class | FirebirdSql.Data.Firebird Namespace


Class Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbError.Class Property

Gets the severity level of the error returned from Firebird.

[Visual Basic]
Public ReadOnly Property Class As Byte
[C#]
public byte Class {get;}

Property Value

A value from 1 to 25 that indicates the severity level of the error. The default is 0.

See Also

FbError Class | FirebirdSql.Data.Firebird Namespace


LineNumber Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbError.LineNumber Property

Gets the line number within the DSQL command batch or stored procedure that contains the error.

[Visual Basic]
Public ReadOnly Property LineNumber As Integer
[C#]
public int LineNumber {get;}

Property Value

The line number within the DSQL command batch or stored procedure that contains the error.

Remarks

Line numbering starts at 1. If the value is 0, the line number is not applicable.

See Also

FbError Class | FirebirdSql.Data.Firebird Namespace


Message Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbError.Message Property

Gets the text describing the error.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}

See Also

FbError Class | FirebirdSql.Data.Firebird Namespace


Number Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbError.Number Property

Gets a number that identifies the type of error.

[Visual Basic]
Public ReadOnly Property Number As Integer
[C#]
public int Number {get;}

See Also

FbError Class | FirebirdSql.Data.Firebird Namespace


FbErrorCollection Class

Collects all errors generated by the Firebird .NET Data Provider. This class cannot be inherited.

For a list of all members of this type, see FbErrorCollection Members.

System.Object
FirebirdSql.Data.Firebird.FbErrorCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item"), _ ListBindable(ListBindable:=False)>
NotInheritable Public Class FbErrorCollection
Implements ICollection, IEnumerable
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
[ListBindable(ListBindable=False)]
public sealed class FbErrorCollection : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This class is created by FbException to collect instances of the FbError class. FbErrorCollection always contains at least one instance of the FbError class.

Example

The example display each FbError within the FbCollection collection.

public void DisplayFbErrors(FbException myException)
{
    for (int i=0; i < myException.Errors.Count; i++)
    {
    MessageBox.Show("Index #" + i + "\n" +
            "Error: " + myException.Errors[i].ToString() + "\n");
    }
}

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbErrorCollection Members | FirebirdSql.Data.Firebird Namespace


FbErrorCollection Members

FbErrorCollection overview

Public Instance Properties

Count | Gets the number of FbError objects in the collection.
Item |

Public Instance Methods

CopyTo | Copies the elements of the FbErrorCollection collection into an Array, starting at the given index within the Array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbErrorCollection Class | FirebirdSql.Data.Firebird Namespace


FbErrorCollection Properties

The properties of the FbErrorCollection class are listed below. For a complete list of FbErrorCollection class members, see the FbErrorCollection Members topic.

Public Instance Properties

Count | Gets the number of FbError objects in the collection.
Item |

See Also

FbErrorCollection Class | FirebirdSql.Data.Firebird Namespace


Count Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbErrorCollection.Count Property

Gets the number of FbError objects in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Property Value

The number of FbError objects in the collection.

Implements

ICollection.Count

See Also

FbErrorCollection Class | FirebirdSql.Data.Firebird Namespace


Item Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbErrorCollection.Item Property

[Visual Basic]
Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As FbError
[C#]
public FbError this[
int index
] {get;}

See Also

FbErrorCollection Class | FirebirdSql.Data.Firebird Namespace


FbErrorCollection Methods

The methods of the FbErrorCollection class are listed below. For a complete list of FbErrorCollection class members, see the FbErrorCollection Members topic.

Public Instance Methods

CopyTo | Copies the elements of the FbErrorCollection collection into an Array, starting at the given index within the Array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbErrorCollection Class | FirebirdSql.Data.Firebird Namespace


FbErrorCollection.CopyTo Method

Copies the elements of the FbErrorCollection collection into an Array, starting at the given index within the Array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
The Array to copy elements into.
index
The index from which to start copying into the array parameter.

Implements

ICollection.CopyTo

Exceptions

Exception Type | Condition
ArgumentException | The sum of index and the number of elements in the FbErrorCollection collection is greater than Array.
ArgumentNullException | The array is a null reference.
ArgumentOutOfRangeException | The index is not valid for the array.

See Also

FbErrorCollection Class | FirebirdSql.Data.Firebird Namespace


FbException Class

The exception that is thrown when Firebird Server returns a warning or error. This class cannot be inherited.

For a list of all members of this type, see FbException Members.

System.Object
System.Exception
System.SystemException
FirebirdSql.Data.Firebird.FbException

[Visual Basic]
<Serializable, _ Serializable>
NotInheritable Public Class FbException
Inherits SystemException
[C#]
[Serializable]
[Serializable]
public sealed class FbException : SystemException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This class is created whenever the Firebird Server .NET Data Provider encounters an error generated from the server. FbException always contains at least one instance of FbError.

Example

public void ThrowFbException()
{
    string         myConnString = "Database=C:\\PROGRAM FILES\\FIREBIRD\\EXAMPLES\\EMPLOYEE.GDB;User=SYSDBA;Password=masterkey;Dialect=3;Server=localhost";
    FbConnection myConnection  = new FbConnection(myConnString);

    try
    {
    myConnection.Open();
    }
    catch (FbException e)
    {
    FbErrorCollection myErrors = e.Errors;

    Console.WriteLine("Class: {1}", e.Class);
    Console.WriteLine("Error #{1}: {2} on line {3}.", e.Number, e.Message, e.LineNumber);
    Console.WriteLine("Error reported by {1} while connected to {2}", e.Source, e.Server);
    Console.WriteLine("Neither record was written to database.");
    Console.WriteLine("Errors collection contains:");

    for (int i=0; i < myErrors.Errors.Count; i++)
    {
        Console.WriteLine("Class: {1}", myErrors[i].Class);
        Console.WriteLine("Error #{1}: {2} on line {3}.", myErrors[i].Number, myErrors[i].Message, myErrors[i].LineNumber);
        Console.WriteLine("Error reported by {1} while connected to {2}", myErrors[i].Source, myErrors[i].Server);
    }
    }
}

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbException Members | FirebirdSql.Data.Firebird Namespace


FbException Members

FbException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode | Gets a value representing the Firebird error code
Errors | Gets a collection of one or more FbError objects that give detailed information about exceptions generated by the Firebird .NET Data Provider.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Sets the serialization information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

See Also

FbException Class | FirebirdSql.Data.Firebird Namespace


FbException Properties

The properties of the FbException class are listed below. For a complete list of FbException class members, see the FbException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode | Gets a value representing the Firebird error code
Errors | Gets a collection of one or more FbError objects that give detailed information about exceptions generated by the Firebird .NET Data Provider.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

FbException Class | FirebirdSql.Data.Firebird Namespace


ErrorCode Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbException.ErrorCode Property

Gets a value representing the Firebird error code

[Visual Basic]
Public ReadOnly Property ErrorCode As Integer
[C#]
public int ErrorCode {get;}

See Also

FbException Class | FirebirdSql.Data.Firebird Namespace


Errors Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbException.Errors Property

Gets a collection of one or more FbError objects that give detailed information about exceptions generated by the Firebird .NET Data Provider.

[Visual Basic]
<DesignerSerializationVisibility(Visibility:=DesignerSerializationVisibility.Content)>
Public ReadOnly Property Errors As FbErrorCollection
[C#]
[DesignerSerializationVisibility(Visibility=DesignerSerializationVisibility.Content)]
public FbErrorCollection Errors {get;}

See Also

FbException Class | FirebirdSql.Data.Firebird Namespace


FbException Methods

The methods of the FbException class are listed below. For a complete list of FbException class members, see the FbException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Sets the serialization information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

See Also

FbException Class | FirebirdSql.Data.Firebird Namespace


FbException.GetObjectData Method

Sets the serialization information about the exception.

[Visual Basic]
Overrides Public Sub GetObjectData( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
) _
Implements ISerializable.GetObjectData
[C#]
public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable.GetObjectData

See Also

FbException Class | FirebirdSql.Data.Firebird Namespace


FbInfoMessageEventArgs Class

Provides data for the InfoMessage event. This class cannot be inherited.

For a list of all members of this type, see FbInfoMessageEventArgs Members.

System.Object
System.EventArgs
FirebirdSql.Data.Firebird.FbInfoMessageEventArgs

[Visual Basic]
NotInheritable Public Class FbInfoMessageEventArgs
Inherits EventArgs
[C#]
public sealed class FbInfoMessageEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The InfoMessage event contains an FbErrorCollection collection with warnings messages sent from the Firebird Server.

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbInfoMessageEventArgs Members | FirebirdSql.Data.Firebird Namespace


FbInfoMessageEventArgs Members

FbInfoMessageEventArgs overview

Public Instance Properties

Errors | Gets the collection of warnings sent from the Firebird Server.
Message | Gets a value representing the complete error message sent from the Firebird Server.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbInfoMessageEventArgs Class | FirebirdSql.Data.Firebird Namespace


FbInfoMessageEventArgs Properties

The properties of the FbInfoMessageEventArgs class are listed below. For a complete list of FbInfoMessageEventArgs class members, see the FbInfoMessageEventArgs Members topic.

Public Instance Properties

Errors | Gets the collection of warnings sent from the Firebird Server.
Message | Gets a value representing the complete error message sent from the Firebird Server.

See Also

FbInfoMessageEventArgs Class | FirebirdSql.Data.Firebird Namespace


Errors Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbInfoMessageEventArgs.Errors Property

Gets the collection of warnings sent from the Firebird Server.

[Visual Basic]
Public ReadOnly Property Errors As FbErrorCollection
[C#]
public FbErrorCollection Errors {get;}

Property Value

The collection of warnings sent from the Firebird Server.

See Also

FbInfoMessageEventArgs Class | FirebirdSql.Data.Firebird Namespace


Message Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbInfoMessageEventArgs.Message Property

Gets a value representing the complete error message sent from the Firebird Server.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}

Property Value

Complete error message.

See Also

FbInfoMessageEventArgs Class | FirebirdSql.Data.Firebird Namespace


FbInfoMessageEventHandler Delegate

Represents the method that will handle the InfoMessage event of an FbConnection.

[Visual Basic]
Public Delegate Sub FbInfoMessageEventHandler( _
ByVal sender As Object, _
ByVal e As FbInfoMessageEventArgs _
)
[C#]
public delegate void FbInfoMessageEventHandler(
object sender,
FbInfoMessageEventArgs e
);

Parameters

sender
The source of the event.
e
An FbInfoMessageEventArgs object that contains the event data.

Remarks

When you create an FbInfoMessageEventArgs delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird Namespace


FbParameter Class

Represents a parameter of a FbCommand, and optionally, its mapping to DataSet columns. This class cannot be inherited.

For a list of all members of this type, see FbParameter Members.

System.Object
System.MarshalByRefObject
FirebirdSql.Data.Firebird.FbParameter

[Visual Basic]
<ParenthesizePropertyName(NeedParenthesis:=True), _ TypeConverter(ConverterTypeName:="FirebirdSql.Data.Firebird.Design.FbParameterConverter, FirebirdSql.Data.Firebird, Version=1.7.1.0, Culture=neutral, PublicKeyToken=fa843d180294369d")>
NotInheritable Public Class FbParameter
Inherits MarshalByRefObject
Implements IDbDataParameter, IDataParameter, ICloneable
[C#]
[ParenthesizePropertyName(NeedParenthesis=True)]
[TypeConverter(ConverterTypeName="FirebirdSql.Data.Firebird.Design.FbParameterConverter, FirebirdSql.Data.Firebird, Version=1.7.1.0, Culture=neutral, PublicKeyToken=fa843d180294369d")]
public sealed class FbParameter : MarshalByRefObject, IDbDataParameter, IDataParameter, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Parameter names are not case sensitive.

Example

public void AddFbParameters()
{
// ...
// create myDataSet and myDataAdapter
// ...

  myDataAdapter.SelectCommand.Parameters.Add("@CategoryName", FbDbType.VarChar, 80).Value = "toasters";
  myDataAdapter.SelectCommand.Parameters.Add("@SerialNum", FbDbType.Integer).Value = 239;
  myDataAdapter.Fill(myDataSet);

}

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbParameter Members | FirebirdSql.Data.Firebird Namespace


FbParameter Members

FbParameter overview

Public Instance Constructors

FbParameter Overloaded. Initializes a new instance of the FbParameter class.

Public Instance Properties

Charset | Gets or sets the Charset of the parameter.
DbType | Gets or sets the DbType of the parameter.
Direction | Gets or sets the Direction of the parameter.
FbDbType |
IsNullable | Gets or sets whether the parameter accepts null values.
ParameterName | Gets or sets the name of the FbParameter.
Precision | Gets or sets the maximum number of digits used to represent the parameter value.
Scale | Gets or sets the number of decimal places to which parameter value is resolved.
Size | Gets or sets the maximum size, in bytes, of the data within the column.
SourceColumn | Gets or sets the name of the source column that is mapped to the DataSet and used for loading or returning the Value.
SourceVersion | Gets or sets the DataRowVersion to use when loading value.
Value | Gets or sets the value of the parameter.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString |

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace


FbParameter Constructor

Initializes a new instance of the FbParameter class.

Overload List

Initializes a new instance of the FbParameter class.

public FbParameter();

public FbParameter(string,FbDbType);

public FbParameter(string,FbDbType,int);

public FbParameter(string,FbDbType,int,ParameterDirection,bool,byte,byte,string,DataRowVersion,object);

public FbParameter(string,FbDbType,int,string);

public FbParameter(string,object);

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace


FbParameter Constructor ()

Initializes a new instance of the FbParameter class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FbParameter();

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace | FbParameter Constructor Overload List


FbParameter Constructor (String, Object)

[Visual Basic]
Overloads Public Sub New( _
ByVal parameterName As String, _
ByVal value As Object _
)
[C#]
public FbParameter(
string parameterName,
object value
);

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace | FbParameter Constructor Overload List


FbParameter Constructor (String, FbDbType)

[Visual Basic]
Overloads Public Sub New( _
ByVal parameterName As String, _
ByVal fbType As FbDbType _
)
[C#]
public FbParameter(
string parameterName,
FbDbType fbType
);

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace | FbParameter Constructor Overload List


FbParameter Constructor (String, FbDbType, Int32)

[Visual Basic]
Overloads Public Sub New( _
ByVal parameterName As String, _
ByVal fbType As FbDbType, _
ByVal size As Integer _
)
[C#]
public FbParameter(
string parameterName,
FbDbType fbType,
int size
);

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace | FbParameter Constructor Overload List


FbParameter Constructor (String, FbDbType, Int32, String)

[Visual Basic]
Overloads Public Sub New( _
ByVal parameterName As String, _
ByVal fbType As FbDbType, _
ByVal size As Integer, _
ByVal sourceColumn As String _
)
[C#]
public FbParameter(
string parameterName,
FbDbType fbType,
int size,
string sourceColumn
);

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace | FbParameter Constructor Overload List


FbParameter Constructor (String, FbDbType, Int32, ParameterDirection, Boolean, Byte, Byte, String, DataRowVersion, Object)

[Visual Basic]
<EditorBrowsable(State:=EditorBrowsableState.Advanced)>
Overloads Public Sub New( _
ByVal parameterName As String, _
ByVal dbType As FbDbType, _
ByVal size As Integer, _
ByVal direction As ParameterDirection, _
ByVal isNullable As Boolean, _
ByVal precision As Byte, _
ByVal scale As Byte, _
ByVal sourceColumn As String, _
ByVal sourceVersion As DataRowVersion, _
ByVal value As Object _
)
[C#]
[EditorBrowsable(State=EditorBrowsableState.Advanced)]
public FbParameter(
string parameterName,
FbDbType dbType,
int size,
ParameterDirection direction,
bool isNullable,
byte precision,
byte scale,
string sourceColumn,
DataRowVersion sourceVersion,
object value
);

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace | FbParameter Constructor Overload List


FbParameter Properties

The properties of the FbParameter class are listed below. For a complete list of FbParameter class members, see the FbParameter Members topic.

Public Instance Properties

Charset | Gets or sets the Charset of the parameter.
DbType | Gets or sets the DbType of the parameter.
Direction | Gets or sets the Direction of the parameter.
FbDbType |
IsNullable | Gets or sets whether the parameter accepts null values.
ParameterName | Gets or sets the name of the FbParameter.
Precision | Gets or sets the maximum number of digits used to represent the parameter value.
Scale | Gets or sets the number of decimal places to which parameter value is resolved.
Size | Gets or sets the maximum size, in bytes, of the data within the column.
SourceColumn | Gets or sets the name of the source column that is mapped to the DataSet and used for loading or returning the Value.
SourceVersion | Gets or sets the DataRowVersion to use when loading value.
Value | Gets or sets the value of the parameter.

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace


Charset Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameter.Charset Property

Gets or sets the Charset of the parameter.

[Visual Basic]
<DefaultValue(Value:=FbCharset.Default), _ Category(Category:="Data")>
Public Property Charset As FbCharset
[C#]
[DefaultValue(Value=FbCharset.Default)]
[Category(Category="Data")]
public FbCharset Charset {get; set;}

Remarks

The Charset is used only with char and varcar parameters.

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace


DbType Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameter.DbType Property

Gets or sets the DbType of the parameter.

[Visual Basic]
<Browsable(Browsable:=False), _
 DesignerSerializationVisibility(Visibility:=DesignerSerializationVisibility.Hidden), _
 Category(Category:="Data"), _
 RefreshProperties(RefreshProperties:=RefreshProperties.All)>
NotOverridable Public Property DbType As DbType _
Implements IDataParameter.DbType
[C#]
[Browsable(Browsable=False)]
[DesignerSerializationVisibility(Visibility=DesignerSerializationVisibility.Hidden)]
[Category(Category="Data")]
[RefreshProperties(RefreshProperties=RefreshProperties.All)]
public System.Data.DbType DbType {get; set;}

Implements

IDataParameter.DbType

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace


Direction Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameter.Direction Property

Gets or sets the Direction of the parameter.

[Visual Basic]
<Category(Category:="Data"), _ DefaultValue(Value:=ParameterDirection.Input)>
NotOverridable Public Property Direction As ParameterDirection _
Implements IDataParameter.Direction
[C#]
[Category(Category="Data")]
[DefaultValue(Value=ParameterDirection.Input)]
public System.Data.ParameterDirection Direction {get; set;}

Implements

IDataParameter.Direction

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace


FbDbType Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameter.FbDbType Property

[Visual Basic]
<Category(Category:="Data"), _
 RefreshProperties(RefreshProperties:=RefreshProperties.All), _
 DefaultValue(Value:=FbDbType.VarChar)>
Public Property FbDbType As FbDbType
[C#]
[Category(Category="Data")]
[RefreshProperties(RefreshProperties=RefreshProperties.All)]
[DefaultValue(Value=FbDbType.VarChar)]
public FbDbType FbDbType {get; set;}

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace


IsNullable Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameter.IsNullable Property

Gets or sets whether the parameter accepts null values.

[Visual Basic]
<EditorBrowsable(State:=EditorBrowsableState.Advanced), _ Browsable(Browsable:=False), _ DesignOnly(IsDesignOnly:=True), _ DefaultValue(Value:=False)>
NotOverridable Public Property IsNullable As Boolean _
Implements IDataParameter.IsNullable
[C#]
[EditorBrowsable(State=EditorBrowsableState.Advanced)]
[Browsable(Browsable=False)]
[DesignOnly(IsDesignOnly=True)]
[DefaultValue(Value=False)]
public bool IsNullable {get; set;}

Implements

IDataParameter.IsNullable

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace


ParameterName Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameter.ParameterName Property

Gets or sets the name of the FbParameter.

[Visual Basic]
<DefaultValue>
Public Property ParameterName As String
[C#]
[DefaultValue]
public string ParameterName {get; set;}

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace


Precision Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameter.Precision Property

Gets or sets the maximum number of digits used to represent the parameter value.

[Visual Basic]
<DefaultValue(Value:=0), _ Category(Category:="Data")>
NotOverridable Public Property Precision As Byte _
Implements IDbDataParameter.Precision
[C#]
[DefaultValue(Value=0)]
[Category(Category="Data")]
public byte Precision {get; set;}

Implements

IDbDataParameter.Precision

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace


Scale Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameter.Scale Property

Gets or sets the number of decimal places to which parameter value is resolved.

[Visual Basic]
<Category(Category:="Data"), _ DefaultValue(Value:=0)>
NotOverridable Public Property Scale As Byte _
Implements IDbDataParameter.Scale
[C#]
[Category(Category="Data")]
[DefaultValue(Value=0)]
public byte Scale {get; set;}

Implements

IDbDataParameter.Scale

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace


Size Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameter.Size Property

Gets or sets the maximum size, in bytes, of the data within the column.

[Visual Basic]
<DefaultValue(Value:=0), _ Category(Category:="Data")>
NotOverridable Public Property Size As Integer _
Implements IDbDataParameter.Size
[C#]
[DefaultValue(Value=0)]
[Category(Category="Data")]
public int Size {get; set;}

Implements

IDbDataParameter.Size

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace


SourceColumn Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameter.SourceColumn Property

Gets or sets the name of the source column that is mapped to the DataSet and used for loading or returning the Value.

[Visual Basic]
<DefaultValue, _ Category(Category:="Data")>
NotOverridable Public Property SourceColumn As String _
Implements IDataParameter.SourceColumn
[C#]
[DefaultValue]
[Category(Category="Data")]
public string SourceColumn {get; set;}

Implements

IDataParameter.SourceColumn

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace


SourceVersion Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameter.SourceVersion Property

Gets or sets the DataRowVersion to use when loading value.

[Visual Basic]
<Category(Category:="Data"), _ DefaultValue(Value:=DataRowVersion.Current)>
NotOverridable Public Property SourceVersion As DataRowVersion _
Implements IDataParameter.SourceVersion
[C#]
[Category(Category="Data")]
[DefaultValue(Value=DataRowVersion.Current)]
public System.Data.DataRowVersion SourceVersion {get; set;}

Implements

IDataParameter.SourceVersion

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace


Value Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameter.Value Property

Gets or sets the value of the parameter.

[Visual Basic]
<TypeConverter(ConverterTypeName:="System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"), _ Category(Category:="Data"), _ DefaultValue(Value:=null)>
NotOverridable Public Property Value As Object _
Implements IDataParameter.Value
[C#]
[TypeConverter(ConverterTypeName="System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[Category(Category="Data")]
[DefaultValue(Value=null)]
public object Value {get; set;}

Implements

IDataParameter.Value

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace


FbParameter Methods

The methods of the FbParameter class are listed below. For a complete list of FbParameter class members, see the FbParameter Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString |

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace


FbParameter.ToString Method

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

FbParameter Class | FirebirdSql.Data.Firebird Namespace


FbParameterCollection Class

A collection of parameters associated to a FbCommand. This class cannot be inherited.

For a list of all members of this type, see FbParameterCollection Members.

System.Object
System.MarshalByRefObject
FirebirdSql.Data.Firebird.FbParameterCollection

[Visual Basic]
<ListBindable(ListBindable:=False), _ Editor(EditorBaseTypeName:="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName:="FirebirdSql.Data.Firebird.Design.FbParameterCollectionEditor, FirebirdSql.Data.Firebird, Version=1.7.1.0, Culture=neutral, PublicKeyToken=fa843d180294369d"), _ DefaultMember(MemberName:="Item")>
NotInheritable Public Class FbParameterCollection
Inherits MarshalByRefObject
Implements IDataParameterCollection, IList, ICollection, IEnumerable
[C#]
[ListBindable(ListBindable=False)]
[Editor(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="FirebirdSql.Data.Firebird.Design.FbParameterCollectionEditor, FirebirdSql.Data.Firebird, Version=1.7.1.0, Culture=neutral, PublicKeyToken=fa843d180294369d")]
[DefaultMember(MemberName="Item")]
public sealed class FbParameterCollection : MarshalByRefObject, IDataParameterCollection, IList, ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The number of the parameters in the collection must be equal to the number of parameter placeholders and/or named parameters in the command text, or Firebird will raise an exceptionraises an error.

Example

public void AddFbParameters()
{
// ...
// create myDataSet and myDataAdapter
// ...

myDataAdapter.SelectCommand.Parameters.Add("@CategoryName", FbDbType.VarChar, 80).Value = "toasters";
myDataAdapter.SelectCommand.Parameters.Add("@SerialNum", FbDbType.Integer).Value = 239;
myDataAdapter.Fill(myDataSet);

}

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbParameterCollection Members | FirebirdSql.Data.Firebird Namespace


FbParameterCollection Members

FbParameterCollection overview

Public Instance Properties

Count | Gets the number of FbParameter objects in the collection.
Item | Overloaded. Gets or sets the FbParameter with the specified name.

Public Instance Methods

Add | Overloaded. Adds a FbParameter to the FbParameterCollection with the parameter name and the data type.
Clear | Removes all items from the collection.
Contains | Overloaded. Indicates whether a FbParameter exists in the collection.
CopyTo | Copies FbParameterCollection to the specified array.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Overloaded. Gets the location of the FbParameter in the collection.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Insert | Gets the location of the FbParameter in the collection.
Remove | Removes the specified FbParameter from the collection.
RemoveAt | Overloaded. Removes the specified FbParameter from the collection using a specific index.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace


FbParameterCollection Properties

The properties of the FbParameterCollection class are listed below. For a complete list of FbParameterCollection class members, see the FbParameterCollection Members topic.

Public Instance Properties

Count | Gets the number of FbParameter objects in the collection.
Item | Overloaded. Gets or sets the FbParameter with the specified name.

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace


Count Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameterCollection.Count Property

Gets the number of FbParameter objects in the collection.

[Visual Basic]
<Browsable(Browsable:=False), _ DesignerSerializationVisibility(Visibility:=DesignerSerializationVisibility.Hidden)>
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
[Browsable(Browsable=False)]
[DesignerSerializationVisibility(Visibility=DesignerSerializationVisibility.Hidden)]
public int Count {get;}

Property Value

The number of FbParameter objects in the collection.

Implements

ICollection.Count

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace


Item Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameterCollection.Item Property

Gets or sets the FbParameter at the specified index.

Overload List

Gets or sets the FbParameter at the specified index.

[Browsable(Browsable=False)]
[DesignerSerializationVisibility(Visibility=DesignerSerializationVisibility.Hidden)]
public FbParameter this[int] {get; set;}

Gets or sets the FbParameter with the specified name.

[Browsable(Browsable=False)]
[DesignerSerializationVisibility(Visibility=DesignerSerializationVisibility.Hidden)]
public FbParameter this[string] {get; set;}

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace


Item Property (Int32)

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameterCollection.Item Property (Int32)

Gets or sets the FbParameter at the specified index.

[Visual Basic]
<Browsable(Browsable:=False), _ DesignerSerializationVisibility(Visibility:=DesignerSerializationVisibility.Hidden)>
Overloads Public Default Property Item( _
ByVal index As Integer _
) As FbParameter
[C#]
[Browsable(Browsable=False)]
[DesignerSerializationVisibility(Visibility=DesignerSerializationVisibility.Hidden)]
public FbParameter this[
int index
] {get; set;}

Parameters

index
The zero-based index of the parameter to retrieve.

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace | FbParameterCollection.Item Overload List


Item Property (String)

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameterCollection.Item Property (String)

Gets or sets the FbParameter with the specified name.

[Visual Basic]
<Browsable(Browsable:=False), _ DesignerSerializationVisibility(Visibility:=DesignerSerializationVisibility.Hidden)>
Overloads Public Default Property Item( _
ByVal parameterName As String _
) As FbParameter
[C#]
[Browsable(Browsable=False)]
[DesignerSerializationVisibility(Visibility=DesignerSerializationVisibility.Hidden)]
public FbParameter this[
string parameterName
] {get; set;}

Parameters

parameterName
The name of the parameter to retrieve.

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace | FbParameterCollection.Item Overload List


FbParameterCollection Methods

The methods of the FbParameterCollection class are listed below. For a complete list of FbParameterCollection class members, see the FbParameterCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a FbParameter to the FbParameterCollection with the parameter name and the data type.
Clear | Removes all items from the collection.
Contains | Overloaded. Indicates whether a FbParameter exists in the collection.
CopyTo | Copies FbParameterCollection to the specified array.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Overloaded. Gets the location of the FbParameter in the collection.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Insert | Gets the location of the FbParameter in the collection.
Remove | Removes the specified FbParameter from the collection.
RemoveAt | Overloaded. Removes the specified FbParameter from the collection using a specific index.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace


Add Method

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameterCollection.Add Method

Overload List

public FbParameter Add(FbParameter);

Adds the specified FbParameter object to the collection.

public int Add(object);

public FbParameter Add(string,FbDbType);

public FbParameter Add(string,FbDbType,int);

public FbParameter Add(string,FbDbType,int,string);

Adds a FbParameter to the FbParameterCollection with the parameter name and the data type.

public FbParameter Add(string,object);

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace


FbParameterCollection.Add Method (FbParameter)

[Visual Basic]
Overloads Public Function Add( _
ByVal value As FbParameter _
) As FbParameter
[C#]
public FbParameter Add(
FbParameter value
);

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace | FbParameterCollection.Add Overload List


FbParameterCollection.Add Method (Object)

Adds the specified FbParameter object to the collection.

[Visual Basic]
NotOverridable Overloads Public Function Add( _
ByVal value As Object _
) As Integer _
Implements IList.Add
[C#]
public int Add(
object value
);

Parameters

value
The FbParameter to be added.

Return Value

A reference to the new FbParameter object.

Implements

IList.Add

Exceptions

Exception Type | Condition
InvalidCastException | The parameter passed was not a FbParameter.

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace | FbParameterCollection.Add Overload List


FbParameterCollection.Add Method (String, FbDbType)

[Visual Basic]
Overloads Public Function Add( _
ByVal parameterName As String, _
ByVal type As FbDbType _
) As FbParameter
[C#]
public FbParameter Add(
string parameterName,
FbDbType type
);

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace | FbParameterCollection.Add Overload List


FbParameterCollection.Add Method (String, FbDbType, Int32)

[Visual Basic]
Overloads Public Function Add( _
ByVal parameterName As String, _
ByVal fbType As FbDbType, _
ByVal size As Integer _
) As FbParameter
[C#]
public FbParameter Add(
string parameterName,
FbDbType fbType,
int size
);

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace | FbParameterCollection.Add Overload List


FbParameterCollection.Add Method (String, FbDbType, Int32, String)

[Visual Basic]
Overloads Public Function Add( _
ByVal parameterName As String, _
ByVal fbType As FbDbType, _
ByVal size As Integer, _
ByVal sourceColumn As String _
) As FbParameter
[C#]
public FbParameter Add(
string parameterName,
FbDbType fbType,
int size,
string sourceColumn
);

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace | FbParameterCollection.Add Overload List


FbParameterCollection.Add Method (String, Object)

Adds a FbParameter to the FbParameterCollection with the parameter name and the data type.

[Visual Basic]
Overloads Public Function Add( _
ByVal parameterName As String, _
ByVal value As Object _
) As FbParameter
[C#]
public FbParameter Add(
string parameterName,
object value
);

Parameters

parameterName
The name of the parameter.
value
The value of the parameter.

Return Value

A reference to the new FbParameter object.

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace | FbParameterCollection.Add Overload List


FbParameterCollection.Clear Method

Removes all items from the collection.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IList.Clear
[C#]
public void Clear();

Implements

IList.Clear

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace


Contains Method

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameterCollection.Contains Method

Indicates whether a FbParameter exists in the collection.

Overload List

Indicates whether a FbParameter exists in the collection.

public bool Contains(object);

Indicates whether a FbParameter exists in the collection.

public bool Contains(string);

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace


FbParameterCollection.Contains Method (Object)

Indicates whether a FbParameter exists in the collection.

[Visual Basic]
NotOverridable Overloads Public Function Contains( _
ByVal value As Object _
) As Boolean _
Implements IList.Contains
[C#]
public bool Contains(
object value
);

Parameters

value
A FbParameter object.

Return Value

True if the collection contains the FbParameter object; otherwise, false.

Implements

IList.Contains

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace | FbParameterCollection.Contains Overload List


FbParameterCollection.Contains Method (String)

Indicates whether a FbParameter exists in the collection.

[Visual Basic]
NotOverridable Overloads Public Function Contains( _
ByVal parameterName As String _
) As Boolean _
Implements IDataParameterCollection.Contains
[C#]
public bool Contains(
string parameterName
);

Parameters

parameterName
The name of the parameter to retrieve.

Return Value

True if the collection contains the parameter; otherwise, false.

Implements

IDataParameterCollection.Contains

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace | FbParameterCollection.Contains Overload List


FbParameterCollection.CopyTo Method

Copies FbParameterCollection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
The Array to copy elements into.
index
The index from which to start copying into the array parameter.

Implements

ICollection.CopyTo

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace


FbParameterCollection.GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace


IndexOf Method

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameterCollection.IndexOf Method

Gets the location of the FbParameter in the collection.

Overload List

Gets the location of the FbParameter in the collection.

public int IndexOf(object);

Gets the location of the FbParameter in the collection with a specific parameter name.

public int IndexOf(string);

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace


FbParameterCollection.IndexOf Method (Object)

Gets the location of the FbParameter in the collection.

[Visual Basic]
NotOverridable Overloads Public Function IndexOf( _
ByVal value As Object _
) As Integer _
Implements IList.IndexOf
[C#]
public int IndexOf(
object value
);

Parameters

value
The FbParameter object to locate.

Return Value

The zero-based location of the FbParameter in the collection.

Implements

IList.IndexOf

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace | FbParameterCollection.IndexOf Overload List


FbParameterCollection.IndexOf Method (String)

Gets the location of the FbParameter in the collection with a specific parameter name.

[Visual Basic]
NotOverridable Overloads Public Function IndexOf( _
ByVal parameterName As String _
) As Integer _
Implements IDataParameterCollection.IndexOf
[C#]
public int IndexOf(
string parameterName
);

Parameters

parameterName
The name of the parameter to retrieve.

Return Value

The zero-based location of the FbParameter in the collection.

Implements

IDataParameterCollection.IndexOf

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace | FbParameterCollection.IndexOf Overload List


FbParameterCollection.Insert Method

Gets the location of the FbParameter in the collection.

[Visual Basic]
NotOverridable Public Sub Insert( _
ByVal index As Integer, _
ByVal value As Object _
) _
Implements IList.Insert
[C#]
public void Insert(
int index,
object value
);

Parameters

index
The zero-based index within the collection to insert the value parameter.
value
The FbParameter to add to the collection.

Return Value

The zero-based location of the FbParameter in the collection.

Implements

IList.Insert

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace


FbParameterCollection.Remove Method

Removes the specified FbParameter from the collection.

[Visual Basic]
NotOverridable Public Sub Remove( _
ByVal value As Object _
) _
Implements IList.Remove
[C#]
public void Remove(
object value
);

Parameters

value
A FbParameter object to remove from the collection.

Implements

IList.Remove

Exceptions

Exception Type | Condition
InvalidCastException | The parameter is not a FbParameter.
SystemException | The parameter does not exist in the collection.

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace


RemoveAt Method

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbParameterCollection.RemoveAt Method

Removes the specified FbParameter from the collection using a specific index.

Overload List

Removes the specified FbParameter from the collection using a specific index.

public void RemoveAt(int);

Removes the specified FbParameter from the collection.

public void RemoveAt(string);

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace


FbParameterCollection.RemoveAt Method (Int32)

Removes the specified FbParameter from the collection using a specific index.

[Visual Basic]
NotOverridable Overloads Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements IList.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
The zero-based index of the parameter.

Implements

IList.RemoveAt

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The specified index does not exist.

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace | FbParameterCollection.RemoveAt Overload List


FbParameterCollection.RemoveAt Method (String)

Removes the specified FbParameter from the collection.

[Visual Basic]
NotOverridable Overloads Public Sub RemoveAt( _
ByVal parameterName As String _
) _
Implements IDataParameterCollection.RemoveAt
[C#]
public void RemoveAt(
string parameterName
);

Parameters

parameterName
The name of the parameter to remove.

Implements

IDataParameterCollection.RemoveAt

See Also

FbParameterCollection Class | FirebirdSql.Data.Firebird Namespace | FbParameterCollection.RemoveAt Overload List


FbRemoteEvent Class

Represents a Firebird Event. This class cannot be inherited.

For a list of all members of this type, see FbRemoteEvent Members.

System.Object
FirebirdSql.Data.Firebird.FbRemoteEvent

[Visual Basic]
<DefaultMember(MemberName:="Item")>
NotInheritable Public Class FbRemoteEvent
[C#]
[DefaultMember(MemberName="Item")]
public sealed class FbRemoteEvent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbRemoteEvent Members | FirebirdSql.Data.Firebird Namespace


FbRemoteEvent Members

FbRemoteEvent overview

Public Instance Constructors

FbRemoteEvent Overloaded. Initializes a new instance of the FbRemoteEvent class.

Public Instance Properties

Connection | Gets or sets the FbConnection associated to the remote event.
HasChanges | Incates if there are changes in the event counts since the last time they were received.
Item | Gets the event name at the specified index.

Public Instance Methods

AddEvents | Adds the specified events to the event list.
CancelEvents |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
QueueEvents | Register interest in a set of events (works in asynchronous mode).
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

RemoteEventCounts Gets or sets the event handlers that will be fired each time the event counts notification is received from server.

See Also

FbRemoteEvent Class | FirebirdSql.Data.Firebird Namespace


FbRemoteEvent Constructor

Creates a new instance of the FbRemoteEvent class with the given FbConnection instance.

Overload List

Creates a new instance of the FbRemoteEvent class with the given FbConnection instance.

public FbRemoteEvent(FbConnection);

Creates a new instance of the FbRemoteEvent class with the given FbConnection instance and the given list of events.

public FbRemoteEvent(FbConnection,string[]);

See Also

FbRemoteEvent Class | FirebirdSql.Data.Firebird Namespace


FbRemoteEvent Constructor (FbConnection)

Creates a new instance of the FbRemoteEvent class with the given FbConnection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal connection As FbConnection _
)
[C#]
public FbRemoteEvent(
FbConnection connection
);

Parameters

connection
A FbConnection instance.

See Also

FbRemoteEvent Class | FirebirdSql.Data.Firebird Namespace | FbRemoteEvent Constructor Overload List


FbRemoteEvent Constructor (FbConnection, String[])

Creates a new instance of the FbRemoteEvent class with the given FbConnection instance and the given list of events.

[Visual Basic]
Overloads Public Sub New( _
ByVal connection As FbConnection, _
ByVal events As String() _
)
[C#]
public FbRemoteEvent(
FbConnection connection,
string[] events
);

Parameters

connection
A FbConnection instance.
events
List of requested events.

Exceptions

Exception Type | Condition
 | If the event list count is greater than 15.

See Also

FbRemoteEvent Class | FirebirdSql.Data.Firebird Namespace | FbRemoteEvent Constructor Overload List


FbRemoteEvent Properties

The properties of the FbRemoteEvent class are listed below. For a complete list of FbRemoteEvent class members, see the FbRemoteEvent Members topic.

Public Instance Properties

Connection | Gets or sets the FbConnection associated to the remote event.
HasChanges | Incates if there are changes in the event counts since the last time they were received.
Item | Gets the event name at the specified index.

See Also

FbRemoteEvent Class | FirebirdSql.Data.Firebird Namespace


Connection Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbRemoteEvent.Connection Property

Gets or sets the FbConnection associated to the remote event.

[Visual Basic]
Public Property Connection As FbConnection
[C#]
public FbConnection Connection {get; set;}

See Also

FbRemoteEvent Class | FirebirdSql.Data.Firebird Namespace


HasChanges Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbRemoteEvent.HasChanges Property

Incates if there are changes in the event counts since the last time they were received.

[Visual Basic]
Public ReadOnly Property HasChanges As Boolean
[C#]
public bool HasChanges {get;}

See Also

FbRemoteEvent Class | FirebirdSql.Data.Firebird Namespace


Item Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbRemoteEvent.Item Property

Gets the event name at the specified index.

[Visual Basic]
Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As String
[C#]
public string this[
int index
] {get;}

See Also

FbRemoteEvent Class | FirebirdSql.Data.Firebird Namespace


FbRemoteEvent Methods

The methods of the FbRemoteEvent class are listed below. For a complete list of FbRemoteEvent class members, see the FbRemoteEvent Members topic.

Public Instance Methods

AddEvents | Adds the specified events to the event list.
CancelEvents |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
QueueEvents | Register interest in a set of events (works in asynchronous mode).
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbRemoteEvent Class | FirebirdSql.Data.Firebird Namespace


FbRemoteEvent.AddEvents Method

Adds the specified events to the event list.

[Visual Basic]
Public Sub AddEvents( _
ByVal events As String() _
)
[C#]
public void AddEvents(
string[] events
);

Parameters

events
List of requested events.

Remarks

If there are existent events in the list of requested events that will be lost.

Exceptions

Exception Type | Condition
 | If the event list count is greater than 15.
 | If the events parameter is null.

See Also

FbRemoteEvent Class | FirebirdSql.Data.Firebird Namespace


FbRemoteEvent.CancelEvents Method

[Visual Basic]
Public Sub CancelEvents()
[C#]
public void CancelEvents();

See Also

FbRemoteEvent Class | FirebirdSql.Data.Firebird Namespace


FbRemoteEvent.QueueEvents Method

Register interest in a set of events (works in asynchronous mode).

[Visual Basic]
Public Sub QueueEvents()
[C#]
public void QueueEvents();

See Also

FbRemoteEvent Class | FirebirdSql.Data.Firebird Namespace


FbRemoteEvent Events

The events of the FbRemoteEvent class are listed below. For a complete list of FbRemoteEvent class members, see the FbRemoteEvent Members topic.

Public Instance Events

RemoteEventCounts Gets or sets the event handlers that will be fired each time the event counts notification is received from server.

See Also

FbRemoteEvent Class | FirebirdSql.Data.Firebird Namespace


FbRemoteEvent.RemoteEventCounts Event

Gets or sets the event handlers that will be fired each time the event counts notification is received from server.

[Visual Basic]
Public Event RemoteEventCounts As FbRemoteEventEventHandler
[C#]
public event FbRemoteEventEventHandler RemoteEventCounts;

Event Data

The event handler receives an argument of type FbRemoteEventEventArgs containing data related to this event. The following FbRemoteEventEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
Counts | Gets the counts of the remote event.
Name | Gets the name of the remote event.

See Also

FbRemoteEvent Class | FirebirdSql.Data.Firebird Namespace


FbRemoteEventEventArgs Class

Provides data for the RemoteEventCounts event. This class cannot be inherited.

For a list of all members of this type, see FbRemoteEventEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
FirebirdSql.Data.Firebird.FbRemoteEventEventArgs

[Visual Basic]
NotInheritable Public Class FbRemoteEventEventArgs
Inherits CancelEventArgs
[C#]
public sealed class FbRemoteEventEventArgs : CancelEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbRemoteEventEventArgs Members | FirebirdSql.Data.Firebird Namespace


FbRemoteEventEventArgs Members

FbRemoteEventEventArgs overview

Public Instance Constructors

FbRemoteEventEventArgs Overloaded. Initializes a new instance of the FbRemoteEventEventArgs class.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
Counts | Gets the counts of the remote event.
Name | Gets the name of the remote event.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbRemoteEventEventArgs Class | FirebirdSql.Data.Firebird Namespace


FbRemoteEventEventArgs Constructor

Overload List

public FbRemoteEventEventArgs(string,int);

public FbRemoteEventEventArgs(string,int,bool);

See Also

FbRemoteEventEventArgs Class | FirebirdSql.Data.Firebird Namespace


FbRemoteEventEventArgs Constructor (String, Int32)

[Visual Basic]
Overloads Public Sub New( _
ByVal name As String, _
ByVal counts As Integer _
)
[C#]
public FbRemoteEventEventArgs(
string name,
int counts
);

See Also

FbRemoteEventEventArgs Class | FirebirdSql.Data.Firebird Namespace | FbRemoteEventEventArgs Constructor Overload List


FbRemoteEventEventArgs Constructor (String, Int32, Boolean)

[Visual Basic]
Overloads Public Sub New( _
ByVal name As String, _
ByVal counts As Integer, _
ByVal cancel As Boolean _
)
[C#]
public FbRemoteEventEventArgs(
string name,
int counts,
bool cancel
);

See Also

FbRemoteEventEventArgs Class | FirebirdSql.Data.Firebird Namespace | FbRemoteEventEventArgs Constructor Overload List


FbRemoteEventEventArgs Properties

The properties of the FbRemoteEventEventArgs class are listed below. For a complete list of FbRemoteEventEventArgs class members, see the FbRemoteEventEventArgs Members topic.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
Counts | Gets the counts of the remote event.
Name | Gets the name of the remote event.

See Also

FbRemoteEventEventArgs Class | FirebirdSql.Data.Firebird Namespace


Counts Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbRemoteEventEventArgs.Counts Property

Gets the counts of the remote event.

[Visual Basic]
Public ReadOnly Property Counts As Integer
[C#]
public int Counts {get;}

Property Value

The remote event counts.

See Also

FbRemoteEventEventArgs Class | FirebirdSql.Data.Firebird Namespace


Name Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbRemoteEventEventArgs.Name Property

Gets the name of the remote event.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}

Property Value

The remote event name.

See Also

FbRemoteEventEventArgs Class | FirebirdSql.Data.Firebird Namespace


FbRemoteEventEventHandler Delegate

[Visual Basic]
Public Delegate Sub FbRemoteEventEventHandler( _
ByVal sender As Object, _
ByVal e As FbRemoteEventEventArgs _
)
[C#]
public delegate void FbRemoteEventEventHandler(
object sender,
FbRemoteEventEventArgs e
);

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird Namespace


FbRowUpdatedEventArgs Class

Provides data for the RowUpdated event. This class cannot be inherited.

For a list of all members of this type, see FbRowUpdatedEventArgs Members.

System.Object
System.EventArgs
System.Data.Common.RowUpdatedEventArgs
FirebirdSql.Data.Firebird.FbRowUpdatedEventArgs

[Visual Basic]
NotInheritable Public Class FbRowUpdatedEventArgs
Inherits RowUpdatedEventArgs
[C#]
public sealed class FbRowUpdatedEventArgs : RowUpdatedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbRowUpdatedEventArgs Members | FirebirdSql.Data.Firebird Namespace


FbRowUpdatedEventArgs Members

FbRowUpdatedEventArgs overview

Public Instance Constructors

FbRowUpdatedEventArgs Constructor Initializes a new instance of the FbRowUpdatedEventArgs class.

Public Instance Properties

Command | Overloaded. Gets the FbCommand executed when Update is called.
Errors (inherited from RowUpdatedEventArgs) | Gets any errors generated by the .NET Framework data provider when the Command was executed.
RecordsAffected (inherited from RowUpdatedEventArgs) | Gets the number of rows changed, inserted, or deleted by execution of the SQL statement.
Row (inherited from RowUpdatedEventArgs) | Gets the DataRow sent through an Update.
RowCount (inherited from RowUpdatedEventArgs) | Gets the number of rows processed in a batch of updated records.
StatementType (inherited from RowUpdatedEventArgs) | Gets the type of SQL statement executed.
Status (inherited from RowUpdatedEventArgs) | Gets the UpdateStatus of the Command property.
TableMapping (inherited from RowUpdatedEventArgs) | Gets the DataTableMapping sent through an Update.

Public Instance Methods

CopyToRows (inherited from RowUpdatedEventArgs) | Overloaded. Copies references to the modified rows into the provided array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbRowUpdatedEventArgs Class | FirebirdSql.Data.Firebird Namespace


FbRowUpdatedEventArgs Constructor

Initializes a new instance of the FbRowUpdatedEventArgs class.

[Visual Basic]
Public Sub New( _
ByVal row As DataRow, _
ByVal command As IDbCommand, _
ByVal statementType As StatementType, _
ByVal tableMapping As DataTableMapping _
)
[C#]
public FbRowUpdatedEventArgs(
DataRow row,
IDbCommand command,
StatementType statementType,
DataTableMapping tableMapping
);

Parameters

row
The DataRow sent through an update operation.
command
The FbCommand executed when Update is called.
statementType
One of the System.Data.StatementType values that specifies the type of query executed.
tableMapping
The System.Data.Common.DataTableMapping sent through Update.

See Also

FbRowUpdatedEventArgs Class | FirebirdSql.Data.Firebird Namespace


FbRowUpdatedEventArgs Properties

The properties of the FbRowUpdatedEventArgs class are listed below. For a complete list of FbRowUpdatedEventArgs class members, see the FbRowUpdatedEventArgs Members topic.

Public Instance Properties

Command | Overloaded. Gets the FbCommand executed when Update is called.
Errors (inherited from RowUpdatedEventArgs) | Gets any errors generated by the .NET Framework data provider when the Command was executed.
RecordsAffected (inherited from RowUpdatedEventArgs) | Gets the number of rows changed, inserted, or deleted by execution of the SQL statement.
Row (inherited from RowUpdatedEventArgs) | Gets the DataRow sent through an Update.
RowCount (inherited from RowUpdatedEventArgs) | Gets the number of rows processed in a batch of updated records.
StatementType (inherited from RowUpdatedEventArgs) | Gets the type of SQL statement executed.
Status (inherited from RowUpdatedEventArgs) | Gets the UpdateStatus of the Command property.
TableMapping (inherited from RowUpdatedEventArgs) | Gets the DataTableMapping sent through an Update.

See Also

FbRowUpdatedEventArgs Class | FirebirdSql.Data.Firebird Namespace


Command Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbRowUpdatedEventArgs.Command Property

Gets the FbCommand executed when Update is called.

[Visual Basic]
Overloads Public ReadOnly Property Command As FbCommand
[C#]
new public FbCommand Command {get;}

Property Value

The FbCommand executed when Update is called.

See Also

FbRowUpdatedEventArgs Class | FirebirdSql.Data.Firebird Namespace


FbRowUpdatedEventHandler Delegate

Represents the method that will handle the RowUpdated event of an FbDataAdapter.

[Visual Basic]
Public Delegate Sub FbRowUpdatedEventHandler( _
ByVal sender As Object, _
ByVal e As FbRowUpdatedEventArgs _
)
[C#]
public delegate void FbRowUpdatedEventHandler(
object sender,
FbRowUpdatedEventArgs e
);

Parameters

sender
The source of the event.
e
The FbRowUpdatedEventArgs that contains the event data.

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird Namespace


FbRowUpdatingEventArgs Class

Provides data for the RowUpdating event. This class cannot be inherited.

For a list of all members of this type, see FbRowUpdatingEventArgs Members.

System.Object
System.EventArgs
System.Data.Common.RowUpdatingEventArgs
FirebirdSql.Data.Firebird.FbRowUpdatingEventArgs

[Visual Basic]
NotInheritable Public Class FbRowUpdatingEventArgs
Inherits RowUpdatingEventArgs
[C#]
public sealed class FbRowUpdatingEventArgs : RowUpdatingEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbRowUpdatingEventArgs Members | FirebirdSql.Data.Firebird Namespace


FbRowUpdatingEventArgs Members

FbRowUpdatingEventArgs overview

Public Instance Constructors

FbRowUpdatingEventArgs Constructor Initializes a new instance of the FbRowUpdatingEventArgs class.

Public Instance Properties

Command | Overloaded. Gets the FbCommand executed when Update is called.
Errors (inherited from RowUpdatingEventArgs) | Gets any errors generated by the .NET Framework data provider when the Command executes.
Row (inherited from RowUpdatingEventArgs) | Gets the DataRow that will be sent to the server as part of an insert, update, or delete operation.
StatementType (inherited from RowUpdatingEventArgs) | Gets the type of SQL statement to execute.
Status (inherited from RowUpdatingEventArgs) | Gets or sets the UpdateStatus of the Command property.
TableMapping (inherited from RowUpdatingEventArgs) | Gets the DataTableMapping to send through the Update.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbRowUpdatingEventArgs Class | FirebirdSql.Data.Firebird Namespace


FbRowUpdatingEventArgs Constructor

Initializes a new instance of the FbRowUpdatingEventArgs class.

[Visual Basic]
Public Sub New( _
ByVal row As DataRow, _
ByVal command As IDbCommand, _
ByVal statementType As StatementType, _
ByVal tableMapping As DataTableMapping _
)
[C#]
public FbRowUpdatingEventArgs(
DataRow row,
IDbCommand command,
StatementType statementType,
DataTableMapping tableMapping
);

Parameters

row
The DataRow sent through an update operation.
command
The FbCommand executed when Update is called.
statementType
One of the System.Data.StatementType values that specifies the type of query executed.
tableMapping
The System.Data.Common.DataTableMapping sent through Update.

See Also

FbRowUpdatingEventArgs Class | FirebirdSql.Data.Firebird Namespace


FbRowUpdatingEventArgs Properties

The properties of the FbRowUpdatingEventArgs class are listed below. For a complete list of FbRowUpdatingEventArgs class members, see the FbRowUpdatingEventArgs Members topic.

Public Instance Properties

Command | Overloaded. Gets the FbCommand executed when Update is called.
Errors (inherited from RowUpdatingEventArgs) | Gets any errors generated by the .NET Framework data provider when the Command executes.
Row (inherited from RowUpdatingEventArgs) | Gets the DataRow that will be sent to the server as part of an insert, update, or delete operation.
StatementType (inherited from RowUpdatingEventArgs) | Gets the type of SQL statement to execute.
Status (inherited from RowUpdatingEventArgs) | Gets or sets the UpdateStatus of the Command property.
TableMapping (inherited from RowUpdatingEventArgs) | Gets the DataTableMapping to send through the Update.

See Also

FbRowUpdatingEventArgs Class | FirebirdSql.Data.Firebird Namespace


Command Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbRowUpdatingEventArgs.Command Property

Gets the FbCommand executed when Update is called.

[Visual Basic]
Overloads Public Property Command As FbCommand
[C#]
new public FbCommand Command {get; set;}

Property Value

The FbCommand executed when Update is called.

See Also

FbRowUpdatingEventArgs Class | FirebirdSql.Data.Firebird Namespace


FbRowUpdatingEventHandler Delegate

Represents the method that will handle the RowUpdating event of an FbDataAdapter.

[Visual Basic]
Public Delegate Sub FbRowUpdatingEventHandler( _
ByVal sender As Object, _
ByVal e As FbRowUpdatingEventArgs _
)
[C#]
public delegate void FbRowUpdatingEventHandler(
object sender,
FbRowUpdatingEventArgs e
);

Parameters

sender
The source of the event.
e
The FbRowUpdatingEventArgs that contains the event data.

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird Namespace


FbTransaction Class

Represents a Firebird transaction. This class cannot be inherited.

For a list of all members of this type, see FbTransaction Members.

System.Object
System.MarshalByRefObject
FirebirdSql.Data.Firebird.FbTransaction

[Visual Basic]
NotInheritable Public Class FbTransaction
Inherits MarshalByRefObject
Implements IDbTransaction, IDisposable
[C#]
public sealed class FbTransaction : MarshalByRefObject, IDbTransaction, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbTransaction Members | FirebirdSql.Data.Firebird Namespace


FbTransaction Members

FbTransaction overview

Public Instance Properties

Connection | Gets the FbConnection object associated with the transaction, or a null reference if the transaction is no longer valid.
IsolationLevel | Specifies the IsolationLevel for this transaction.

Public Instance Methods

Commit | Overloaded. Commits the transaction.
CommitRetaining | Commits the transaction and retains the transaction context after a commit.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose | Releases the unmanaged resources used by the FbTransaction and optionally releases the managed resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Rollback | Overloaded. Rolls back a transaction from a pending state.
RollbackRetaining | Rolls back a transaction from a pending state and retains the transaction context after the rollback.
Save | Establish a new Save point for the current transaction with the given name.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbTransaction Class | FirebirdSql.Data.Firebird Namespace


FbTransaction Properties

The properties of the FbTransaction class are listed below. For a complete list of FbTransaction class members, see the FbTransaction Members topic.

Public Instance Properties

Connection | Gets the FbConnection object associated with the transaction, or a null reference if the transaction is no longer valid.
IsolationLevel | Specifies the IsolationLevel for this transaction.

See Also

FbTransaction Class | FirebirdSql.Data.Firebird Namespace


Connection Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbTransaction.Connection Property

Gets the FbConnection object associated with the transaction, or a null reference if the transaction is no longer valid.

[Visual Basic]
Public ReadOnly Property Connection As FbConnection
[C#]
public FbConnection Connection {get;}

Property Value

The FbConnection object associated with the transaction.

Remarks

A single application may have multiple database connections, each with or without a transaction. This property allow you to know the connection object associated with a specific transaction created by BeginTransaction.

See Also

FbTransaction Class | FirebirdSql.Data.Firebird Namespace


IsolationLevel Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbTransaction.IsolationLevel Property

Specifies the IsolationLevel for this transaction.

[Visual Basic]
NotOverridable Public ReadOnly Property IsolationLevel As IsolationLevel _
Implements IDbTransaction.IsolationLevel
[C#]
public System.Data.IsolationLevel IsolationLevel {get;}

Property Value

The IsolationLevel for this transaction. The default is ReadCommitted.

Implements

IDbTransaction.IsolationLevel

Remarks

Parallel transactions are not supported. Therefore, the IsolationLevel applies to the entire transaction.

See Also

FbTransaction Class | FirebirdSql.Data.Firebird Namespace


FbTransaction Methods

The methods of the FbTransaction class are listed below. For a complete list of FbTransaction class members, see the FbTransaction Members topic.

Public Instance Methods

Commit | Overloaded. Commits the transaction.
CommitRetaining | Commits the transaction and retains the transaction context after a commit.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose | Releases the unmanaged resources used by the FbTransaction and optionally releases the managed resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Rollback | Overloaded. Rolls back a transaction from a pending state.
RollbackRetaining | Rolls back a transaction from a pending state and retains the transaction context after the rollback.
Save | Establish a new Save point for the current transaction with the given name.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbTransaction Class | FirebirdSql.Data.Firebird Namespace


Commit Method

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbTransaction.Commit Method

Commits the transaction.

Overload List

Commits the transaction.

public void Commit();

Commits a transaction from a pending state, and specifies a savepoint name.

public void Commit(string);

See Also

FbTransaction Class | FirebirdSql.Data.Firebird Namespace


FbTransaction.Commit Method ()

Commits the transaction.

[Visual Basic]
NotOverridable Overloads Public Sub Commit() _
Implements IDbTransaction.Commit
[C#]
public void Commit();

Implements

IDbTransaction.Commit

Exceptions

Exception Type | Condition
FbException | An error occurred while trying to commit the transaction.
InvalidOperationException | The transaction has already been committed or rolled back.
InvalidOperationException | FbCommand is currently busy Open, Fetching.

See Also

FbTransaction Class | FirebirdSql.Data.Firebird Namespace | FbTransaction.Commit Overload List


FbTransaction.Commit Method (String)

Commits a transaction from a pending state, and specifies a savepoint name.

[Visual Basic]
Overloads Public Sub Commit( _
ByVal savePointName As String _
)
[C#]
public void Commit(
string savePointName
);

Parameters

savePointName
The savepoint name to which commit changes.

Exceptions

Exception Type | Condition
FbException | An error occurred while trying to commit the transaction.
InvalidOperationException | The transaction has already been committed or rolled back.
InvalidOperationException | FbCommand is currently busy Open, Fetching.

See Also

FbTransaction Class | FirebirdSql.Data.Firebird Namespace | FbTransaction.Commit Overload List


FbTransaction.CommitRetaining Method

Commits the transaction and retains the transaction context after a commit.

[Visual Basic]
Public Sub CommitRetaining()
[C#]
public void CommitRetaining();

Exceptions

Exception Type | Condition
FbException | An error occurred while trying to commit the transaction.
InvalidOperationException | The transaction has already been committed or rolled back.
InvalidOperationException | FbCommand is currently busy Open, Fetching.

See Also

FbTransaction Class | FirebirdSql.Data.Firebird Namespace


FbTransaction.Dispose Method

Releases the unmanaged resources used by the FbTransaction and optionally releases the managed resources.

[Visual Basic]
NotOverridable Public Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

FbTransaction Class | FirebirdSql.Data.Firebird Namespace


Rollback Method

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbTransaction.Rollback Method

Rolls back a transaction from a pending state.

Overload List

Rolls back a transaction from a pending state.

public void Rollback();

Rolls back a transaction from a pending state, and specifies a savepoint name.

public void Rollback(string);

See Also

FbTransaction Class | FirebirdSql.Data.Firebird Namespace


FbTransaction.Rollback Method ()

Rolls back a transaction from a pending state.

[Visual Basic]
NotOverridable Overloads Public Sub Rollback() _
Implements IDbTransaction.Rollback
[C#]
public void Rollback();

Implements

IDbTransaction.Rollback

Exceptions

Exception Type | Condition
FbException | An error occurred while trying to commit the transaction.
InvalidOperationException | The transaction has already been committed or rolled back.
InvalidOperationException | FbCommand is currently busy Open, Fetching.

See Also

FbTransaction Class | FirebirdSql.Data.Firebird Namespace | FbTransaction.Rollback Overload List


FbTransaction.Rollback Method (String)

Rolls back a transaction from a pending state, and specifies a savepoint name.

[Visual Basic]
Overloads Public Sub Rollback( _
ByVal savePointName As String _
)
[C#]
public void Rollback(
string savePointName
);

Parameters

savePointName
The savepoint name to which rollback changes.

Exceptions

Exception Type | Condition
FbException | An error occurred while trying to rollback the transaction.
InvalidOperationException | The transaction has already been committed or rolled back.
InvalidOperationException | FbCommand is currently busy Open, Fetching.

Example

FbConnection myConnection = new FbConnection(connectionString);
myConnection.Open();

FbCommand myCommand = new FbCommand();
FbTransaction myTrans;

// Start a local transaction
myTrans = myConnection.BeginTransaction();
// Assign transaction object for a pending local transaction
myCommand.Connection = myConnection;
myCommand.Transaction = myTrans;

try
{
    myCommand.CommandText = "INSERT INTO PROJECT(proj_id, proj_name, product) Values('FBNP', '.Net Provider', 'N/A')";
    myCommand.ExecuteNonQuery();
    myTrans.Save("SampleTransaction");
    myCommand.CommandText = "INSERT INTO PROJECT(proj_id, proj_name, product) Values('FBN1', '.Net Provider1.', 'N/A')";
    myCommand.ExecuteNonQuery();
    myTrans.Commit();
    Console.WriteLine("Both records are written to database.");
}
catch(Exception e)
{
    try
    {
        myTrans.Rollback("SampleTransaction");
    }
    catch (FbException ex)
    {
        if (myTrans.Connection != null)
        {
            Console.WriteLine("An exception of type " + ex.GetType() +
                " was encountered while attempting to roll back the transaction.");
        }
    }

    Console.WriteLine("An exception of type " + e.GetType() +
        " was encountered while inserting the data.");
    Console.WriteLine("Neither record was written to database.");
}
finally
{
    myConnection.Close();
}

See Also

FbTransaction Class | FirebirdSql.Data.Firebird Namespace | FbTransaction.Rollback Overload List


FbTransaction.RollbackRetaining Method

Rolls back a transaction from a pending state and retains the transaction context after the rollback.

[Visual Basic]
Public Sub RollbackRetaining()
[C#]
public void RollbackRetaining();

Exceptions

Exception Type | Condition
ArgumentException | No transaction name was be specified.
InvalidOperationException | The transaction has already been committed or rolled back.
InvalidOperationException | FbCommand is currently busy Open, Fetching.

See Also

FbTransaction Class | FirebirdSql.Data.Firebird Namespace


FbTransaction.Save Method

Establish a new Save point for the current transaction with the given name.

[Visual Basic]
Public Sub Save( _
ByVal savePointName As String _
)
[C#]
public void Save(
string savePointName
);

Parameters

savePointName
The savepoint name.

Remarks

Savepoints offer a mechanism to roll back portions of transactions. You create a savepoint using the Save method, and then later call the Rollback method to roll back to the savepoint instead of rolling back to the start of the transaction.

Exceptions

Exception Type | Condition
FbException | An error occurred while trying to commit the transaction.
InvalidOperationException | The transaction has already been committed or rolled back.
InvalidOperationException | FbCommand is currently busy Open, Fetching.

Example

FbConnection myConnection = new FbConnection(connectionString);
myConnection.Open();

FbCommand myCommand = new FbCommand();
FbTransaction myTrans;

// Start a local transaction
myTrans = myConnection.BeginTransaction();
// Assign transaction object for a pending local transaction
myCommand.Connection = myConnection;
myCommand.Transaction = myTrans;

try
{
    myCommand.CommandText = "INSERT INTO PROJECT(proj_id, proj_name, product) Values('FBNP', '.Net Provider', 'N/A')";
    myCommand.ExecuteNonQuery();
    myTrans.Save("SampleTransaction");
    myCommand.CommandText = "INSERT INTO PROJECT(proj_id, proj_name, product) Values('FBN1', '.Net Provider1.', 'N/A')";
    myCommand.ExecuteNonQuery();
    myTrans.Commit();
    Console.WriteLine("Both records are written to database.");
}
catch(Exception e)
{
    try
    {
        myTrans.Rollback("SampleTransaction");
    }
    catch (FbException ex)
    {
        if (myTrans.Connection != null)
        {
            Console.WriteLine("An exception of type " + ex.GetType() +
                " was encountered while attempting to roll back the transaction.");
        }
    }

    Console.WriteLine("An exception of type " + e.GetType() +
        " was encountered while inserting the data.");
    Console.WriteLine("Neither record was written to database.");
}
finally
{
    myConnection.Close();
}

See Also

FbTransaction Class | FirebirdSql.Data.Firebird Namespace


FbTransactionOptions Enumeration

Specifies Firebird transactions specific options that can be used with BeginTransaction.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Serializable, _ Serializable, _ Flags>
Public Enum FbTransactionOptions
[C#]
[Serializable]
[Serializable]
[Flags]
public enum FbTransactionOptions

Members

Member Name | Description | Value
Consistency | Table locking transaction model. | 1
Concurrency | High concurrency transaction with acceptable consistency. The use of this parameter takes full advantage multi-generational transaction model. | 2
Shared | Concurrent, shared access of a specified table among all transactions. Used with LockRead and Lock Write options to establish the lock option. | 4
Protected | Concurrent, restricted access of a specified table. Used with LockRead and Lock Write options to establish the lock option. | 8
Exclusive | Exclusive access of a specified table. | 16
Wait | Lock resolution specifies that the transaction is to wait until locked resources are released before retrying an operation. | 32
NoWait | Lock resolution specifies that the transaction is not to wait for locks to be released, but instead, a lock conflict error should be returned immediately. | 64
Read | Read-only access mode that allows a transaction only to select data. | 128
Write | Read-write access mode of that allows a transaction to select, insert, update, and delete table data. | 256
LockRead | Read only access of a specified table. Used with Shared, Protected and Exclusive options to establish the lock option. | 512
LockWrite | Read/write access of a specified table. Used with Shared, Protected and Exclusive options to establish the lock option. | 1024
ReadCommitted | High throughput, high concurrency transaction that can read changes committed by other concurrent transactions. The use of this parameter takes full advantage multi-generational transaction model. | 2048
Autocommit |  | 4096
RecVersion | Enables an ReadCommitted transaction to read the most recently committed version of a record even if other, uncommitted versions are pending. | 8192
NoRecVersion | Enables an ReadCommitted transaction to read only the latest committed version of a record. If an uncommitted version of a record is pending and Wait is also specified, then the transaction waits for the pending record to be committed or rolled back before proceeding. Otherwise, a lock conflict error is reported at once. | 16384
RestartRequests |  | 32768
NoAutoUndo |  | 65536

Requirements

Namespace: FirebirdSql.Data.Firebird

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird Namespace


FirebirdSql.Data.Firebird.Isql

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FirebirdSql.Data.Firebird.Isql Namespace

Namespace hierarchy

Classes

Class | Description
CommandExecutedEventArgs | Summary description for CommandExecutedEventArgs.
CommandExecutingEventArgs | CommandExecutingEventArgs encapsulates the events arguments for the event trigged from the FbBatchExecution during the execution.
FbBatchExecution | Performs batch execution of ISQL commands.
FbScript | FbScript parses a SQL file and returns its SQL statements. The class take in consideration that the statement separator can change in code. For instance, in Firebird databases the statement SET TERM !! ; will change the statement token terminator ; into !!.
StringParser | StringParser parses a string returnning the (sub)strings between tokens.

Delegates

Delegate | Description
CommandExecutedEventHandler | The event handler type trigged after a SQL statement execution.
CommandExecutingEventHandler | The event handler type trigged before a SQL statement execution.

Enumerations

Enumeration | Description
SqlStatementType | DSQL and ISQL statement types.


CommandExecutedEventArgs Class

Summary description for CommandExecutedEventArgs.

For a list of all members of this type, see CommandExecutedEventArgs Members.

System.Object
FirebirdSql.Data.Firebird.Isql.CommandExecutedEventArgs

[Visual Basic]
Public Class CommandExecutedEventArgs
[C#]
public class CommandExecutedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: FirebirdSql.Data.Firebird.Isql

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

CommandExecutedEventArgs Members | FirebirdSql.Data.Firebird.Isql Namespace


CommandExecutedEventArgs Members

CommandExecutedEventArgs overview

Public Instance Constructors

CommandExecutedEventArgs Constructor Creates an instance of CommandExecutedEventArgs class.

Public Instance Properties

CommandText | Returns the SQL statement that was executed.
DataReader | Returns a FbDataReader instance case the executed SQL command returns data. If the executed SQL command does not returns data, (for instance: the case of an UPDATE statement), the DataReader is setled to null.
StatementType | Returns the SqlStatementType of the current CommandText.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Overrided. Returns the SQL statement that was executed.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandExecutedEventArgs Class | FirebirdSql.Data.Firebird.Isql Namespace


CommandExecutedEventArgs Constructor

Creates an instance of CommandExecutedEventArgs class.

[Visual Basic]
Public Sub New( _
ByVal dataReader As FbDataReader, _
ByVal commandText As String, _
ByVal rowsAffected As Integer _
)
[C#]
public CommandExecutedEventArgs(
FbDataReader dataReader,
string commandText,
int rowsAffected
);

Parameters

dataReader
commandText
The CommandText of the FbCommand that was executed.
rowsAffected

See Also

CommandExecutedEventArgs Class | FirebirdSql.Data.Firebird.Isql Namespace


CommandExecutedEventArgs Properties

The properties of the CommandExecutedEventArgs class are listed below. For a complete list of CommandExecutedEventArgs class members, see the CommandExecutedEventArgs Members topic.

Public Instance Properties

CommandText | Returns the SQL statement that was executed.
DataReader | Returns a FbDataReader instance case the executed SQL command returns data. If the executed SQL command does not returns data, (for instance: the case of an UPDATE statement), the DataReader is setled to null.
StatementType | Returns the SqlStatementType of the current CommandText.

See Also

CommandExecutedEventArgs Class | FirebirdSql.Data.Firebird.Isql Namespace


CommandText Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

CommandExecutedEventArgs.CommandText Property

Returns the SQL statement that was executed.

[Visual Basic]
Public ReadOnly Property CommandText As String
[C#]
public string CommandText {get;}

See Also

CommandExecutedEventArgs Class | FirebirdSql.Data.Firebird.Isql Namespace


DataReader Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

CommandExecutedEventArgs.DataReader Property

Returns a FbDataReader instance case the executed SQL command returns data. If the executed SQL command does not returns data, (for instance: the case of an UPDATE statement), the DataReader is setled to null.

[Visual Basic]
Public ReadOnly Property DataReader As FbDataReader
[C#]
public FirebirdSql.Data.Firebird.FbDataReader DataReader {get;}

See Also

CommandExecutedEventArgs Class | FirebirdSql.Data.Firebird.Isql Namespace


StatementType Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

CommandExecutedEventArgs.StatementType Property

Returns the SqlStatementType of the current CommandText.

[Visual Basic]
Public ReadOnly Property StatementType As SqlStatementType
[C#]
public SqlStatementType StatementType {get;}

See Also

CommandExecutedEventArgs Class | FirebirdSql.Data.Firebird.Isql Namespace


CommandExecutedEventArgs Methods

The methods of the CommandExecutedEventArgs class are listed below. For a complete list of CommandExecutedEventArgs class members, see the CommandExecutedEventArgs Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Overrided. Returns the SQL statement that was executed.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandExecutedEventArgs Class | FirebirdSql.Data.Firebird.Isql Namespace


CommandExecutedEventArgs.ToString Method

Overrided. Returns the SQL statement that was executed.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The SQL statement that will be executed.

See Also

CommandExecutedEventArgs Class | FirebirdSql.Data.Firebird.Isql Namespace


CommandExecutedEventHandler Delegate

The event handler type trigged after a SQL statement execution.

[Visual Basic]
Public Delegate Sub CommandExecutedEventHandler( _
ByVal sender As Object, _
ByVal e As CommandExecutedEventArgs _
)
[C#]
public delegate void CommandExecutedEventHandler(
object sender,
CommandExecutedEventArgs e
);

Requirements

Namespace: FirebirdSql.Data.Firebird.Isql

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird.Isql Namespace


CommandExecutingEventArgs Class

CommandExecutingEventArgs encapsulates the events arguments for the event trigged from the FbBatchExecution during the execution.

For a list of all members of this type, see CommandExecutingEventArgs Members.

System.Object
System.EventArgs
FirebirdSql.Data.Firebird.Isql.CommandExecutingEventArgs

[Visual Basic]
Public Class CommandExecutingEventArgs
Inherits EventArgs
[C#]
public class CommandExecutingEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: FirebirdSql.Data.Firebird.Isql

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

CommandExecutingEventArgs Members | FirebirdSql.Data.Firebird.Isql Namespace


CommandExecutingEventArgs Members

CommandExecutingEventArgs overview

Public Instance Constructors

CommandExecutingEventArgs Constructor Creates an instance of CommandExecutingEventArgs class.

Public Instance Properties

SqlCommand | Returns the FbCommand instance that created for the SQL statement that goes for execution.
StatementType | Returns the SqlStatementType of the current SqlCommand.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Overrided. Returns the SQL statement that goes for execution.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandExecutingEventArgs Class | FirebirdSql.Data.Firebird.Isql Namespace


CommandExecutingEventArgs Constructor

Creates an instance of CommandExecutingEventArgs class.

[Visual Basic]
Public Sub New( _
ByVal sqlCommand As FbCommand _
)
[C#]
public CommandExecutingEventArgs(
FbCommand sqlCommand
);

Parameters

sqlCommand
The FbCommand properly instanciated.

Remarks

The sqlCommand should be proper instanciated with a valid FbCommand and with the SQL statement loaded in CommandText.

See Also

CommandExecutingEventArgs Class | FirebirdSql.Data.Firebird.Isql Namespace


CommandExecutingEventArgs Properties

The properties of the CommandExecutingEventArgs class are listed below. For a complete list of CommandExecutingEventArgs class members, see the CommandExecutingEventArgs Members topic.

Public Instance Properties

SqlCommand | Returns the FbCommand instance that created for the SQL statement that goes for execution.
StatementType | Returns the SqlStatementType of the current SqlCommand.

See Also

CommandExecutingEventArgs Class | FirebirdSql.Data.Firebird.Isql Namespace


SqlCommand Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

CommandExecutingEventArgs.SqlCommand Property

Returns the FbCommand instance that created for the SQL statement that goes for execution.

[Visual Basic]
Public ReadOnly Property SqlCommand As FbCommand
[C#]
public FirebirdSql.Data.Firebird.FbCommand SqlCommand {get;}

See Also

CommandExecutingEventArgs Class | FirebirdSql.Data.Firebird.Isql Namespace


StatementType Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

CommandExecutingEventArgs.StatementType Property

Returns the SqlStatementType of the current SqlCommand.

[Visual Basic]
Public ReadOnly Property StatementType As SqlStatementType
[C#]
public SqlStatementType StatementType {get;}

See Also

CommandExecutingEventArgs Class | FirebirdSql.Data.Firebird.Isql Namespace


CommandExecutingEventArgs Methods

The methods of the CommandExecutingEventArgs class are listed below. For a complete list of CommandExecutingEventArgs class members, see the CommandExecutingEventArgs Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Overrided. Returns the SQL statement that goes for execution.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandExecutingEventArgs Class | FirebirdSql.Data.Firebird.Isql Namespace


CommandExecutingEventArgs.ToString Method

Overrided. Returns the SQL statement that goes for execution.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The SQL statement that will be executed.

See Also

CommandExecutingEventArgs Class | FirebirdSql.Data.Firebird.Isql Namespace


CommandExecutingEventHandler Delegate

The event handler type trigged before a SQL statement execution.

[Visual Basic]
Public Delegate Sub CommandExecutingEventHandler( _
ByVal sender As Object, _
ByVal e As CommandExecutingEventArgs _
)
[C#]
public delegate void CommandExecutingEventHandler(
object sender,
CommandExecutingEventArgs e
);

Requirements

Namespace: FirebirdSql.Data.Firebird.Isql

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird.Isql Namespace


FbBatchExecution Class

Performs batch execution of ISQL commands.

For a list of all members of this type, see FbBatchExecution Members.

System.Object
FirebirdSql.Data.Firebird.Isql.FbBatchExecution

[Visual Basic]
Public Class FbBatchExecution
[C#]
public class FbBatchExecution

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: FirebirdSql.Data.Firebird.Isql

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbBatchExecution Members | FirebirdSql.Data.Firebird.Isql Namespace


FbBatchExecution Members

FbBatchExecution overview

Public Static (Shared) Methods

GetStatementType Determines the SqlStatementType of the provided SQL statement.

Public Instance Constructors

FbBatchExecution Overloaded. Initializes a new instance of the FbBatchExecution class.

Public Instance Properties

SqlStatements Represents the list of SQL statements for batch execution.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Overloaded. Starts the ordered execution of the SQL statements that are in SqlStatements collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

CommandExecuted | The event trigged after a SQL statement execution.
CommandExecuting | The event trigged before a SQL statement goes for execution.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCommandExecuted | The trigger function for CommandExecuted event.
OnCommandExecuting | The trigger function for CommandExecuting event.

Protected Internal Instance Methods

ConnectToDatabase | Updates the connection string with the data parsed from the parameter and opens a connection to the database.
CreateDatabase | Parses the isql statement CREATE DATABASE and creates the database and opens a connection to the recently created database.
ExecuteCommand | Executes a command and optionally commits the transaction.
ProvideCommand | Gets a FbCommand instance.
ProvideConnection | Gets a FbConnection instance.
SetDatabase |

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace


FbBatchExecution Constructor

Creates an instance of FbBatchExecution engine.

Overload List

Creates an instance of FbBatchExecution engine.

public FbBatchExecution();

Creates an instance of FbBatchExecution engine with the given connection.

public FbBatchExecution(FbConnection);

public FbBatchExecution(FbConnection,FbScript);

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace


FbBatchExecution Constructor ()

Creates an instance of FbBatchExecution engine.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FbBatchExecution();

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace | FbBatchExecution Constructor Overload List


FbBatchExecution Constructor (FbConnection)

Creates an instance of FbBatchExecution engine with the given connection.

[Visual Basic]
Overloads Public Sub New( _
ByVal sqlConnection As FbConnection _
)
[C#]
public FbBatchExecution(
FbConnection sqlConnection
);

Parameters

sqlConnection
A FbConnection object.

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace | FbBatchExecution Constructor Overload List


FbBatchExecution Constructor (FbConnection, FbScript)

[Visual Basic]
Overloads Public Sub New( _
ByVal sqlConnection As FbConnection, _
ByVal isqlScript As FbScript _
)
[C#]
public FbBatchExecution(
FbConnection sqlConnection,
FbScript isqlScript
);

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace | FbBatchExecution Constructor Overload List


FbBatchExecution Properties

The properties of the FbBatchExecution class are listed below. For a complete list of FbBatchExecution class members, see the FbBatchExecution Members topic.

Public Instance Properties

SqlStatements Represents the list of SQL statements for batch execution.

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace


SqlStatements Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbBatchExecution.SqlStatements Property

Represents the list of SQL statements for batch execution.

[Visual Basic]
Public ReadOnly Property SqlStatements As StringCollection
[C#]
public System.Collections.Specialized.StringCollection SqlStatements {get;}

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace


FbBatchExecution Methods

The methods of the FbBatchExecution class are listed below. For a complete list of FbBatchExecution class members, see the FbBatchExecution Members topic.

Public Static (Shared) Methods

GetStatementType Determines the SqlStatementType of the provided SQL statement.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Overloaded. Starts the ordered execution of the SQL statements that are in SqlStatements collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCommandExecuted | The trigger function for CommandExecuted event.
OnCommandExecuting | The trigger function for CommandExecuting event.

Protected Internal Instance Methods

ConnectToDatabase | Updates the connection string with the data parsed from the parameter and opens a connection to the database.
CreateDatabase | Parses the isql statement CREATE DATABASE and creates the database and opens a connection to the recently created database.
ExecuteCommand | Executes a command and optionally commits the transaction.
ProvideCommand | Gets a FbCommand instance.
ProvideConnection | Gets a FbConnection instance.
SetDatabase |

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace


FbBatchExecution.ConnectToDatabase Method

Updates the connection string with the data parsed from the parameter and opens a connection to the database.

[Visual Basic]
Protected Friend Sub ConnectToDatabase( _
ByVal connectDbStatement As String _
)
[C#]
protected internal void ConnectToDatabase(
string connectDbStatement
);

Parameters

connectDbStatement

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace


FbBatchExecution.CreateDatabase Method

Parses the isql statement CREATE DATABASE and creates the database and opens a connection to the recently created database.

[Visual Basic]
Protected Friend Sub CreateDatabase( _
ByVal createDbStatement As String _
)
[C#]
protected internal void CreateDatabase(
string createDbStatement
);

Parameters

createDbStatement
the create database statement.

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace


Execute Method

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbBatchExecution.Execute Method

Starts the ordered execution of the SQL statements that are in SqlStatements collection.

Overload List

Starts the ordered execution of the SQL statements that are in SqlStatements collection.

public virtual void Execute();

Starts the ordered execution of the SQL statements that are in SqlStatements collection.

public virtual void Execute(bool);

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace


FbBatchExecution.Execute Method ()

Starts the ordered execution of the SQL statements that are in SqlStatements collection.

[Visual Basic]
Overridable Overloads Public Sub Execute()
[C#]
public virtual void Execute();

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace | FbBatchExecution.Execute Overload List


FbBatchExecution.Execute Method (Boolean)

Starts the ordered execution of the SQL statements that are in SqlStatements collection.

[Visual Basic]
Overridable Overloads Public Sub Execute( _
ByVal autoCommit As Boolean _
)
[C#]
public virtual void Execute(
bool autoCommit
);

Parameters

autoCommit
Specifies if the transaction should be committed after a DDL command execution

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace | FbBatchExecution.Execute Overload List


FbBatchExecution.ExecuteCommand Method

Executes a command and optionally commits the transaction.

[Visual Basic]
Protected Friend Function ExecuteCommand( _
ByVal command As FbCommand, _
ByVal autocommit As Boolean _
) As Integer
[C#]
protected internal int ExecuteCommand(
FbCommand command,
bool autocommit
);

Parameters

command
Command to execute.
autocommit
true to commit the transaction after execution; or false if not.

Return Value

The number of rows affected by the query execution.

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace


FbBatchExecution.GetStatementType Method

Determines the SqlStatementType of the provided SQL statement.

[Visual Basic]
Public Shared Function GetStatementType( _
ByVal sqlStatement As String _
) As SqlStatementType
[C#]
public static SqlStatementType GetStatementType(
string sqlStatement
);

Parameters

sqlStatement
The string containing the SQL statement.

Return Value

The SqlStatementType of the sqlStatement.

Remarks

If the type of sqlStatement could not be determinated this method will throw an exception.

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace


FbBatchExecution.OnCommandExecuted Method

The trigger function for CommandExecuted event.

[Visual Basic]
Overridable Protected Sub OnCommandExecuted( _
ByVal commandText As String, _
ByVal dataReader As FbDataReader, _
ByVal rowsAffected As Integer _
)
[C#]
protected virtual void OnCommandExecuted(
string commandText,
FbDataReader dataReader,
int rowsAffected
);

Parameters

commandText
The CommandText of the executed SQL command.
dataReader
The FbDataReader instance with the returned data. If the command executed is not meant to return data (ex: UPDATE, INSERT...) this parameter must be setled to null.
rowsAffected
The rows that were affected by the executed SQL command. If the executed command is not meant to return this kind of information (ex: SELECT) this parameter must be setled to -1.

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace


FbBatchExecution.OnCommandExecuting Method

The trigger function for CommandExecuting event.

[Visual Basic]
Overridable Protected Sub OnCommandExecuting( _
ByVal sqlCommand As FbCommand _
)
[C#]
protected virtual void OnCommandExecuting(
FbCommand sqlCommand
);

Parameters

sqlCommand
The SQL command that is going for execution.

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace


FbBatchExecution.ProvideCommand Method

Gets a FbCommand instance.

[Visual Basic]
Protected Friend Function ProvideCommand() As FbCommand
[C#]
protected internal FbCommand ProvideCommand();

Return Value

An instance of the FbCommand class.

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace


FbBatchExecution.ProvideConnection Method

Gets a FbConnection instance.

[Visual Basic]
Protected Friend Function ProvideConnection() As FbConnection
[C#]
protected internal FbConnection ProvideConnection();

Return Value

An instance of the FbConnection class.

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace


FbBatchExecution.SetDatabase Method

[Visual Basic]
Protected Friend Function SetDatabase( _
ByVal setDbStatement As String _
) As FbConnection
[C#]
protected internal FbConnection SetDatabase(
string setDbStatement
);

Return Value

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace


FbBatchExecution Events

The events of the FbBatchExecution class are listed below. For a complete list of FbBatchExecution class members, see the FbBatchExecution Members topic.

Public Instance Events

CommandExecuted | The event trigged after a SQL statement execution.
CommandExecuting | The event trigged before a SQL statement goes for execution.

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace


FbBatchExecution.CommandExecuted Event

The event trigged after a SQL statement execution.

[Visual Basic]
Public Event CommandExecuted As CommandExecutedEventHandler
[C#]
public event CommandExecutedEventHandler CommandExecuted;

Event Data

The event handler receives an argument of type CommandExecutedEventArgs containing data related to this event. The following CommandExecutedEventArgs properties provide information specific to this event.

Property | Description
CommandText | Returns the SQL statement that was executed.
DataReader | Returns a FbDataReader instance case the executed SQL command returns data. If the executed SQL command does not returns data, (for instance: the case of an UPDATE statement), the DataReader is setled to null.
StatementType | Returns the SqlStatementType of the current CommandText.

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace


FbBatchExecution.CommandExecuting Event

The event trigged before a SQL statement goes for execution.

[Visual Basic]
Public Event CommandExecuting As CommandExecutingEventHandler
[C#]
public event CommandExecutingEventHandler CommandExecuting;

Event Data

The event handler receives an argument of type CommandExecutingEventArgs containing data related to this event. The following CommandExecutingEventArgs properties provide information specific to this event.

Property | Description
SqlCommand | Returns the FbCommand instance that created for the SQL statement that goes for execution.
StatementType | Returns the SqlStatementType of the current SqlCommand.

See Also

FbBatchExecution Class | FirebirdSql.Data.Firebird.Isql Namespace


FbScript Class

FbScript parses a SQL file and returns its SQL statements. The class take in consideration that the statement separator can change in code. For instance, in Firebird databases the statement SET TERM !! ; will change the statement token terminator ; into !!.

For a list of all members of this type, see FbScript Members.

System.Object
FirebirdSql.Data.Firebird.Isql.FbScript

[Visual Basic]
Public Class FbScript
[C#]
public class FbScript

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: FirebirdSql.Data.Firebird.Isql

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbScript Members | FirebirdSql.Data.Firebird.Isql Namespace


FbScript Members

FbScript overview

Protected Static (Shared) Methods

RemoveComments Removes from the SQL code all comments of the type: /*...*/ or --

Public Instance Constructors

FbScript Overloaded. Initializes a new instance of the FbScript class.

Public Instance Properties

Results Returns a StringCollection containing all the SQL statements (without comments) present on the file. This property is loaded after the method call Parse.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Parse | Parses the SQL code and loads the SQL statements into the StringCollection Results.
ToString | Overrided method, returns the the SQL code to be parsed (with comments removed).

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FbScript Class | FirebirdSql.Data.Firebird.Isql Namespace


FbScript Constructor

Creates an instance of FbScript class.

Overload List

Creates an instance of FbScript class.

public FbScript(TextReader);

Creates an instance of FbScript class.

public FbScript(string);

See Also

FbScript Class | FirebirdSql.Data.Firebird.Isql Namespace


FbScript Constructor (String)

Creates an instance of FbScript class.

[Visual Basic]
Overloads Public Sub New( _
ByVal sqlFilename As String _
)
[C#]
public FbScript(
string sqlFilename
);

Parameters

sqlFilename
The filename for the SQL file.

See Also

FbScript Class | FirebirdSql.Data.Firebird.Isql Namespace | FbScript Constructor Overload List


FbScript Constructor (TextReader)

Creates an instance of FbScript class.

[Visual Basic]
Overloads Public Sub New( _
ByVal sqlCode As TextReader _
)
[C#]
public FbScript(
TextReader sqlCode
);

Parameters

sqlCode
A TextReader instance.

Remarks

The all data in TextReader is read.

See Also

FbScript Class | FirebirdSql.Data.Firebird.Isql Namespace | FbScript Constructor Overload List


FbScript Properties

The properties of the FbScript class are listed below. For a complete list of FbScript class members, see the FbScript Members topic.

Public Instance Properties

Results Returns a StringCollection containing all the SQL statements (without comments) present on the file. This property is loaded after the method call Parse.

See Also

FbScript Class | FirebirdSql.Data.Firebird.Isql Namespace


Results Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbScript.Results Property

Returns a StringCollection containing all the SQL statements (without comments) present on the file. This property is loaded after the method call Parse.

[Visual Basic]
Public ReadOnly Property Results As StringCollection
[C#]
public System.Collections.Specialized.StringCollection Results {get;}

See Also

FbScript Class | FirebirdSql.Data.Firebird.Isql Namespace


FbScript Methods

The methods of the FbScript class are listed below. For a complete list of FbScript class members, see the FbScript Members topic.

Protected Static (Shared) Methods

RemoveComments Removes from the SQL code all comments of the type: /*...*/ or --

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Parse | Parses the SQL code and loads the SQL statements into the StringCollection Results.
ToString | Overrided method, returns the the SQL code to be parsed (with comments removed).

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FbScript Class | FirebirdSql.Data.Firebird.Isql Namespace


FbScript.Parse Method

Parses the SQL code and loads the SQL statements into the StringCollection Results.

[Visual Basic]
Public Function Parse() As Integer
[C#]
public int Parse();

Return Value

The number of statements found.

See Also

FbScript Class | FirebirdSql.Data.Firebird.Isql Namespace


FbScript.RemoveComments Method

Removes from the SQL code all comments of the type: /*...*/ or --

[Visual Basic]
Protected Shared Function RemoveComments( _
ByVal source As String _
) As String
[C#]
protected static string RemoveComments(
string source
);

Parameters

source
The string containing the original SQL code.

Return Value

A string containing the SQL code without comments.

See Also

FbScript Class | FirebirdSql.Data.Firebird.Isql Namespace


FbScript.ToString Method

Overrided method, returns the the SQL code to be parsed (with comments removed).

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The SQL code to be parsed (without comments).

See Also

FbScript Class | FirebirdSql.Data.Firebird.Isql Namespace


SqlStatementType Enumeration

DSQL and ISQL statement types.

[Visual Basic]
Public Enum SqlStatementType
[C#]
public enum SqlStatementType

Members

Member Name | Description
AlterDatabase | Represents the SQL statement: ALTER DATABASE
AlterDomain | Represents the SQL statement: ALTER DOMAIN
AlterException | Represents the SQL statement: ALTER EXCEPTION
AlterIndex | Represents the SQL statement: ALTER INDEX
AlterProcedure | Represents the SQL statement: ALTER PROCEDURE
AlterTable | Represents the SQL statement: ALTER TABLE
AlterTrigger | Represents the SQL statement: ALTER TRIGGER
Close | Represents the SQL statement: CLOSE
Commit | Represents the SQL statement: COMMIT
Connect | Represents the SQL statement: CONNECT
CreateDatabase | Represents the SQL statement: CREATE DATABASE
CreateDomain | Represents the SQL statement: CREATE DOMAIN
CreateException | Represents the SQL statement: CREATE EXCEPTION
CreateGenerator | Represents the SQL statement: CREATE GENERATOR
CreateIndex | Represents the SQL statement: CREATE INDEX
CreateProcedure | Represents the SQL statement: CREATE PROCEDURE
CreateRole | Represents the SQL statement: CREATE ROLE
CreateShadow | Represents the SQL statement: CREATE SHADOW
CreateTable | Represents the SQL statement: CREATE TABLE
CreateTrigger | Represents the SQL statement: CREATE TRIGGER
CreateView | Represents the SQL statement: CREATE VIEW
DeclareCursor | Represents the SQL statement: DECLARE CURSOR
DeclareExternalFunction | Represents the SQL statement: DECLARE EXTERNAL FUNCTION
DeclareFilter | Represents the SQL statement: DECLARE FILTER
DeclareStatement | Represents the SQL statement: DECLARE STATEMENT
DeclareTable | Represents the SQL statement: DECLARE TABLE
Delete | Represents the SQL statement: DELETE
Describe | Represents the SQL statement: DESCRIBE
Disconnect | Represents the SQL statement: DISCONNECT
DropDatabase | Represents the SQL statement: DROP DATABASE
DropDomain | Represents the SQL statement: DROP DOMAIN
DropException | Represents the SQL statement: DROP EXCEPTION
DropExternalFunction | Represents the SQL statement: DROP EXTERNAL FUNCTION
DropFilter | Represents the SQL statement: DROP FILTER
DropGenerator | Represents the SQL statement: DROP GENERATOR
DropIndex | Represents the SQL statement: DROP INDEX
DropProcedure | Represents the SQL statement: DROP PROCEDURE
DropRole | Represents the SQL statement: DROP ROLE
DropShadow | Represents the SQL statement: DROP SHADOW
DropTable | Represents the SQL statement: DROP TABLE
DropTrigger | Represents the SQL statement: DROP TRIGGER
DropView | Represents the SQL statement: DROP VIEW
EndDeclareSection | Represents the SQL statement: END DECLARE SECTION
EventInit | Represents the SQL statement: EVENT INIT
EventWait | Represents the SQL statement: EVENT WAIT
Execute | Represents the SQL statement: EXECUTE
ExecuteImmediate | Represents the SQL statement: EXECUTE IMMEDIATE
ExecuteProcedure | Represents the SQL statement: EXECUTE PROCEDURE
Fetch | Represents the SQL statement: FETCH
Grant | Represents the SQL statement: GRANT
Insert | Represents the SQL statement: INSERT
InsertCursor | Represents the SQL statement: INSERT CURSOR
Open | Represents the SQL statement: OPEN
Prepare | Represents the SQL statement: PREPARE
Revoke | Represents the SQL statement: REVOKE
Rollback | Represents the SQL statement: ROLLBACK
Select | Represents the SQL statement: SELECT
SetDatabase | Represents the SQL statement: SET DATABASE
SetGenerator | Represents the SQL statement: SET GENERATOR
SetNames | Represents the SQL statement: SET NAMES
SetSQLDialect | Represents the SQL statement: SET SQL DIALECT
SetStatistics | Represents the SQL statement: SET STATISTICS
SetTransaction | Represents the SQL statement: SET TRANSACTION
ShowSQLDialect | Represents the SQL statement: SHOW SQL DIALECT
Update | Represents the SQL statement: UPDATE
Whenever | Represents the SQL statement: WHENEVER

Requirements

Namespace: FirebirdSql.Data.Firebird.Isql

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird.Isql Namespace


StringParser Class

StringParser parses a string returnning the (sub)strings between tokens.

For a list of all members of this type, see StringParser Members.

System.Object
FirebirdSql.Data.Firebird.Isql.StringParser

[Visual Basic]
Public Class StringParser
[C#]
public class StringParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

An example of how to use this class.

[STAThread]
static void    Main(string[] args)    {
    int    currentIndex = 0;
    string s = ".NET Framework doesn't have a string parsing class?!";
    StringParser parser = new StringParser(s, false);
    while (currentIndex    < s.Length) {
        Console.WriteLine("Returned Index: {0}", currentIndex = parser.ParseNext());
        Console.WriteLine("Chars scanned: {0}",    parser.CharsParsed);
        Console.WriteLine("Parsing result: {0}\n", parser.Result);
    }
}

The output:

Returned Index:    5
Chars scanned: 5
Parsing    result:    .NET

Returned Index:    15
Chars scanned: 10
Parsing    result:    Framework

Returned Index:    23
Chars scanned: 8
Parsing    result:    doesn't

Returned Index:    28
Chars scanned: 5
Parsing    result:    have

Returned Index:    30
Chars scanned: 2
Parsing    result:    a

Returned Index:    37
Chars scanned: 7
Parsing    result:    string

Returned Index:    45
Chars scanned: 8
Parsing    result:    parsing

Returned Index:    52
Chars scanned: 7
Parsing    result:    class?!

Requirements

Namespace: FirebirdSql.Data.Firebird.Isql

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

StringParser Members | FirebirdSql.Data.Firebird.Isql Namespace


StringParser Members

StringParser overview

Public Static (Shared) Methods

StartsWith Indicates if the string specified as source starts with the token string.

Public Instance Constructors

StringParser Overloaded. Initializes a new instance of the StringParser class.

Public Instance Properties

CharsParsed | Loaded after a parsing operation with the number of chars parsed.
Length | Returns the length of the string that is being parsed.
Result | Loaded after a parsing operation with the string that was found between tokens.
Token | The string separator. The default value is a white space: 0x32 ASCII code.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Overloaded. Returns the index of the substring in the string. If the substring does not exists the method returns -1.
Parse | Overloaded. Parses target string attempting to determine the (sub)string between the beginning of this string and the Token. After the parse is complete system will load into CharsParsed then number of chars scanned and into Result the string that was found.
ParseNext | Repeats the parsing starting on the index returned by Parse method. You can also call ParseNext directly (without calling Parse) if you define the text to be parsed at instance construction.
ToString | Overrided method that returns the string to be parsed.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace


StringParser Constructor

Creates an instance of StringParser.

Overload List

Creates an instance of StringParser.

public StringParser(bool);

Creates an instance of StringParser.

public StringParser(string,bool);

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace


StringParser Constructor (Boolean)

Creates an instance of StringParser.

[Visual Basic]
Overloads Public Sub New( _
ByVal caseSensitive As Boolean _
)
[C#]
public StringParser(
bool caseSensitive
);

Parameters

caseSensitive
Indicates if parser system should be case-sensitive (true) or case-intensitive (false).

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace | StringParser Constructor Overload List


StringParser Constructor (String, Boolean)

Creates an instance of StringParser.

[Visual Basic]
Overloads Public Sub New( _
ByVal targetString As String, _
ByVal caseSensitive As Boolean _
)
[C#]
public StringParser(
string targetString,
bool caseSensitive
);

Parameters

targetString
Indicates if parser system should be case-sensitive (true) or case-intensitive (false).
caseSensitive
The string to parse.

Remarks

By defining the string (to parse) in constructor you can call directly the method ParseNext without having to initializate the target string on Parse method. See the example for further details.

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace | StringParser Constructor Overload List


StringParser Properties

The properties of the StringParser class are listed below. For a complete list of StringParser class members, see the StringParser Members topic.

Public Instance Properties

CharsParsed | Loaded after a parsing operation with the number of chars parsed.
Length | Returns the length of the string that is being parsed.
Result | Loaded after a parsing operation with the string that was found between tokens.
Token | The string separator. The default value is a white space: 0x32 ASCII code.

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace


CharsParsed Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

StringParser.CharsParsed Property

Loaded after a parsing operation with the number of chars parsed.

[Visual Basic]
Public ReadOnly Property CharsParsed As Integer
[C#]
public int CharsParsed {get;}

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace


Length Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

StringParser.Length Property

Returns the length of the string that is being parsed.

[Visual Basic]
Public ReadOnly Property Length As Integer
[C#]
public int Length {get;}

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace


Result Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

StringParser.Result Property

Loaded after a parsing operation with the string that was found between tokens.

[Visual Basic]
Public ReadOnly Property Result As String
[C#]
public string Result {get;}

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace


Token Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

StringParser.Token Property

The string separator. The default value is a white space: 0x32 ASCII code.

[Visual Basic]
Public Property Token As String
[C#]
public string Token {get; set;}

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace


StringParser Methods

The methods of the StringParser class are listed below. For a complete list of StringParser class members, see the StringParser Members topic.

Public Static (Shared) Methods

StartsWith Indicates if the string specified as source starts with the token string.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Overloaded. Returns the index of the substring in the string. If the substring does not exists the method returns -1.
Parse | Overloaded. Parses target string attempting to determine the (sub)string between the beginning of this string and the Token. After the parse is complete system will load into CharsParsed then number of chars scanned and into Result the string that was found.
ParseNext | Repeats the parsing starting on the index returned by Parse method. You can also call ParseNext directly (without calling Parse) if you define the text to be parsed at instance construction.
ToString | Overrided method that returns the string to be parsed.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace


IndexOf Method

Firebird ADO.NET Provider SDK Documentation - v1.7.1

StringParser.IndexOf Method

Returns the index of the substring in the string. If the substring does not exists the method returns -1.

Overload List

Returns the index of the substring in the string. If the substring does not exists the method returns -1.

public int IndexOf(string);

Returns the index of the substring in the string starting on index startIndex. If the substring does not exists the method returns -1.

public int IndexOf(string,int);

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace


StringParser.IndexOf Method (String)

Returns the index of the substring in the string. If the substring does not exists the method returns -1.

[Visual Basic]
Overloads Public Function IndexOf( _
ByVal substring As String _
) As Integer
[C#]
public int IndexOf(
string substring
);

Parameters

substring
The string to be located.

Return Value

The index of the substring or -1 if the string does not exists within the source string. If the the substring is empty method returns 0.

Remarks

The instance parses for the substring in a case sensitive or intensive way, as you specify at class construction.

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace | StringParser.IndexOf Overload List


StringParser.IndexOf Method (String, Int32)

Returns the index of the substring in the string starting on index startIndex. If the substring does not exists the method returns -1.

[Visual Basic]
Overloads Public Function IndexOf( _
ByVal substring As String, _
ByVal startIndex As Integer _
) As Integer
[C#]
public int IndexOf(
string substring,
int startIndex
);

Parameters

substring
The string to be located.
startIndex
The start index of the source string where parser will start.

Return Value

The index of the substring or -1 if the string does not exists within the source string. If the the substring is empty method returns startIndex.

Remarks

The instance parses for the substring in a case sensitive or intensive way, as you specify at class construction.

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace | StringParser.IndexOf Overload List


Parse Method

Firebird ADO.NET Provider SDK Documentation - v1.7.1

StringParser.Parse Method

Parses target string attempting to determine the (sub)string between the beginning of this string and the Token. After the parse is complete system will load into CharsParsed then number of chars scanned and into Result the string that was found.

Overload List

Parses target string attempting to determine the (sub)string between the beginning of this string and the Token. After the parse is complete system will load into CharsParsed then number of chars scanned and into Result the string that was found.

public int Parse(string);

Parses target string attempting to determine the (sub)string between the index start of this string and the Token. After the parse is complete system will load into CharsParsed then number of chars scanned and into Result the string that was found.

public int Parse(string,int);

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace


StringParser.Parse Method (String)

Parses target string attempting to determine the (sub)string between the beginning of this string and the Token. After the parse is complete system will load into CharsParsed then number of chars scanned and into Result the string that was found.

[Visual Basic]
Overloads Public Function Parse( _
ByVal targetString As String _
) As Integer
[C#]
public int Parse(
string targetString
);

Parameters

targetString
The string to be parsed.

Return Value

The index of the char next char after the Token end.

Remarks

If nothing is parsed the method will return -1. Case the Token wasn't found until the end of the string the method retuns (in Result) the string found between the starting index and the end of the string.

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace | StringParser.Parse Overload List


StringParser.Parse Method (String, Int32)

Parses target string attempting to determine the (sub)string between the index start of this string and the Token. After the parse is complete system will load into CharsParsed then number of chars scanned and into Result the string that was found.

[Visual Basic]
Overloads Public Function Parse( _
ByVal targetString As String, _
ByVal start As Integer _
) As Integer
[C#]
public int Parse(
string targetString,
int start
);

Parameters

targetString
The string to be parsed.
start
The start index for parsing purposes.

Return Value

The index of the char next char after the Token end.

Remarks

If nothing is parsed the method will return -1. Case the Token wasn't found until the end of the string the method returns (in Result) the string found between the starting index and the end of the string.

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace | StringParser.Parse Overload List


StringParser.ParseNext Method

Repeats the parsing starting on the index returned by Parse method.

You can also call ParseNext directly (without calling Parse) if you define the text to be parsed at instance construction.
[Visual Basic]
Public Function ParseNext() As Integer
[C#]
public int ParseNext();

Return Value

The index of the char next char after the Token end.

Remarks

If nothing is parsed the method will return -1. Case the Token wasn't found until the end of the string the method returns (in Result) the string found between the starting index and the end of the string.

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace


StringParser.StartsWith Method

Indicates if the string specified as source starts with the token string.

[Visual Basic]
Public Shared Function StartsWith( _
ByVal source As String, _
ByVal token As String, _
ByVal ignoreCase As Boolean _
) As Boolean
[C#]
public static bool StartsWith(
string source,
string token,
bool ignoreCase
);

Parameters

source
The source string.
token
The token that is intended to find.
ignoreCase
Indicated is char case should be ignored.

Return Value

Returns true if the token precedes the source.

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace


StringParser.ToString Method

Overrided method that returns the string to be parsed.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The string to be parsed.

See Also

StringParser Class | FirebirdSql.Data.Firebird.Isql Namespace


FirebirdSql.Data.Firebird.Services

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FirebirdSql.Data.Firebird.Services Namespace

Namespace hierarchy

Classes

Class | Description
FbBackup | Back up a database to a file or tape device. This class cannot be inherited.
FbBackupFile | Specifies a backup file path and length to be used in Backup or Restore process.
FbConfiguration | Allow configuration of local or remote databases properties.
FbLog | Retrieve the firebird.log file from the server if the log file exists. An error is returned if the log file does not exist. This class cannot be inherited.
FbRestore | Restore a database from backup files. This class cannot be inherited.
FbSecurity | Allow to list, add, delete, and modify users.
FbServerProperties | Retrieve server configuration information.
FbService | Base class for Firebird Services implementation.
FbStatistical | Retrieve database statistics for the database specified. This class cannot be inherited.
FbUserData | Represents data of a user of security.fdb security database.
FbValidation | Request a database validation. This class cannot be inherited.
ServiceOutputEventArgs | Provides data for the ServiceOutput event. This class cannot be inherited.

Structures

Structure | Description
FbDatabasesInfo | Retrieves information about databases on server.
FbServerConfig | Parameters and values in the firebird.conf file on the server.

Delegates

Delegate | Description
ServiceOutputEventHandler |

Enumerations

Enumeration | Description
FbBackupFlags | Specifies access flags for database backup.
FbRestoreFlags | Specifies access flags for database restore.
FbServiceState |
FbShutdownMode | Allowed shutdown modes.
FbStatisticalFlags | Specifies access flags for retrieve database statistics.
FbValidationFlags | Specifies access flags for database validation.


FbBackup Class

Back up a database to a file or tape device. This class cannot be inherited.

For a list of all members of this type, see FbBackup Members.

System.Object
FirebirdSql.Data.Firebird.Services.FbService
FirebirdSql.Data.Firebird.Services.FbBackup

[Visual Basic]
NotInheritable Public Class FbBackup
Inherits FbService
[C#]
public sealed class FbBackup : FbService

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Paths of backup files are relative to the server. Since the Services Manager executes backup and restore tasks on the server host, the Services Manager reads and writes backup files on the server host.

The username and password used to connect to the services manager will be used to connect to the database for backup. This helps add some degree of security for this operation. Only the SYSDBA user or the owner of the database will be able to backup a database.

Example

The following example makes a backup of a database to a single file and display server output on Console.

[STAThread]
static void Main(string[] args)
{
    FbConnectionStringBuilder cs = new FbConnectionStringBuilder();

    cs.UserID   = "SYSDBA";
    cs.Password = "masterkey";
    cs.Database = "nunit_testdb";

    FbBackup backupSvc = new FbBackup();

    backupSvc.ConnectionString = cs.ToString();
    backupSvc.BackupFiles.Add(new FbBackupFile(@"c:\testdb.gbk", 2048));
    backupSvc.Verbose = true;

    backupSvc.Options = FbBackupFlags.IgnoreLimbo;

    backupSvc.ServiceOutput += new ServiceOutputEventHandler(ServiceOutput);

    backupSvc.Execute();
}

static void ServiceOutput(object sender, ServiceOutputEventArgs e)
{
    Console.WriteLine(e.Message);
}

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbBackup Members | FirebirdSql.Data.Firebird.Services Namespace


FbBackup Members

FbBackup overview

Public Instance Constructors

FbBackup Constructor Creates a new instance of FbBackup class.

Public Instance Properties

BackupFiles | Gets or sets the collection of backup files.
ConnectionString (inherited from FbService) | Gets or sets the connection string.
Factor | Gets the Tape device blocking factor.
Options | Gets a value that specifies options used for database backup.
QueryBufferSize (inherited from FbService) | Gets or sets the buffer size for service query calls.
State (inherited from FbService) | Gets the current state of the service.
Verbose | Gets or sets wheter the output be sent to the client.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Executes database backup service task.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ServiceOutput (inherited from FbService) Occurs when the service returns output information.

See Also

FbBackup Class | FirebirdSql.Data.Firebird.Services Namespace


FbBackup Constructor

Creates a new instance of FbBackup class.

[Visual Basic]
Public Sub New()
[C#]
public FbBackup();

See Also

FbBackup Class | FirebirdSql.Data.Firebird.Services Namespace


FbBackup Properties

The properties of the FbBackup class are listed below. For a complete list of FbBackup class members, see the FbBackup Members topic.

Public Instance Properties

BackupFiles | Gets or sets the collection of backup files.
ConnectionString (inherited from FbService) | Gets or sets the connection string.
Factor | Gets the Tape device blocking factor.
Options | Gets a value that specifies options used for database backup.
QueryBufferSize (inherited from FbService) | Gets or sets the buffer size for service query calls.
State (inherited from FbService) | Gets the current state of the service.
Verbose | Gets or sets wheter the output be sent to the client.

See Also

FbBackup Class | FirebirdSql.Data.Firebird.Services Namespace


BackupFiles Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbBackup.BackupFiles Property

Gets or sets the collection of backup files.

[Visual Basic]
Public ReadOnly Property BackupFiles As ArrayList
[C#]
public System.Collections.ArrayList BackupFiles {get;}

Property Value

The backup files paths and lengths FbBackupFile.

See Also

FbBackup Class | FirebirdSql.Data.Firebird.Services Namespace


Factor Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbBackup.Factor Property

Gets the Tape device blocking factor.

[Visual Basic]
Public Property Factor As Integer
[C#]
public int Factor {get; set;}

See Also

FbBackup Class | FirebirdSql.Data.Firebird.Services Namespace


Options Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbBackup.Options Property

Gets a value that specifies options used for database backup.

[Visual Basic]
Public Property Options As FbBackupFlags
[C#]
public FbBackupFlags Options {get; set;}

Property Value

A bitwise combination of the FbBackupFlags values which provides information about backup options.

See Also

FbBackup Class | FirebirdSql.Data.Firebird.Services Namespace


Verbose Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbBackup.Verbose Property

Gets or sets wheter the output be sent to the client.

[Visual Basic]
Public Property Verbose As Boolean
[C#]
public bool Verbose {get; set;}

See Also

FbBackup Class | FirebirdSql.Data.Firebird.Services Namespace


FbBackup Methods

The methods of the FbBackup class are listed below. For a complete list of FbBackup class members, see the FbBackup Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Executes database backup service task.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbBackup Class | FirebirdSql.Data.Firebird.Services Namespace


FbBackup.Execute Method

Executes database backup service task.

[Visual Basic]
Public Sub Execute()
[C#]
public void Execute();

See Also

FbBackup Class | FirebirdSql.Data.Firebird.Services Namespace


FbBackupFile Class

Specifies a backup file path and length to be used in Backup or Restore process.

For a list of all members of this type, see FbBackupFile Members.

System.Object
FirebirdSql.Data.Firebird.Services.FbBackupFile

[Visual Basic]
Public Class FbBackupFile
[C#]
public class FbBackupFile

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbBackupFile Members | FirebirdSql.Data.Firebird.Services Namespace


FbBackupFile Members

FbBackupFile overview

Public Instance Constructors

FbBackupFile Constructor

Public Instance Properties

BackupFile | Path of a backup output file; you can specify multiple output files.
BackupLength | The length of the buckup file.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FbBackupFile Class | FirebirdSql.Data.Firebird.Services Namespace


FbBackupFile Constructor

[Visual Basic]
Public Sub New( _
ByVal fileName As String, _
ByVal fileLength As Integer _
)
[C#]
public FbBackupFile(
string fileName,
int fileLength
);

See Also

FbBackupFile Class | FirebirdSql.Data.Firebird.Services Namespace


FbBackupFile Properties

The properties of the FbBackupFile class are listed below. For a complete list of FbBackupFile class members, see the FbBackupFile Members topic.

Public Instance Properties

BackupFile | Path of a backup output file; you can specify multiple output files.
BackupLength | The length of the buckup file.

See Also

FbBackupFile Class | FirebirdSql.Data.Firebird.Services Namespace


BackupFile Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbBackupFile.BackupFile Property

Path of a backup output file; you can specify multiple output files.

[Visual Basic]
Public Property BackupFile As String
[C#]
public string BackupFile {get; set;}

See Also

FbBackupFile Class | FirebirdSql.Data.Firebird.Services Namespace


BackupLength Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbBackupFile.BackupLength Property

The length of the buckup file.

[Visual Basic]
Public Property BackupLength As Integer
[C#]
public int BackupLength {get; set;}

See Also

FbBackupFile Class | FirebirdSql.Data.Firebird.Services Namespace


FbBackupFlags Enumeration

Specifies access flags for database backup.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum FbBackupFlags
[C#]
[Flags]
public enum FbBackupFlags

Members

Member Name | Description | Value
IgnoreChecksums |  | 1
IgnoreLimbo | Ignore limbo transactions during backup. | 2
MetaDataOnly | Output backup file for metadata only with empty tables. | 4
NoGarbageCollect | Suppress normal garbage collection during backup. Improves performance on some databases. | 8
OldDescriptions | Output metadata in pre-4.0 format. | 16
NonTransportable | Output backup file format with non-XDR data format. Improves space and performance by a negligible amount. | 32
Convert | Convert external table data to internal tables. | 64
Expand | No data compression. | 128

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird.Services Namespace


FbConfiguration Class

Allow configuration of local or remote databases properties.

For a list of all members of this type, see FbConfiguration Members.

System.Object
FirebirdSql.Data.Firebird.Services.FbService
FirebirdSql.Data.Firebird.Services.FbConfiguration

[Visual Basic]
NotInheritable Public Class FbConfiguration
Inherits FbService
[C#]
public sealed class FbConfiguration : FbService

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

The following example changes the sweep interval, reserve space, forced writes database properties.

FbConfiguration configurationSvc = new FbConfiguration();

configurationSvc.UserName = "SYSDBA";
configurationSvc.UserPassword = "masterkey";

configurationSvc.Database = @"C:\TESTDB.GDB";

configurationSvc.SetSweepInterval(1000);
configurationSvc.SetReserveSpace(true);
configurationSvc.SetForcedWrites(true);

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbConfiguration Members | FirebirdSql.Data.Firebird.Services Namespace


FbConfiguration Members

FbConfiguration overview

Public Instance Constructors

FbConfiguration Constructor Initializes a new instance of the FbConfiguration class.

Public Instance Properties

ConnectionString (inherited from FbService) | Gets or sets the connection string.
QueryBufferSize (inherited from FbService) | Gets or sets the buffer size for service query calls.
State (inherited from FbService) | Gets the current state of the service.

Public Instance Methods

ActivateShadows | Activates a shadow file for database use.
DatabaseOnline | Bring a database back online.
DatabaseShutdown |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetAccessMode | Set the access mode of the database.
SetForcedWrites | Sets the write mode for the database.
SetPageBuffers | Sets the number of database page buffers.
SetReserveSpace | Configure the database to fill data pages when inserting new records, or reserve 20% of each page for later record deltas;
SetSqlDialect | Sets the SQL dialect of the Firebird Database.
SetSweepInterval | Sets the number of transactions between database sweeps.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ServiceOutput (inherited from FbService) Occurs when the service returns output information.

See Also

FbConfiguration Class | FirebirdSql.Data.Firebird.Services Namespace


FbConfiguration Constructor

Initializes a new instance of the FbConfiguration class.

[Visual Basic]
Public Sub New()
[C#]
public FbConfiguration();

See Also

FbConfiguration Class | FirebirdSql.Data.Firebird.Services Namespace


FbConfiguration Methods

The methods of the FbConfiguration class are listed below. For a complete list of FbConfiguration class members, see the FbConfiguration Members topic.

Public Instance Methods

ActivateShadows | Activates a shadow file for database use.
DatabaseOnline | Bring a database back online.
DatabaseShutdown |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetAccessMode | Set the access mode of the database.
SetForcedWrites | Sets the write mode for the database.
SetPageBuffers | Sets the number of database page buffers.
SetReserveSpace | Configure the database to fill data pages when inserting new records, or reserve 20% of each page for later record deltas;
SetSqlDialect | Sets the SQL dialect of the Firebird Database.
SetSweepInterval | Sets the number of transactions between database sweeps.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbConfiguration Class | FirebirdSql.Data.Firebird.Services Namespace


FbConfiguration.ActivateShadows Method

Activates a shadow file for database use.

[Visual Basic]
Public Sub ActivateShadows()
[C#]
public void ActivateShadows();

See Also

FbConfiguration Class | FirebirdSql.Data.Firebird.Services Namespace


FbConfiguration.DatabaseOnline Method

Bring a database back online.

[Visual Basic]
Public Sub DatabaseOnline()
[C#]
public void DatabaseOnline();

See Also

FbConfiguration Class | FirebirdSql.Data.Firebird.Services Namespace


FbConfiguration.DatabaseShutdown Method

[Visual Basic]
Public Sub DatabaseShutdown( _
ByVal mode As FbShutdownMode, _
ByVal seconds As Integer _
)
[C#]
public void DatabaseShutdown(
FbShutdownMode mode,
int seconds
);

See Also

FbConfiguration Class | FirebirdSql.Data.Firebird.Services Namespace


FbConfiguration.SetAccessMode Method

Set the access mode of the database.

[Visual Basic]
Public Sub SetAccessMode( _
ByVal readOnly As Boolean _
)
[C#]
public void SetAccessMode(
bool readOnly
);

Parameters

readOnly
true to set database in read only access; or false for read write access.

See Also

FbConfiguration Class | FirebirdSql.Data.Firebird.Services Namespace


FbConfiguration.SetForcedWrites Method

Sets the write mode for the database.

[Visual Basic]
Public Sub SetForcedWrites( _
ByVal forcedWrites As Boolean _
)
[C#]
public void SetForcedWrites(
bool forcedWrites
);

Parameters

forcedWrites
true to enable forced writes mode; or false for disable it.

See Also

FbConfiguration Class | FirebirdSql.Data.Firebird.Services Namespace


FbConfiguration.SetPageBuffers Method

Sets the number of database page buffers.

[Visual Basic]
Public Sub SetPageBuffers( _
ByVal pageBuffers As Integer _
)
[C#]
public void SetPageBuffers(
int pageBuffers
);

Parameters

pageBuffers
Number of page buffers.

See Also

FbConfiguration Class | FirebirdSql.Data.Firebird.Services Namespace


FbConfiguration.SetReserveSpace Method

Configure the database to fill data pages when inserting new records, or reserve 20% of each page for later record deltas;

[Visual Basic]
Public Sub SetReserveSpace( _
ByVal reserveSpace As Boolean _
)
[C#]
public void SetReserveSpace(
bool reserveSpace
);

Parameters

reserveSpace
true to enable database to reserve space; or false for disable it.

See Also

FbConfiguration Class | FirebirdSql.Data.Firebird.Services Namespace


FbConfiguration.SetSqlDialect Method

Sets the SQL dialect of the Firebird Database.

[Visual Basic]
Public Sub SetSqlDialect( _
ByVal sqlDialect As Integer _
)
[C#]
public void SetSqlDialect(
int sqlDialect
);

See Also

FbConfiguration Class | FirebirdSql.Data.Firebird.Services Namespace


FbConfiguration.SetSweepInterval Method

Sets the number of transactions between database sweeps.

[Visual Basic]
Public Sub SetSweepInterval( _
ByVal sweepInterval As Integer _
)
[C#]
public void SetSweepInterval(
int sweepInterval
);

Parameters

sweepInterval
Sweep interval. To turn off database sweeps, set the sweep interval to 0.

See Also

FbConfiguration Class | FirebirdSql.Data.Firebird.Services Namespace


FbDatabasesInfo Structure

Retrieves information about databases on server.

For a list of all members of this type, see FbDatabasesInfo Members.

System.Object
System.ValueType
FirebirdSql.Data.Firebird.Services.FbDatabasesInfo

[Visual Basic]
Public Structure FbDatabasesInfo
[C#]
public struct FbDatabasesInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbDatabasesInfo Members | FirebirdSql.Data.Firebird.Services Namespace


FbDatabasesInfo Members

FbDatabasesInfo overview

Public Instance Properties

ConnectionCount | Returns the number of databases attached to the server.
Databases | Returns the list of database file paths.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

FbDatabasesInfo Class | FirebirdSql.Data.Firebird.Services Namespace


FbDatabasesInfo Properties

The properties of the FbDatabasesInfo structure are listed below. For a complete list of FbDatabasesInfo structure members, see the FbDatabasesInfo Members topic.

Public Instance Properties

ConnectionCount | Returns the number of databases attached to the server.
Databases | Returns the list of database file paths.

See Also

FbDatabasesInfo Class | FirebirdSql.Data.Firebird.Services Namespace


ConnectionCount Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabasesInfo.ConnectionCount Property

Returns the number of databases attached to the server.

[Visual Basic]
Public Property ConnectionCount As Integer
[C#]
public int ConnectionCount {get; set;}

Property Value

Number of databases attached to the server.

See Also

FbDatabasesInfo Class | FirebirdSql.Data.Firebird.Services Namespace


Databases Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbDatabasesInfo.Databases Property

Returns the list of database file paths.

[Visual Basic]
Public ReadOnly Property Databases As StringCollection
[C#]
public System.Collections.Specialized.StringCollection Databases {get;}

Property Value

List of database file paths.

See Also

FbDatabasesInfo Class | FirebirdSql.Data.Firebird.Services Namespace


FbLog Class

Retrieve the firebird.log file from the server if the log file exists. An error is returned if the log file does not exist. This class cannot be inherited.

For a list of all members of this type, see FbLog Members.

System.Object
FirebirdSql.Data.Firebird.Services.FbService
FirebirdSql.Data.Firebird.Services.FbLog

[Visual Basic]
NotInheritable Public Class FbLog
Inherits FbService
[C#]
public sealed class FbLog : FbService

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

The following example retrieve the firebird.log and displays it in Console.

FbLog logSvc = new FbLog();

logSvc.UserName = "SYSDBA";
logSvc.UserPassword = "masterkey";

logSvc.Start();

string lineOutput;
while((lineOutput = logSvc.GetNextLine()) != null)
{
    Console.WriteLine(lineOutput);
}

logSvc.Close();

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbLog Members | FirebirdSql.Data.Firebird.Services Namespace


FbLog Members

FbLog overview

Public Instance Constructors

FbLog Constructor Initializes a new instance of the FbLog class.

Public Instance Properties

ConnectionString (inherited from FbService) | Gets or sets the connection string.
QueryBufferSize (inherited from FbService) | Gets or sets the buffer size for service query calls.
State (inherited from FbService) | Gets the current state of the service.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Executes Firebird log service task.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ServiceOutput (inherited from FbService) Occurs when the service returns output information.

See Also

FbLog Class | FirebirdSql.Data.Firebird.Services Namespace


FbLog Constructor

Initializes a new instance of the FbLog class.

[Visual Basic]
Public Sub New()
[C#]
public FbLog();

See Also

FbLog Class | FirebirdSql.Data.Firebird.Services Namespace


FbLog Methods

The methods of the FbLog class are listed below. For a complete list of FbLog class members, see the FbLog Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Executes Firebird log service task.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbLog Class | FirebirdSql.Data.Firebird.Services Namespace


FbLog.Execute Method

Executes Firebird log service task.

[Visual Basic]
Public Sub Execute()
[C#]
public void Execute();

See Also

FbLog Class | FirebirdSql.Data.Firebird.Services Namespace


FbRestore Class

Restore a database from backup files. This class cannot be inherited.

For a list of all members of this type, see FbRestore Members.

System.Object
FirebirdSql.Data.Firebird.Services.FbService
FirebirdSql.Data.Firebird.Services.FbRestore

[Visual Basic]
NotInheritable Public Class FbRestore
Inherits FbService
[C#]
public sealed class FbRestore : FbService

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The username and password used to connect to the services manager will be used to connect to the database for restore. This helps add some degree of security for this operation.

Only the SYSDBA or owner of a database may use Replace to overwrite an existing database.

Example

The following example makes a restore of a database from a single backup file and display server output on Console.

[STAThread]
static void Main(string[] args)
{
    FbConnectionStringBuilder cs = new FbConnectionStringBuilder();

    cs.UserID   = "SYSDBA";
    cs.Password = "masterkey";
    cs.Database = "nunit_testdb";

    FbRestore restoreSvc = new FbRestore();

    restoreSvc.ConnectionString = cs.ToString();
    restoreSvc.BackupFiles.Add(new FbBackupFile(@"c:\testdb.gbk", 2048));
    restoreSvc.Verbose = true;
    restoreSvc.PageSize = 4096;
    restoreSvc.Options = FbRestoreFlags.Create | FbRestoreFlags.Replace;

    restoreSvc.ServiceOutput += new ServiceOutputEventHandler(ServiceOutput);

    restoreSvc.Execute();
}

static void ServiceOutput(object sender, ServiceOutputEventArgs e)
{
    Console.WriteLine(e.Message);
}

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbRestore Members | FirebirdSql.Data.Firebird.Services Namespace


FbRestore Members

FbRestore overview

Public Instance Constructors

FbRestore Constructor Creates a new instance of FbRestore class.

Public Instance Properties

BackupFiles | Gets or sets the collections of backup files.
ConnectionString (inherited from FbService) | Gets or sets the connection string.
Options | Gets or sets the options used for database restore.
PageBuffers | Gets or sets the cache size for the restored database.
PageSize | Gets or sets the page size for the restored database.
QueryBufferSize (inherited from FbService) | Gets or sets the buffer size for service query calls.
State (inherited from FbService) | Gets the current state of the service.
Verbose | Gets or sets wheter the output be sent to the client.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Executes Firebird database restore service task.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ServiceOutput (inherited from FbService) Occurs when the service returns output information.

See Also

FbRestore Class | FirebirdSql.Data.Firebird.Services Namespace


FbRestore Constructor

Creates a new instance of FbRestore class.

[Visual Basic]
Public Sub New()
[C#]
public FbRestore();

See Also

FbRestore Class | FirebirdSql.Data.Firebird.Services Namespace


FbRestore Properties

The properties of the FbRestore class are listed below. For a complete list of FbRestore class members, see the FbRestore Members topic.

Public Instance Properties

BackupFiles | Gets or sets the collections of backup files.
ConnectionString (inherited from FbService) | Gets or sets the connection string.
Options | Gets or sets the options used for database restore.
PageBuffers | Gets or sets the cache size for the restored database.
PageSize | Gets or sets the page size for the restored database.
QueryBufferSize (inherited from FbService) | Gets or sets the buffer size for service query calls.
State (inherited from FbService) | Gets the current state of the service.
Verbose | Gets or sets wheter the output be sent to the client.

See Also

FbRestore Class | FirebirdSql.Data.Firebird.Services Namespace


BackupFiles Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbRestore.BackupFiles Property

Gets or sets the collections of backup files.

[Visual Basic]
Public ReadOnly Property BackupFiles As ArrayList
[C#]
public System.Collections.ArrayList BackupFiles {get;}

Property Value

The backup files paths and lengths FbBackupFile.

See Also

FbRestore Class | FirebirdSql.Data.Firebird.Services Namespace


Options Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbRestore.Options Property

Gets or sets the options used for database restore.

[Visual Basic]
Public Property Options As FbRestoreFlags
[C#]
public FbRestoreFlags Options {get; set;}

Property Value

A bitwise combination of the FbRestoreFlags values which provides information about restore options.

See Also

FbRestore Class | FirebirdSql.Data.Firebird.Services Namespace


PageBuffers Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbRestore.PageBuffers Property

Gets or sets the cache size for the restored database.

[Visual Basic]
Public Property PageBuffers As Integer
[C#]
public int PageBuffers {get; set;}

Property Value

The cache size of the restored database. The default is 2048 buffer pages in the database cache.

See Also

FbRestore Class | FirebirdSql.Data.Firebird.Services Namespace


PageSize Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbRestore.PageSize Property

Gets or sets the page size for the restored database.

[Visual Basic]
Public Property PageSize As Integer
[C#]
public int PageSize {get; set;}

Property Value

Database page sizes can be of 1024, 2048, 4096, 8192 and 16384 bytes.

See Also

FbRestore Class | FirebirdSql.Data.Firebird.Services Namespace


Verbose Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbRestore.Verbose Property

Gets or sets wheter the output be sent to the client.

[Visual Basic]
Public Property Verbose As Boolean
[C#]
public bool Verbose {get; set;}

See Also

FbRestore Class | FirebirdSql.Data.Firebird.Services Namespace


FbRestore Methods

The methods of the FbRestore class are listed below. For a complete list of FbRestore class members, see the FbRestore Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Executes Firebird database restore service task.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbRestore Class | FirebirdSql.Data.Firebird.Services Namespace


FbRestore.Execute Method

Executes Firebird database restore service task.

[Visual Basic]
Public Sub Execute()
[C#]
public void Execute();

See Also

FbRestore Class | FirebirdSql.Data.Firebird.Services Namespace


FbRestoreFlags Enumeration

Specifies access flags for database restore.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum FbRestoreFlags
[C#]
[Flags]
public enum FbRestoreFlags

Members

Member Name | Description | Value
DeactivateIndexes | Do not build user indexes during restore. | 256
NoShadow | Do not recreate shadow files during restore. | 512
NoValidity | Do not enforce validity conditions (for example, NOT NULL) during restore. | 1024
IndividualCommit | Commit after completing restore of each table. | 2048
Replace | Replace database, if one exists. | 4096
Create | Restore but do not overwrite an existing database. | 8192
UseAllSpace | Do not reserve 20% of each data page for future record versions. | 16384

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird.Services Namespace


FbSecurity Class

Allow to list, add, delete, and modify users.

For a list of all members of this type, see FbSecurity Members.

System.Object
FirebirdSql.Data.Firebird.Services.FbService
FirebirdSql.Data.Firebird.Services.FbSecurity

[Visual Basic]
NotInheritable Public Class FbSecurity
Inherits FbService
[C#]
public sealed class FbSecurity : FbService

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbSecurity Members | FirebirdSql.Data.Firebird.Services Namespace


FbSecurity Members

FbSecurity overview

Public Instance Constructors

FbSecurity Constructor Initializes a new instance of the FbSecurity class.

Public Instance Properties

ConnectionString (inherited from FbService) | Gets or sets the connection string.
QueryBufferSize (inherited from FbService) | Gets or sets the buffer size for service query calls.
State (inherited from FbService) | Gets the current state of the service.
UsersDbPath | The path to the security database on the server; for example, /usr/interbase/.

Public Instance Methods

AddUser |
DeleteUser |
DisplayUser |
DisplayUsers | Display information for a single user or all users in the isc4.gdb security database, respectively.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ModifyUser |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ServiceOutput (inherited from FbService) Occurs when the service returns output information.

See Also

FbSecurity Class | FirebirdSql.Data.Firebird.Services Namespace


FbSecurity Constructor

Initializes a new instance of the FbSecurity class.

[Visual Basic]
Public Sub New()
[C#]
public FbSecurity();

See Also

FbSecurity Class | FirebirdSql.Data.Firebird.Services Namespace


FbSecurity Properties

The properties of the FbSecurity class are listed below. For a complete list of FbSecurity class members, see the FbSecurity Members topic.

Public Instance Properties

ConnectionString (inherited from FbService) | Gets or sets the connection string.
QueryBufferSize (inherited from FbService) | Gets or sets the buffer size for service query calls.
State (inherited from FbService) | Gets the current state of the service.
UsersDbPath | The path to the security database on the server; for example, /usr/interbase/.

See Also

FbSecurity Class | FirebirdSql.Data.Firebird.Services Namespace


UsersDbPath Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbSecurity.UsersDbPath Property

The path to the security database on the server; for example, /usr/interbase/.

[Visual Basic]
Public ReadOnly Property UsersDbPath As String
[C#]
public string UsersDbPath {get;}

See Also

FbSecurity Class | FirebirdSql.Data.Firebird.Services Namespace


FbSecurity Methods

The methods of the FbSecurity class are listed below. For a complete list of FbSecurity class members, see the FbSecurity Members topic.

Public Instance Methods

AddUser |
DeleteUser |
DisplayUser |
DisplayUsers | Display information for a single user or all users in the isc4.gdb security database, respectively.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ModifyUser |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbSecurity Class | FirebirdSql.Data.Firebird.Services Namespace


FbSecurity.AddUser Method

[Visual Basic]
Public Sub AddUser( _
ByVal user As FbUserData _
)
[C#]
public void AddUser(
FbUserData user
);

See Also

FbSecurity Class | FirebirdSql.Data.Firebird.Services Namespace


FbSecurity.DeleteUser Method

[Visual Basic]
Public Sub DeleteUser( _
ByVal user As FbUserData _
)
[C#]
public void DeleteUser(
FbUserData user
);

See Also

FbSecurity Class | FirebirdSql.Data.Firebird.Services Namespace


FbSecurity.DisplayUser Method

[Visual Basic]
Public Function DisplayUser( _
ByVal userName As String _
) As FbUserData
[C#]
public FbUserData DisplayUser(
string userName
);

See Also

FbSecurity Class | FirebirdSql.Data.Firebird.Services Namespace


FbSecurity.DisplayUsers Method

Display information for a single user or all users in the isc4.gdb security database, respectively.

[Visual Basic]
Public Function DisplayUsers() As FbUserData()
[C#]
public FbUserData[] DisplayUsers();

Return Value

An array of FbUserData objects.

See Also

FbSecurity Class | FirebirdSql.Data.Firebird.Services Namespace


FbSecurity.ModifyUser Method

[Visual Basic]
Public Sub ModifyUser( _
ByVal user As FbUserData _
)
[C#]
public void ModifyUser(
FbUserData user
);

See Also

FbSecurity Class | FirebirdSql.Data.Firebird.Services Namespace


FbServerConfig Structure

Parameters and values in the firebird.conf file on the server.

For a list of all members of this type, see FbServerConfig Members.

System.Object
System.ValueType
FirebirdSql.Data.Firebird.Services.FbServerConfig

[Visual Basic]
Public Structure FbServerConfig
[C#]
public struct FbServerConfig

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbServerConfig Members | FirebirdSql.Data.Firebird.Services Namespace


FbServerConfig Members

FbServerConfig overview

Public Instance Properties

AnyEventMemory |
AnyLockMemory |
AnyLockSemaphore |
AnyLockSignal |
ConnectionTimeout | Seconds to wait before concluding an attempt to connect has failed.
DeadlockTimeout | Determines the number of seconds that the lock manager will wait after a conflict has been encountered before purging locks from dead processes and doing extra deadlock scan cycle. Engine detects deadlocks instantly in all normal cases, so this value affects things only if something goes wrong. Setting it too low may degrade system performance.
DefaultDbCachePages | Number of cached database pages.
DummyPacketInterval | Seconds to wait on a silent client connection before the server sends dummy packets to request acknowledgment.
EventMemorySize | Bytes of shared memory allocated for event manager.
IpcMapSize | Size in bytes of one client's portion of the memory mapped file used for local connections.
LockGrantOrder | When a connection wants to lock an object, it gets a lock request block which specifies the object and the lock level requested. Eack locked object has a lock block. Request blocks are connected to those lock blocks either as requests that have been granted, or as pending requests.
LockHashSlots | Tune lock hash list; more hash slots mean shorter hash chains. Only necessary under very high load. Prime number values are recommended.
LockMemSize | Bytes of shared memory allocated for lock manager.
LockRequireSpins | In Classic, only one client process may access the lock table at any time. Access to the lock table is governed by a mutex. The mutex can be requested conditionally -a wait is a failure and the request must be retried - or unconditionally - the request will wait until it is satisfied. This parameter establishes the number of attempts that will be made conditionally. Relevant only on SMP machines.
LockSemCount | Number of semaphores for interprocess communication.
LockSignal |
MaxMemory |
MinMemory |
PrioritySwitchDelay |

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


FbServerConfig Properties

The properties of the FbServerConfig structure are listed below. For a complete list of FbServerConfig structure members, see the FbServerConfig Members topic.

Public Instance Properties

AnyEventMemory |
AnyLockMemory |
AnyLockSemaphore |
AnyLockSignal |
ConnectionTimeout | Seconds to wait before concluding an attempt to connect has failed.
DeadlockTimeout | Determines the number of seconds that the lock manager will wait after a conflict has been encountered before purging locks from dead processes and doing extra deadlock scan cycle. Engine detects deadlocks instantly in all normal cases, so this value affects things only if something goes wrong. Setting it too low may degrade system performance.
DefaultDbCachePages | Number of cached database pages.
DummyPacketInterval | Seconds to wait on a silent client connection before the server sends dummy packets to request acknowledgment.
EventMemorySize | Bytes of shared memory allocated for event manager.
IpcMapSize | Size in bytes of one client's portion of the memory mapped file used for local connections.
LockGrantOrder | When a connection wants to lock an object, it gets a lock request block which specifies the object and the lock level requested. Eack locked object has a lock block. Request blocks are connected to those lock blocks either as requests that have been granted, or as pending requests.
LockHashSlots | Tune lock hash list; more hash slots mean shorter hash chains. Only necessary under very high load. Prime number values are recommended.
LockMemSize | Bytes of shared memory allocated for lock manager.
LockRequireSpins | In Classic, only one client process may access the lock table at any time. Access to the lock table is governed by a mutex. The mutex can be requested conditionally -a wait is a failure and the request must be retried - or unconditionally - the request will wait until it is satisfied. This parameter establishes the number of attempts that will be made conditionally. Relevant only on SMP machines.
LockSemCount | Number of semaphores for interprocess communication.
LockSignal |
MaxMemory |
MinMemory |
PrioritySwitchDelay |

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


AnyEventMemory Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.AnyEventMemory Property

[Visual Basic]
Public Property AnyEventMemory As Integer
[C#]
public int AnyEventMemory {get; set;}

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


AnyLockMemory Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.AnyLockMemory Property

[Visual Basic]
Public Property AnyLockMemory As Integer
[C#]
public int AnyLockMemory {get; set;}

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


AnyLockSemaphore Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.AnyLockSemaphore Property

[Visual Basic]
Public Property AnyLockSemaphore As Integer
[C#]
public int AnyLockSemaphore {get; set;}

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


AnyLockSignal Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.AnyLockSignal Property

[Visual Basic]
Public Property AnyLockSignal As Integer
[C#]
public int AnyLockSignal {get; set;}

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


ConnectionTimeout Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.ConnectionTimeout Property

Seconds to wait before concluding an attempt to connect has failed.

[Visual Basic]
Public Property ConnectionTimeout As Integer
[C#]
public int ConnectionTimeout {get; set;}

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


DeadlockTimeout Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.DeadlockTimeout Property

Determines the number of seconds that the lock manager will wait after a conflict has been encountered before purging locks from dead processes and doing extra deadlock scan cycle. Engine detects deadlocks instantly in all normal cases, so this value affects things only if something goes wrong. Setting it too low may degrade system performance.

[Visual Basic]
Public Property DeadlockTimeout As Integer
[C#]
public int DeadlockTimeout {get; set;}

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


DefaultDbCachePages Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.DefaultDbCachePages Property

Number of cached database pages.

[Visual Basic]
Public Property DefaultDbCachePages As Integer
[C#]
public int DefaultDbCachePages {get; set;}

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


DummyPacketInterval Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.DummyPacketInterval Property

Seconds to wait on a silent client connection before the server sends dummy packets to request acknowledgment.

[Visual Basic]
Public Property DummyPacketInterval As Integer
[C#]
public int DummyPacketInterval {get; set;}

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


EventMemorySize Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.EventMemorySize Property

Bytes of shared memory allocated for event manager.

[Visual Basic]
Public Property EventMemorySize As Integer
[C#]
public int EventMemorySize {get; set;}

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


IpcMapSize Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.IpcMapSize Property

Size in bytes of one client's portion of the memory mapped file used for local connections.

[Visual Basic]
Public Property IpcMapSize As Integer
[C#]
public int IpcMapSize {get; set;}

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


LockGrantOrder Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.LockGrantOrder Property

When a connection wants to lock an object, it gets a lock request block which specifies the object and the lock level requested. Eack locked object has a lock block. Request blocks are connected to those lock blocks either as requests that have been granted, or as pending requests.

[Visual Basic]
Public Property LockGrantOrder As Integer
[C#]
public int LockGrantOrder {get; set;}

Remarks

The settings:

1 means locks are granted first come, first served.

0 means emulate InterBase v3.3 behavior, where locks are granted as soon as they are available; can result in lock request starvation.

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


LockHashSlots Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.LockHashSlots Property

Tune lock hash list; more hash slots mean shorter hash chains. Only necessary under very high load. Prime number values are recommended.

[Visual Basic]
Public Property LockHashSlots As Integer
[C#]
public int LockHashSlots {get; set;}

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


LockMemSize Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.LockMemSize Property

Bytes of shared memory allocated for lock manager.

[Visual Basic]
Public Property LockMemSize As Integer
[C#]
public int LockMemSize {get; set;}

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


LockRequireSpins Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.LockRequireSpins Property

In Classic, only one client process may access the lock table at any time. Access to the lock table is governed by a mutex. The mutex can be requested conditionally -a wait is a failure and the request must be retried - or unconditionally - the request will wait until it is satisfied. This parameter establishes the number of attempts that will be made conditionally. Relevant only on SMP machines.

[Visual Basic]
Public Property LockRequireSpins As Integer
[C#]
public int LockRequireSpins {get; set;}

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


LockSemCount Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.LockSemCount Property

Number of semaphores for interprocess communication.

[Visual Basic]
Public Property LockSemCount As Integer
[C#]
public int LockSemCount {get; set;}

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


LockSignal Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.LockSignal Property

[Visual Basic]
Public Property LockSignal As Integer
[C#]
public int LockSignal {get; set;}

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


MaxMemory Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.MaxMemory Property

[Visual Basic]
Public Property MaxMemory As Integer
[C#]
public int MaxMemory {get; set;}

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


MinMemory Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.MinMemory Property

[Visual Basic]
Public Property MinMemory As Integer
[C#]
public int MinMemory {get; set;}

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


PrioritySwitchDelay Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerConfig.PrioritySwitchDelay Property

[Visual Basic]
Public Property PrioritySwitchDelay As Integer
[C#]
public int PrioritySwitchDelay {get; set;}

See Also

FbServerConfig Class | FirebirdSql.Data.Firebird.Services Namespace


FbServerProperties Class

Retrieve server configuration information.

For a list of all members of this type, see FbServerProperties Members.

System.Object
FirebirdSql.Data.Firebird.Services.FbService
FirebirdSql.Data.Firebird.Services.FbServerProperties

[Visual Basic]
NotInheritable Public Class FbServerProperties
Inherits FbService
[C#]
public sealed class FbServerProperties : FbService

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbServerProperties Members | FirebirdSql.Data.Firebird.Services Namespace


FbServerProperties Members

FbServerProperties overview

Public Instance Constructors

FbServerProperties Constructor Initializes a new instance of the FbServerProperties class.

Public Instance Properties

ConnectionString (inherited from FbService) | Gets or sets the connection string.
DatabasesInfo | Gets information about databases on server.
Implementation | Gets the implementation of the Firebird server.
LockManager | Gets the location of the InterBase lock manager file on the server; this is the value of the $INTERBASE_LCK system environment variable, or by default $INTERBASE/serverhostname.lck.
MessageFile | Gets the location of the InterBase message file on the server; this is the value of the $INTERBASE_MSG system environment variable, or by default $INTERBASE/interbase.msg.
QueryBufferSize (inherited from FbService) | Gets or sets the buffer size for service query calls.
RootDirectory | Gets the location of the Firebird root directory on the server; this is the value of the $INTERBASE system environment variable, or the contents of the registry key.
ServerConfig | Gets the parameters and values for IB_CONFIG.
ServerVersion | Gets the version of the Firebird server.
State (inherited from FbService) | Gets the current state of the service.
Version | Gets the version of the services manager.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ServiceOutput (inherited from FbService) Occurs when the service returns output information.

See Also

FbServerProperties Class | FirebirdSql.Data.Firebird.Services Namespace


FbServerProperties Constructor

Initializes a new instance of the FbServerProperties class.

[Visual Basic]
Public Sub New()
[C#]
public FbServerProperties();

See Also

FbServerProperties Class | FirebirdSql.Data.Firebird.Services Namespace


FbServerProperties Properties

The properties of the FbServerProperties class are listed below. For a complete list of FbServerProperties class members, see the FbServerProperties Members topic.

Public Instance Properties

ConnectionString (inherited from FbService) | Gets or sets the connection string.
DatabasesInfo | Gets information about databases on server.
Implementation | Gets the implementation of the Firebird server.
LockManager | Gets the location of the InterBase lock manager file on the server; this is the value of the $INTERBASE_LCK system environment variable, or by default $INTERBASE/serverhostname.lck.
MessageFile | Gets the location of the InterBase message file on the server; this is the value of the $INTERBASE_MSG system environment variable, or by default $INTERBASE/interbase.msg.
QueryBufferSize (inherited from FbService) | Gets or sets the buffer size for service query calls.
RootDirectory | Gets the location of the Firebird root directory on the server; this is the value of the $INTERBASE system environment variable, or the contents of the registry key.
ServerConfig | Gets the parameters and values for IB_CONFIG.
ServerVersion | Gets the version of the Firebird server.
State (inherited from FbService) | Gets the current state of the service.
Version | Gets the version of the services manager.

See Also

FbServerProperties Class | FirebirdSql.Data.Firebird.Services Namespace


DatabasesInfo Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerProperties.DatabasesInfo Property

Gets information about databases on server.

[Visual Basic]
Public ReadOnly Property DatabasesInfo As FbDatabasesInfo
[C#]
public FbDatabasesInfo DatabasesInfo {get;}

See Also

FbServerProperties Class | FirebirdSql.Data.Firebird.Services Namespace


Implementation Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerProperties.Implementation Property

Gets the implementation of the Firebird server.

[Visual Basic]
Public ReadOnly Property Implementation As String
[C#]
public string Implementation {get;}

See Also

FbServerProperties Class | FirebirdSql.Data.Firebird.Services Namespace


LockManager Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerProperties.LockManager Property

Gets the location of the InterBase lock manager file on the server; this is the value of the $INTERBASE_LCK system environment variable, or by default $INTERBASE/serverhostname.lck.

[Visual Basic]
Public ReadOnly Property LockManager As String
[C#]
public string LockManager {get;}

See Also

FbServerProperties Class | FirebirdSql.Data.Firebird.Services Namespace


MessageFile Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerProperties.MessageFile Property

Gets the location of the InterBase message file on the server; this is the value of the $INTERBASE_MSG system environment variable, or by default $INTERBASE/interbase.msg.

[Visual Basic]
Public ReadOnly Property MessageFile As String
[C#]
public string MessageFile {get;}

See Also

FbServerProperties Class | FirebirdSql.Data.Firebird.Services Namespace


RootDirectory Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerProperties.RootDirectory Property

Gets the location of the Firebird root directory on the server; this is the value of the $INTERBASE system environment variable, or the contents of the registry key.

[Visual Basic]
Public ReadOnly Property RootDirectory As String
[C#]
public string RootDirectory {get;}

See Also

FbServerProperties Class | FirebirdSql.Data.Firebird.Services Namespace


ServerConfig Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerProperties.ServerConfig Property

Gets the parameters and values for IB_CONFIG.

[Visual Basic]
Public ReadOnly Property ServerConfig As FbServerConfig
[C#]
public FbServerConfig ServerConfig {get;}

See Also

FbServerProperties Class | FirebirdSql.Data.Firebird.Services Namespace


ServerVersion Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerProperties.ServerVersion Property

Gets the version of the Firebird server.

[Visual Basic]
Public ReadOnly Property ServerVersion As String
[C#]
public string ServerVersion {get;}

See Also

FbServerProperties Class | FirebirdSql.Data.Firebird.Services Namespace


Version Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbServerProperties.Version Property

Gets the version of the services manager.

[Visual Basic]
Public ReadOnly Property Version As Integer
[C#]
public int Version {get;}

See Also

FbServerProperties Class | FirebirdSql.Data.Firebird.Services Namespace


FbService Class

Base class for Firebird Services implementation.

For a list of all members of this type, see FbService Members.

System.Object
FirebirdSql.Data.Firebird.Services.FbService
Derived types

[Visual Basic]
MustInherit Public Class FbService
[C#]
public abstract class FbService

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbService Members | FirebirdSql.Data.Firebird.Services Namespace


FbService Members

FbService overview

Public Instance Properties

ConnectionString | Gets or sets the connection string.
QueryBufferSize | Gets or sets the buffer size for service query calls.
State | Gets the current state of the service.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ServiceOutput Occurs when the service returns output information.

Protected Instance Constructors

FbService Constructor Creates a new instance of the FbService class.

Protected Instance Properties

Database Gets the target database path.

Protected Instance Methods

Close | Closes the connection to the Firebird Service Manager. This is the preferred method of closing any open connection.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetNextLine | Returns one line of output from a service task.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Open | Opens a connection to the Firebird Services Manager.
ParseQueryInfo |
ProcessServiceOutput |
QueryService | Retrieves information about a firebird service based on a given set of information items.
StartTask | Starts the execution of a service task.

See Also

FbService Class | FirebirdSql.Data.Firebird.Services Namespace


FbService Constructor

Creates a new instance of the FbService class.

[Visual Basic]
Protected Sub New()
[C#]
protected FbService();

See Also

FbService Class | FirebirdSql.Data.Firebird.Services Namespace


FbService Properties

The properties of the FbService class are listed below. For a complete list of FbService class members, see the FbService Members topic.

Public Instance Properties

ConnectionString | Gets or sets the connection string.
QueryBufferSize | Gets or sets the buffer size for service query calls.
State | Gets the current state of the service.

Protected Instance Properties

Database Gets the target database path.

See Also

FbService Class | FirebirdSql.Data.Firebird.Services Namespace


ConnectionString Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbService.ConnectionString Property

Gets or sets the connection string.

[Visual Basic]
Public Property ConnectionString As String
[C#]
public string ConnectionString {get; set;}

See Also

FbService Class | FirebirdSql.Data.Firebird.Services Namespace


Database Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbService.Database Property

Gets the target database path.

[Visual Basic]
Protected ReadOnly Property Database As String
[C#]
protected string Database {get;}

See Also

FbService Class | FirebirdSql.Data.Firebird.Services Namespace


QueryBufferSize Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbService.QueryBufferSize Property

Gets or sets the buffer size for service query calls.

[Visual Basic]
Public Property QueryBufferSize As Integer
[C#]
public int QueryBufferSize {get; set;}

See Also

FbService Class | FirebirdSql.Data.Firebird.Services Namespace


State Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbService.State Property

Gets the current state of the service.

[Visual Basic]
Public ReadOnly Property State As FbServiceState
[C#]
public FbServiceState State {get;}

Property Value

A bitwise combination of the FbServiceState values. The default is Closed.

Remarks

The allowed state changes are:

  • From Closed to Open, using the Open method of the service object.
  • From Open to Closed, using either the Close method or the Dispose method of the service object.

See Also

FbService Class | FirebirdSql.Data.Firebird.Services Namespace


FbService Methods

The methods of the FbService class are listed below. For a complete list of FbService class members, see the FbService Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Close | Closes the connection to the Firebird Service Manager. This is the preferred method of closing any open connection.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetNextLine | Returns one line of output from a service task.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Open | Opens a connection to the Firebird Services Manager.
ParseQueryInfo |
ProcessServiceOutput |
QueryService | Retrieves information about a firebird service based on a given set of information items.
StartTask | Starts the execution of a service task.

See Also

FbService Class | FirebirdSql.Data.Firebird.Services Namespace


FbService.Close Method

Closes the connection to the Firebird Service Manager. This is the preferred method of closing any open connection.

[Visual Basic]
Protected Sub Close()
[C#]
protected void Close();

See Also

FbService Class | FirebirdSql.Data.Firebird.Services Namespace


FbService.GetNextLine Method

Returns one line of output from a service task.

[Visual Basic]
Protected Function GetNextLine() As String
[C#]
protected string GetNextLine();

Return Value

One line of output from a service task.

See Also

FbService Class | FirebirdSql.Data.Firebird.Services Namespace


FbService.Open Method

Opens a connection to the Firebird Services Manager.

[Visual Basic]
Protected Sub Open()
[C#]
protected void Open();

See Also

FbService Class | FirebirdSql.Data.Firebird.Services Namespace


FbService.ParseQueryInfo Method

[Visual Basic]
Protected Function ParseQueryInfo( _
ByVal buffer As Byte() _
) As ArrayList
[C#]
protected ArrayList ParseQueryInfo(
byte[] buffer
);

See Also

FbService Class | FirebirdSql.Data.Firebird.Services Namespace


FbService.ProcessServiceOutput Method

[Visual Basic]
Protected Sub ProcessServiceOutput()
[C#]
protected void ProcessServiceOutput();

See Also

FbService Class | FirebirdSql.Data.Firebird.Services Namespace


FbService.QueryService Method

Retrieves information about a firebird service based on a given set of information items.

[Visual Basic]
Protected Function QueryService( _
ByVal items As Byte() _
) As Byte()
[C#]
protected byte[] QueryService(
byte[] items
);

Parameters

items
Information items to be retrieved.

See Also

FbService Class | FirebirdSql.Data.Firebird.Services Namespace


FbService.StartTask Method

Starts the execution of a service task.

[Visual Basic]
Protected Sub StartTask()
[C#]
protected void StartTask();

See Also

FbService Class | FirebirdSql.Data.Firebird.Services Namespace


FbService Events

The events of the FbService class are listed below. For a complete list of FbService class members, see the FbService Members topic.

Public Instance Events

ServiceOutput Occurs when the service returns output information.

See Also

FbService Class | FirebirdSql.Data.Firebird.Services Namespace


FbService.ServiceOutput Event

Occurs when the service returns output information.

[Visual Basic]
Public Event ServiceOutput As ServiceOutputEventHandler
[C#]
public event ServiceOutputEventHandler ServiceOutput;

Event Data

The event handler receives an argument of type ServiceOutputEventArgs containing data related to this event. The following ServiceOutputEventArgs property provides information specific to this event.

Property | Description
Message | Gets the service output message.

See Also

FbService Class | FirebirdSql.Data.Firebird.Services Namespace


FbServiceState Enumeration

[Visual Basic]
Public Enum FbServiceState
[C#]
public enum FbServiceState

Members

Member Name | Description
Closed |
Open |

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird.Services Namespace


FbShutdownMode Enumeration

Allowed shutdown modes.

[Visual Basic]
Public Enum FbShutdownMode
[C#]
public enum FbShutdownMode

Members

Member Name | Description
Forced | Shut down the database after the specified number of seconds; to shut down the database immediately, set the shutdown interval to 0.
DenyTransaction | Deny new transactions and shut down the database after the specified number of seconds; if transactions are active after the shutdown interval has expired, the shutdown will fail; to shut down the database immediately, set the shutdown interval to 0.
DenyConnection | Deny new connections and shut down the database after the specified number of seconds; if connections are active after the shutdown interval has expired, the shutdown will fail; to shut down the database immediately, set the shutdown interval to 0

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird.Services Namespace


FbStatistical Class

Retrieve database statistics for the database specified. This class cannot be inherited.

For a list of all members of this type, see FbStatistical Members.

System.Object
FirebirdSql.Data.Firebird.Services.FbService
FirebirdSql.Data.Firebird.Services.FbStatistical

[Visual Basic]
NotInheritable Public Class FbStatistical
Inherits FbService
[C#]
public sealed class FbStatistical : FbService

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

The following sample request statistics for system tables and indexes in addition to user tables and indexes and displays it in Console.

FbStatistical statisticalSvc = new FbStatistical();

statisticalSvc.UserName = "SYSDBA";
statisticalSvc.UserPassword = "masterkey";

statisticalSvc.Database = @"C:\TESTDB.GDB";
statisticalSvc.Options = FbStatisticalFlags.SystemTablesRelations;

statisticalSvc.Start();

string lineOutput;
while((lineOutput = statisticalSvc.GetNextLine()) != null)
{
    Console.WriteLine(lineOutput);
}

statisticalSvc.Close();

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbStatistical Members | FirebirdSql.Data.Firebird.Services Namespace


FbStatistical Members

FbStatistical overview

Public Instance Constructors

FbStatistical Constructor Initializes a new instance of the FbStatistical class.

Public Instance Properties

ConnectionString (inherited from FbService) | Gets or sets the connection string.
Options | Gets a value that specifies options used for retrieve database statistics.
QueryBufferSize (inherited from FbService) | Gets or sets the buffer size for service query calls.
State (inherited from FbService) | Gets the current state of the service.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ServiceOutput (inherited from FbService) Occurs when the service returns output information.

See Also

FbStatistical Class | FirebirdSql.Data.Firebird.Services Namespace


FbStatistical Constructor

Initializes a new instance of the FbStatistical class.

[Visual Basic]
Public Sub New()
[C#]
public FbStatistical();

See Also

FbStatistical Class | FirebirdSql.Data.Firebird.Services Namespace


FbStatistical Properties

The properties of the FbStatistical class are listed below. For a complete list of FbStatistical class members, see the FbStatistical Members topic.

Public Instance Properties

ConnectionString (inherited from FbService) | Gets or sets the connection string.
Options | Gets a value that specifies options used for retrieve database statistics.
QueryBufferSize (inherited from FbService) | Gets or sets the buffer size for service query calls.
State (inherited from FbService) | Gets the current state of the service.

See Also

FbStatistical Class | FirebirdSql.Data.Firebird.Services Namespace


Options Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbStatistical.Options Property

Gets a value that specifies options used for retrieve database statistics.

[Visual Basic]
Public Property Options As FbStatisticalFlags
[C#]
public FbStatisticalFlags Options {get; set;}

Property Value

A bitwise combination of the FbStatisticalFlags values which provides information about statistics options.

See Also

FbStatistical Class | FirebirdSql.Data.Firebird.Services Namespace


FbStatistical Methods

The methods of the FbStatistical class are listed below. For a complete list of FbStatistical class members, see the FbStatistical Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbStatistical Class | FirebirdSql.Data.Firebird.Services Namespace


FbStatistical.Execute Method

[Visual Basic]
Public Sub Execute()
[C#]
public void Execute();

See Also

FbStatistical Class | FirebirdSql.Data.Firebird.Services Namespace


FbStatisticalFlags Enumeration

Specifies access flags for retrieve database statistics.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum FbStatisticalFlags
[C#]
[Flags]
public enum FbStatisticalFlags

Members

Member Name | Description | Value
DataPages |  | 1
DatabaseLog |  | 2
HeaderPages |  | 4
IndexPages |  | 8
SystemTablesRelations |  | 16

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird.Services Namespace


FbUserData Class

Represents data of a user of security.fdb security database.

For a list of all members of this type, see FbUserData Members.

System.Object
FirebirdSql.Data.Firebird.Services.FbUserData

[Visual Basic]
NotInheritable Public Class FbUserData
[C#]
public sealed class FbUserData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbUserData Members | FirebirdSql.Data.Firebird.Services Namespace


FbUserData Members

FbUserData overview

Public Instance Constructors

FbUserData Constructor Initializes a new instance of the FbUserData class.

Public Instance Properties

FirstName
GroupID
GroupName
LastName
MiddleName
RoleName
UserID
UserName
UserPassword

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbUserData Class | FirebirdSql.Data.Firebird.Services Namespace


FbUserData Constructor

Initializes a new instance of the FbUserData class.

[Visual Basic]
Public Sub New()
[C#]
public FbUserData();

See Also

FbUserData Class | FirebirdSql.Data.Firebird.Services Namespace


FbUserData Properties

The properties of the FbUserData class are listed below. For a complete list of FbUserData class members, see the FbUserData Members topic.

Public Instance Properties

FirstName
GroupID
GroupName
LastName
MiddleName
RoleName
UserID
UserName
UserPassword

See Also

FbUserData Class | FirebirdSql.Data.Firebird.Services Namespace


FirstName Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbUserData.FirstName Property

[Visual Basic]
Public Property FirstName As String
[C#]
public string FirstName {get; set;}

See Also

FbUserData Class | FirebirdSql.Data.Firebird.Services Namespace


GroupID Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbUserData.GroupID Property

[Visual Basic]
Public Property GroupID As Integer
[C#]
public int GroupID {get; set;}

See Also

FbUserData Class | FirebirdSql.Data.Firebird.Services Namespace


GroupName Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbUserData.GroupName Property

[Visual Basic]
Public Property GroupName As String
[C#]
public string GroupName {get; set;}

See Also

FbUserData Class | FirebirdSql.Data.Firebird.Services Namespace


LastName Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbUserData.LastName Property

[Visual Basic]
Public Property LastName As String
[C#]
public string LastName {get; set;}

See Also

FbUserData Class | FirebirdSql.Data.Firebird.Services Namespace


MiddleName Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbUserData.MiddleName Property

[Visual Basic]
Public Property MiddleName As String
[C#]
public string MiddleName {get; set;}

See Also

FbUserData Class | FirebirdSql.Data.Firebird.Services Namespace


RoleName Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbUserData.RoleName Property

[Visual Basic]
Public Property RoleName As String
[C#]
public string RoleName {get; set;}

See Also

FbUserData Class | FirebirdSql.Data.Firebird.Services Namespace


UserID Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbUserData.UserID Property

[Visual Basic]
Public Property UserID As Integer
[C#]
public int UserID {get; set;}

See Also

FbUserData Class | FirebirdSql.Data.Firebird.Services Namespace


UserName Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbUserData.UserName Property

[Visual Basic]
Public Property UserName As String
[C#]
public string UserName {get; set;}

See Also

FbUserData Class | FirebirdSql.Data.Firebird.Services Namespace


UserPassword Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbUserData.UserPassword Property

[Visual Basic]
Public Property UserPassword As String
[C#]
public string UserPassword {get; set;}

See Also

FbUserData Class | FirebirdSql.Data.Firebird.Services Namespace


FbValidation Class

Request a database validation. This class cannot be inherited.

For a list of all members of this type, see FbValidation Members.

System.Object
FirebirdSql.Data.Firebird.Services.FbService
FirebirdSql.Data.Firebird.Services.FbValidation

[Visual Basic]
NotInheritable Public Class FbValidation
Inherits FbService
[C#]
public sealed class FbValidation : FbService

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Database validation scans internal data structures for specific types of corruption. In some cases, the validation operation can repair corruption.

The validation operation cannot guarantee to repair all cases of corruption. Do not rely on database validation as a disaster recovery policy in lieu of making regular backups of your database.

Example

The following example makes a database validation for locate and release pages that are allocated but unassigned to any data structures.

FbValidation validationSvc = new FbValidation();

validationSvc.UserName = "SYSDBA";
validationSvc.UserPassword = "masterkey";

validationSvc.Database = @"D:\TESTDB.GDB";
validationSvc.Options = FbValidationFlags.ValidateDatabase;

validationSvc.Start();

string lineOutput;
while((lineOutput = validationSvc.GetNextLine()) != null)
{
    Console.WriteLine(lineOutput);
}

validationSvc.Close();

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FbValidation Members | FirebirdSql.Data.Firebird.Services Namespace


FbValidation Members

FbValidation overview

Public Instance Constructors

FbValidation Constructor Creates a new instance of FbValidation class.

Public Instance Properties

ConnectionString (inherited from FbService) | Gets or sets the connection string.
Options |
QueryBufferSize (inherited from FbService) | Gets or sets the buffer size for service query calls.
State (inherited from FbService) | Gets the current state of the service.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Executes Firebird database validation service task.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ServiceOutput (inherited from FbService) Occurs when the service returns output information.

See Also

FbValidation Class | FirebirdSql.Data.Firebird.Services Namespace


FbValidation Constructor

Creates a new instance of FbValidation class.

[Visual Basic]
Public Sub New()
[C#]
public FbValidation();

See Also

FbValidation Class | FirebirdSql.Data.Firebird.Services Namespace


FbValidation Properties

The properties of the FbValidation class are listed below. For a complete list of FbValidation class members, see the FbValidation Members topic.

Public Instance Properties

ConnectionString (inherited from FbService) | Gets or sets the connection string.
Options |
QueryBufferSize (inherited from FbService) | Gets or sets the buffer size for service query calls.
State (inherited from FbService) | Gets the current state of the service.

See Also

FbValidation Class | FirebirdSql.Data.Firebird.Services Namespace


Options Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FbValidation.Options Property

[Visual Basic]
Public Property Options As FbValidationFlags
[C#]
public FbValidationFlags Options {get; set;}

See Also

FbValidation Class | FirebirdSql.Data.Firebird.Services Namespace


FbValidation Methods

The methods of the FbValidation class are listed below. For a complete list of FbValidation class members, see the FbValidation Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Executes Firebird database validation service task.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FbValidation Class | FirebirdSql.Data.Firebird.Services Namespace


FbValidation.Execute Method

Executes Firebird database validation service task.

[Visual Basic]
Public Sub Execute()
[C#]
public void Execute();

See Also

FbValidation Class | FirebirdSql.Data.Firebird.Services Namespace


FbValidationFlags Enumeration

Specifies access flags for database validation.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum FbValidationFlags
[C#]
[Flags]
public enum FbValidationFlags

Members

Member Name | Description | Value
ValidateDatabase | Locate and release pages that are allocated but unassigned to any data structures. | 1
SweepDatabase | Request database sweep to mark outdated records as free space. | 2
MendDatabase | Mark corrupted records as unavailable, so subsequent operations skip them. | 4
CheckDatabase | Request read-only validation of the database, without correcting any problems. | 16
IgnoreChecksum | Ignore all checksum errors. | 32
KillShadows | Remove references to unavailable shadow files. | 64
Full | Check record and page structures, releasing unassigned record fragments. | 128

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird.Services Namespace


ServiceOutputEventArgs Class

Provides data for the ServiceOutput event. This class cannot be inherited.

For a list of all members of this type, see ServiceOutputEventArgs Members.

System.Object
System.EventArgs
FirebirdSql.Data.Firebird.Services.ServiceOutputEventArgs

[Visual Basic]
NotInheritable Public Class ServiceOutputEventArgs
Inherits EventArgs
[C#]
public sealed class ServiceOutputEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

ServiceOutputEventArgs Members | FirebirdSql.Data.Firebird.Services Namespace


ServiceOutputEventArgs Members

ServiceOutputEventArgs overview

Public Instance Constructors

ServiceOutputEventArgs Constructor Initializes a new instance of the ServiceOutputEventArgs class with the given service output message.

Public Instance Properties

Message Gets the service output message.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ServiceOutputEventArgs Class | FirebirdSql.Data.Firebird.Services Namespace


ServiceOutputEventArgs Constructor

Initializes a new instance of the ServiceOutputEventArgs class with the given service output message.

[Visual Basic]
Public Sub New( _
ByVal message As String _
)
[C#]
public ServiceOutputEventArgs(
string message
);

Parameters

message
The service output message.

See Also

ServiceOutputEventArgs Class | FirebirdSql.Data.Firebird.Services Namespace


ServiceOutputEventArgs Properties

The properties of the ServiceOutputEventArgs class are listed below. For a complete list of ServiceOutputEventArgs class members, see the ServiceOutputEventArgs Members topic.

Public Instance Properties

Message Gets the service output message.

See Also

ServiceOutputEventArgs Class | FirebirdSql.Data.Firebird.Services Namespace


Message Property

Firebird ADO.NET Provider SDK Documentation - v1.7.1

ServiceOutputEventArgs.Message Property

Gets the service output message.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}

Property Value

A string that represents the service output message.

See Also

ServiceOutputEventArgs Class | FirebirdSql.Data.Firebird.Services Namespace


ServiceOutputEventHandler Delegate

[Visual Basic]
Public Delegate Sub ServiceOutputEventHandler( _
ByVal sender As Object, _
ByVal e As ServiceOutputEventArgs _
)
[C#]
public delegate void ServiceOutputEventHandler(
object sender,
ServiceOutputEventArgs e
);

Requirements

Namespace: FirebirdSql.Data.Firebird.Services

Assembly: FirebirdSql.Data.Firebird (in FirebirdSql.Data.Firebird.dll)

See Also

FirebirdSql.Data.Firebird.Services Namespace


FirebirdSql.Data.Firebird.IsqlHierarchy

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FirebirdSql.Data.Firebird.Isql Hierarchy

System.Object
FirebirdSql.Data.Firebird.Isql.CommandExecutedEventArgs
FirebirdSql.Data.Firebird.Isql.FbBatchExecution
FirebirdSql.Data.Firebird.Isql.FbScript
FirebirdSql.Data.Firebird.Isql.StringParser
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
FirebirdSql.Data.Firebird.Isql.CommandExecutedEventHandler
FirebirdSql.Data.Firebird.Isql.CommandExecutingEventHandler
System.EventArgs
FirebirdSql.Data.Firebird.Isql.CommandExecutingEventArgs
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
FirebirdSql.Data.Firebird.Isql.SqlStatementType

See Also

FirebirdSql.Data.Firebird.Isql Namespace


FbService Hierarchy

System.Object
FbService
FbBackup
FbConfiguration
FbLog
FbRestore
FbSecurity
FbServerProperties
FbStatistical
FbValidation

See Also

FbService Class | FbService Members | FirebirdSql.Data.Firebird.Services Namespace


FirebirdSql.Data.Firebird.ServicesHierarchy

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FirebirdSql.Data.Firebird.Services Hierarchy

System.Object
FirebirdSql.Data.Firebird.Services.FbBackupFile
FirebirdSql.Data.Firebird.Services.FbService
FirebirdSql.Data.Firebird.Services.FbBackup
FirebirdSql.Data.Firebird.Services.FbConfiguration
FirebirdSql.Data.Firebird.Services.FbLog
FirebirdSql.Data.Firebird.Services.FbRestore
FirebirdSql.Data.Firebird.Services.FbSecurity
FirebirdSql.Data.Firebird.Services.FbServerProperties
FirebirdSql.Data.Firebird.Services.FbStatistical
FirebirdSql.Data.Firebird.Services.FbValidation
FirebirdSql.Data.Firebird.Services.FbUserData
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
FirebirdSql.Data.Firebird.Services.ServiceOutputEventHandler
System.EventArgs
FirebirdSql.Data.Firebird.Services.ServiceOutputEventArgs
System.ValueType
FirebirdSql.Data.Firebird.Services.FbDatabasesInfo
FirebirdSql.Data.Firebird.Services.FbServerConfig
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
FirebirdSql.Data.Firebird.Services.FbBackupFlags
FirebirdSql.Data.Firebird.Services.FbRestoreFlags
FirebirdSql.Data.Firebird.Services.FbServiceState
FirebirdSql.Data.Firebird.Services.FbShutdownMode
FirebirdSql.Data.Firebird.Services.FbStatisticalFlags
FirebirdSql.Data.Firebird.Services.FbValidationFlags

See Also

FirebirdSql.Data.Firebird.Services Namespace


FirebirdSql.Data.FirebirdHierarchy

Firebird ADO.NET Provider SDK Documentation - v1.7.1

FirebirdSql.Data.Firebird Hierarchy

System.Object
FirebirdSql.Data.Firebird.FbConnectionStringBuilder
FirebirdSql.Data.Firebird.FbDatabaseInfo
FirebirdSql.Data.Firebird.FbError
FirebirdSql.Data.Firebird.FbErrorCollection ---- System.Collections.ICollection, System.Collections.IEnumerable
FirebirdSql.Data.Firebird.FbRemoteEvent
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
FirebirdSql.Data.Firebird.FbInfoMessageEventHandler
FirebirdSql.Data.Firebird.FbRemoteEventEventHandler
FirebirdSql.Data.Firebird.FbRowUpdatedEventHandler
FirebirdSql.Data.Firebird.FbRowUpdatingEventHandler
System.EventArgs
FirebirdSql.Data.Firebird.FbInfoMessageEventArgs
System.ComponentModel.CancelEventArgs
FirebirdSql.Data.Firebird.FbRemoteEventEventArgs
System.Data.Common.RowUpdatedEventArgs
FirebirdSql.Data.Firebird.FbRowUpdatedEventArgs
System.Data.Common.RowUpdatingEventArgs
FirebirdSql.Data.Firebird.FbRowUpdatingEventArgs
System.Exception ---- System.Runtime.Serialization.ISerializable
System.SystemException
FirebirdSql.Data.Firebird.FbException
System.MarshalByRefObject
FirebirdSql.Data.Firebird.FbDataReader ---- System.Collections.IEnumerable, System.Data.IDataReader, System.Data.IDataRecord, System.IDisposable
FirebirdSql.Data.Firebird.FbParameter ---- System.Data.IDataParameter, System.Data.IDbDataParameter, System.ICloneable
FirebirdSql.Data.Firebird.FbParameterCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.Data.IDataParameterCollection
FirebirdSql.Data.Firebird.FbTransaction ---- System.Data.IDbTransaction, System.IDisposable
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
FirebirdSql.Data.Firebird.FbCommand ---- System.Data.IDbCommand, System.ICloneable
FirebirdSql.Data.Firebird.FbCommandBuilder
FirebirdSql.Data.Firebird.FbConnection ---- System.Data.IDbConnection, System.ICloneable
System.Data.Common.DataAdapter ---- System.Data.IDataAdapter
System.Data.Common.DbDataAdapter ---- System.Data.IDbDataAdapter, System.ICloneable
FirebirdSql.Data.Firebird.FbDataAdapter
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
FirebirdSql.Data.Firebird.FbCharset
FirebirdSql.Data.Firebird.FbCommandBuilderBehavior
FirebirdSql.Data.Firebird.FbDbSchemaType
FirebirdSql.Data.Firebird.FbDbType
FirebirdSql.Data.Firebird.FbTransactionOptions

See Also

FirebirdSql.Data.Firebird Namespace