Alvas.Audio

Alvas.Audio Class Library

Alvas.Audio Namespace

Namespace hierarchy

Classes

Class | Description
AcmConverter | AcmConverter class converts audio data from one format to another.
AudioCompressionManager | The audio compression manager adds system-level support for the transparent run-time audio compression, decompression and waveform-audio data format selection
AudioEffect | Base class for audio effects
AudioException | The exception that is thrown when an audio error occurs.
AudioReader | Represents a reader that can read an audio data from the stream. This class is abstract.
AudioWriter | Represents a writer that can write an audio data to the stream. This class is abstract.
AuReader | Reads an audio data from the .AU and .SND streams.
AviReader | Reads audio data from the Avi stream.
AviReaderException | The exception that is thrown when a avi reader error occurs.
ChorusAudioEffect | Chorus is a voice-doubling effect created by echoing the original sound with a slight delay and slightly modulating the delay of the echo.
CompressorAudioEffect | Compression is a reduction in the fluctuation of a signal above a certain amplitude.
ControlChangeEventArgs | Provides data for ControlChange event.
DataEventArgs | Provides data for Data event.
DestinationLine | Destination line.
DistortionAudioEffect | Distortion is achieved by adding harmonics to the signal in such a way that, as the level increases, the top of the waveform becomes squared off or clipped.
DoneEventArgs | Provides data for Done event.
DsReader | Reads audio data using DirectShow.
DsReaderException | The exception that is thrown when a DirectShow reader error occurs.
EchoAudioEffect | An echo effect causes an entire sound to be repeated after a fixed delay.
FlangerAudioEffect | Flange is an echo effect in which the delay between the original signal and its echo is very short and varies over time. The result is sometimes referred to as a sweeping sound. The term flange originated with the practice of grabbing the flanges of a tape reel to change the speed.
FormatChooseResult | Class represents the ChooseCompatibleFormat result
GargleAudioEffect | The gargle effect modulates the amplitude of the signal.
HResult | HResult
I3DL2ReverbAudioEffect | I3DL2Reverb audio effect
ID3v1 | Class represents a ID3 tag version 1.0 for MPEG Layer3 streams.
MediaBuffer | Attempting to implement the COM IMediaBuffer interface as a .NET object Not sure what will happen when I pass this to an unmanaged object
Mixer | Mixer component.
MixerBoolControl | Mixer boolean control
MixerControl | Mixer control.
MixerException | The exception that is thrown when an Mixer error occurs.
MixerIntControl | Mixer integer control
MixerLine | Mixer line.
MixerListControl | Mixer list control
MixerMuteControl | Mixer mute control
Mp3Reader | Reads audio data from the Mp3 stream.
Mp3ReaderException | The exception that is thrown when a mp3 reader error occurs.
Mp3ReadWriter | Reads/writes audio data from/to the Mp3 stream.
Mp3Writer | Writes MP3 data to the stream.
ParamEqAudioEffect | A parametric equalizer amplifies or attenuates signals of a given frequency.
Player | Player is a component for audio files playing.
PlayerEx | PlayerEx is a component for playing sound in PCM, IMA ADPCM, Microsoft ADPCM, CCITT A-Law, CCITT u-Law, GSM 6.10, Windows Media Audio V2, MPEG Layer-3 (mp3) and other wave file format.
RawReader | Reads an audio data from the headerless stream. Slinear, Gsm, A-law, mu-law etc.
RawReadWriter | Reads/writes an audio data from/to the headerless stream. Slinear, Gsm, A-law, mu-law etc.
RawWriter | Writes an audio data to the headerless stream. Slinear, Gsm, A-law, mu-law etc.
Recorder | Recorder is a component for sound recording in pulse code modulation (PCM) wave file format.
RecorderEx | RecorderEx is a component for sound recording in PCM, IMA ADPCM, Microsoft ADPCM, CCITT A-Law, CCITT u-Law, GSM 6.10, Windows Media Audio V2, MPEG Layer-3 (mp3) and other wave file format.
RecordPlayer | Class for recording and playback
SoundLevelMeter | Sound level meter is a component that allows audio signal level to be viewed. The sound level meter draws a horizontal line across the middle of the screen from left to right. If the input sound level departs from zero, the line is deflected either upwards or downwards.
Vox | Class for encoding and decoding Dialogic .vox (adpcm) format data
WaveFormat | Describes the format of the waveform-audio data.
WaveformVisualizer | WaveformVisualizer draws picture of the sound amplitude-time representation (Waveform).
WaveInException | The exception that is thrown when a WaveIn error occurs.
WaveOutException | The exception that is thrown when a WaveOut error occurs.
WaveReader | Reads WAVE (waveform audio format) data from the stream.
WaveReaderException | The exception that is thrown when a wave reader error occurs.
WaveReadWriter | Reads/writes audio data from/to the Wave stream.
WavesReverbAudioEffect | The Waves reverberation effect is intended for use with music.
WaveWriter | Writes WAVE (waveform audio format) data to the stream.

Interfaces

Interface | Description
IAudioReader | IAudioReader interface provides methods for reading audio data.
IAudioReadWriter | IAudioReadWriter interface provides methods for reading/writing audio data.
IAudioWriter | IAudioWriter interface provides methods for writing audio data.

Structures

Structure | Description
DriverDetails | The DriverDetails structure describes the features of an ACM driver.
FormatDetails | The FormatDetails structure details a waveform-audio format for a specific format tag for an ACM (AudioCompressionManager) driver.
FormatTagDetails | The FormatTagDetails structure details a waveform-audio format tag for an ACM driver.
Vox.AdpcmStatus | Coder status strucrure

Delegates

Delegate | Description
Mixer.ControlChangeEventHandler | ControlChange event handler
PlayerEx.DoneEventHandler | Represents the method that will handle the Done event of the PlayerEx.
RecorderEx.DataEventHandler | Represents the method that will handle the Data event of the RecorderEx.

Enumerations

Enumeration | Description
DeviceState | Specifies the audio device state.
Genre | Genre list for ID3 tag version 1.0
Recorder.BitsPerSample | Bits per sample enumeration.
Recorder.Channel | Channels enumeration.
Recorder.SamplesPerSec | Samples per second enumeration.
TimeFormat | TimeFormat specifies the sound position in milliseconds, bytes or samples.
WaveInfo | Wave Info tag list
WriteMode | Write mode

Copyright © 2003 - 2011 alvas.net


AcmConverter Class

AcmConverter class converts audio data from one format to another.

For a list of all members of this type, see AcmConverter Members.

System.Object
AcmConverter

[Visual Basic]
Public Class AcmConverter
[C#]
public class AcmConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

AcmConverter Members | Alvas.Audio Namespace


AcmConverter Members

AcmConverter overview

Public Instance Constructors

AcmConverter Constructor Initializes a new instance of the AcmConverter class

Public Instance Methods

Close | Closes the AcmConverter object and releases any system resources associated with it.
Convert | Converts audio data from one format to another.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AcmConverter Class | Alvas.Audio Namespace


AcmConverter Constructor

Initializes a new instance of the AcmConverter class

[Visual Basic]
Public Sub New( _
ByVal oldFormat As IntPtr, _
ByVal newFormat As IntPtr, _
ByVal fastConversion As Boolean _
)
[C#]
public AcmConverter(
IntPtr oldFormat,
IntPtr newFormat,
Boolean fastConversion
);

Parameters

oldFormat
Old audio format
newFormat
New audio format. Use ChooseCompatibleFormat or GetCompatibleFormatList or GetCompatibleFormat for search compatible format
fastConversion
true if the conversion is fast; otherwise, the conversion is high-quality.

See Also

AcmConverter Class | Alvas.Audio Namespace


AcmConverter Methods

The methods of the AcmConverter class are listed below. For a complete list of AcmConverter class members, see the AcmConverter Members topic.

Public Instance Methods

Close | Closes the AcmConverter object and releases any system resources associated with it.
Convert | Converts audio data from one format to another.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AcmConverter Class | Alvas.Audio Namespace


AcmConverter.Close Method

Closes the AcmConverter object and releases any system resources associated with it.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();

See Also

AcmConverter Class | Alvas.Audio Namespace


AcmConverter.Convert Method

Converts audio data from one format to another.

[Visual Basic]
Public Function Convert( _
ByVal data As Byte() _
) As Byte()
[C#]
public byte[] Convert(
Byte[] data
);

Parameters

data

Return Value

See Also

AcmConverter Class | Alvas.Audio Namespace


AudioCompressionManager Class

The audio compression manager adds system-level support for the transparent run-time audio compression, decompression and waveform-audio data format selection

For a list of all members of this type, see AudioCompressionManager Members.

System.Object
MarshalByRefObject
Component
AudioCompressionManager

[Visual Basic]
NotInheritable Public Class AudioCompressionManager
Inherits
[C#]
public class AudioCompressionManager : Component

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

AudioCompressionManager Members | Alvas.Audio Namespace


AudioCompressionManager Members

AudioCompressionManager overview

Public Static (Shared) Fields

AdpcmFormatTag | Microsoft ADPCM format tag
ALawFormatTag | A-Law format tag
Gsm610FormatTag | GSM 6.10 format tag
ImaAdpcmFormatTag | IMA ADPCM format tag
MpegLayer3FormatTag | ISO/MPEG Layer3 format tag
MuLawFormatTag | Mu-Law format tag
PcmFormatTag | PCM format tag

Public Static (Shared) Methods

ChangeSpeed | Overloaded. Changes the speed of audio file
ChangeVolume | Changes the volume of audio data
CheckSilent | Checks the level of audio signal. If it is above silentLevel returns false otherwise it returns true.
ChooseCompatibleFormat | Overloaded. Shows the dialog box that enables the user to select the waveform-audio format.
Convert | Overloaded. Converts the audio data from the specified old format to the new format.
Copy | Overloaded. Copy part audio data from in file to out file
CreateFormat | Create audio format from the byte array.
Fade | Creates fade in/out effect
FormatBytes | Returns audio format byte array.
FreeFormat | Frees memory previously allocated for audio format.
GetCompatibleFormat | Gets the format for the conversion from the specified format and specified format tag.
GetCompatibleFormatList | Overloaded. Gets the format list for the conversion from the specified format.
GetDriverDetails | Gets the driver details for specified driver.
GetDriverList | Gets the driver list.
GetFloat32Format | Creates 32-bit IEEE Float audio format.
GetFormatDetails | Overloaded. Gets the format details for specified format.
GetFormatList | Overloaded. Gets the format list for specified format tag and suitable driver.
GetFormatTagDetails | Overloaded. Gets the format tag details for specified format tag and suitable driver.
GetFormatTagList | Overloaded. Gets the format tag list for suitable driver.
GetMp3Format | Creates audio format for MPEG Layer3 audio data
GetPcmFormat | Creates audio format for PCM data
GetWaveFormat | Gets the WaveFormat for specified format handle.
Insert | Overloaded. Insert audio data to stream.
Inverse | Inverts the audio signal to 180 degrees. All positive values in the wave form are replaced by negative and vice versa.
Join | Overloaded. Join multiple audio files into one. The audio data formats must be the same.
MaxVolume | Gets max volume for specified audio format and data
MergeStereo | Overloaded. Merges 2 mono WAVE files into one stereo.
Milliseconds2Bytes | Returns bytes number for specified format and time, expressed in milliseconds
Mix | Overloaded. Mix several audio files. The audio data formats must be the same.
MixMany | Inserts and mixes one piece of audio data into main audio data with specified offset multiple times.
Mp3ToWav | Converts Mp3 file to Wav file with PCM (Pulse-code modulation) data
Normalize | Overloaded. Normalize method raises the volume so that the highest sample level reaches a maximum level.
RecalculateData | Recalculates audio data array to the specified length. (For SoundLevelMeter)
Remove | Overloaded. Remove part audio data from stream.
RemoveDcOffset | Overloaded. Removes DC offset. DC offset is an offsetting of a signal from zero. Occurs when hardware, such as a sound card, adds DC offset to a recorded audio signal.
Resample | Overloaded. Performs resampling audio data from and to 8/16/24/32-bit integer PCM and 32-bit IEEE Float audio formats.
Reverse | Overloaded. Reverses Wave audio data from one file to another.
Silence | Creates silence
SplitStereo | Overloaded. Splits one stereo file into two mono files (left and right channels).
SwapStereo | Overloaded. Swaps stereo channels.
ToFormat | Overloaded. Converts audio data to the specified audio format.
ToPcm |
ToPcm16Bit |
Wave2Mp3 | Overloaded. Converts Wave file to Mp3 file.

Public Instance Constructors

AudioCompressionManager Constructor Initializes a new instance of the AudioCompressionManager class.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
Site (inherited from Component) | Gets or sets the ISite of the Component.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

Public Instance Events

Disposed (inherited from Component) Occurs when the component is disposed by a call to the Dispose method.

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager Constructor

Initializes a new instance of the AudioCompressionManager class.

[Visual Basic]
Public Sub New()
[C#]
public AudioCompressionManager();

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager Fields

The fields of the AudioCompressionManager class are listed below. For a complete list of AudioCompressionManager class members, see the AudioCompressionManager Members topic.

Public Static (Shared) Fields

AdpcmFormatTag | Microsoft ADPCM format tag
ALawFormatTag | A-Law format tag
Gsm610FormatTag | GSM 6.10 format tag
ImaAdpcmFormatTag | IMA ADPCM format tag
MpegLayer3FormatTag | ISO/MPEG Layer3 format tag
MuLawFormatTag | Mu-Law format tag
PcmFormatTag | PCM format tag

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.AdpcmFormatTag Field

Microsoft ADPCM format tag

[Visual Basic]
Public Const AdpcmFormatTag As Short = 2
[C#]
public const Int16 AdpcmFormatTag = 2;

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.ALawFormatTag Field

A-Law format tag

[Visual Basic]
Public Const ALawFormatTag As Short = 6
[C#]
public const Int16 ALawFormatTag = 6;

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.Gsm610FormatTag Field

GSM 6.10 format tag

[Visual Basic]
Public Const Gsm610FormatTag As Short = 49
[C#]
public const Int16 Gsm610FormatTag = 49;

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.ImaAdpcmFormatTag Field

IMA ADPCM format tag

[Visual Basic]
Public Const ImaAdpcmFormatTag As Short = 17
[C#]
public const Int16 ImaAdpcmFormatTag = 17;

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.MpegLayer3FormatTag Field

ISO/MPEG Layer3 format tag

[Visual Basic]
Public Const MpegLayer3FormatTag As Short = 85
[C#]
public const Int16 MpegLayer3FormatTag = 85;

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.MuLawFormatTag Field

Mu-Law format tag

[Visual Basic]
Public Const MuLawFormatTag As Short = 7
[C#]
public const Int16 MuLawFormatTag = 7;

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.PcmFormatTag Field

PCM format tag

[Visual Basic]
Public Const PcmFormatTag As Short = 1
[C#]
public const Int16 PcmFormatTag = 1;

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager Methods

The methods of the AudioCompressionManager class are listed below. For a complete list of AudioCompressionManager class members, see the AudioCompressionManager Members topic.

Public Static (Shared) Methods

ChangeSpeed | Overloaded. Changes the speed of audio file
ChangeVolume | Changes the volume of audio data
CheckSilent | Checks the level of audio signal. If it is above silentLevel returns false otherwise it returns true.
ChooseCompatibleFormat | Overloaded. Shows the dialog box that enables the user to select the waveform-audio format.
Convert | Overloaded. Converts the audio data from the specified old format to the new format.
Copy | Overloaded. Copy part audio data from in file to out file
CreateFormat | Create audio format from the byte array.
Fade | Creates fade in/out effect
FormatBytes | Returns audio format byte array.
FreeFormat | Frees memory previously allocated for audio format.
GetCompatibleFormat | Gets the format for the conversion from the specified format and specified format tag.
GetCompatibleFormatList | Overloaded. Gets the format list for the conversion from the specified format.
GetDriverDetails | Gets the driver details for specified driver.
GetDriverList | Gets the driver list.
GetFloat32Format | Creates 32-bit IEEE Float audio format.
GetFormatDetails | Overloaded. Gets the format details for specified format.
GetFormatList | Overloaded. Gets the format list for specified format tag and suitable driver.
GetFormatTagDetails | Overloaded. Gets the format tag details for specified format tag and suitable driver.
GetFormatTagList | Overloaded. Gets the format tag list for suitable driver.
GetMp3Format | Creates audio format for MPEG Layer3 audio data
GetPcmFormat | Creates audio format for PCM data
GetWaveFormat | Gets the WaveFormat for specified format handle.
Insert | Overloaded. Insert audio data to stream.
Inverse | Inverts the audio signal to 180 degrees. All positive values in the wave form are replaced by negative and vice versa.
Join | Overloaded. Join multiple audio files into one. The audio data formats must be the same.
MaxVolume | Gets max volume for specified audio format and data
MergeStereo | Overloaded. Merges 2 mono WAVE files into one stereo.
Milliseconds2Bytes | Returns bytes number for specified format and time, expressed in milliseconds
Mix | Overloaded. Mix several audio files. The audio data formats must be the same.
MixMany | Inserts and mixes one piece of audio data into main audio data with specified offset multiple times.
Mp3ToWav | Converts Mp3 file to Wav file with PCM (Pulse-code modulation) data
Normalize | Overloaded. Normalize method raises the volume so that the highest sample level reaches a maximum level.
RecalculateData | Recalculates audio data array to the specified length. (For SoundLevelMeter)
Remove | Overloaded. Remove part audio data from stream.
RemoveDcOffset | Overloaded. Removes DC offset. DC offset is an offsetting of a signal from zero. Occurs when hardware, such as a sound card, adds DC offset to a recorded audio signal.
Resample | Overloaded. Performs resampling audio data from and to 8/16/24/32-bit integer PCM and 32-bit IEEE Float audio formats.
Reverse | Overloaded. Reverses Wave audio data from one file to another.
Silence | Creates silence
SplitStereo | Overloaded. Splits one stereo file into two mono files (left and right channels).
SwapStereo | Overloaded. Swaps stereo channels.
ToFormat | Overloaded. Converts audio data to the specified audio format.
ToPcm |
ToPcm16Bit |
Wave2Mp3 | Overloaded. Converts Wave file to Mp3 file.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


ChangeSpeed Method

Alvas.Audio Class Library

AudioCompressionManager.ChangeSpeed Method

Changes the speed of audio data

Overload List

Changes the speed of audio data

public static byte[] ChangeSpeed(IntPtr,Byte[],Int32);

Changes the speed of audio stream.

public static void ChangeSpeed(Stream,Stream,Int32);

Changes the speed of audio file

public static void ChangeSpeed(String,String,Int32);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.ChangeSpeed Method (IntPtr, Byte[], Int32)

Changes the speed of audio data

[Visual Basic]
Overloads Public Shared Function ChangeSpeed( _
ByVal format As IntPtr, _
ByVal data As Byte(), _
ByVal persent As Integer _
) As Byte()
[C#]
public static byte[] ChangeSpeed(
IntPtr format,
Byte[] data,
Int32 persent
);

Parameters

format
audio format
data
audio data
persent
100 is normal speed, 50 is reduced by half, 200 is increased in 2 times

Return Value

Example

This example shows simple using of ChangeSpeed method.

string inFile = @"in.mp3";
string outFile = @"out.mp3";
int persent = 50;
Mp3Reader mr = new Mp3Reader(File.OpenRead(inFile));
IntPtr format = mr.ReadFormat();
byte[] data = mr.ReadData();
mr.Close();
byte[] outData = AudioCompressionManager.ChangeSpeed(format, data, persent);
Mp3Writer mw = new Mp3Writer(File.Create(outFile));
mw.WriteData(outData);
mw.Close();

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.ChangeSpeed Overload List


AudioCompressionManager.ChangeSpeed Method (Stream, Stream, Int32)

Changes the speed of audio stream.

[Visual Basic]
Overloads Public Shared Sub ChangeSpeed( _
ByVal inStream As Stream, _
ByVal outStream As Stream, _
ByVal persent As Integer _
)
[C#]
public static void ChangeSpeed(
Stream inStream,
Stream outStream,
Int32 persent
);

Parameters

inStream
input stream
outStream
output stream
persent
100 is normal speed, 50 is reduced by half, 200 is increased in 2 times

Example

This example shows simple using of ChangeSpeed method.

string inFile = @"in.wav";
string outFile = @"out.wav";
int persent = 50;
AudioCompressionManager.ChangeSpeed(File.OpenRead(inFile), File.Create(outFile), persent);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.ChangeSpeed Overload List


AudioCompressionManager.ChangeSpeed Method (String, String, Int32)

Changes the speed of audio file

[Visual Basic]
Overloads Public Shared Sub ChangeSpeed( _
ByVal inFile As String, _
ByVal outFile As String, _
ByVal persent As Integer _
)
[C#]
public static void ChangeSpeed(
String inFile,
String outFile,
Int32 persent
);

Parameters

inFile
input file
outFile
output file
persent
100 is normal speed, 50 is reduced by half, 200 is increased in 2 times

Example

This example shows simple using of ChangeSpeed method.

string inFile = @"in.wav";
string outFile = @"out.wav";
int persent = 50;
AudioCompressionManager.ChangeSpeed(inFile, outFile, persent);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.ChangeSpeed Overload List


AudioCompressionManager.ChangeVolume Method

Changes the volume of audio data

[Visual Basic]
Public Shared Function ChangeVolume( _
ByVal format As IntPtr, _
ByVal data As Byte(), _
ByVal persent As Integer _
) As Byte()
[C#]
public static byte[] ChangeVolume(
IntPtr format,
Byte[] data,
Int32 persent
);

Parameters

format
audio format
data
audio data
persent
100 is normal volume, 50 is reduced by half, 200 is increased in 2 times

Return Value

Example

This example shows simple using of ChangeVolume method.

string inFile = @"in.mp3";
string outFile = @"out.mp3";
int persent = 50;
Mp3Reader mr = new Mp3Reader(File.OpenRead(inFile));
IntPtr format = mr.ReadFormat();
byte[] data = mr.ReadData();
mr.Close();
byte[] outData = AudioCompressionManager.ChangeVolume(format, data, persent);
Mp3Writer mw = new Mp3Writer(File.Create(outFile));
mw.WriteData(outData);
mw.Close();

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.CheckSilent Method

Checks the level of audio signal. If it is above silentLevel returns false otherwise it returns true.

[Visual Basic]
Public Shared Function CheckSilent( _
ByVal format As IntPtr, _
ByVal data As Byte(), _
ByVal silentLevel As Short _
) As Boolean
[C#]
public static bool CheckSilent(
IntPtr format,
Byte[] data,
Int16 silentLevel
);

Parameters

format
audio format
data
audio data
silentLevel
Can be in the range 0 .. short.MaxValue

Return Value

Example

This example shows simple using of CheckSilent method.

private static void SkipSilent(string fileName, short silentLevel)
{
    WaveReader wr = new WaveReader(File.OpenRead(fileName));
    IntPtr format = wr.ReadFormat();
    WaveWriter ww = new WaveWriter(File.Create(fileName + ".wav"), AudioCompressionManager.FormatBytes(format));
    int i = 0;
    while (true)
    {
        byte[] data = wr.ReadData(i, 1);
        if (data.Length == 0)
        {
            break;
        }
        if (!AudioCompressionManager.CheckSilent(format, data, silentLevel))
        {
            ww.WriteData(data);
        }
    }
    ww.Close();
    wr.Close();
}

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


ChooseCompatibleFormat Method

Alvas.Audio Class Library

AudioCompressionManager.ChooseCompatibleFormat Method

Shows the dialog box that enables the user to select the waveform-audio format.

Overload List

Shows the dialog box that enables the user to select the waveform-audio format.

public static FormatChooseResult ChooseCompatibleFormat(IntPtr,IntPtr);

Shows the dialog box that enables the user to select the waveform-audio format.

public static FormatChooseResult ChooseCompatibleFormat(IntPtr,IntPtr,String);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.ChooseCompatibleFormat Method (IntPtr, IntPtr)

Shows the dialog box that enables the user to select the waveform-audio format.

[Visual Basic]
Overloads Public Shared Function ChooseCompatibleFormat( _
ByVal owner As IntPtr, _
ByVal oldFormat As IntPtr _
) As FormatChooseResult
[C#]
public static FormatChooseResult ChooseCompatibleFormat(
IntPtr owner,
IntPtr oldFormat
);

Parameters

owner
Handle to the window that owns the dialog box.
oldFormat
Specify valid format handle to get the destination formats that can be converted from this format.Or IntPtr.Zero to get all supported formats.

Return Value

Example

This example shows simple using of ChooseCompatibleFormat method.

IntPtr formatOld = AudioCompressionManager.GetPcmFormat(1, 16, 44100);
FormatChooseResult fcr = AudioCompressionManager.ChooseCompatibleFormat(IntPtr.Zero, formatOld);
if (fcr.Result == 0)
{
    Console.WriteLine("{0} {1}", fcr.FormatTagName, fcr.FormatName);
    IntPtr format = fcr.Format;
}

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.ChooseCompatibleFormat Overload List


AudioCompressionManager.ChooseCompatibleFormat Method (IntPtr, IntPtr, String)

Shows the dialog box that enables the user to select the waveform-audio format.

[Visual Basic]
Overloads Public Shared Function ChooseCompatibleFormat( _
ByVal owner As IntPtr, _
ByVal oldFormat As IntPtr, _
ByVal title As String _
) As FormatChooseResult
[C#]
public static FormatChooseResult ChooseCompatibleFormat(
IntPtr owner,
IntPtr oldFormat,
String title
);

Parameters

owner
Handle to the window that owns the dialog box.
oldFormat
Specify valid format handle to get the destination formats that can be converted from this format.Or IntPtr.Zero to get all supported formats.
title
Dialog box title

Return Value

Example

This example shows simple using of ChooseCompatibleFormat method.

IntPtr formatOld = AudioCompressionManager.GetPcmFormat(1, 16, 44100);
FormatChooseResult fcr = AudioCompressionManager.ChooseCompatibleFormat(IntPtr.Zero, formatOld, "Select Audio Format");
if (fcr.Result == 0)
{
    Console.WriteLine("{0} {1}", fcr.FormatTagName, fcr.FormatName);
    IntPtr format = fcr.Format;
}

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.ChooseCompatibleFormat Overload List


Convert Method

Alvas.Audio Class Library

AudioCompressionManager.Convert Method

Converts the audio data from the specified old format to the new format.

Overload List

Converts the audio data from the specified old format to the new format.

public static void Convert(IAudioReader,WaveWriter,Boolean);

Converts the audio data from the specified old format to the new format.

public static byte[] Convert(IntPtr,IntPtr,Byte[],Boolean);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.Convert Method (IAudioReader, WaveWriter, Boolean)

Converts the audio data from the specified old format to the new format.

[Visual Basic]
Overloads Public Shared Sub Convert( _
ByVal wr As IAudioReader, _
ByVal ww As WaveWriter, _
ByVal fastConversion As Boolean _
)
[C#]
public static void Convert(
IAudioReader wr,
WaveWriter ww,
Boolean fastConversion
);

Parameters

wr
ww
fastConversion

Example

This example shows simple using of Convert method.

Mp3Reader mr = new Mp3Reader(File.OpenRead("in.mp3"));
IntPtr formatMp3 = mr.ReadFormat();
IntPtr formatPcm = AudioCompressionManager.GetCompatibleFormat(formatMp3,
    AudioCompressionManager.PcmFormatTag);
WaveWriter ww = new WaveWriter(File.Create("out.wav"),
    AudioCompressionManager.FormatBytes(formatPcm));
AudioCompressionManager.Convert(mr, ww, false);
mr.Close();
ww.Close();

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Convert Overload List


AudioCompressionManager.Convert Method (IntPtr, IntPtr, Byte[], Boolean)

Converts the audio data from the specified old format to the new format.

[Visual Basic]
Overloads Public Shared Function Convert( _
ByVal oldFormat As IntPtr, _
ByVal newFormat As IntPtr, _
ByVal data As Byte(), _
ByVal fastConversion As Boolean _
) As Byte()
[C#]
public static byte[] Convert(
IntPtr oldFormat,
IntPtr newFormat,
Byte[] data,
Boolean fastConversion
);

Parameters

oldFormat
Old audio format.
newFormat
New audio format. Use ChooseCompatibleFormat or GetCompatibleFormatList or GetCompatibleFormat for search compatible format
data
The audio data.
fastConversion
true if the conversion is fast; otherwise, the conversion is high-quality.

Return Value

Returns the audio data in the new format.

Example

This example shows simple using of Convert method.

Mp3Reader mr = new Mp3Reader(File.OpenRead("in.mp3"));
IntPtr formatMp3 = mr.ReadFormat();
byte[] dataMp3 = mr.ReadData();
mr.Close();
IntPtr formatPcm = AudioCompressionManager.GetCompatibleFormat(formatMp3,
    AudioCompressionManager.PcmFormatTag);
byte[] dataPcm = AudioCompressionManager.Convert(formatMp3, formatPcm, dataMp3, false);
WaveWriter ww = new WaveWriter(File.Create("out.wav"),
    AudioCompressionManager.FormatBytes(formatPcm));
ww.WriteData(dataPcm);
ww.Close();

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Convert Overload List


Copy Method

Alvas.Audio Class Library

AudioCompressionManager.Copy Method

Copy part audio data from byte array

Overload List

Copy part audio data from byte array

public static byte[] Copy(IntPtr,Byte[],Int32,Int32);

Copy part audio data from in stream to out stream

public static void Copy(Stream,Stream,Int32,Int32);

Copy part audio data from in file to out file

public static void Copy(String,String,Int32,Int32);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.Copy Method (IntPtr, Byte[], Int32, Int32)

Copy part audio data from byte array

[Visual Basic]
Overloads Public Shared Function Copy( _
ByVal format As IntPtr, _
ByVal data As Byte(), _
ByVal skipSeconds As Integer, _
ByVal readSeconds As Integer _
) As Byte()
[C#]
public static byte[] Copy(
IntPtr format,
Byte[] data,
Int32 skipSeconds,
Int32 readSeconds
);

Parameters

format
audio format
data
audio data
skipSeconds
skip seconds
readSeconds
read seconds

Return Value

Returns audio data byte array

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Copy Overload List


AudioCompressionManager.Copy Method (Stream, Stream, Int32, Int32)

Copy part audio data from in stream to out stream

[Visual Basic]
Overloads Public Shared Sub Copy( _
ByVal inStream As Stream, _
ByVal outStream As Stream, _
ByVal skipSeconds As Integer, _
ByVal readSeconds As Integer _
)
[C#]
public static void Copy(
Stream inStream,
Stream outStream,
Int32 skipSeconds,
Int32 readSeconds
);

Parameters

inStream
input stream
outStream
output stream
skipSeconds
skip seconds
readSeconds
read seconds

Example

This example shows simple using of Copy method.

string inFile = "in.wav";
string outFile = "out.wav";
int skipSeconds = 1;
int readSeconds = 2;
AudioCompressionManager.Copy(File.OpenRead(inFile), File.Create(outFile), skipSeconds, readSeconds);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Copy Overload List


AudioCompressionManager.Copy Method (String, String, Int32, Int32)

Copy part audio data from in file to out file

[Visual Basic]
Overloads Public Shared Sub Copy( _
ByVal inFile As String, _
ByVal outFile As String, _
ByVal skipSeconds As Integer, _
ByVal readSeconds As Integer _
)
[C#]
public static void Copy(
String inFile,
String outFile,
Int32 skipSeconds,
Int32 readSeconds
);

Parameters

inFile
input file
outFile
output file
skipSeconds
skip seconds
readSeconds
read seconds

Example

This example shows simple using of Copy method.

string inFile = "in.wav";
string outFile = "out.wav";
int skipSeconds = 1;
int readSeconds = 2;
AudioCompressionManager.Copy(inFile, outFile, skipSeconds, readSeconds);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Copy Overload List


AudioCompressionManager.CreateFormat Method

Create audio format from the byte array.

[Visual Basic]
Public Shared Function CreateFormat( _
ByVal arr As Byte() _
) As IntPtr
[C#]
public static IntPtr CreateFormat(
Byte[] arr
);

Parameters

arr
byte array

Return Value

audio format

Example

This example shows simple using of CreateFormat method.

IntPtr format = AudioCompressionManager.CreateFormat(AudioCompressionManager.FormatBytes(AudioCompressionManager.GetPcmFormat(2, 16, 8000)));
FormatDetails fd = AudioCompressionManager.GetFormatDetails(format, true);
Console.WriteLine(fd.ToString());

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.Fade Method

Creates fade in/out effect

[Visual Basic]
Public Shared Function Fade( _
ByVal format As IntPtr, _
ByVal data As Byte(), _
ByVal isIn As Boolean _
) As Byte()
[C#]
public static byte[] Fade(
IntPtr format,
Byte[] data,
Boolean isIn
);

Parameters

format
input audio format
data
input audio data
isIn
true for fade in; otherwise, fade out.

Return Value

audio data with fade in/out effect

Example

This example shows simple using of Fade method.

WaveReader wr = new WaveReader(File.OpenRead("in.wav"));
IntPtr format = wr.ReadFormat();
byte[] data1 = wr.ReadData(0, 1);
byte[] data2 = wr.ReadData(1, 1);
byte[] data3 = wr.ReadData(2, 1);
wr.Close();
byte[] data11 = AudioCompressionManager.Fade(format, data1, true);
byte[] data33 = AudioCompressionManager.Fade(format, data3, false);
WaveWriter ww = new WaveWriter(File.Create("out.wav"), AudioCompressionManager.FormatBytes(format));
ww.WriteData(data11);
ww.WriteData(data2);
ww.WriteData(data33);
ww.Close();

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.FormatBytes Method

Returns audio format byte array.

[Visual Basic]
Public Shared Function FormatBytes( _
ByVal format As IntPtr _
) As Byte()
[C#]
public static byte[] FormatBytes(
IntPtr format
);

Parameters

format

Return Value

Example

This example shows simple using of FormatBytes method.

WaveWriter ww = new WaveWriter(File.Create("out.wav"),
    AudioCompressionManager.FormatBytes(AudioCompressionManager.GetPcmFormat(2, 16, 8000)));
ww.Close();

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.FreeFormat Method

Frees memory previously allocated for audio format.

[Visual Basic]
Public Shared Sub FreeFormat( _
ByVal format As IntPtr _
)
[C#]
public static void FreeFormat(
IntPtr format
);

Parameters

format
audio format

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.GetCompatibleFormat Method

Gets the format for the conversion from the specified format and specified format tag.

[Visual Basic]
Public Shared Function GetCompatibleFormat( _
ByVal format As IntPtr, _
ByVal formatTag As Short _
) As IntPtr
[C#]
public static IntPtr GetCompatibleFormat(
IntPtr format,
Int16 formatTag
);

Parameters

format
The format handle
formatTag
The format tag

Return Value

Example

This example shows simple using of GetCompatibleFormat method.

IntPtr formaGsm = AudioCompressionManager.GetCompatibleFormat(AudioCompressionManager.GetPcmFormat(1, 16, 16000),
                AudioCompressionManager.Gsm610FormatTag);
FormatDetails fd = AudioCompressionManager.GetFormatDetails(formaGsm, true);
Console.WriteLine(fd.ToString());

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


GetCompatibleFormatList Method

Alvas.Audio Class Library

AudioCompressionManager.GetCompatibleFormatList Method

Gets the format list for the conversion from the specified format.

Overload List

Gets the format list for the conversion from the specified format.

public static FormatDetails[] GetCompatibleFormatList(IntPtr);

Gets the format list for the conversion from the specified format.

public static FormatDetails[] GetCompatibleFormatList(IntPtr,Boolean);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.GetCompatibleFormatList Method (IntPtr)

Gets the format list for the conversion from the specified format.

[Visual Basic]
Overloads Public Shared Function GetCompatibleFormatList( _
ByVal format As IntPtr _
) As FormatDetails()
[C#]
public static FormatDetails[] GetCompatibleFormatList(
IntPtr format
);

Parameters

format
The format handle.

Return Value

Example

This example shows simple using of GetCompatibleFormatList method.

IntPtr formaGsm = AudioCompressionManager.GetCompatibleFormat(AudioCompressionManager.GetPcmFormat(1, 16, 16000),
                AudioCompressionManager.Gsm610FormatTag);
FormatDetails fd = AudioCompressionManager.GetFormatDetails(formaGsm);
Console.WriteLine(fd.ToString());

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.GetCompatibleFormatList Overload List


AudioCompressionManager.GetCompatibleFormatList Method (IntPtr, Boolean)

Gets the format list for the conversion from the specified format.

[Visual Basic]
Overloads Public Shared Function GetCompatibleFormatList( _
ByVal format As IntPtr, _
ByVal showFormatTag As Boolean _
) As FormatDetails()
[C#]
public static FormatDetails[] GetCompatibleFormatList(
IntPtr format,
Boolean showFormatTag
);

Parameters

format
The format handle.
showFormatTag
Shows format tag name as result of ToString()method.

Return Value

Example

This example shows simple using of GetCompatibleFormatList method.

IntPtr formaGsm = AudioCompressionManager.GetCompatibleFormat(AudioCompressionManager.GetPcmFormat(1, 16, 16000),
                AudioCompressionManager.Gsm610FormatTag);
FormatDetails fd = AudioCompressionManager.GetFormatDetails(formaGsm, true);
Console.WriteLine(fd.ToString());

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.GetCompatibleFormatList Overload List


AudioCompressionManager.GetDriverDetails Method

Gets the driver details for specified driver.

[Visual Basic]
Public Shared Function GetDriverDetails( _
ByVal driver As Integer _
) As DriverDetails
[C#]
public static DriverDetails GetDriverDetails(
Int32 driver
);

Parameters

driver
The driver.

Return Value

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.GetDriverList Method

Gets the driver list.

[Visual Basic]
Public Shared Function GetDriverList() As DriverDetails()
[C#]
public static DriverDetails[] GetDriverList();

Return Value

Example

This example shows simple using of GetDriverList method.

DriverDetails[] driverList = AudioCompressionManager.GetDriverList();

foreach (DriverDetails driverDetails in driverList)
{
    Console.WriteLine("Driver: {0}, Version: {1}, LongName: {2}", driverDetails.Driver, driverDetails.DriverVersion, driverDetails.LongName);
}

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.GetFloat32Format Method

Creates 32-bit IEEE Float audio format.

[Visual Basic]
Public Shared Function GetFloat32Format( _
ByVal channels As Short, _
ByVal samplesPerSec As Integer _
) As IntPtr
[C#]
public static IntPtr GetFloat32Format(
Int16 channels,
Int32 samplesPerSec
);

Parameters

channels
channels count
samplesPerSec
samples per second

Return Value

32-bit IEEE Float audio format

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


GetFormatDetails Method

Alvas.Audio Class Library

AudioCompressionManager.GetFormatDetails Method

Gets the format details for specified format.

Overload List

Gets the format details for specified format.

public static FormatDetails GetFormatDetails(IntPtr);

Gets the format details for specified format.

public static FormatDetails GetFormatDetails(IntPtr,Boolean);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.GetFormatDetails Method (IntPtr)

Gets the format details for specified format.

[Visual Basic]
Overloads Public Shared Function GetFormatDetails( _
ByVal format As IntPtr _
) As FormatDetails
[C#]
public static FormatDetails GetFormatDetails(
IntPtr format
);

Parameters

format
The format.

Return Value

Example

This example shows simple using of GetFormatDetails method.

IntPtr format = AudioCompressionManager.GetPcmFormat(2, 16, 24000);
FormatDetails fd = AudioCompressionManager.GetFormatDetails(format);
Console.WriteLine(fd.ToString());

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.GetFormatDetails Overload List


AudioCompressionManager.GetFormatDetails Method (IntPtr, Boolean)

Gets the format details for specified format.

[Visual Basic]
Overloads Public Shared Function GetFormatDetails( _
ByVal format As IntPtr, _
ByVal showFormatTag As Boolean _
) As FormatDetails
[C#]
public static FormatDetails GetFormatDetails(
IntPtr format,
Boolean showFormatTag
);

Parameters

format
The format.
showFormatTag
Shows format tag name as result of ToString()method.

Return Value

Example

This example shows simple using of GetFormatDetails method.

IntPtr format = AudioCompressionManager.GetPcmFormat(2, 16, 24000);
FormatDetails fd = AudioCompressionManager.GetFormatDetails(format, true);
Console.WriteLine(fd.ToString());

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.GetFormatDetails Overload List


GetFormatList Method

Alvas.Audio Class Library

AudioCompressionManager.GetFormatList Method

Gets the format list for specified WaveFormat and suitable driver.

  • To filter the format list by nChannels please specify the valid value or 0 otherwise;
  • To filter the format list by wBitsPerSample please specify the valid value or 0 otherwise;
  • To filter the format list by nSamplesPerSec please specify the valid value or 0 otherwise;
  • To filter the format list by wFormatTag please specify the valid value or 0 otherwise;

Overload List

Gets the format list for specified WaveFormat and suitable driver.

  • To filter the format list by nChannels please specify the valid value or 0 otherwise;
  • To filter the format list by wBitsPerSample please specify the valid value or 0 otherwise;
  • To filter the format list by nSamplesPerSec please specify the valid value or 0 otherwise;
  • To filter the format list by wFormatTag please specify the valid value or 0 otherwise;

public static FormatDetails[] GetFormatList(WaveFormat);

Gets the format list for specified format tag and suitable driver.

public static FormatDetails[] GetFormatList(Int32);

Gets the format list for specified format tag and suitable driver.

public static FormatDetails[] GetFormatList(Int32,Boolean);

Gets the format list for specified format tag and driver.

public static FormatDetails[] GetFormatList(Int32,Int32);

Gets the format list for specified format tag and driver.

public static FormatDetails[] GetFormatList(Int32,Int32,Boolean);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.GetFormatList Method (WaveFormat)

Gets the format list for specified WaveFormat and suitable driver.

  • To filter the format list by nChannels please specify the valid value or 0 otherwise;
  • To filter the format list by wBitsPerSample please specify the valid value or 0 otherwise;
  • To filter the format list by nSamplesPerSec please specify the valid value or 0 otherwise;
  • To filter the format list by wFormatTag please specify the valid value or 0 otherwise;

[Visual Basic]
Overloads Public Shared Function GetFormatList( _
ByVal waveFormat As WaveFormat _
) As FormatDetails()
[C#]
public static FormatDetails[] GetFormatList(
WaveFormat waveFormat
);

Parameters

waveFormat
The wave format.

Return Value

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.GetFormatList Overload List


AudioCompressionManager.GetFormatList Method (Int32)

Gets the format list for specified format tag and suitable driver.

[Visual Basic]
Overloads Public Shared Function GetFormatList( _
ByVal formatTag As Integer _
) As FormatDetails()
[C#]
public static FormatDetails[] GetFormatList(
Int32 formatTag
);

Parameters

formatTag
The format tag.

Return Value

Example

This example shows simple using of GetFormatList method.

FormatDetails[] fdArr = AudioCompressionManager.GetFormatList(AudioCompressionManager.ImaAdpcmFormatTag);
foreach (FormatDetails fd in fdArr)
{
    Console.WriteLine(fd.ToString());
}

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.GetFormatList Overload List


AudioCompressionManager.GetFormatList Method (Int32, Boolean)

Gets the format list for specified format tag and suitable driver.

[Visual Basic]
Overloads Public Shared Function GetFormatList( _
ByVal formatTag As Integer, _
ByVal showFormatTag As Boolean _
) As FormatDetails()
[C#]
public static FormatDetails[] GetFormatList(
Int32 formatTag,
Boolean showFormatTag
);

Parameters

formatTag
The format tag.
showFormatTag
Shows format tag name as result of ToString()method.

Return Value

Example

This example shows simple using of GetFormatList method.

FormatDetails[] fdArr = AudioCompressionManager.GetFormatList(AudioCompressionManager.AdpcmFormatTag, true);
foreach (FormatDetails fd in fdArr)
{
    Console.WriteLine(fd.ToString());
}

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.GetFormatList Overload List


AudioCompressionManager.GetFormatList Method (Int32, Int32)

Gets the format list for specified format tag and driver.

[Visual Basic]
Overloads Public Shared Function GetFormatList( _
ByVal formatTag As Integer, _
ByVal driver As Integer _
) As FormatDetails()
[C#]
public static FormatDetails[] GetFormatList(
Int32 formatTag,
Int32 driver
);

Parameters

formatTag
The format tag.
driver
The driver id.

Return Value

Example

This example shows simple using of GetFormatList method for specified driver.

private void GetDriver()
{
    foreach (DriverDetails dd in AudioCompressionManager.GetDriverList())
    {
        if (dd.LongName.Contains("{insert text here}"))
        {
            int driverId = dd.Driver;
            FormatDetails[] fd = AudioCompressionManager.GetFormatList(AudioCompressionManager.MpegLayer3FormatTag, driverId);
            break;
        }
    };
}

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.GetFormatList Overload List


AudioCompressionManager.GetFormatList Method (Int32, Int32, Boolean)

Gets the format list for specified format tag and driver.

[Visual Basic]
Overloads Public Shared Function GetFormatList( _
ByVal formatTag As Integer, _
ByVal driver As Integer, _
ByVal showFormatTag As Boolean _
) As FormatDetails()
[C#]
public static FormatDetails[] GetFormatList(
Int32 formatTag,
Int32 driver,
Boolean showFormatTag
);

Parameters

formatTag
The format tag.
driver
The driver id.
showFormatTag
Shows format tag name as result of ToString()method.

Return Value

Example

This example shows simple using of GetFormatList method for specified driver.

private void GetDriver()
{
    foreach (DriverDetails dd in AudioCompressionManager.GetDriverList())
    {
        if (dd.LongName.Contains("{insert text here}"))
        {
            int driverId = dd.Driver;
            FormatDetails[] fd = AudioCompressionManager.GetFormatList(AudioCompressionManager.MpegLayer3FormatTag, driverId, true);
            break;
        }
    };
}

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.GetFormatList Overload List


GetFormatTagDetails Method

Alvas.Audio Class Library

AudioCompressionManager.GetFormatTagDetails Method

Gets the format tag details for specified format tag and suitable driver.

Overload List

Gets the format tag details for specified format tag and suitable driver.

public static FormatTagDetails GetFormatTagDetails(Int32);

Gets the format tag details for specified format tag and driver.

public static FormatTagDetails GetFormatTagDetails(Int32,Int32);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.GetFormatTagDetails Method (Int32)

Gets the format tag details for specified format tag and suitable driver.

[Visual Basic]
Overloads Public Shared Function GetFormatTagDetails( _
ByVal formatTag As Integer _
) As FormatTagDetails
[C#]
public static FormatTagDetails GetFormatTagDetails(
Int32 formatTag
);

Parameters

formatTag
The format tag.

Return Value

Example

This example shows simple using of GetFormatTagDetails method.

FormatTagDetails ftd = AudioCompressionManager.GetFormatTagDetails(AudioCompressionManager.PcmFormatTag);
Console.WriteLine(ftd.FormatTagName);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.GetFormatTagDetails Overload List


AudioCompressionManager.GetFormatTagDetails Method (Int32, Int32)

Gets the format tag details for specified format tag and driver.

[Visual Basic]
Overloads Public Shared Function GetFormatTagDetails( _
ByVal formatTag As Integer, _
ByVal driver As Integer _
) As FormatTagDetails
[C#]
public static FormatTagDetails GetFormatTagDetails(
Int32 formatTag,
Int32 driver
);

Parameters

formatTag
The format tag.
driver
The driver.

Return Value

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.GetFormatTagDetails Overload List


GetFormatTagList Method

Alvas.Audio Class Library

AudioCompressionManager.GetFormatTagList Method

Gets the format tag list for suitable driver.

Overload List

Gets the format tag list for suitable driver.

public static FormatTagDetails[] GetFormatTagList();

Gets the format tag list for specified driver.

public static FormatTagDetails[] GetFormatTagList(Int32);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.GetFormatTagList Method ()

Gets the format tag list for suitable driver.

[Visual Basic]
Overloads Public Shared Function GetFormatTagList() As FormatTagDetails()
[C#]
public static FormatTagDetails[] GetFormatTagList();

Return Value

Example

This example shows simple using of GetFormatTagList method.

FormatTagDetails ftd = AudioCompressionManager.GetFormatTagDetails(AudioCompressionManager.PcmFormatTag);
Console.WriteLine(ftd.FormatTagName);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.GetFormatTagList Overload List


AudioCompressionManager.GetFormatTagList Method (Int32)

Gets the format tag list for specified driver.

[Visual Basic]
Overloads Public Shared Function GetFormatTagList( _
ByVal driver As Integer _
) As FormatTagDetails()
[C#]
public static FormatTagDetails[] GetFormatTagList(
Int32 driver
);

Parameters

driver
The driver.

Return Value

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.GetFormatTagList Overload List


AudioCompressionManager.GetMp3Format Method

Creates audio format for MPEG Layer3 audio data

[Visual Basic]
Public Shared Function GetMp3Format( _
ByVal channels As Short, _
ByVal kbps As Short, _
ByVal samplesPerSec As Integer _
) As IntPtr
[C#]
public static IntPtr GetMp3Format(
Int16 channels,
Int16 kbps,
Int32 samplesPerSec
);

Parameters

channels
channels number (1 - mono, 2 - stereo)
kbps
kbits per second (56, for example)
samplesPerSec
samples per second (11025, for example)

Return Value

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.GetPcmFormat Method

Creates audio format for PCM data

[Visual Basic]
Public Shared Function GetPcmFormat( _
ByVal channels As Short, _
ByVal bitsPerSample As Short, _
ByVal samplesPerSec As Integer _
) As IntPtr
[C#]
public static IntPtr GetPcmFormat(
Int16 channels,
Int16 bitsPerSample,
Int32 samplesPerSec
);

Parameters

channels
channels number (1 - mono, 2 - stereo)
bitsPerSample
bits per sample (8 or 16)
samplesPerSec
samples per second (6000, for example)

Return Value

Returns pointer to PCM format

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.GetWaveFormat Method

Gets the WaveFormat for specified format handle.

[Visual Basic]
Public Shared Function GetWaveFormat( _
ByVal format As IntPtr _
) As WaveFormat
[C#]
public static WaveFormat GetWaveFormat(
IntPtr format
);

Parameters

format
The format handle.

Return Value

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


Insert Method

Alvas.Audio Class Library

AudioCompressionManager.Insert Method

Insert audio data to stream.

Overload List

Insert audio data to stream.

public static void Insert(Stream,Stream,Int32,Byte[]);

Insert audio data to file.

public static void Insert(String,String,Int32,Byte[]);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.Insert Method (Stream, Stream, Int32, Byte[])

Insert audio data to stream.

[Visual Basic]
Overloads Public Shared Sub Insert( _
ByVal inStream As Stream, _
ByVal outStream As Stream, _
ByVal fromSeconds As Integer, _
ByVal insertData As Byte() _
)
[C#]
public static void Insert(
Stream inStream,
Stream outStream,
Int32 fromSeconds,
Byte[] insertData
);

Parameters

inStream
input stream
outStream
output stream
fromSeconds
start position(in seconds)
insertData
audio data

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Insert Overload List


AudioCompressionManager.Insert Method (String, String, Int32, Byte[])

Insert audio data to file.

[Visual Basic]
Overloads Public Shared Sub Insert( _
ByVal inFile As String, _
ByVal outFile As String, _
ByVal fromSeconds As Integer, _
ByVal insertData As Byte() _
)
[C#]
public static void Insert(
String inFile,
String outFile,
Int32 fromSeconds,
Byte[] insertData
);

Parameters

inFile
input file
outFile
output file
fromSeconds
start position(in seconds)
insertData
audio data

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Insert Overload List


AudioCompressionManager.Inverse Method

Inverts the audio signal to 180 degrees. All positive values in the wave form are replaced by negative and vice versa.

[Visual Basic]
Public Shared Function Inverse( _
ByVal format As IntPtr, _
ByVal data As Byte() _
) As Byte()
[C#]
public static byte[] Inverse(
IntPtr format,
Byte[] data
);

Parameters

format
audio format
data
audio data

Return Value

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


Join Method

Alvas.Audio Class Library

AudioCompressionManager.Join Method

Join multiple audio streams into one. The audio data formats must be the same.

Overload List

Join multiple audio streams into one. The audio data formats must be the same.

public static void Join(Stream,params Stream[]);

Join multiple audio files into one. The audio data formats must be the same.

public static void Join(String,params String[]);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.Join Method (Stream, Stream[])

Join multiple audio streams into one. The audio data formats must be the same.

[Visual Basic]
Overloads Public Shared Sub Join( _
ByVal outStream As Stream, _
ParamArray inStreams As Stream() _
)
[C#]
public static void Join(
Stream outStream,
params Stream[] inStreams
);

Parameters

outStream
output stream
inStreams
input stream list

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Join Overload List


AudioCompressionManager.Join Method (String, String[])

Join multiple audio files into one. The audio data formats must be the same.

[Visual Basic]
Overloads Public Shared Sub Join( _
ByVal outFile As String, _
ParamArray inFiles As String() _
)
[C#]
public static void Join(
String outFile,
params String[] inFiles
);

Parameters

outFile
output file
inFiles
input file list

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Join Overload List


AudioCompressionManager.MaxVolume Method

Gets max volume for specified audio format and data

[Visual Basic]
Public Shared Function MaxVolume( _
ByVal format As IntPtr, _
ByVal data As Byte() _
) As Short
[C#]
public static short MaxVolume(
IntPtr format,
Byte[] data
);

Parameters

format
audio format
data
audio data

Return Value

Returns max volume for specified audio format and data

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


MergeStereo Method

Alvas.Audio Class Library

AudioCompressionManager.MergeStereo Method

Overload List

public static void MergeStereo(IntPtr,Byte[],Byte[],ref IntPtr&,ref Byte[]&);

Merges 2 mono WAVE streams into one stereo.

public static void MergeStereo(Stream,Stream,Stream);

Merges 2 mono WAVE files into one stereo.

public static void MergeStereo(String,String,String);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.MergeStereo Method (IntPtr, Byte[], Byte[], IntPtr, Byte[])

[Visual Basic]
Overloads Public Shared Sub MergeStereo( _
ByVal formatMono As IntPtr, _
ByVal leftData As Byte(), _
ByVal rightData As Byte(), _
ByRef formatStereo As IntPtr, _
ByRef dataStereo As Byte() _
)
[C#]
public static void MergeStereo(
IntPtr formatMono,
Byte[] leftData,
Byte[] rightData,
ref IntPtr& formatStereo,
ref Byte[]& dataStereo
);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.MergeStereo Overload List


AudioCompressionManager.MergeStereo Method (Stream, Stream, Stream)

Merges 2 mono WAVE streams into one stereo.

[Visual Basic]
Overloads Public Shared Sub MergeStereo( _
ByVal leftStream As Stream, _
ByVal rightStream As Stream, _
ByVal stereoStream As Stream _
)
[C#]
public static void MergeStereo(
Stream leftStream,
Stream rightStream,
Stream stereoStream
);

Parameters

leftStream
stream for left channel
rightStream
stream for right channel
stereoStream
result stereo stream

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.MergeStereo Overload List


AudioCompressionManager.MergeStereo Method (String, String, String)

Merges 2 mono WAVE files into one stereo.

[Visual Basic]
Overloads Public Shared Sub MergeStereo( _
ByVal leftFile As String, _
ByVal rightFile As String, _
ByVal stereoFile As String _
)
[C#]
public static void MergeStereo(
String leftFile,
String rightFile,
String stereoFile
);

Parameters

leftFile
file name for left channel
rightFile
file name for right channel
stereoFile
file name for result stereo file

Example

This example shows simple using of MergeStereo method.

AudioCompressionManager.MergeStereo(@"Left.wav", @"Right.wav", @"res.wav");

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.MergeStereo Overload List


AudioCompressionManager.Milliseconds2Bytes Method

Returns bytes number for specified format and time, expressed in milliseconds

[Visual Basic]
Public Shared Function Milliseconds2Bytes( _
ByVal format As IntPtr, _
ByVal milliseconds As Integer _
) As Integer
[C#]
public static int Milliseconds2Bytes(
IntPtr format,
Int32 milliseconds
);

Parameters

format
audio format
milliseconds
time, expressed in milliseconds

Return Value

bytes number

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


Mix Method

Alvas.Audio Class Library

AudioCompressionManager.Mix Method

Mixes the audio data.

Overload List

Mixes the audio data.

public static byte[] Mix(IntPtr,params Byte[][]);

Mix several audio streams. The audio data formats must be the same.

public static void Mix(Stream,params Stream[]);

Mix several audio files. The audio data formats must be the same.

public static void Mix(String,params String[]);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.Mix Method (IntPtr, Byte[][])

Mixes the audio data.

[Visual Basic]
Overloads Public Shared Function Mix( _
ByVal format As IntPtr, _
ParamArray data As Byte()[) _
) As Byte()
[C#]
public static byte[] Mix(
IntPtr format,
params Byte[][] data
);

Parameters

format
audio format
data
audio data array

Return Value

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Mix Overload List


AudioCompressionManager.Mix Method (Stream, Stream[])

Mix several audio streams. The audio data formats must be the same.

[Visual Basic]
Overloads Public Shared Sub Mix( _
ByVal outStream As Stream, _
ParamArray inStreams As Stream() _
)
[C#]
public static void Mix(
Stream outStream,
params Stream[] inStreams
);

Parameters

outStream
output stream
inStreams
input stream list

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Mix Overload List


AudioCompressionManager.Mix Method (String, String[])

Mix several audio files. The audio data formats must be the same.

[Visual Basic]
Overloads Public Shared Sub Mix( _
ByVal outFile As String, _
ParamArray inFiles As String() _
)
[C#]
public static void Mix(
String outFile,
params String[] inFiles
);

Parameters

outFile
output file
inFiles
input file list

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Mix Overload List


AudioCompressionManager.MixMany Method

Inserts and mixes one piece of audio data into main audio data with specified offset multiple times.

[Visual Basic]
Public Shared Function MixMany( _
ByVal format As IntPtr, _
ByVal data As Byte(), _
ByVal dataPiece As Byte(), _
ParamArray offsetSamples As Integer() _
) As Byte()
[C#]
public static byte[] MixMany(
IntPtr format,
Byte[] data,
Byte[] dataPiece,
params Int32[] offsetSamples
);

Parameters

format
audio format
data
main audio data
dataPiece
offsetSamples
offset list in samples

Return Value

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.Mp3ToWav Method

Converts Mp3 file to Wav file with PCM (Pulse-code modulation) data

[Visual Basic]
Public Shared Sub Mp3ToWav( _
ByVal fileMp3 As String, _
ByVal fileWave As String _
)
[C#]
public static void Mp3ToWav(
String fileMp3,
String fileWave
);

Parameters

fileMp3
input Mp3 file
fileWave
output Wave file

Example

This example shows simple using of Mp3ToWav method.

AudioCompressionManager.Mp3ToWav("in.mp3", "out.wav");

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


Normalize Method

Alvas.Audio Class Library

AudioCompressionManager.Normalize Method

Normalize method raises the volume so that the highest sample level reaches a maximum level.

Overload List

Normalize method raises the volume so that the highest sample level reaches a maximum level.

public static void Normalize(IAudioReader,IAudioWriter);

Normalize method raises the volume so that the highest sample level reaches a maximum level.

public static byte[] Normalize(IntPtr,Byte[]);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.Normalize Method (IAudioReader, IAudioWriter)

Normalize method raises the volume so that the highest sample level reaches a maximum level.

[Visual Basic]
Overloads Public Shared Sub Normalize( _
ByVal ar As IAudioReader, _
ByVal aw As IAudioWriter _
)
[C#]
public static void Normalize(
IAudioReader ar,
IAudioWriter aw
);

Parameters

ar
aw

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Normalize Overload List


AudioCompressionManager.Normalize Method (IntPtr, Byte[])

Normalize method raises the volume so that the highest sample level reaches a maximum level.

[Visual Basic]
Overloads Public Shared Function Normalize( _
ByVal format As IntPtr, _
ByVal data As Byte() _
) As Byte()
[C#]
public static byte[] Normalize(
IntPtr format,
Byte[] data
);

Parameters

format
audio format
data
audio data

Return Value

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Normalize Overload List


AudioCompressionManager.RecalculateData Method

Recalculates audio data array to the specified length. (For SoundLevelMeter)

[Visual Basic]
Public Shared Function RecalculateData( _
ByVal format As IntPtr, _
ByVal data As Byte(), _
ByVal length As Integer _
) As Short()
[C#]
public static short[] RecalculateData(
IntPtr format,
Byte[] data,
Int32 length
);

Parameters

format
Audio format
data
Audio data array
length
New length of audio data array

Return Value

New audio data array

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


Remove Method

Alvas.Audio Class Library

AudioCompressionManager.Remove Method

Remove part audio data from stream.

Overload List

Remove part audio data from stream.

public static void Remove(Stream,Stream,Int32,Int32);

Remove part audio data from file.

public static void Remove(String,String,Int32,Int32);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.Remove Method (Stream, Stream, Int32, Int32)

Remove part audio data from stream.

[Visual Basic]
Overloads Public Shared Sub Remove( _
ByVal inStream As Stream, _
ByVal outStream As Stream, _
ByVal fromSeconds As Integer, _
ByVal duration As Integer _
)
[C#]
public static void Remove(
Stream inStream,
Stream outStream,
Int32 fromSeconds,
Int32 duration
);

Parameters

inStream
input stream
outStream
output stream
fromSeconds
start position(in seconds)
duration
duration (in seconds)

Example

This example shows simple using of Remove method.

string inFile = "in.wav";
string outFile = "out.wav";
int fromSeconds = 0;
int duration = 1;
AudioCompressionManager.Remove(File.OpenRead(inFile), File.Create(outFile), fromSeconds, duration);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Remove Overload List


AudioCompressionManager.Remove Method (String, String, Int32, Int32)

Remove part audio data from file.

[Visual Basic]
Overloads Public Shared Sub Remove( _
ByVal inFile As String, _
ByVal outFile As String, _
ByVal fromSeconds As Integer, _
ByVal duration As Integer _
)
[C#]
public static void Remove(
String inFile,
String outFile,
Int32 fromSeconds,
Int32 duration
);

Parameters

inFile
input file
outFile
output file
fromSeconds
start position(in seconds)
duration
duration (in seconds)

Example

This example shows simple using of Remove method.

string inFile = "in.wav";
string outFile = "out.wav";
int fromSeconds = 0;
int duration = 1;
AudioCompressionManager.Remove(inFile, outFile, fromSeconds, duration);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Remove Overload List


RemoveDcOffset Method

Alvas.Audio Class Library

AudioCompressionManager.RemoveDcOffset Method

Removes DC offset. DC offset is an offsetting of a signal from zero. Occurs when hardware, such as a sound card, adds DC offset to a recorded audio signal.

Overload List

Removes DC offset. DC offset is an offsetting of a signal from zero. Occurs when hardware, such as a sound card, adds DC offset to a recorded audio signal.

public static byte[] RemoveDcOffset(IntPtr,Byte[]);

Removes DC offset. DC offset is an offsetting of a signal from zero. Occurs when hardware, such as a sound card, adds DC offset to a recorded audio signal.

public static byte[] RemoveDcOffset(IntPtr,Byte[],Int16);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.RemoveDcOffset Method (IntPtr, Byte[])

Removes DC offset. DC offset is an offsetting of a signal from zero. Occurs when hardware, such as a sound card, adds DC offset to a recorded audio signal.

[Visual Basic]
Overloads Public Shared Function RemoveDcOffset( _
ByVal format As IntPtr, _
ByVal data As Byte() _
) As Byte()
[C#]
public static byte[] RemoveDcOffset(
IntPtr format,
Byte[] data
);

Parameters

format
audio format
data
audio data

Return Value

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.RemoveDcOffset Overload List


AudioCompressionManager.RemoveDcOffset Method (IntPtr, Byte[], Int16)

Removes DC offset. DC offset is an offsetting of a signal from zero. Occurs when hardware, such as a sound card, adds DC offset to a recorded audio signal.

[Visual Basic]
Overloads Public Shared Function RemoveDcOffset( _
ByVal format As IntPtr, _
ByVal data As Byte(), _
ByVal offset As Short _
) As Byte()
[C#]
public static byte[] RemoveDcOffset(
IntPtr format,
Byte[] data,
Int16 offset
);

Parameters

format
audio format
data
audio data
offset
If the value is 0, the DC offset will be calculated automatically; otherwise, the specified value is used.

Return Value

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.RemoveDcOffset Overload List


Resample Method

Alvas.Audio Class Library

AudioCompressionManager.Resample Method

Performs resampling audio data from and to 8/16/24/32-bit integer PCM and 32-bit IEEE Float audio formats.

Overload List

Performs resampling audio data from and to 8/16/24/32-bit integer PCM and 32-bit IEEE Float audio formats.

public static void Resample(IAudioReader,WaveWriter);

Performs resampling audio data from and to 8/16/24/32-bit integer PCM and 32-bit IEEE Float audio formats.

public static byte[] Resample(IAudioReader,IntPtr);

Performs resampling audio data from and to 8/16/24/32-bit integer PCM and 32-bit IEEE Float audio formats.

public static byte[] Resample(IntPtr,Byte[],IntPtr);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.Resample Method (IAudioReader, WaveWriter)

Performs resampling audio data from and to 8/16/24/32-bit integer PCM and 32-bit IEEE Float audio formats.

[Visual Basic]
Overloads Public Shared Sub Resample( _
ByVal ar As IAudioReader, _
ByVal ww As WaveWriter _
)
[C#]
public static void Resample(
IAudioReader ar,
WaveWriter ww
);

Parameters

ar
ww

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Resample Overload List


AudioCompressionManager.Resample Method (IAudioReader, IntPtr)

Performs resampling audio data from and to 8/16/24/32-bit integer PCM and 32-bit IEEE Float audio formats.

[Visual Basic]
Overloads Public Shared Function Resample( _
ByVal ar As IAudioReader, _
ByVal format As IntPtr _
) As Byte()
[C#]
public static byte[] Resample(
IAudioReader ar,
IntPtr format
);

Parameters

ar
format

Return Value

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Resample Overload List


AudioCompressionManager.Resample Method (IntPtr, Byte[], IntPtr)

Performs resampling audio data from and to 8/16/24/32-bit integer PCM and 32-bit IEEE Float audio formats.

[Visual Basic]
Overloads Public Shared Function Resample( _
ByVal inFormat As IntPtr, _
ByVal data As Byte(), _
ByVal outFormat As IntPtr _
) As Byte()
[C#]
public static byte[] Resample(
IntPtr inFormat,
Byte[] data,
IntPtr outFormat
);

Parameters

inFormat
input audio format
data
input audio data
outFormat
output audio format

Return Value

output audio data

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Resample Overload List


Reverse Method

Alvas.Audio Class Library

AudioCompressionManager.Reverse Method

Reverses Wave audio data.

Overload List

Reverses Wave audio data.

public static byte[] Reverse(IntPtr,Byte[]);

Reverses Wave audio data from one stream to another.

public static void Reverse(Stream,Stream);

Reverses Wave audio data from one file to another.

public static void Reverse(String,String);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.Reverse Method (IntPtr, Byte[])

Reverses Wave audio data.

[Visual Basic]
Overloads Public Shared Function Reverse( _
ByVal format As IntPtr, _
ByVal data As Byte() _
) As Byte()
[C#]
public static byte[] Reverse(
IntPtr format,
Byte[] data
);

Parameters

format
audio format
data
audio data

Return Value

Example

This example shows simple using of Reverse method.

string inFile = "test2.wav";
string outFile = "ReverseTest3.wav";

WaveReader wr = new WaveReader(File.OpenRead(inFile));
IntPtr format = wr.ReadFormat();
byte[] data = wr.ReadData();
wr.Close();
WaveWriter ww = new WaveWriter(File.Create(outFile), AudioCompressionManager.FormatBytes(format));
ww.WriteData(AudioCompressionManager.Reverse(format, data));
ww.Close();

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Reverse Overload List


AudioCompressionManager.Reverse Method (Stream, Stream)

Reverses Wave audio data from one stream to another.

[Visual Basic]
Overloads Public Shared Sub Reverse( _
ByVal inStream As Stream, _
ByVal outStream As Stream _
)
[C#]
public static void Reverse(
Stream inStream,
Stream outStream
);

Parameters

inStream
input Wave stream
outStream
output Wave stream

Example

This example shows simple using of Reverse method.

string inFile = "test2.wav";
string outFile = "ReverseTest3.wav";

AudioCompressionManager.Reverse(File.OpenRead(inFile), File.Create(outFile));

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Reverse Overload List


AudioCompressionManager.Reverse Method (String, String)

Reverses Wave audio data from one file to another.

[Visual Basic]
Overloads Public Shared Sub Reverse( _
ByVal inFile As String, _
ByVal outFile As String _
)
[C#]
public static void Reverse(
String inFile,
String outFile
);

Parameters

inFile
input Wave file
outFile
output Wave file

Example

This example shows simple using of Reverse method.

string inFile = "test2.wav";
string outFile = "ReverseTest3.wav";

AudioCompressionManager.Reverse(inFile, outFile);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Reverse Overload List


AudioCompressionManager.Silence Method

Creates silence

[Visual Basic]
Public Shared Function Silence( _
ByVal format As IntPtr, _
ByVal milliseconds As Integer _
) As Byte()
[C#]
public static byte[] Silence(
IntPtr format,
Int32 milliseconds
);

Parameters

format
audio format
milliseconds
silence in milliseconds

Return Value

audio data with silence

Example

This example shows simple using of Silence method.

FormatDetails[] formatList = AudioCompressionManager.GetFormatList(AudioCompressionManager.Gsm610FormatTag);
IntPtr format = formatList[formatList.Length - 1].FormatHandle;
WaveWriter ww = new WaveWriter(File.Create("file.wav"), AudioCompressionManager.FormatBytes(format));
byte[] data = AudioCompressionManager.Silence(format, 10000);
ww.WriteData(data);
ww.Close();

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


SplitStereo Method

Alvas.Audio Class Library

AudioCompressionManager.SplitStereo Method

Overload List

public static void SplitStereo(IntPtr,Byte[],ref IntPtr&,ref Byte[]&,ref Byte[]&);

Splits one stereo stream into two mono streams (left and right channels).

public static void SplitStereo(Stream,Stream,Stream);

Splits one stereo file into two mono files (left and right channels).

public static void SplitStereo(String,String,String);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.SplitStereo Method (IntPtr, Byte[], IntPtr, Byte[], Byte[])

[Visual Basic]
Overloads Public Shared Sub SplitStereo( _
ByVal formatStereo As IntPtr, _
ByVal dataStereo As Byte(), _
ByRef formatMono As IntPtr, _
ByRef leftData As Byte(), _
ByRef rightData As Byte() _
)
[C#]
public static void SplitStereo(
IntPtr formatStereo,
Byte[] dataStereo,
ref IntPtr& formatMono,
ref Byte[]& leftData,
ref Byte[]& rightData
);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.SplitStereo Overload List


AudioCompressionManager.SplitStereo Method (Stream, Stream, Stream)

Splits one stereo stream into two mono streams (left and right channels).

[Visual Basic]
Overloads Public Shared Sub SplitStereo( _
ByVal stereoStream As Stream, _
ByVal leftStream As Stream, _
ByVal rightStream As Stream _
)
[C#]
public static void SplitStereo(
Stream stereoStream,
Stream leftStream,
Stream rightStream
);

Parameters

stereoStream
input stereo Wave stream
leftStream
output mono Wave stream for left channel
rightStream
output mono Wave stream for right channel

Example

This example shows simple using of SplitStereo method.

string inFile = "stereo.wav";
string leftFile = "left.wav";
string rightFile = "right.wav";
AudioCompressionManager.SplitStereo(File.OpenRead(inFile),
    File.Create(leftFile), File.Create(rightFile));

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.SplitStereo Overload List


AudioCompressionManager.SplitStereo Method (String, String, String)

Splits one stereo file into two mono files (left and right channels).

[Visual Basic]
Overloads Public Shared Sub SplitStereo( _
ByVal stereoFile As String, _
ByVal leftFile As String, _
ByVal rightFile As String _
)
[C#]
public static void SplitStereo(
String stereoFile,
String leftFile,
String rightFile
);

Parameters

stereoFile
input stereo Wave file
leftFile
output mono Wave file for left channel
rightFile
output mono Wave file for right channel

Example

This example shows simple using of SplitStereo method.

string inFile = "stereo.wav";
string leftFile = "left.wav";
string rightFile = "right.wav";
AudioCompressionManager.SplitStereo(inFile, leftFile, rightFile);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.SplitStereo Overload List


SwapStereo Method

Alvas.Audio Class Library

AudioCompressionManager.SwapStereo Method

Swaps stereo channels.

Overload List

Swaps stereo channels.

public static void SwapStereo(IAudioReader,WaveWriter);

Swaps stereo channels.

public static byte[] SwapStereo(IntPtr,Byte[]);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.SwapStereo Method (IAudioReader, WaveWriter)

Swaps stereo channels.

[Visual Basic]
Overloads Public Shared Sub SwapStereo( _
ByVal ar As IAudioReader, _
ByVal ww As WaveWriter _
)
[C#]
public static void SwapStereo(
IAudioReader ar,
WaveWriter ww
);

Parameters

ar
ww

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.SwapStereo Overload List


AudioCompressionManager.SwapStereo Method (IntPtr, Byte[])

Swaps stereo channels.

[Visual Basic]
Overloads Public Shared Function SwapStereo( _
ByVal format As IntPtr, _
ByVal data As Byte() _
) As Byte()
[C#]
public static byte[] SwapStereo(
IntPtr format,
Byte[] data
);

Parameters

format
audio format
data
audio data

Return Value

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.SwapStereo Overload List


ToFormat Method

Alvas.Audio Class Library

AudioCompressionManager.ToFormat Method

Converts audio data to the specified audio format.

Overload List

Converts audio data to the specified audio format.

public static byte[] ToFormat(IAudioReader,IntPtr);

Converts audio data to the specified audio format.

public static byte[] ToFormat(IntPtr,Byte[],IntPtr);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.ToFormat Method (IAudioReader, IntPtr)

Converts audio data to the specified audio format.

[Visual Basic]
Overloads Public Shared Function ToFormat( _
ByVal ar As IAudioReader, _
ByVal formatNew As IntPtr _
) As Byte()
[C#]
public static byte[] ToFormat(
IAudioReader ar,
IntPtr formatNew
);

Parameters

ar
formatNew

Return Value

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.ToFormat Overload List


AudioCompressionManager.ToFormat Method (IntPtr, Byte[], IntPtr)

Converts audio data to the specified audio format.

[Visual Basic]
Overloads Public Shared Function ToFormat( _
ByVal format As IntPtr, _
ByVal data As Byte(), _
ByVal formatNew As IntPtr _
) As Byte()
[C#]
public static byte[] ToFormat(
IntPtr format,
Byte[] data,
IntPtr formatNew
);

Parameters

format
old audio format
data
audio data
formatNew
new audio format

Return Value

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.ToFormat Overload List


AudioCompressionManager.ToPcm Method

[Visual Basic]
Public Shared Sub ToPcm( _
ByVal format As IntPtr, _
ByVal data As Byte(), _
ByRef formatPcm As IntPtr, _
ByRef dataPcm As Byte() _
)
[C#]
public static void ToPcm(
IntPtr format,
Byte[] data,
ref IntPtr& formatPcm,
ref Byte[]& dataPcm
);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.ToPcm16Bit Method

[Visual Basic]
Public Shared Sub ToPcm16Bit( _
ByVal format As IntPtr, _
ByVal data As Byte(), _
ByRef formatPcm16Bit As IntPtr, _
ByRef dataPcm16Bit As Byte() _
)
[C#]
public static void ToPcm16Bit(
IntPtr format,
Byte[] data,
ref IntPtr& formatPcm16Bit,
ref Byte[]& dataPcm16Bit
);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


Wave2Mp3 Method

Alvas.Audio Class Library

AudioCompressionManager.Wave2Mp3 Method

Converts Wave audio data to Mp3 audio data.

Overload List

Converts Wave audio data to Mp3 audio data.

public static byte[] Wave2Mp3(IntPtr,Byte[]);

Converts Wave stream to Mp3 stream.

public static void Wave2Mp3(Stream,Stream);

Converts Wave file to Mp3 file.

public static void Wave2Mp3(String,String);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace


AudioCompressionManager.Wave2Mp3 Method (IntPtr, Byte[])

Converts Wave audio data to Mp3 audio data.

[Visual Basic]
Overloads Public Shared Function Wave2Mp3( _
ByVal format As IntPtr, _
ByVal data As Byte() _
) As Byte()
[C#]
public static byte[] Wave2Mp3(
IntPtr format,
Byte[] data
);

Parameters

format
audio format
data
audio data

Return Value

Example

This example shows simple using of Wave2Mp3 method.

string inFile = "test2.wav";
string outFile = @"test2.mp3";

WaveReader wr = new WaveReader(File.OpenRead(inFile));
IntPtr format = wr.ReadFormat();
byte[] data = wr.ReadData();
wr.Close();
byte[] dataMp3 = AudioCompressionManager.Wave2Mp3(format, data);
Mp3Writer mw = new Mp3Writer(File.Create(outFile));
mw.WriteData(dataMp3);
mw.Close();

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Wave2Mp3 Overload List


AudioCompressionManager.Wave2Mp3 Method (Stream, Stream)

Converts Wave stream to Mp3 stream.

[Visual Basic]
Overloads Public Shared Sub Wave2Mp3( _
ByVal waveStream As Stream, _
ByVal mp3Stream As Stream _
)
[C#]
public static void Wave2Mp3(
Stream waveStream,
Stream mp3Stream
);

Parameters

waveStream
input Wave stream
mp3Stream
output Mp3 stream

Example

This example shows simple using of Wave2Mp3 method.

string inFile = "test2.wav";
string outFile = @"test2.mp3";

AudioCompressionManager.Wave2Mp3(File.OpenRead(inFile), File.Create(outFile));

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Wave2Mp3 Overload List


AudioCompressionManager.Wave2Mp3 Method (String, String)

Converts Wave file to Mp3 file.

[Visual Basic]
Overloads Public Shared Sub Wave2Mp3( _
ByVal waveFile As String, _
ByVal mp3File As String _
)
[C#]
public static void Wave2Mp3(
String waveFile,
String mp3File
);

Parameters

waveFile
input Wave file
mp3File
output Mp3 file

Example

This example shows simple using of Wave2Mp3 method.

string inFile = "test2.wav";
string outFile = @"test2.mp3";

AudioCompressionManager.Wave2Mp3(inFile, outFile);

See Also

AudioCompressionManager Class | Alvas.Audio Namespace | AudioCompressionManager.Wave2Mp3 Overload List


AudioEffect Class

Base class for audio effects

For a list of all members of this type, see AudioEffect Members.

System.Object
AudioEffect
Derived types

[Visual Basic]
Public Class AudioEffect
[C#]
public class AudioEffect

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

AudioEffect Members | Alvas.Audio Namespace


AudioEffect Members

AudioEffect overview

Public Static (Shared) Methods

CreateChorusAudioEffect | Creates Chorus audio effect
CreateCompressorAudioEffect | Creates Compressor audio effect
CreateDistortionAudioEffect | Creates Distortion audio effect
CreateEchoAudioEffect | Creates Echo audio effect
CreateFlangerAudioEffect | Creates Flanger audio effect
CreateGargleAudioEffect | Creates Gargle audio effect
CreateI3DL2ReverbAudioEffect | Creates I3DL2Reverb audio effect
CreateParamEqAudioEffect | Creates ParamEq audio effect
CreateWavesReverbAudioEffect | Creates WavesReverb audio effect

Public Instance Properties

HasProcessInPlace Checks can whether process in place

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessInPlace | Process in place audio data and put the resulting audio data into data array
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AudioEffect Class | Alvas.Audio Namespace


AudioEffect Properties

The properties of the AudioEffect class are listed below. For a complete list of AudioEffect class members, see the AudioEffect Members topic.

Public Instance Properties

HasProcessInPlace Checks can whether process in place

See Also

AudioEffect Class | Alvas.Audio Namespace


HasProcessInPlace Property

Alvas.Audio Class Library

AudioEffect.HasProcessInPlace Property

Checks can whether process in place

[Visual Basic]
Public ReadOnly Property HasProcessInPlace As Boolean
[C#]
public Boolean HasProcessInPlace {get;}

See Also

AudioEffect Class | Alvas.Audio Namespace


AudioEffect Methods

The methods of the AudioEffect class are listed below. For a complete list of AudioEffect class members, see the AudioEffect Members topic.

Public Static (Shared) Methods

CreateChorusAudioEffect | Creates Chorus audio effect
CreateCompressorAudioEffect | Creates Compressor audio effect
CreateDistortionAudioEffect | Creates Distortion audio effect
CreateEchoAudioEffect | Creates Echo audio effect
CreateFlangerAudioEffect | Creates Flanger audio effect
CreateGargleAudioEffect | Creates Gargle audio effect
CreateI3DL2ReverbAudioEffect | Creates I3DL2Reverb audio effect
CreateParamEqAudioEffect | Creates ParamEq audio effect
CreateWavesReverbAudioEffect | Creates WavesReverb audio effect

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessInPlace | Process in place audio data and put the resulting audio data into data array
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AudioEffect Class | Alvas.Audio Namespace


AudioEffect.CreateChorusAudioEffect Method

Creates Chorus audio effect

[Visual Basic]
Public Shared Function CreateChorusAudioEffect() As ChorusAudioEffect
[C#]
public static ChorusAudioEffect CreateChorusAudioEffect();

Return Value

See Also

AudioEffect Class | Alvas.Audio Namespace


AudioEffect.CreateCompressorAudioEffect Method

Creates Compressor audio effect

[Visual Basic]
Public Shared Function CreateCompressorAudioEffect() As CompressorAudioEffect
[C#]
public static CompressorAudioEffect CreateCompressorAudioEffect();

Return Value

See Also

AudioEffect Class | Alvas.Audio Namespace


AudioEffect.CreateDistortionAudioEffect Method

Creates Distortion audio effect

[Visual Basic]
Public Shared Function CreateDistortionAudioEffect() As DistortionAudioEffect
[C#]
public static DistortionAudioEffect CreateDistortionAudioEffect();

Return Value

See Also

AudioEffect Class | Alvas.Audio Namespace


AudioEffect.CreateEchoAudioEffect Method

Creates Echo audio effect

[Visual Basic]
Public Shared Function CreateEchoAudioEffect() As EchoAudioEffect
[C#]
public static EchoAudioEffect CreateEchoAudioEffect();

Return Value

See Also

AudioEffect Class | Alvas.Audio Namespace


AudioEffect.CreateFlangerAudioEffect Method

Creates Flanger audio effect

[Visual Basic]
Public Shared Function CreateFlangerAudioEffect() As FlangerAudioEffect
[C#]
public static FlangerAudioEffect CreateFlangerAudioEffect();

Return Value

See Also

AudioEffect Class | Alvas.Audio Namespace


AudioEffect.CreateGargleAudioEffect Method

Creates Gargle audio effect

[Visual Basic]
Public Shared Function CreateGargleAudioEffect() As GargleAudioEffect
[C#]
public static GargleAudioEffect CreateGargleAudioEffect();

Return Value

See Also

AudioEffect Class | Alvas.Audio Namespace


AudioEffect.CreateI3DL2ReverbAudioEffect Method

Creates I3DL2Reverb audio effect

[Visual Basic]
Public Shared Function CreateI3DL2ReverbAudioEffect() As I3DL2ReverbAudioEffect
[C#]
public static I3DL2ReverbAudioEffect CreateI3DL2ReverbAudioEffect();

Return Value

See Also

AudioEffect Class | Alvas.Audio Namespace


AudioEffect.CreateParamEqAudioEffect Method

Creates ParamEq audio effect

[Visual Basic]
Public Shared Function CreateParamEqAudioEffect() As ParamEqAudioEffect
[C#]
public static ParamEqAudioEffect CreateParamEqAudioEffect();

Return Value

See Also

AudioEffect Class | Alvas.Audio Namespace


AudioEffect.CreateWavesReverbAudioEffect Method

Creates WavesReverb audio effect

[Visual Basic]
Public Shared Function CreateWavesReverbAudioEffect() As WavesReverbAudioEffect
[C#]
public static WavesReverbAudioEffect CreateWavesReverbAudioEffect();

Return Value

See Also

AudioEffect Class | Alvas.Audio Namespace


AudioEffect.ProcessInPlace Method

Process in place audio data and put the resulting audio data into data array

[Visual Basic]
Public Function ProcessInPlace( _
ByVal format As IntPtr, _
ByVal data As Byte() _
) As Boolean
[C#]
public bool ProcessInPlace(
IntPtr format,
Byte[] data
);

Parameters

format
input audio format
data
input audio data

Return Value

Returns true if successful

See Also

AudioEffect Class | Alvas.Audio Namespace


AudioException Class

The exception that is thrown when an audio error occurs.

For a list of all members of this type, see AudioException Members.

System.Object
Exception
AudioException
Derived types

[Visual Basic]
Public Class AudioException
Inherits
[C#]
public class AudioException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

AudioException Members | Alvas.Audio Namespace


AudioException Members

AudioException overview

Public Instance Constructors

AudioException Overloaded. Initializes a new instance of the AudioException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

See Also

AudioException Class | Alvas.Audio Namespace


AudioException Constructor

Overload List

public AudioException();

public AudioException(String);

See Also

AudioException Class | Alvas.Audio Namespace


AudioException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public AudioException(
String message
);

Parameters

message

See Also

AudioException Class | Alvas.Audio Namespace | AudioException Constructor Overload List


AudioException Constructor ()

[Visual Basic]
Overloads Public Sub New()
[C#]
public AudioException();

See Also

AudioException Class | Alvas.Audio Namespace | AudioException Constructor Overload List


AudioException Properties

The properties of the AudioException class are listed below. For a complete list of AudioException class members, see the AudioException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

AudioException Class | Alvas.Audio Namespace


Message Property

Alvas.Audio Class Library

AudioException.Message Property

[Visual Basic]
Overrides Public ReadOnly Property Message As String
[C#]
public override String Message {get;}

See Also

AudioException Class | Alvas.Audio Namespace


AudioReader Class

Represents a reader that can read an audio data from the stream. This class is abstract.

For a list of all members of this type, see AudioReader Members.

System.Object
BinaryReader
AudioReader
AuReader
AviReader
Mp3Reader
RawReader
WaveReader

[Visual Basic]
MustInherit Public Class AudioReader
Inherits
Implements IAudioReader
[C#]
public class AudioReader : BinaryReader, IAudioReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

AudioReader Members | Alvas.Audio Namespace


AudioReader Members

AudioReader overview

Public Instance Constructors

AudioReader Constructor Initializes a new instance of the AudioReader class for the specified stream.

Public Instance Properties

BaseStream (inherited from BinaryReader) Exposes access to the underlying stream of the BinaryReader.

Public Instance Methods

Close (inherited from BinaryReader) | Closes the current reader and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS | Gets audio stream duration in milliseconds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
Milliseconds2Bytes | Converts from milliseconds to bytes for current stream.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadData | Overloaded. Reads all audio data from the stream.
ReadDataInBytes | Overloaded. Reads audio data from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadFormat | Reads an audio format.
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AudioReader Class | Alvas.Audio Namespace


AudioReader Constructor

Initializes a new instance of the AudioReader class for the specified stream.

[Visual Basic]
Public Sub New( _
ByVal input As Stream _
)
[C#]
public AudioReader(
Stream input
);

Parameters

input
The stream to be read.

See Also

AudioReader Class | Alvas.Audio Namespace


AudioReader Methods

The methods of the AudioReader class are listed below. For a complete list of AudioReader class members, see the AudioReader Members topic.

Public Instance Methods

Close (inherited from BinaryReader) | Closes the current reader and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS | Gets audio stream duration in milliseconds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
Milliseconds2Bytes | Converts from milliseconds to bytes for current stream.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadData | Overloaded. Reads all audio data from the stream.
ReadDataInBytes | Overloaded. Reads audio data from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadFormat | Reads an audio format.
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AudioReader Class | Alvas.Audio Namespace


AudioReader.GetDurationInMS Method

Gets audio stream duration in milliseconds.

[Visual Basic]
MustOverride Public Function GetDurationInMS() As Integer _
Implements IAudioReader.GetDurationInMS
[C#]
public abstract int GetDurationInMS();

Return Value

Implements

IAudioReader.GetDurationInMS

See Also

AudioReader Class | Alvas.Audio Namespace


AudioReader.GetLengthInBytes Method

Gets audio stream length in bytes.

[Visual Basic]
MustOverride Public Function GetLengthInBytes() As Integer _
Implements IAudioReader.GetLengthInBytes
[C#]
public abstract int GetLengthInBytes();

Return Value

Implements

IAudioReader.GetLengthInBytes

See Also

AudioReader Class | Alvas.Audio Namespace


AudioReader.Milliseconds2Bytes Method

Converts from milliseconds to bytes for current stream.

[Visual Basic]
Overridable Public Function Milliseconds2Bytes( _
ByVal milliseconds As Integer _
) As Integer _
Implements IAudioReader.Milliseconds2Bytes
[C#]
public virtual int Milliseconds2Bytes(
Int32 milliseconds
);

Parameters

milliseconds
Time, expressed in milliseconds.

Return Value

Implements

IAudioReader.Milliseconds2Bytes

See Also

AudioReader Class | Alvas.Audio Namespace


ReadData Method

Alvas.Audio Class Library

AudioReader.ReadData Method

Reads all audio data from the stream.

Overload List

Reads all audio data from the stream.

public abstract byte[] ReadData();

Reads audio data from the stream.

public abstract byte[] ReadData(Int32);

Reads audio data from the stream.

public abstract byte[] ReadData(Int32,Int32);

See Also

AudioReader Class | Alvas.Audio Namespace


AudioReader.ReadData Method ()

Reads all audio data from the stream.

[Visual Basic]
MustOverride Overloads Public Function ReadData() As Byte() _
Implements IAudioReader.ReadData
[C#]
public abstract byte[] ReadData();

Return Value

audio data array

Implements

IAudioReader.ReadData

See Also

AudioReader Class | Alvas.Audio Namespace | AudioReader.ReadData Overload List


AudioReader.ReadData Method (Int32)

Reads audio data from the stream.

[Visual Basic]
MustOverride Overloads Public Function ReadData( _
ByVal skipSeconds As Integer _
) As Byte() _
Implements IAudioReader.ReadData
[C#]
public abstract byte[] ReadData(
Int32 skipSeconds
);

Parameters

skipSeconds
skip seconds

Return Value

Implements

IAudioReader.ReadData

See Also

AudioReader Class | Alvas.Audio Namespace | AudioReader.ReadData Overload List


AudioReader.ReadData Method (Int32, Int32)

Reads audio data from the stream.

[Visual Basic]
MustOverride Overloads Public Function ReadData( _
ByVal skipSeconds As Integer, _
ByVal readSeconds As Integer _
) As Byte() _
Implements IAudioReader.ReadData
[C#]
public abstract byte[] ReadData(
Int32 skipSeconds,
Int32 readSeconds
);

Parameters

skipSeconds
skip seconds
readSeconds
read seconds

Return Value

Implements

IAudioReader.ReadData

See Also

AudioReader Class | Alvas.Audio Namespace | AudioReader.ReadData Overload List


ReadDataInBytes Method

Alvas.Audio Class Library

AudioReader.ReadDataInBytes Method

Reads audio data from the stream.

Overload List

Reads audio data from the stream.

public abstract byte[] ReadDataInBytes(Int32);

Reads audio data from the stream.

public abstract byte[] ReadDataInBytes(Int32,Int32);

See Also

AudioReader Class | Alvas.Audio Namespace


AudioReader.ReadDataInBytes Method (Int32)

Reads audio data from the stream.

[Visual Basic]
MustOverride Overloads Public Function ReadDataInBytes( _
ByVal skipBytes As Integer _
) As Byte() _
Implements IAudioReader.ReadDataInBytes
[C#]
public abstract byte[] ReadDataInBytes(
Int32 skipBytes
);

Parameters

skipBytes
Skips length of bytes. Use Milliseconds2Bytes for this parameter.

Return Value

Implements

IAudioReader.ReadDataInBytes

See Also

AudioReader Class | Alvas.Audio Namespace | AudioReader.ReadDataInBytes Overload List


AudioReader.ReadDataInBytes Method (Int32, Int32)

Reads audio data from the stream.

[Visual Basic]
MustOverride Overloads Public Function ReadDataInBytes( _
ByVal skipBytes As Integer, _
ByVal readBytes As Integer _
) As Byte() _
Implements IAudioReader.ReadDataInBytes
[C#]
public abstract byte[] ReadDataInBytes(
Int32 skipBytes,
Int32 readBytes
);

Parameters

skipBytes
Skips length of bytes. Use Milliseconds2Bytes for this parameter.
readBytes
Reads length of bytes. Use Milliseconds2Bytes for this parameter.

Return Value

Implements

IAudioReader.ReadDataInBytes

See Also

AudioReader Class | Alvas.Audio Namespace | AudioReader.ReadDataInBytes Overload List


AudioReader.ReadFormat Method

Reads an audio format.

[Visual Basic]
MustOverride Public Function ReadFormat() As IntPtr _
Implements IAudioReader.ReadFormat
[C#]
public abstract IntPtr ReadFormat();

Return Value

Implements

IAudioReader.ReadFormat

See Also

AudioReader Class | Alvas.Audio Namespace


AudioWriter Class

Represents a writer that can write an audio data to the stream. This class is abstract.

For a list of all members of this type, see AudioWriter Members.

System.Object
BinaryWriter
AudioWriter
Mp3Writer
RawWriter
WaveWriter

[Visual Basic]
MustInherit Public Class AudioWriter
Inherits
Implements IAudioWriter
[C#]
public class AudioWriter : BinaryWriter, IAudioWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

AudioWriter Members | Alvas.Audio Namespace


AudioWriter Members

AudioWriter overview

Public Instance Constructors

AudioWriter Constructor Initializes a new instance of the AudioWriter class based on the supplied stream.

Public Instance Properties

BaseStream (inherited from BinaryWriter) Gets the underlying stream of the BinaryWriter.

Public Instance Methods

Close (inherited from BinaryWriter) | Closes the current BinaryWriter and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from BinaryWriter) | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Seek (inherited from BinaryWriter) | Sets the position within the current stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from BinaryWriter) | Overloaded. Writes a one-byte Boolean value to the current stream, with 0 representing false and 1 representing true.
WriteData | Overloaded. Writes an audio byte array to the underlying stream.

See Also

AudioWriter Class | Alvas.Audio Namespace


AudioWriter Constructor

Initializes a new instance of the AudioWriter class based on the supplied stream.

[Visual Basic]
Public Sub New( _
ByVal output As Stream _
)
[C#]
public AudioWriter(
Stream output
);

Parameters

output
The supplied stream.

See Also

AudioWriter Class | Alvas.Audio Namespace


AudioWriter Methods

The methods of the AudioWriter class are listed below. For a complete list of AudioWriter class members, see the AudioWriter Members topic.

Public Instance Methods

Close (inherited from BinaryWriter) | Closes the current BinaryWriter and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from BinaryWriter) | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Seek (inherited from BinaryWriter) | Sets the position within the current stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from BinaryWriter) | Overloaded. Writes a one-byte Boolean value to the current stream, with 0 representing false and 1 representing true.
WriteData | Overloaded. Writes an audio byte array to the underlying stream.

See Also

AudioWriter Class | Alvas.Audio Namespace


WriteData Method

Alvas.Audio Class Library

AudioWriter.WriteData Method

Writes an audio byte array to the underlying stream.

Overload List

Writes an audio byte array to the underlying stream.

public abstract void WriteData(Byte[]);

Writes an audio byte array to the underlying stream from specified position.

public abstract long WriteData(Byte[],Int64);

Writes an audio byte array from specified position in specified mode

public abstract long WriteData(Byte[],Int64,WriteMode);

See Also

AudioWriter Class | Alvas.Audio Namespace


AudioWriter.WriteData Method (Byte[])

Writes an audio byte array to the underlying stream.

[Visual Basic]
MustOverride Overloads Public Sub WriteData( _
ByVal buffer As Byte() _
) _
Implements IAudioWriter.WriteData
[C#]
public abstract void WriteData(
Byte[] buffer
);

Parameters

buffer
A byte array containing the data to write.

Implements

IAudioWriter.WriteData

See Also

AudioWriter Class | Alvas.Audio Namespace | AudioWriter.WriteData Overload List


AudioWriter.WriteData Method (Byte[], Int64)

Writes an audio byte array to the underlying stream from specified position.

[Visual Basic]
MustOverride Overloads Public Function WriteData( _
ByVal buffer As Byte(), _
ByVal position As Long _
) As Long _
Implements IAudioWriter.WriteData
[C#]
public abstract long WriteData(
Byte[] buffer,
Int64 position
);

Parameters

buffer
A byte array containing the data to write.
position
Data position in bytes

Return Value

Returns new data position in bytes

Implements

IAudioWriter.WriteData

See Also

AudioWriter Class | Alvas.Audio Namespace | AudioWriter.WriteData Overload List


AudioWriter.WriteData Method (Byte[], Int64, WriteMode)

Writes an audio byte array from specified position in specified mode

[Visual Basic]
MustOverride Overloads Public Function WriteData( _
ByVal buffer As Byte(), _
ByVal position As Long, _
ByVal mode As WriteMode _
) As Long _
Implements IAudioWriter.WriteData
[C#]
public abstract long WriteData(
Byte[] buffer,
Int64 position,
WriteMode mode
);

Parameters

buffer
audio byte array
position
position
mode
mode

Return Value

Implements

IAudioWriter.WriteData

See Also

AudioWriter Class | Alvas.Audio Namespace | AudioWriter.WriteData Overload List


AuReader Class

Reads an audio data from the .AU and .SND streams.

For a list of all members of this type, see AuReader Members.

System.Object
BinaryReader
AudioReader
AuReader

[Visual Basic]
Public Class AuReader
Inherits
[C#]
public class AuReader : AudioReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

AuReader Members | Alvas.Audio Namespace


AuReader Members

AuReader overview

Public Instance Constructors

AuReader Constructor Initializes a new instance of the AuReader class for the specified stream.

Public Instance Properties

BaseStream (inherited from BinaryReader) Exposes access to the underlying stream of the BinaryReader.

Public Instance Methods

Close (inherited from BinaryReader) | Closes the current reader and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS | Gets audio stream duration in milliseconds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
Milliseconds2Bytes (inherited from AudioReader) | Converts from milliseconds to bytes for current stream.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadData | Overloaded. Reads all audio data from the stream.
ReadDataInBytes | Overloaded. Reads audio data from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadFormat | Reads an audio format.
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AuReader Class | Alvas.Audio Namespace


AuReader Constructor

Initializes a new instance of the AuReader class for the specified stream.

[Visual Basic]
Public Sub New( _
ByVal input As Stream _
)
[C#]
public AuReader(
Stream input
);

Parameters

input
The stream to be read.

See Also

AuReader Class | Alvas.Audio Namespace


AuReader Methods

The methods of the AuReader class are listed below. For a complete list of AuReader class members, see the AuReader Members topic.

Public Instance Methods

Close (inherited from BinaryReader) | Closes the current reader and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS | Gets audio stream duration in milliseconds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
Milliseconds2Bytes (inherited from AudioReader) | Converts from milliseconds to bytes for current stream.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadData | Overloaded. Reads all audio data from the stream.
ReadDataInBytes | Overloaded. Reads audio data from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadFormat | Reads an audio format.
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AuReader Class | Alvas.Audio Namespace


AuReader.GetDurationInMS Method

Gets audio stream duration in milliseconds.

[Visual Basic]
Overrides Public Function GetDurationInMS() As Integer _
Implements IAudioReader.GetDurationInMS
[C#]
public override int GetDurationInMS();

Return Value

Implements

IAudioReader.GetDurationInMS

See Also

AuReader Class | Alvas.Audio Namespace


AuReader.GetLengthInBytes Method

Gets audio stream length in bytes.

[Visual Basic]
Overrides Public Function GetLengthInBytes() As Integer _
Implements IAudioReader.GetLengthInBytes
[C#]
public override int GetLengthInBytes();

Return Value

Implements

IAudioReader.GetLengthInBytes

See Also

AuReader Class | Alvas.Audio Namespace


ReadData Method

Alvas.Audio Class Library

AuReader.ReadData Method

Reads all audio data from the stream.

Overload List

Reads all audio data from the stream.

public override byte[] ReadData();

Reads audio data from the stream.

public override byte[] ReadData(Int32);

Reads audio data from the stream.

public override byte[] ReadData(Int32,Int32);

See Also

AuReader Class | Alvas.Audio Namespace


AuReader.ReadData Method ()

Reads all audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadData() As Byte() _
Implements IAudioReader.ReadData
[C#]
public override byte[] ReadData();

Return Value

audio data array

Implements

IAudioReader.ReadData

See Also

AuReader Class | Alvas.Audio Namespace | AuReader.ReadData Overload List


AuReader.ReadData Method (Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadData( _
ByVal skipSeconds As Integer _
) As Byte() _
Implements IAudioReader.ReadData
[C#]
public override byte[] ReadData(
Int32 skipSeconds
);

Parameters

skipSeconds
skip seconds

Return Value

Implements

IAudioReader.ReadData

See Also

AuReader Class | Alvas.Audio Namespace | AuReader.ReadData Overload List


AuReader.ReadData Method (Int32, Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadData( _
ByVal skipSeconds As Integer, _
ByVal readSeconds As Integer _
) As Byte() _
Implements IAudioReader.ReadData
[C#]
public override byte[] ReadData(
Int32 skipSeconds,
Int32 readSeconds
);

Parameters

skipSeconds
skip seconds
readSeconds
read seconds

Return Value

Implements

IAudioReader.ReadData

See Also

AuReader Class | Alvas.Audio Namespace | AuReader.ReadData Overload List


ReadDataInBytes Method

Alvas.Audio Class Library

AuReader.ReadDataInBytes Method

Reads audio data from the stream.

Overload List

Reads audio data from the stream.

public override byte[] ReadDataInBytes(Int32);

Reads audio data from the stream.

public override byte[] ReadDataInBytes(Int32,Int32);

See Also

AuReader Class | Alvas.Audio Namespace


AuReader.ReadDataInBytes Method (Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadDataInBytes( _
ByVal skipBytes As Integer _
) As Byte() _
Implements IAudioReader.ReadDataInBytes
[C#]
public override byte[] ReadDataInBytes(
Int32 skipBytes
);

Parameters

skipBytes
Skips length of bytes. Use Milliseconds2Bytes for this parameter.

Return Value

Implements

IAudioReader.ReadDataInBytes

See Also

AuReader Class | Alvas.Audio Namespace | AuReader.ReadDataInBytes Overload List


AuReader.ReadDataInBytes Method (Int32, Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadDataInBytes( _
ByVal skipBytes As Integer, _
ByVal readBytes As Integer _
) As Byte() _
Implements IAudioReader.ReadDataInBytes
[C#]
public override byte[] ReadDataInBytes(
Int32 skipBytes,
Int32 readBytes
);

Parameters

skipBytes
Skips length of bytes. Use Milliseconds2Bytes for this parameter.
readBytes
Reads length of bytes. Use Milliseconds2Bytes for this parameter.

Return Value

Implements

IAudioReader.ReadDataInBytes

See Also

AuReader Class | Alvas.Audio Namespace | AuReader.ReadDataInBytes Overload List


AuReader.ReadFormat Method

Reads an audio format.

[Visual Basic]
Overrides Public Function ReadFormat() As IntPtr _
Implements IAudioReader.ReadFormat
[C#]
public override IntPtr ReadFormat();

Return Value

Implements

IAudioReader.ReadFormat

See Also

AuReader Class | Alvas.Audio Namespace


AviReader Class

Reads audio data from the Avi stream.

For a list of all members of this type, see AviReader Members.

System.Object
BinaryReader
AudioReader
AviReader

[Visual Basic]
Public Class AviReader
Inherits
[C#]
public class AviReader : AudioReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example shows simple using of AviReader.

AviReader ar = new AviReader(File.OpenRead("123.avi"));
if (ar.HasAudio)
{
    IntPtr format = ar.ReadFormat();
    byte[] data = ar.ReadData();
}
ar.Close();

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

AviReader Members | Alvas.Audio Namespace


AviReader Members

AviReader overview

Public Instance Constructors

AviReader Constructor Initializes a new instance of the AviReader class for the specified stream.

Public Instance Properties

BaseStream (inherited from BinaryReader) | Exposes access to the underlying stream of the BinaryReader.
HasAudio | Indicates whether the stream contains audio data.

Public Instance Methods

Close | Closes the AviReader object and the underlying stream, and releases any system resources associated with the reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS | Gets audio stream duration in milliseconds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
Milliseconds2Bytes (inherited from AudioReader) | Converts from milliseconds to bytes for current stream.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadData | Overloaded. Reads all audio data from the stream.
ReadDataInBytes | Overloaded. Reads audio data from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadFormat | Reads an audio format. Returns IntPtr.Zero if HasAudio property is false.
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AviReader Class | Alvas.Audio Namespace


AviReader Constructor

Initializes a new instance of the AviReader class for the specified stream.

[Visual Basic]
Public Sub New( _
ByVal input As Stream _
)
[C#]
public AviReader(
Stream input
);

Parameters

input
The stream to be read.

See Also

AviReader Class | Alvas.Audio Namespace


AviReader Properties

The properties of the AviReader class are listed below. For a complete list of AviReader class members, see the AviReader Members topic.

Public Instance Properties

BaseStream (inherited from BinaryReader) | Exposes access to the underlying stream of the BinaryReader.
HasAudio | Indicates whether the stream contains audio data.

See Also

AviReader Class | Alvas.Audio Namespace


HasAudio Property

Alvas.Audio Class Library

AviReader.HasAudio Property

Indicates whether the stream contains audio data.

[Visual Basic]
Public ReadOnly Property HasAudio As Boolean
[C#]
public Boolean HasAudio {get;}

See Also

AviReader Class | Alvas.Audio Namespace


AviReader Methods

The methods of the AviReader class are listed below. For a complete list of AviReader class members, see the AviReader Members topic.

Public Instance Methods

Close | Closes the AviReader object and the underlying stream, and releases any system resources associated with the reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS | Gets audio stream duration in milliseconds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
Milliseconds2Bytes (inherited from AudioReader) | Converts from milliseconds to bytes for current stream.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadData | Overloaded. Reads all audio data from the stream.
ReadDataInBytes | Overloaded. Reads audio data from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadFormat | Reads an audio format. Returns IntPtr.Zero if HasAudio property is false.
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AviReader Class | Alvas.Audio Namespace


AviReader.Close Method

Closes the AviReader object and the underlying stream, and releases any system resources associated with the reader.

[Visual Basic]
Overrides Public Sub Close() _
Implements IAudioReader.Close
[C#]
public override void Close();

Implements

IAudioReader.Close

See Also

AviReader Class | Alvas.Audio Namespace


AviReader.GetDurationInMS Method

Gets audio stream duration in milliseconds.

[Visual Basic]
Overrides Public Function GetDurationInMS() As Integer _
Implements IAudioReader.GetDurationInMS
[C#]
public override int GetDurationInMS();

Return Value

Implements

IAudioReader.GetDurationInMS

See Also

AviReader Class | Alvas.Audio Namespace


AviReader.GetLengthInBytes Method

Gets audio stream length in bytes.

[Visual Basic]
Overrides Public Function GetLengthInBytes() As Integer _
Implements IAudioReader.GetLengthInBytes
[C#]
public override int GetLengthInBytes();

Return Value

Implements

IAudioReader.GetLengthInBytes

See Also

AviReader Class | Alvas.Audio Namespace


ReadData Method

Alvas.Audio Class Library

AviReader.ReadData Method

Reads all audio data from the stream.

Overload List

Reads all audio data from the stream.

public override byte[] ReadData();

Reads audio data from the stream.

public override byte[] ReadData(Int32);

Reads audio data from the stream.

public override byte[] ReadData(Int32,Int32);

See Also

AviReader Class | Alvas.Audio Namespace


AviReader.ReadData Method ()

Reads all audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadData() As Byte() _
Implements IAudioReader.ReadData
[C#]
public override byte[] ReadData();

Return Value

audio data array

Implements

IAudioReader.ReadData

See Also

AviReader Class | Alvas.Audio Namespace | AviReader.ReadData Overload List


AviReader.ReadData Method (Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadData( _
ByVal skipSeconds As Integer _
) As Byte() _
Implements IAudioReader.ReadData
[C#]
public override byte[] ReadData(
Int32 skipSeconds
);

Parameters

skipSeconds
skip seconds

Return Value

Implements

IAudioReader.ReadData

See Also

AviReader Class | Alvas.Audio Namespace | AviReader.ReadData Overload List


AviReader.ReadData Method (Int32, Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadData( _
ByVal skipSeconds As Integer, _
ByVal readSeconds As Integer _
) As Byte() _
Implements IAudioReader.ReadData
[C#]
public override byte[] ReadData(
Int32 skipSeconds,
Int32 readSeconds
);

Parameters

skipSeconds
skip seconds
readSeconds
read seconds

Return Value

Implements

IAudioReader.ReadData

See Also

AviReader Class | Alvas.Audio Namespace | AviReader.ReadData Overload List


ReadDataInBytes Method

Alvas.Audio Class Library

AviReader.ReadDataInBytes Method

Reads audio data from the stream.

Overload List

Reads audio data from the stream.

public override byte[] ReadDataInBytes(Int32);

Reads audio data from the stream.

public override byte[] ReadDataInBytes(Int32,Int32);

See Also

AviReader Class | Alvas.Audio Namespace


AviReader.ReadDataInBytes Method (Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadDataInBytes( _
ByVal skipBytes As Integer _
) As Byte() _
Implements IAudioReader.ReadDataInBytes
[C#]
public override byte[] ReadDataInBytes(
Int32 skipBytes
);

Parameters

skipBytes
Skips length of bytes. Use Milliseconds2Bytes for this parameter.

Return Value

Implements

IAudioReader.ReadDataInBytes

See Also

AviReader Class | Alvas.Audio Namespace | AviReader.ReadDataInBytes Overload List


AviReader.ReadDataInBytes Method (Int32, Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadDataInBytes( _
ByVal skipBytes As Integer, _
ByVal readBytes As Integer _
) As Byte() _
Implements IAudioReader.ReadDataInBytes
[C#]
public override byte[] ReadDataInBytes(
Int32 skipBytes,
Int32 readBytes
);

Parameters

skipBytes
Skips length of bytes. Use Milliseconds2Bytes for this parameter.
readBytes
Reads length of bytes. Use Milliseconds2Bytes for this parameter.

Return Value

Implements

IAudioReader.ReadDataInBytes

See Also

AviReader Class | Alvas.Audio Namespace | AviReader.ReadDataInBytes Overload List


AviReader.ReadFormat Method

Reads an audio format. Returns IntPtr.Zero if HasAudio property is false.

[Visual Basic]
Overrides Public Function ReadFormat() As IntPtr _
Implements IAudioReader.ReadFormat
[C#]
public override IntPtr ReadFormat();

Return Value

Implements

IAudioReader.ReadFormat

See Also

AviReader Class | Alvas.Audio Namespace


AviReaderException Class

The exception that is thrown when a avi reader error occurs.

For a list of all members of this type, see AviReaderException Members.

System.Object
Exception
AudioException
AviReaderException

[Visual Basic]
Public Class AviReaderException
Inherits
[C#]
public class AviReaderException : AudioException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

AviReaderException Members | Alvas.Audio Namespace


AviReaderException Members

AviReaderException overview

Public Instance Constructors

AviReaderException Overloaded. Initializes a new instance of the AviReaderException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

See Also

AviReaderException Class | Alvas.Audio Namespace


AviReaderException Constructor

Overload List

public AviReaderException();

public AviReaderException(String);

See Also

AviReaderException Class | Alvas.Audio Namespace


AviReaderException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public AviReaderException(
String message
);

Parameters

message

See Also

AviReaderException Class | Alvas.Audio Namespace | AviReaderException Constructor Overload List


AviReaderException Constructor ()

[Visual Basic]
Overloads Public Sub New()
[C#]
public AviReaderException();

See Also

AviReaderException Class | Alvas.Audio Namespace | AviReaderException Constructor Overload List


AviReaderException Properties

The properties of the AviReaderException class are listed below. For a complete list of AviReaderException class members, see the AviReaderException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

AviReaderException Class | Alvas.Audio Namespace


Message Property

Alvas.Audio Class Library

AviReaderException.Message Property

[Visual Basic]
Overrides Public ReadOnly Property Message As String
[C#]
public override String Message {get;}

See Also

AviReaderException Class | Alvas.Audio Namespace


ChorusAudioEffect Class

Chorus is a voice-doubling effect created by echoing the original sound with a slight delay and slightly modulating the delay of the echo.

For a list of all members of this type, see ChorusAudioEffect Members.

System.Object
AudioEffect
ChorusAudioEffect

[Visual Basic]
Public Class ChorusAudioEffect
Inherits
[C#]
public class ChorusAudioEffect : AudioEffect

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

ChorusAudioEffect Members | Alvas.Audio Namespace


ChorusAudioEffect Members

ChorusAudioEffect overview

Public Instance Properties

HasProcessInPlace (inherited from AudioEffect) Checks can whether process in place

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessInPlace (inherited from AudioEffect) | Process in place audio data and put the resulting audio data into data array
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ChorusAudioEffect Class | Alvas.Audio Namespace


CompressorAudioEffect Class

Compression is a reduction in the fluctuation of a signal above a certain amplitude.

For a list of all members of this type, see CompressorAudioEffect Members.

System.Object
AudioEffect
CompressorAudioEffect

[Visual Basic]
Public Class CompressorAudioEffect
Inherits
[C#]
public class CompressorAudioEffect : AudioEffect

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

CompressorAudioEffect Members | Alvas.Audio Namespace


CompressorAudioEffect Members

CompressorAudioEffect overview

Public Instance Properties

HasProcessInPlace (inherited from AudioEffect) Checks can whether process in place

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessInPlace (inherited from AudioEffect) | Process in place audio data and put the resulting audio data into data array
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CompressorAudioEffect Class | Alvas.Audio Namespace


ControlChangeEventArgs Class

Provides data for ControlChange event.

For a list of all members of this type, see ControlChangeEventArgs Members.

System.Object
EventArgs
ControlChangeEventArgs

[Visual Basic]
Public Class ControlChangeEventArgs
Inherits
[C#]
public class ControlChangeEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

ControlChangeEventArgs Members | Alvas.Audio Namespace


ControlChangeEventArgs Members

ControlChangeEventArgs overview

Public Instance Constructors

ControlChangeEventArgs Constructor Initializes a new instance of the ControlChangeEventArgs class.

Public Instance Properties

ControlID | Gets Control ID
MixerID | Gets Mixer ID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ControlChangeEventArgs Class | Alvas.Audio Namespace


ControlChangeEventArgs Constructor

Initializes a new instance of the ControlChangeEventArgs class.

[Visual Basic]
Public Sub New( _
ByVal mixerID As Integer, _
ByVal controlID As Integer _
)
[C#]
public ControlChangeEventArgs(
Int32 mixerID,
Int32 controlID
);

Parameters

mixerID
The mixer ID.
controlID
The control ID.

See Also

ControlChangeEventArgs Class | Alvas.Audio Namespace


ControlChangeEventArgs Properties

The properties of the ControlChangeEventArgs class are listed below. For a complete list of ControlChangeEventArgs class members, see the ControlChangeEventArgs Members topic.

Public Instance Properties

ControlID | Gets Control ID
MixerID | Gets Mixer ID

See Also

ControlChangeEventArgs Class | Alvas.Audio Namespace


ControlID Property

Alvas.Audio Class Library

ControlChangeEventArgs.ControlID Property

Gets Control ID

[Visual Basic]
Public ReadOnly Property ControlID As Integer
[C#]
public Int32 ControlID {get;}

See Also

ControlChangeEventArgs Class | Alvas.Audio Namespace


MixerID Property

Alvas.Audio Class Library

ControlChangeEventArgs.MixerID Property

Gets Mixer ID

[Visual Basic]
Public ReadOnly Property MixerID As Integer
[C#]
public Int32 MixerID {get;}

See Also

ControlChangeEventArgs Class | Alvas.Audio Namespace


DataEventArgs Class

Provides data for Data event.

For a list of all members of this type, see DataEventArgs Members.

System.Object
EventArgs
DataEventArgs
DoneEventArgs

[Visual Basic]
Public Class DataEventArgs
Inherits
[C#]
public class DataEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

DataEventArgs Members | Alvas.Audio Namespace


DataEventArgs Members

DataEventArgs overview

Public Instance Constructors

DataEventArgs Constructor Initializes a new instance of the DataEventArgs class.

Public Instance Properties

Data Gets byte data array.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DataEventArgs Class | Alvas.Audio Namespace


DataEventArgs Constructor

Initializes a new instance of the DataEventArgs class.

[Visual Basic]
Public Sub New( _
ByVal data As Byte() _
)
[C#]
public DataEventArgs(
Byte[] data
);

Parameters

data
The data array.

See Also

DataEventArgs Class | Alvas.Audio Namespace


DataEventArgs Properties

The properties of the DataEventArgs class are listed below. For a complete list of DataEventArgs class members, see the DataEventArgs Members topic.

Public Instance Properties

Data Gets byte data array.

See Also

DataEventArgs Class | Alvas.Audio Namespace


Data Property

Alvas.Audio Class Library

DataEventArgs.Data Property

Gets byte data array.

[Visual Basic]
Public ReadOnly Property Data As Byte()
[C#]
public Byte[] Data {get;}

Property Value

The data array.

See Also

DataEventArgs Class | Alvas.Audio Namespace


DestinationLine Class

Destination line.

For a list of all members of this type, see DestinationLine Members.

System.Object
MixerLine
DestinationLine

[Visual Basic]
Public Class DestinationLine
Inherits
[C#]
public class DestinationLine : MixerLine

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

DestinationLine Members | Alvas.Audio Namespace


DestinationLine Members

DestinationLine overview

Public Instance Properties

Channels (inherited from MixerLine) | Gets quantity of channels for mixer line
Controls (inherited from MixerLine) | Gets the controls of the mixer line.
MixerID (inherited from MixerLine) | Gets the mixer ID.
MixerLineID (inherited from MixerLine) | Gets the mixer line ID.
Name (inherited from MixerLine) | Gets the mixer line name.
ShortName (inherited from MixerLine) | Gets the short name of the mixer line.
Sources | Gets the source lines.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from MixerLine) | Returns a String that represents the current Object.

See Also

DestinationLine Class | Alvas.Audio Namespace


DestinationLine Properties

The properties of the DestinationLine class are listed below. For a complete list of DestinationLine class members, see the DestinationLine Members topic.

Public Instance Properties

Channels (inherited from MixerLine) | Gets quantity of channels for mixer line
Controls (inherited from MixerLine) | Gets the controls of the mixer line.
MixerID (inherited from MixerLine) | Gets the mixer ID.
MixerLineID (inherited from MixerLine) | Gets the mixer line ID.
Name (inherited from MixerLine) | Gets the mixer line name.
ShortName (inherited from MixerLine) | Gets the short name of the mixer line.
Sources | Gets the source lines.

See Also

DestinationLine Class | Alvas.Audio Namespace


Sources Property

Alvas.Audio Class Library

DestinationLine.Sources Property

Gets the source lines.

[Visual Basic]
Public ReadOnly Property Sources As MixerLine()
[C#]
public MixerLine[] Sources {get;}

Property Value

The sources.

See Also

DestinationLine Class | Alvas.Audio Namespace


DeviceState Enumeration

Specifies the audio device state.

[Visual Basic]
Public Enum DeviceState
[C#]
public enum DeviceState

Members

Member Name | Description
Closed | The device is closed.
Opened | The device is opened.
Stopped | The device is stopped.
Paused | The device is paused.
InProgress | The device is being in progress.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Alvas.Audio Namespace


DistortionAudioEffect Class

Distortion is achieved by adding harmonics to the signal in such a way that, as the level increases, the top of the waveform becomes squared off or clipped.

For a list of all members of this type, see DistortionAudioEffect Members.

System.Object
AudioEffect
DistortionAudioEffect

[Visual Basic]
Public Class DistortionAudioEffect
Inherits
[C#]
public class DistortionAudioEffect : AudioEffect

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

DistortionAudioEffect Members | Alvas.Audio Namespace


DistortionAudioEffect Members

DistortionAudioEffect overview

Public Instance Properties

HasProcessInPlace (inherited from AudioEffect) Checks can whether process in place

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessInPlace (inherited from AudioEffect) | Process in place audio data and put the resulting audio data into data array
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DistortionAudioEffect Class | Alvas.Audio Namespace


DoneEventArgs Class

Provides data for Done event.

For a list of all members of this type, see DoneEventArgs Members.

System.Object
EventArgs
DataEventArgs
DoneEventArgs

[Visual Basic]
Public Class DoneEventArgs
Inherits
[C#]
public class DoneEventArgs : DataEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

DoneEventArgs Members | Alvas.Audio Namespace


DoneEventArgs Members

DoneEventArgs overview

Public Instance Constructors

DoneEventArgs Constructor

Public Instance Properties

Data (inherited from DataEventArgs) | Gets byte data array.
IsEndPlaying | Gets a value indicating whether this instance is end playing.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DoneEventArgs Class | Alvas.Audio Namespace


DoneEventArgs Constructor

[Visual Basic]
Public Sub New( _
ByVal data As Byte(), _
ByVal isEndPlaying As Boolean _
)
[C#]
public DoneEventArgs(
Byte[] data,
Boolean isEndPlaying
);

Parameters

data
isEndPlaying

See Also

DoneEventArgs Class | Alvas.Audio Namespace


DoneEventArgs Properties

The properties of the DoneEventArgs class are listed below. For a complete list of DoneEventArgs class members, see the DoneEventArgs Members topic.

Public Instance Properties

Data (inherited from DataEventArgs) | Gets byte data array.
IsEndPlaying | Gets a value indicating whether this instance is end playing.

See Also

DoneEventArgs Class | Alvas.Audio Namespace


IsEndPlaying Property

Alvas.Audio Class Library

DoneEventArgs.IsEndPlaying Property

Gets a value indicating whether this instance is end playing.

[Visual Basic]
Public ReadOnly Property IsEndPlaying As Boolean
[C#]
public Boolean IsEndPlaying {get;}

Property Value

true if this instance is end playing; otherwise, false.

See Also

DoneEventArgs Class | Alvas.Audio Namespace


DriverDetails Structure

The DriverDetails structure describes the features of an ACM driver.

For a list of all members of this type, see DriverDetails Members.

System.Object
ValueType
DriverDetails

[Visual Basic]
Public Structure DriverDetails
Implements IComparable
[C#]
public struct DriverDetails : IComparable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

DriverDetails Members | Alvas.Audio Namespace


DriverDetails Members

DriverDetails overview

Public Instance Fields

Acm | Version of the ACM for which this driver was compiled. The version number is a hexadecimal number in the format 0xAABBCCCC, where AA is the major version number, BB is the minor version number, and CCCC is the build number. The version parts (major, minor, and build) should be displayed as decimal numbers.
Copyright | String that provides copyright information for the driver.
Driver |
DriverVersion | Version of the driver.
Features | String that provides special feature information for the driver.
FilterTags | Number of unique filter tags supported by this driver.
FormatTags | Number of unique format tags supported by this driver.
Icon | Handle to a custom icon for this driver. This member can be 0.
Licensing | String that provides special licensing information for the driver.
LongName | String that describes the full name of the driver.
ShortName | String that describes the short name of the driver.
Support | Support flags for the driver.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

DriverDetails Class | Alvas.Audio Namespace


DriverDetails Fields

The fields of the DriverDetails structure are listed below. For a complete list of DriverDetails structure members, see the DriverDetails Members topic.

Public Instance Fields

Acm | Version of the ACM for which this driver was compiled. The version number is a hexadecimal number in the format 0xAABBCCCC, where AA is the major version number, BB is the minor version number, and CCCC is the build number. The version parts (major, minor, and build) should be displayed as decimal numbers.
Copyright | String that provides copyright information for the driver.
Driver |
DriverVersion | Version of the driver.
Features | String that provides special feature information for the driver.
FilterTags | Number of unique filter tags supported by this driver.
FormatTags | Number of unique format tags supported by this driver.
Icon | Handle to a custom icon for this driver. This member can be 0.
Licensing | String that provides special licensing information for the driver.
LongName | String that describes the full name of the driver.
ShortName | String that describes the short name of the driver.
Support | Support flags for the driver.

See Also

DriverDetails Class | Alvas.Audio Namespace


DriverDetails.Acm Field

Version of the ACM for which this driver was compiled. The version number is a hexadecimal number in the format 0xAABBCCCC, where AA is the major version number, BB is the minor version number, and CCCC is the build number. The version parts (major, minor, and build) should be displayed as decimal numbers.

[Visual Basic]
Public Acm As Integer
[C#]
public Int32 Acm;

See Also

DriverDetails Class | Alvas.Audio Namespace


DriverDetails.Copyright Field

String that provides copyright information for the driver.

[Visual Basic]
Public Copyright As String
[C#]
public String Copyright;

See Also

DriverDetails Class | Alvas.Audio Namespace


DriverDetails.Driver Field

[Visual Basic]
Public Driver As Integer
[C#]
public Int32 Driver;

See Also

DriverDetails Class | Alvas.Audio Namespace


DriverDetails.DriverVersion Field

Version of the driver.

[Visual Basic]
Public DriverVersion As String
[C#]
public String DriverVersion;

See Also

DriverDetails Class | Alvas.Audio Namespace


DriverDetails.Features Field

String that provides special feature information for the driver.

[Visual Basic]
Public Features As String
[C#]
public String Features;

See Also

DriverDetails Class | Alvas.Audio Namespace


DriverDetails.FilterTags Field

Number of unique filter tags supported by this driver.

[Visual Basic]
Public FilterTags As Integer
[C#]
public Int32 FilterTags;

See Also

DriverDetails Class | Alvas.Audio Namespace


DriverDetails.FormatTags Field

Number of unique format tags supported by this driver.

[Visual Basic]
Public FormatTags As Integer
[C#]
public Int32 FormatTags;

See Also

DriverDetails Class | Alvas.Audio Namespace


DriverDetails.Icon Field

Handle to a custom icon for this driver. This member can be 0.

[Visual Basic]
Public Icon As IntPtr
[C#]
public IntPtr Icon;

See Also

DriverDetails Class | Alvas.Audio Namespace


DriverDetails.Licensing Field

String that provides special licensing information for the driver.

[Visual Basic]
Public Licensing As String
[C#]
public String Licensing;

See Also

DriverDetails Class | Alvas.Audio Namespace


DriverDetails.LongName Field

String that describes the full name of the driver.

[Visual Basic]
Public LongName As String
[C#]
public String LongName;

See Also

DriverDetails Class | Alvas.Audio Namespace


DriverDetails.ShortName Field

String that describes the short name of the driver.

[Visual Basic]
Public ShortName As String
[C#]
public String ShortName;

See Also

DriverDetails Class | Alvas.Audio Namespace


DriverDetails.Support Field

Support flags for the driver.

[Visual Basic]
Public Support As Integer
[C#]
public Int32 Support;

See Also

DriverDetails Class | Alvas.Audio Namespace


DriverDetails Methods

The methods of the DriverDetails structure are listed below. For a complete list of DriverDetails structure members, see the DriverDetails Members topic.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

DriverDetails Class | Alvas.Audio Namespace


DriverDetails.ToString Method

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

See Also

DriverDetails Class | Alvas.Audio Namespace


DsReader Class

Reads audio data using DirectShow.

For a list of all members of this type, see DsReader Members.

System.Object
DsReader

[Visual Basic]
Public Class DsReader
Implements IAudioReader, IDisposable
[C#]
public class DsReader : IAudioReader, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example shows simple using of DsReader class.

DsReader dr = new DsReader("in.wma");
if (dr.HasAudio)
{
    IntPtr format = dr.ReadFormat();
    byte[] data = dr.ReadData();
}
dr.Close();

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

DsReader Members | Alvas.Audio Namespace


DsReader Members

DsReader overview

Public Instance Constructors

DsReader Constructor Initializes a new instance of the DsReader class for the specified file.

Public Instance Properties

HasAudio Indicates whether the stream contains audio data.

Public Instance Methods

Close | Closes the DsReader object and releases any system resources associated with the reader.
Dispose | Closes the DsReader object and releases any system resources associated with the reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS | Gets audio stream duration in milliseconds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
Milliseconds2Bytes | Converts from milliseconds to bytes for current stream.
ReadData | Overloaded. Reads audio data from the stream.
ReadDataInBytes | Overloaded. Reads audio data from the stream.
ReadFormat | Reads an audio format.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DsReader Class | Alvas.Audio Namespace


DsReader Constructor

Initializes a new instance of the DsReader class for the specified file.

[Visual Basic]
Public Sub New( _
ByVal fileName As String _
)
[C#]
public DsReader(
String fileName
);

Parameters

fileName
file name

See Also

DsReader Class | Alvas.Audio Namespace


DsReader Properties

The properties of the DsReader class are listed below. For a complete list of DsReader class members, see the DsReader Members topic.

Public Instance Properties

HasAudio Indicates whether the stream contains audio data.

See Also

DsReader Class | Alvas.Audio Namespace


HasAudio Property

Alvas.Audio Class Library

DsReader.HasAudio Property

Indicates whether the stream contains audio data.

[Visual Basic]
Public ReadOnly Property HasAudio As Boolean
[C#]
public Boolean HasAudio {get;}

See Also

DsReader Class | Alvas.Audio Namespace


DsReader Methods

The methods of the DsReader class are listed below. For a complete list of DsReader class members, see the DsReader Members topic.

Public Instance Methods

Close | Closes the DsReader object and releases any system resources associated with the reader.
Dispose | Closes the DsReader object and releases any system resources associated with the reader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS | Gets audio stream duration in milliseconds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
Milliseconds2Bytes | Converts from milliseconds to bytes for current stream.
ReadData | Overloaded. Reads audio data from the stream.
ReadDataInBytes | Overloaded. Reads audio data from the stream.
ReadFormat | Reads an audio format.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DsReader Class | Alvas.Audio Namespace


DsReader.Close Method

Closes the DsReader object and releases any system resources associated with the reader.

[Visual Basic]
NotOverridable Public Sub Close() _
Implements IAudioReader.Close
[C#]
public void Close();

Implements

IAudioReader.Close

See Also

DsReader Class | Alvas.Audio Namespace


DsReader.Dispose Method

Closes the DsReader object and releases any system resources associated with the reader.

[Visual Basic]
NotOverridable Public Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

DsReader Class | Alvas.Audio Namespace


DsReader.GetDurationInMS Method

Gets audio stream duration in milliseconds.

[Visual Basic]
NotOverridable Public Function GetDurationInMS() As Integer _
Implements IAudioReader.GetDurationInMS
[C#]
public int GetDurationInMS();

Return Value

Implements

IAudioReader.GetDurationInMS

See Also

DsReader Class | Alvas.Audio Namespace


DsReader.GetLengthInBytes Method

Gets audio stream length in bytes.

[Visual Basic]
NotOverridable Public Function GetLengthInBytes() As Integer _
Implements IAudioReader.GetLengthInBytes
[C#]
public int GetLengthInBytes();

Return Value

Implements

IAudioReader.GetLengthInBytes

See Also

DsReader Class | Alvas.Audio Namespace


DsReader.Milliseconds2Bytes Method

Converts from milliseconds to bytes for current stream.

[Visual Basic]
NotOverridable Public Function Milliseconds2Bytes( _
ByVal milliseconds As Integer _
) As Integer _
Implements IAudioReader.Milliseconds2Bytes
[C#]
public int Milliseconds2Bytes(
Int32 milliseconds
);

Parameters

milliseconds
Time, expressed in milliseconds.

Return Value

Implements

IAudioReader.Milliseconds2Bytes

See Also

DsReader Class | Alvas.Audio Namespace


ReadData Method

Alvas.Audio Class Library

DsReader.ReadData Method

Reads all audio data from the stream.

Overload List

Reads all audio data from the stream.

public byte[] ReadData();

Reads audio data from the stream.

public byte[] ReadData(Int32);

Reads audio data from the stream.

public byte[] ReadData(Int32,Int32);

See Also

DsReader Class | Alvas.Audio Namespace


DsReader.ReadData Method ()

Reads all audio data from the stream.

[Visual Basic]
NotOverridable Overloads Public Function ReadData() As Byte() _
Implements IAudioReader.ReadData
[C#]
public byte[] ReadData();

Return Value

audio data array

Implements

IAudioReader.ReadData

See Also

DsReader Class | Alvas.Audio Namespace | DsReader.ReadData Overload List


DsReader.ReadData Method (Int32)

Reads audio data from the stream.

[Visual Basic]
NotOverridable Overloads Public Function ReadData( _
ByVal skipSeconds As Integer _
) As Byte() _
Implements IAudioReader.ReadData
[C#]
public byte[] ReadData(
Int32 skipSeconds
);

Parameters

skipSeconds
skip seconds

Return Value

Implements

IAudioReader.ReadData

See Also

DsReader Class | Alvas.Audio Namespace | DsReader.ReadData Overload List


DsReader.ReadData Method (Int32, Int32)

Reads audio data from the stream.

[Visual Basic]
NotOverridable Overloads Public Function ReadData( _
ByVal skipSeconds As Integer, _
ByVal readSeconds As Integer _
) As Byte() _
Implements IAudioReader.ReadData
[C#]
public byte[] ReadData(
Int32 skipSeconds,
Int32 readSeconds
);

Parameters

skipSeconds
skip seconds
readSeconds
read seconds

Return Value

Implements

IAudioReader.ReadData

See Also

DsReader Class | Alvas.Audio Namespace | DsReader.ReadData Overload List


ReadDataInBytes Method

Alvas.Audio Class Library

DsReader.ReadDataInBytes Method

Reads audio data from the stream.

Overload List

Reads audio data from the stream.

public byte[] ReadDataInBytes(Int32);

Reads audio data from the stream.

public byte[] ReadDataInBytes(Int32,Int32);

See Also

DsReader Class | Alvas.Audio Namespace


DsReader.ReadDataInBytes Method (Int32)

Reads audio data from the stream.

[Visual Basic]
NotOverridable Overloads Public Function ReadDataInBytes( _
ByVal skipBytes As Integer _
) As Byte() _
Implements IAudioReader.ReadDataInBytes
[C#]
public byte[] ReadDataInBytes(
Int32 skipBytes
);

Parameters

skipBytes
Skips length of bytes. Use Milliseconds2Bytes for this parameter.

Return Value

Implements

IAudioReader.ReadDataInBytes

See Also

DsReader Class | Alvas.Audio Namespace | DsReader.ReadDataInBytes Overload List


DsReader.ReadDataInBytes Method (Int32, Int32)

Reads audio data from the stream.

[Visual Basic]
NotOverridable Overloads Public Function ReadDataInBytes( _
ByVal skipBytes As Integer, _
ByVal readBytes As Integer _
) As Byte() _
Implements IAudioReader.ReadDataInBytes
[C#]
public byte[] ReadDataInBytes(
Int32 skipBytes,
Int32 readBytes
);

Parameters

skipBytes
Skips length of bytes. Use Milliseconds2Bytes for this parameter.
readBytes
Reads length of bytes. Use Milliseconds2Bytes for this parameter.

Return Value

Implements

IAudioReader.ReadDataInBytes

See Also

DsReader Class | Alvas.Audio Namespace | DsReader.ReadDataInBytes Overload List


DsReader.ReadFormat Method

Reads an audio format.

[Visual Basic]
NotOverridable Public Function ReadFormat() As IntPtr _
Implements IAudioReader.ReadFormat
[C#]
public IntPtr ReadFormat();

Return Value

Implements

IAudioReader.ReadFormat

See Also

DsReader Class | Alvas.Audio Namespace


DsReaderException Class

The exception that is thrown when a DirectShow reader error occurs.

For a list of all members of this type, see DsReaderException Members.

System.Object
Exception
AudioException
DsReaderException

[Visual Basic]
Public Class DsReaderException
Inherits
[C#]
public class DsReaderException : AudioException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

DsReaderException Members | Alvas.Audio Namespace


DsReaderException Members

DsReaderException overview

Public Instance Constructors

DsReaderException Overloaded. Initializes a new instance of the DsReaderException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

See Also

DsReaderException Class | Alvas.Audio Namespace


DsReaderException Constructor

Overload List

public DsReaderException();

public DsReaderException(String);

See Also

DsReaderException Class | Alvas.Audio Namespace


DsReaderException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public DsReaderException(
String message
);

Parameters

message

See Also

DsReaderException Class | Alvas.Audio Namespace | DsReaderException Constructor Overload List


DsReaderException Constructor ()

[Visual Basic]
Overloads Public Sub New()
[C#]
public DsReaderException();

See Also

DsReaderException Class | Alvas.Audio Namespace | DsReaderException Constructor Overload List


DsReaderException Properties

The properties of the DsReaderException class are listed below. For a complete list of DsReaderException class members, see the DsReaderException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

DsReaderException Class | Alvas.Audio Namespace


Message Property

Alvas.Audio Class Library

DsReaderException.Message Property

[Visual Basic]
Overrides Public ReadOnly Property Message As String
[C#]
public override String Message {get;}

See Also

DsReaderException Class | Alvas.Audio Namespace


EchoAudioEffect Class

An echo effect causes an entire sound to be repeated after a fixed delay.

For a list of all members of this type, see EchoAudioEffect Members.

System.Object
AudioEffect
EchoAudioEffect

[Visual Basic]
Public Class EchoAudioEffect
Inherits
[C#]
public class EchoAudioEffect : AudioEffect

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

EchoAudioEffect Members | Alvas.Audio Namespace


EchoAudioEffect Members

EchoAudioEffect overview

Public Instance Properties

HasProcessInPlace (inherited from AudioEffect) Checks can whether process in place

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessInPlace (inherited from AudioEffect) | Process in place audio data and put the resulting audio data into data array
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EchoAudioEffect Class | Alvas.Audio Namespace


FlangerAudioEffect Class

Flange is an echo effect in which the delay between the original signal and its echo is very short and varies over time. The result is sometimes referred to as a sweeping sound. The term flange originated with the practice of grabbing the flanges of a tape reel to change the speed.

For a list of all members of this type, see FlangerAudioEffect Members.

System.Object
AudioEffect
FlangerAudioEffect

[Visual Basic]
Public Class FlangerAudioEffect
Inherits
[C#]
public class FlangerAudioEffect : AudioEffect

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

FlangerAudioEffect Members | Alvas.Audio Namespace


FlangerAudioEffect Members

FlangerAudioEffect overview

Public Instance Properties

HasProcessInPlace (inherited from AudioEffect) Checks can whether process in place

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessInPlace (inherited from AudioEffect) | Process in place audio data and put the resulting audio data into data array
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FlangerAudioEffect Class | Alvas.Audio Namespace


FormatChooseResult Class

Class represents the ChooseCompatibleFormat result

For a list of all members of this type, see FormatChooseResult Members.

System.Object
FormatChooseResult

[Visual Basic]
Public Class FormatChooseResult
[C#]
public class FormatChooseResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

FormatChooseResult Members | Alvas.Audio Namespace


FormatChooseResult Members

FormatChooseResult overview

Public Instance Constructors

FormatChooseResult Constructor

Public Instance Properties

Format | Gets format
FormatName | Gets format name
FormatTagName | Gets format tag name
Result | Returns 0 if successful (Format property is valid) or an error (including the user chose the Cancel button or the Close command on the System menu to close the dialog box) otherwise (Format property is not valid).

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FormatChooseResult Class | Alvas.Audio Namespace


FormatChooseResult Constructor

[Visual Basic]
Public Sub New( _
ByVal result As Integer, _
ByVal format As IntPtr, _
ByVal formatTagName As String, _
ByVal formatName As String _
)
[C#]
public FormatChooseResult(
Int32 result,
IntPtr format,
String formatTagName,
String formatName
);

Parameters

result
format
formatTagName
formatName

See Also

FormatChooseResult Class | Alvas.Audio Namespace


FormatChooseResult Properties

The properties of the FormatChooseResult class are listed below. For a complete list of FormatChooseResult class members, see the FormatChooseResult Members topic.

Public Instance Properties

Format | Gets format
FormatName | Gets format name
FormatTagName | Gets format tag name
Result | Returns 0 if successful (Format property is valid) or an error (including the user chose the Cancel button or the Close command on the System menu to close the dialog box) otherwise (Format property is not valid).

See Also

FormatChooseResult Class | Alvas.Audio Namespace


Format Property

Alvas.Audio Class Library

FormatChooseResult.Format Property

Gets format

[Visual Basic]
Public ReadOnly Property Format As IntPtr
[C#]
public IntPtr Format {get;}

See Also

FormatChooseResult Class | Alvas.Audio Namespace


FormatName Property

Alvas.Audio Class Library

FormatChooseResult.FormatName Property

Gets format name

[Visual Basic]
Public ReadOnly Property FormatName As String
[C#]
public String FormatName {get;}

See Also

FormatChooseResult Class | Alvas.Audio Namespace


FormatTagName Property

Alvas.Audio Class Library

FormatChooseResult.FormatTagName Property

Gets format tag name

[Visual Basic]
Public ReadOnly Property FormatTagName As String
[C#]
public String FormatTagName {get;}

See Also

FormatChooseResult Class | Alvas.Audio Namespace


Result Property

Alvas.Audio Class Library

FormatChooseResult.Result Property

Returns 0 if successful (Format property is valid) or an error (including the user chose the Cancel button or the Close command on the System menu to close the dialog box) otherwise (Format property is not valid).

[Visual Basic]
Public ReadOnly Property Result As Integer
[C#]
public Int32 Result {get;}

See Also

FormatChooseResult Class | Alvas.Audio Namespace


FormatDetails Structure

The FormatDetails structure details a waveform-audio format for a specific format tag for an ACM (AudioCompressionManager) driver.

For a list of all members of this type, see FormatDetails Members.

System.Object
ValueType
FormatDetails

[Visual Basic]
Public Structure FormatDetails
Implements IComparable
[C#]
public struct FormatDetails : IComparable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

FormatDetails Members | Alvas.Audio Namespace


FormatDetails Members

FormatDetails overview

Public Instance Fields

Driver | Driver id
FormatHandle | Handle of the format structure that will receive the format details.
FormatIndex | Index of the format to retrieve details for. The index ranges from zero to one less than the number of standard formats supported by an ACM driver for a format tag.
FormatName | String that describes the format for the FormatTag type.
FormatTag | Waveform-audio format tag that the FormatDetails structure describes.
Support | Driver-support flags specific to the specified format.

Public Instance Properties

ShowFormatTag Gets or sets the value indicating whether show format tag in ToString.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns the fully qualified type name of this instance.

See Also

FormatDetails Class | Alvas.Audio Namespace


FormatDetails Fields

The fields of the FormatDetails structure are listed below. For a complete list of FormatDetails structure members, see the FormatDetails Members topic.

Public Instance Fields

Driver | Driver id
FormatHandle | Handle of the format structure that will receive the format details.
FormatIndex | Index of the format to retrieve details for. The index ranges from zero to one less than the number of standard formats supported by an ACM driver for a format tag.
FormatName | String that describes the format for the FormatTag type.
FormatTag | Waveform-audio format tag that the FormatDetails structure describes.
Support | Driver-support flags specific to the specified format.

See Also

FormatDetails Class | Alvas.Audio Namespace


FormatDetails.Driver Field

Driver id

[Visual Basic]
Public Driver As Integer
[C#]
public Int32 Driver;

See Also

FormatDetails Class | Alvas.Audio Namespace


FormatDetails.FormatHandle Field

Handle of the format structure that will receive the format details.

[Visual Basic]
Public FormatHandle As IntPtr
[C#]
public IntPtr FormatHandle;

See Also

FormatDetails Class | Alvas.Audio Namespace


FormatDetails.FormatIndex Field

Index of the format to retrieve details for. The index ranges from zero to one less than the number of standard formats supported by an ACM driver for a format tag.

[Visual Basic]
Public FormatIndex As Integer
[C#]
public Int32 FormatIndex;

See Also

FormatDetails Class | Alvas.Audio Namespace


FormatDetails.FormatName Field

String that describes the format for the FormatTag type.

[Visual Basic]
Public FormatName As String
[C#]
public String FormatName;

See Also

FormatDetails Class | Alvas.Audio Namespace


FormatDetails.FormatTag Field

Waveform-audio format tag that the FormatDetails structure describes.

[Visual Basic]
Public FormatTag As Integer
[C#]
public Int32 FormatTag;

See Also

FormatDetails Class | Alvas.Audio Namespace


FormatDetails.Support Field

Driver-support flags specific to the specified format.

[Visual Basic]
Public Support As Integer
[C#]
public Int32 Support;

See Also

FormatDetails Class | Alvas.Audio Namespace


FormatDetails Properties

The properties of the FormatDetails structure are listed below. For a complete list of FormatDetails structure members, see the FormatDetails Members topic.

Public Instance Properties

ShowFormatTag Gets or sets the value indicating whether show format tag in ToString.

See Also

FormatDetails Class | Alvas.Audio Namespace


ShowFormatTag Property

Alvas.Audio Class Library

FormatDetails.ShowFormatTag Property

Gets or sets the value indicating whether show format tag in ToString.

[Visual Basic]
Public Property ShowFormatTag As Boolean
[C#]
public Boolean ShowFormatTag {get; set;}

See Also

FormatDetails Class | Alvas.Audio Namespace


FormatDetails Methods

The methods of the FormatDetails structure are listed below. For a complete list of FormatDetails structure members, see the FormatDetails Members topic.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns the fully qualified type name of this instance.

See Also

FormatDetails Class | Alvas.Audio Namespace


FormatDetails.ToString Method

Returns the fully qualified type name of this instance.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

A String containing a fully qualified type name.

See Also

FormatDetails Class | Alvas.Audio Namespace


FormatTagDetails Structure

The FormatTagDetails structure details a waveform-audio format tag for an ACM driver.

For a list of all members of this type, see FormatTagDetails Members.

System.Object
ValueType
FormatTagDetails

[Visual Basic]
Public Structure FormatTagDetails
Implements IComparable
[C#]
public struct FormatTagDetails : IComparable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

FormatTagDetails Members | Alvas.Audio Namespace


FormatTagDetails Members

FormatTagDetails overview

Public Instance Fields

Driver |
FormatSize | Largest total size in bytes of the waveform-audio format of the FormatTag type. For example, this member will be 16 for PCM and 50 for ADPCM.
FormatTag | Waveform-audio format tag that the FormatTagDetails structure describes.
FormatTagIndex | Index of the format tag for which details will be retrieved. The index ranges from zero to one less than the number of format tags supported by an ACM driver.
FormatTagName | String that describes the FormatTag type.
StandardFormats | Number of standard formats of the FormatTag type; that is, the combination of all sample rates, bits per sample, channels, and so on. This value can specify all formats supported by the driver, but not necessarily.
Support | Driver-support flags specific to the format tag.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

FormatTagDetails Class | Alvas.Audio Namespace


FormatTagDetails Fields

The fields of the FormatTagDetails structure are listed below. For a complete list of FormatTagDetails structure members, see the FormatTagDetails Members topic.

Public Instance Fields

Driver |
FormatSize | Largest total size in bytes of the waveform-audio format of the FormatTag type. For example, this member will be 16 for PCM and 50 for ADPCM.
FormatTag | Waveform-audio format tag that the FormatTagDetails structure describes.
FormatTagIndex | Index of the format tag for which details will be retrieved. The index ranges from zero to one less than the number of format tags supported by an ACM driver.
FormatTagName | String that describes the FormatTag type.
StandardFormats | Number of standard formats of the FormatTag type; that is, the combination of all sample rates, bits per sample, channels, and so on. This value can specify all formats supported by the driver, but not necessarily.
Support | Driver-support flags specific to the format tag.

See Also

FormatTagDetails Class | Alvas.Audio Namespace


FormatTagDetails.Driver Field

[Visual Basic]
Public Driver As Integer
[C#]
public Int32 Driver;

See Also

FormatTagDetails Class | Alvas.Audio Namespace


FormatTagDetails.FormatSize Field

Largest total size in bytes of the waveform-audio format of the FormatTag type. For example, this member will be 16 for PCM and 50 for ADPCM.

[Visual Basic]
Public FormatSize As Integer
[C#]
public Int32 FormatSize;

See Also

FormatTagDetails Class | Alvas.Audio Namespace


FormatTagDetails.FormatTag Field

Waveform-audio format tag that the FormatTagDetails structure describes.

[Visual Basic]
Public FormatTag As Integer
[C#]
public Int32 FormatTag;

See Also

FormatTagDetails Class | Alvas.Audio Namespace


FormatTagDetails.FormatTagIndex Field

Index of the format tag for which details will be retrieved. The index ranges from zero to one less than the number of format tags supported by an ACM driver.

[Visual Basic]
Public FormatTagIndex As Integer
[C#]
public Int32 FormatTagIndex;

See Also

FormatTagDetails Class | Alvas.Audio Namespace


FormatTagDetails.FormatTagName Field

String that describes the FormatTag type.

[Visual Basic]
Public FormatTagName As String
[C#]
public String FormatTagName;

See Also

FormatTagDetails Class | Alvas.Audio Namespace


FormatTagDetails.StandardFormats Field

Number of standard formats of the FormatTag type; that is, the combination of all sample rates, bits per sample, channels, and so on. This value can specify all formats supported by the driver, but not necessarily.

[Visual Basic]
Public StandardFormats As Integer
[C#]
public Int32 StandardFormats;

See Also

FormatTagDetails Class | Alvas.Audio Namespace


FormatTagDetails.Support Field

Driver-support flags specific to the format tag.

[Visual Basic]
Public Support As Integer
[C#]
public Int32 Support;

See Also

FormatTagDetails Class | Alvas.Audio Namespace


FormatTagDetails Methods

The methods of the FormatTagDetails structure are listed below. For a complete list of FormatTagDetails structure members, see the FormatTagDetails Members topic.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

FormatTagDetails Class | Alvas.Audio Namespace


FormatTagDetails.ToString Method

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

See Also

FormatTagDetails Class | Alvas.Audio Namespace


GargleAudioEffect Class

The gargle effect modulates the amplitude of the signal.

For a list of all members of this type, see GargleAudioEffect Members.

System.Object
AudioEffect
GargleAudioEffect

[Visual Basic]
Public Class GargleAudioEffect
Inherits
[C#]
public class GargleAudioEffect : AudioEffect

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

GargleAudioEffect Members | Alvas.Audio Namespace


GargleAudioEffect Members

GargleAudioEffect overview

Public Instance Properties

HasProcessInPlace (inherited from AudioEffect) Checks can whether process in place

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessInPlace (inherited from AudioEffect) | Process in place audio data and put the resulting audio data into data array
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GargleAudioEffect Class | Alvas.Audio Namespace


Genre Enumeration

Genre list for ID3 tag version 1.0

[Visual Basic]
Public Enum Genre
Inherits
[C#]
public enum Genre

Members

Member Name | Description
Blues | Blues
ClassicRock | Classic Rock
Country | Country
Dance | Dance
Disco | Disco
Funk | Funk
Grunge | Grunge
Hip_Hop | Hip-Hop
Jazz | Jazz
Metal | Metal
NewAge | New Age
Oldies | Oldies
OtherGenre | Other Genre
Pop | Pop
RnB | R&B
Rap | Rap
Reggae | Reggae
Rock | Rock
Techno | Techno
Industrial | Industrial
Alternative | Alternative
Ska | Ska
DeathMetal | Death Metal
Pranks | Pranks
Soundtrack | Soundtrack
Euro_Techno | Euro-Techno
Ambient | Ambient
Trip_Hop | Trip-Hop
Vocal | Vocal
JazznFunk | Jazz&Funk
Fusion | Fusion
Trance | Trance
Classical | Classical
Instrumental | Instrumental
Acid | Acid
House | House
Game | Game
SoundClip | Sound Clip
Gospel | Gospel
Noise | Noise
AlternativRock | Alternativ Rock
Bass | Bass
Soul | Soul
Punk | Punk
Space | Space
Meditative | Meditative
InstrumentalPop | Instrumental Pop
InstrumentalRock | Instrumental Rock
Ethnic | Ethnic
Gothic | Gothic
Darkwave | Darkwave
Techno_Industrial | Techno-Industrial
Electronic | Electronic
Pop_Folk | Pop-Folk
Eurodance | Eurodance
Dream | Dream
SouthernRock | Southern Rock
Comedy | Comedy
Cult | Cult
Gangsta | Gangsta
Top40 | Top 40
ChristianRap | Christian Rap
Pop_Funk | Pop/Funk
Jungle | Jungle
NativeUS | Native US
Carbaret | Carbaret
NewWave | New Wave
Psychedelic | Psychedelic
Rave | Rave
Showtunes | Showtunes
Trailer | Trailer
Lo_Fi | Lo-Fi
Tribal | Tribal
AcidPunk | Acid Punk
AcidJazz | Acid Jazz
Polka | Polka
Retro | Retro
Musical | Musical
RocknRoll | Rock & Roll
HardRock | Hard Rock
Folk | Folk
Folk_Rock | Folk-Rock
NationalFolk | National Folk
Swing | Swing
FastFusion | Fast Fusion
Bebop | Bebop
Latin | Latin
Revival | Revival
Celtic | Celtic
Bluegrass | Bluegrass
Avantgarde | Avantgarde
GothicRock | Gothic Rock
ProgressiveRock | Progressive Rock
PsychadelicRock | Psychadelic Rock
SymphonicRock | Symphonic Rock
SlowRock | Slow Rock
BigBand | Big Band
Chorus | Chorus
EasyListening | Easy Listening
Acoustic | Acoustic
Homour | Homour
Speech | Speech
Chanson | Chanson
Opera | Opera
ChamberMusic | Chamber Music
Sonata | Sonata
Symphony | Symphony
BootyBass | Booty Bass
Primus | Primus
PornGroove | Porn Groove
Satire | Satire
SlowJam | Slow Jam
Club | Club
Tango | Tango
Samba | Samba
Folklore | Folklore
Ballad | Ballad
PowerBallad | Power Ballad
RythmicSoul | Rythmic Soul
Freestyle | Freestyle
Duet | Duet
PunkRock | Punk Rock
DrumSolo | Drum Solo
Acapella | Acapella
Euor_House | Euor-House
DanceHall | Dance Hall
Goa | Goa
DrumnBass | Drum & Bass
Club_House | Club-House
Hardcore | Hardcore
Terror | Terror
Indie | Indie
BritPop | BritPop
Negerpunk | Negerpunk
PolskPunk | Polsk Punk
Beat | Beat
ChristianGangsta | Christian Gangsta
HeavyMetal | Heavy Metal
BlackMetal | Black Metal
Crossover | Crossover
Contemporary | Contemporary
ChristianRock | Christian Rock
Merengue | Merengue
Salsa | Salsa
TrashMetal | Trash Metal
Anime | Anime
JPop | JPop
SynthPop | SynthPop
None | Undefined genre

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Alvas.Audio Namespace


HResult Class

HResult

For a list of all members of this type, see HResult Members.

System.Object
HResult

[Visual Basic]
MustInherit NotInheritable Public Class HResult
[C#]
public static class HResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

HResult Members | Alvas.Audio Namespace


HResult Members

HResult overview

Public Static (Shared) Fields

E_INVALIDARG | E_INVALIDARG (from winerror.h)
S_FALSE | S_FALSE
S_OK | S_OK

Public Static (Shared) Methods

MAKE_HRESULT MAKE_HRESULT macro

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

HResult Class | Alvas.Audio Namespace


HResult Fields

The fields of the HResult class are listed below. For a complete list of HResult class members, see the HResult Members topic.

Public Static (Shared) Fields

E_INVALIDARG | E_INVALIDARG (from winerror.h)
S_FALSE | S_FALSE
S_OK | S_OK

See Also

HResult Class | Alvas.Audio Namespace


HResult.E_INVALIDARG Field

E_INVALIDARG (from winerror.h)

[Visual Basic]
Public Const E_INVALIDARG As Integer = -2147483645
[C#]
public const Int32 E_INVALIDARG = -2147483645;

See Also

HResult Class | Alvas.Audio Namespace


HResult.S_FALSE Field

S_FALSE

[Visual Basic]
Public Const S_FALSE As Integer = 1
[C#]
public const Int32 S_FALSE = 1;

See Also

HResult Class | Alvas.Audio Namespace


HResult.S_OK Field

S_OK

[Visual Basic]
Public Const S_OK As Integer = 0
[C#]
public const Int32 S_OK = 0;

See Also

HResult Class | Alvas.Audio Namespace


HResult Methods

The methods of the HResult class are listed below. For a complete list of HResult class members, see the HResult Members topic.

Public Static (Shared) Methods

MAKE_HRESULT MAKE_HRESULT macro

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

HResult Class | Alvas.Audio Namespace


HResult.MAKE_HRESULT Method

MAKE_HRESULT macro

[Visual Basic]
Public Shared Function MAKE_HRESULT( _
ByVal sev As Integer, _
ByVal fac As Integer, _
ByVal code As Integer _
) As Integer
[C#]
public static int MAKE_HRESULT(
Int32 sev,
Int32 fac,
Int32 code
);

See Also

HResult Class | Alvas.Audio Namespace


I3DL2ReverbAudioEffect Class

I3DL2Reverb audio effect

For a list of all members of this type, see I3DL2ReverbAudioEffect Members.

System.Object
AudioEffect
I3DL2ReverbAudioEffect

[Visual Basic]
Public Class I3DL2ReverbAudioEffect
Inherits
[C#]
public class I3DL2ReverbAudioEffect : AudioEffect

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

I3DL2ReverbAudioEffect Members | Alvas.Audio Namespace


I3DL2ReverbAudioEffect Members

I3DL2ReverbAudioEffect overview

Public Instance Properties

HasProcessInPlace (inherited from AudioEffect) Checks can whether process in place

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessInPlace (inherited from AudioEffect) | Process in place audio data and put the resulting audio data into data array
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

I3DL2ReverbAudioEffect Class | Alvas.Audio Namespace


IAudioReader Interface

IAudioReader interface provides methods for reading audio data.

For a list of all members of this type, see IAudioReader Members.

Alvas.Audio.IAudioReader
IAudioReadWriter

[Visual Basic]
Public Interface IAudioReader
[C#]
public interface IAudioReader

Types that implement IAudioReader

Type | Description
AudioReader | Represents a reader that can read an audio data from the stream. This class is abstract.
AuReader | Reads an audio data from the .AU and .SND streams.
AviReader | Reads audio data from the Avi stream.
DsReader | Reads audio data using DirectShow.
Mp3Reader | Reads audio data from the Mp3 stream.
Mp3ReadWriter | Reads/writes audio data from/to the Mp3 stream.
RawReader | Reads an audio data from the headerless stream. Slinear, Gsm, A-law, mu-law etc.
RawReadWriter | Reads/writes an audio data from/to the headerless stream. Slinear, Gsm, A-law, mu-law etc.
WaveReader | Reads WAVE (waveform audio format) data from the stream.
WaveReadWriter | Reads/writes audio data from/to the Wave stream.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

IAudioReader Members | Alvas.Audio Namespace


IAudioReader Members

IAudioReader overview

Public Instance Methods

Close | Closes the current reader and the underlying stream.
GetDurationInMS | Gets audio stream duration in milliseconds.
GetLengthInBytes | Gets audio stream length in bytes.
Milliseconds2Bytes | Converts from milliseconds to bytes for current stream.
ReadData | Overloaded. Reads all audio data from the stream.
ReadDataInBytes | Overloaded. Reads audio data from the stream.
ReadFormat | Reads an audio format.

See Also

IAudioReader Interface | Alvas.Audio Namespace


IAudioReader Methods

The methods of the IAudioReader interface are listed below. For a complete list of IAudioReader interface members, see the IAudioReader Members topic.

Public Instance Methods

Close | Closes the current reader and the underlying stream.
GetDurationInMS | Gets audio stream duration in milliseconds.
GetLengthInBytes | Gets audio stream length in bytes.
Milliseconds2Bytes | Converts from milliseconds to bytes for current stream.
ReadData | Overloaded. Reads all audio data from the stream.
ReadDataInBytes | Overloaded. Reads audio data from the stream.
ReadFormat | Reads an audio format.

See Also

IAudioReader Interface | Alvas.Audio Namespace


IAudioReader.Close Method

Closes the current reader and the underlying stream.

[Visual Basic]
Sub Close()
[C#]
void Close();

See Also

IAudioReader Interface | Alvas.Audio Namespace


IAudioReader.GetDurationInMS Method

Gets audio stream duration in milliseconds.

[Visual Basic]
Function GetDurationInMS() As Integer
[C#]
int GetDurationInMS();

Return Value

See Also

IAudioReader Interface | Alvas.Audio Namespace


IAudioReader.GetLengthInBytes Method

Gets audio stream length in bytes.

[Visual Basic]
Function GetLengthInBytes() As Integer
[C#]
int GetLengthInBytes();

Return Value

See Also

IAudioReader Interface | Alvas.Audio Namespace


IAudioReader.Milliseconds2Bytes Method

Converts from milliseconds to bytes for current stream.

[Visual Basic]
Function Milliseconds2Bytes( _
ByVal milliseconds As Integer _
) As Integer
[C#]
int Milliseconds2Bytes(
Int32 milliseconds
);

Parameters

milliseconds
Time, expressed in milliseconds.

Return Value

See Also

IAudioReader Interface | Alvas.Audio Namespace


ReadData Method

Alvas.Audio Class Library

IAudioReader.ReadData Method

Reads all audio data from the stream.

Overload List

Reads all audio data from the stream.

byte[] ReadData();

Reads audio data from the stream.

byte[] ReadData(Int32);

Reads audio data from the stream.

byte[] ReadData(Int32,Int32);

See Also

IAudioReader Interface | Alvas.Audio Namespace


IAudioReader.ReadData Method ()

Reads all audio data from the stream.

[Visual Basic]
Function ReadData() As Byte()
[C#]
byte[] ReadData();

Return Value

audio data array

See Also

IAudioReader Interface | Alvas.Audio Namespace | IAudioReader.ReadData Overload List


IAudioReader.ReadData Method (Int32)

Reads audio data from the stream.

[Visual Basic]
Function ReadData( _
ByVal skipSeconds As Integer _
) As Byte()
[C#]
byte[] ReadData(
Int32 skipSeconds
);

Parameters

skipSeconds
skip seconds

Return Value

See Also

IAudioReader Interface | Alvas.Audio Namespace | IAudioReader.ReadData Overload List


IAudioReader.ReadData Method (Int32, Int32)

Reads audio data from the stream.

[Visual Basic]
Function ReadData( _
ByVal skipSeconds As Integer, _
ByVal readSeconds As Integer _
) As Byte()
[C#]
byte[] ReadData(
Int32 skipSeconds,
Int32 readSeconds
);

Parameters

skipSeconds
skip seconds
readSeconds
read seconds

Return Value

See Also

IAudioReader Interface | Alvas.Audio Namespace | IAudioReader.ReadData Overload List


ReadDataInBytes Method

Alvas.Audio Class Library

IAudioReader.ReadDataInBytes Method

Reads audio data from the stream.

Overload List

Reads audio data from the stream.

byte[] ReadDataInBytes(Int32);

Reads audio data from the stream.

byte[] ReadDataInBytes(Int32,Int32);

See Also

IAudioReader Interface | Alvas.Audio Namespace


IAudioReader.ReadDataInBytes Method (Int32)

Reads audio data from the stream.

[Visual Basic]
Function ReadDataInBytes( _
ByVal skipBytes As Integer _
) As Byte()
[C#]
byte[] ReadDataInBytes(
Int32 skipBytes
);

Parameters

skipBytes
Skips length of bytes. Use Milliseconds2Bytes for this parameter.

Return Value

See Also

IAudioReader Interface | Alvas.Audio Namespace | IAudioReader.ReadDataInBytes Overload List


IAudioReader.ReadDataInBytes Method (Int32, Int32)

Reads audio data from the stream.

[Visual Basic]
Function ReadDataInBytes( _
ByVal skipBytes As Integer, _
ByVal readBytes As Integer _
) As Byte()
[C#]
byte[] ReadDataInBytes(
Int32 skipBytes,
Int32 readBytes
);

Parameters

skipBytes
Skips length of bytes. Use Milliseconds2Bytes for this parameter.
readBytes
Reads length of bytes. Use Milliseconds2Bytes for this parameter.

Return Value

See Also

IAudioReader Interface | Alvas.Audio Namespace | IAudioReader.ReadDataInBytes Overload List


IAudioReader.ReadFormat Method

Reads an audio format.

[Visual Basic]
Function ReadFormat() As IntPtr
[C#]
IntPtr ReadFormat();

Return Value

See Also

IAudioReader Interface | Alvas.Audio Namespace


IAudioReadWriter Interface

IAudioReadWriter interface provides methods for reading/writing audio data.

[Visual Basic]
Public Interface IAudioReadWriter
Implements IAudioReader, IAudioWriter
[C#]
public interface IAudioReadWriter : IAudioReader, IAudioWriter

Types that implement IAudioReadWriter

Type | Description
Mp3ReadWriter | Reads/writes audio data from/to the Mp3 stream.
RawReadWriter | Reads/writes an audio data from/to the headerless stream. Slinear, Gsm, A-law, mu-law etc.
WaveReadWriter | Reads/writes audio data from/to the Wave stream.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Alvas.Audio Namespace


IAudioWriter Interface

IAudioWriter interface provides methods for writing audio data.

For a list of all members of this type, see IAudioWriter Members.

Alvas.Audio.IAudioWriter
IAudioReadWriter

[Visual Basic]
Public Interface IAudioWriter
[C#]
public interface IAudioWriter

Types that implement IAudioWriter

Type | Description
AudioWriter | Represents a writer that can write an audio data to the stream. This class is abstract.
Mp3ReadWriter | Reads/writes audio data from/to the Mp3 stream.
Mp3Writer | Writes MP3 data to the stream.
RawReadWriter | Reads/writes an audio data from/to the headerless stream. Slinear, Gsm, A-law, mu-law etc.
RawWriter | Writes an audio data to the headerless stream. Slinear, Gsm, A-law, mu-law etc.
WaveReadWriter | Reads/writes audio data from/to the Wave stream.
WaveWriter | Writes WAVE (waveform audio format) data to the stream.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

IAudioWriter Members | Alvas.Audio Namespace


IAudioWriter Members

IAudioWriter overview

Public Instance Methods

WriteData Overloaded. Writes an audio byte array

See Also

IAudioWriter Interface | Alvas.Audio Namespace


IAudioWriter Methods

The methods of the IAudioWriter interface are listed below. For a complete list of IAudioWriter interface members, see the IAudioWriter Members topic.

Public Instance Methods

WriteData Overloaded. Writes an audio byte array

See Also

IAudioWriter Interface | Alvas.Audio Namespace


WriteData Method

Alvas.Audio Class Library

IAudioWriter.WriteData Method

Writes an audio byte array

Overload List

Writes an audio byte array

void WriteData(Byte[]);

Writes an audio byte array to the underlying stream from specified position.

long WriteData(Byte[],Int64);

Writes an audio byte array from specified position in specified mode

long WriteData(Byte[],Int64,WriteMode);

See Also

IAudioWriter Interface | Alvas.Audio Namespace


IAudioWriter.WriteData Method (Byte[])

Writes an audio byte array

[Visual Basic]
Sub WriteData( _
ByVal buffer As Byte() _
)
[C#]
void WriteData(
Byte[] buffer
);

Parameters

buffer

See Also

IAudioWriter Interface | Alvas.Audio Namespace | IAudioWriter.WriteData Overload List


IAudioWriter.WriteData Method (Byte[], Int64)

Writes an audio byte array to the underlying stream from specified position.

[Visual Basic]
Function WriteData( _
ByVal buffer As Byte(), _
ByVal position As Long _
) As Long
[C#]
long WriteData(
Byte[] buffer,
Int64 position
);

Parameters

buffer
A byte array containing the data to write.
position
Data position in bytes

Return Value

Returns new data position in bytes

See Also

IAudioWriter Interface | Alvas.Audio Namespace | IAudioWriter.WriteData Overload List


IAudioWriter.WriteData Method (Byte[], Int64, WriteMode)

Writes an audio byte array from specified position in specified mode

[Visual Basic]
Function WriteData( _
ByVal buffer As Byte(), _
ByVal position As Long, _
ByVal mode As WriteMode _
) As Long
[C#]
long WriteData(
Byte[] buffer,
Int64 position,
WriteMode mode
);

Parameters

buffer
audio byte array
position
position
mode
mode

Return Value

See Also

IAudioWriter Interface | Alvas.Audio Namespace | IAudioWriter.WriteData Overload List


ID3v1 Class

Class represents a ID3 tag version 1.0 for MPEG Layer3 streams.

For a list of all members of this type, see ID3v1 Members.

System.Object
ID3v1

[Visual Basic]
Public Class ID3v1
[C#]
public class ID3v1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

ID3v1 Members | Alvas.Audio Namespace


ID3v1 Members

ID3v1 overview

Public Instance Constructors

ID3v1 Constructor Initializes a new instance of the ID3v1 class.

Public Instance Properties

Album | 30 characters of the album name
Artist | 30 characters of the artist name
Comment | The comment. Up to 30 characters
Genre | Genre. Use Genre.None if undefined.
Title | 30 characters of the title
Year | A four-digit year

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ID3v1 Class | Alvas.Audio Namespace


ID3v1 Constructor

Initializes a new instance of the ID3v1 class.

[Visual Basic]
Public Sub New()
[C#]
public ID3v1();

See Also

ID3v1 Class | Alvas.Audio Namespace


ID3v1 Properties

The properties of the ID3v1 class are listed below. For a complete list of ID3v1 class members, see the ID3v1 Members topic.

Public Instance Properties

Album | 30 characters of the album name
Artist | 30 characters of the artist name
Comment | The comment. Up to 30 characters
Genre | Genre. Use Genre.None if undefined.
Title | 30 characters of the title
Year | A four-digit year

See Also

ID3v1 Class | Alvas.Audio Namespace


Album Property

Alvas.Audio Class Library

ID3v1.Album Property

30 characters of the album name

[Visual Basic]
Public Property Album As String
[C#]
public String Album {get; set;}

See Also

ID3v1 Class | Alvas.Audio Namespace


Artist Property

Alvas.Audio Class Library

ID3v1.Artist Property

30 characters of the artist name

[Visual Basic]
Public Property Artist As String
[C#]
public String Artist {get; set;}

See Also

ID3v1 Class | Alvas.Audio Namespace


Comment Property

Alvas.Audio Class Library

ID3v1.Comment Property

The comment. Up to 30 characters

[Visual Basic]
Public Property Comment As String
[C#]
public String Comment {get; set;}

See Also

ID3v1 Class | Alvas.Audio Namespace


Genre Property

Alvas.Audio Class Library

ID3v1.Genre Property

Genre. Use Genre.None if undefined.

[Visual Basic]
Public Property Genre As Genre
[C#]
public Genre Genre {get; set;}

See Also

ID3v1 Class | Alvas.Audio Namespace


Title Property

Alvas.Audio Class Library

ID3v1.Title Property

30 characters of the title

[Visual Basic]
Public Property Title As String
[C#]
public String Title {get; set;}

See Also

ID3v1 Class | Alvas.Audio Namespace


Year Property

Alvas.Audio Class Library

ID3v1.Year Property

A four-digit year

[Visual Basic]
Public Property Year As String
[C#]
public String Year {get; set;}

See Also

ID3v1 Class | Alvas.Audio Namespace


MediaBuffer Class

Attempting to implement the COM IMediaBuffer interface as a .NET object Not sure what will happen when I pass this to an unmanaged object

For a list of all members of this type, see MediaBuffer Members.

System.Object
MediaBuffer

[Visual Basic]
Public Class MediaBuffer
Implements IDisposable
[C#]
public class MediaBuffer : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

MediaBuffer Members | Alvas.Audio Namespace


MediaBuffer Members

MediaBuffer overview

Public Instance Constructors

MediaBuffer Constructor Creates a new Media Buffer

Public Instance Properties

Length Length of data in the media buffer

Public Instance Methods

Dispose | Dispose and free memory for buffer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadData | Loads data into this buffer
RetrieveData | Retrieves the data in the output buffer
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MediaBuffer Class | Alvas.Audio Namespace


MediaBuffer Constructor

Creates a new Media Buffer

[Visual Basic]
Public Sub New( _
ByVal maxLength As Integer _
)
[C#]
public MediaBuffer(
Int32 maxLength
);

Parameters

maxLength
Maximum length in bytes

See Also

MediaBuffer Class | Alvas.Audio Namespace


MediaBuffer Properties

The properties of the MediaBuffer class are listed below. For a complete list of MediaBuffer class members, see the MediaBuffer Members topic.

Public Instance Properties

Length Length of data in the media buffer

See Also

MediaBuffer Class | Alvas.Audio Namespace


Length Property

Alvas.Audio Class Library

MediaBuffer.Length Property

Length of data in the media buffer

[Visual Basic]
Public Property Length As Integer
[C#]
public Int32 Length {get; set;}

See Also

MediaBuffer Class | Alvas.Audio Namespace


MediaBuffer Methods

The methods of the MediaBuffer class are listed below. For a complete list of MediaBuffer class members, see the MediaBuffer Members topic.

Public Instance Methods

Dispose | Dispose and free memory for buffer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadData | Loads data into this buffer
RetrieveData | Retrieves the data in the output buffer
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MediaBuffer Class | Alvas.Audio Namespace


MediaBuffer.Dispose Method

Dispose and free memory for buffer

[Visual Basic]
NotOverridable Public Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

MediaBuffer Class | Alvas.Audio Namespace


MediaBuffer.LoadData Method

Loads data into this buffer

[Visual Basic]
Public Sub LoadData( _
ByVal data As Byte(), _
ByVal bytes As Integer _
)
[C#]
public void LoadData(
Byte[] data,
Int32 bytes
);

Parameters

data
Data to load
bytes
Number of bytes to load

See Also

MediaBuffer Class | Alvas.Audio Namespace


MediaBuffer.RetrieveData Method

Retrieves the data in the output buffer

[Visual Basic]
Public Sub RetrieveData( _
ByVal data As Byte(), _
ByVal offset As Integer _
)
[C#]
public void RetrieveData(
Byte[] data,
Int32 offset
);

Parameters

data
buffer to retrieve into
offset
offset within that buffer

See Also

MediaBuffer Class | Alvas.Audio Namespace


Mixer Class

Mixer component.

For a list of all members of this type, see Mixer Members.

System.Object
MarshalByRefObject
Component
Mixer

[Visual Basic]
Public Class Mixer
Inherits
[C#]
public class Mixer : Component

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example shows simple using of Mixer class.

public static void TestMixer()
{
    PlayerEx plex = new PlayerEx();
    int playerMixerNo = plex.GetMixerNo();
    bool isMute = GetPlayerMute(playerMixerNo);
    SetPlayerMute(playerMixerNo, !isMute);

    RecorderEx rex = new RecorderEx();
    SetRecorderVolumeMax(rex.GetMixerNo());
}

private static void SetRecorderVolumeMax(int recorderMixerNo)
{
    Mixer mx = new Mixer();
    mx.MixerNo = recorderMixerNo;
    DestinationLine dl = mx.GetDestination(Mixer.Recording);
    if (dl != null)
    {
        foreach (MixerControl mc in dl.Controls)
        {
            if (mc is MixerIntControl)
            {
                MixerIntControl mic = mc as MixerIntControl;
                mic.Value = mic.Maximum;
                break;
            }
            else if (mc is MixerListControl)
            {
                MixerListControl mlc = dl.Controls[0] as MixerListControl;
                MixerLine ml = mlc.Lines[mlc.Value];
                foreach (MixerControl ctrl in ml.Controls)
                {
                    if (ctrl is MixerIntControl)
                    {
                        MixerIntControl mic = ctrl as MixerIntControl;
                        mic.Value = mic.Maximum;
                        break;
                    }
                }
            }
        }
    }
}

private static bool GetPlayerMute(int playerMixerNo)
{
    Mixer mx = new Mixer();
    mx.MixerNo = playerMixerNo;
    DestinationLine dl = mx.GetDestination(Mixer.Playback);
    if (dl != null)
    {
        foreach (MixerControl ctrl in dl.Controls)
        {
            if (ctrl is MixerMuteControl)
            {
                return ((MixerMuteControl)ctrl).Value != 0;
            }
        }
    }
    return false;
}

private static void SetPlayerMute(int playerMixerNo, bool value)
{
    Mixer mx = new Mixer();
    mx.MixerNo = playerMixerNo;
    DestinationLine dl = mx.GetDestination(Mixer.Playback);
    if (dl != null)
    {
        foreach (MixerControl ctrl in dl.Controls)
        {
            if (ctrl is MixerMuteControl)
            {
                ((MixerMuteControl)ctrl).Value = (value) ? 1 : 0;
                break;
            }
        }
    }
}

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Mixer Members | Alvas.Audio Namespace


Mixer Members

Mixer overview

Public Static (Shared) Fields

Playback | Playback line
Recording | Recording line

Public Static (Shared) Properties

MixerCount Gets mixer quantity.

Public Static (Shared) Methods

GetMixerName Gets the name of the mixer by index.

Public Instance Constructors

Mixer Constructor

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
MixerID | Gets the mixer ID.
MixerName | Gets the name of the mixer.
MixerNo | Gets or sets the current mixer number.
Site (inherited from Component) | Gets or sets the ISite of the Component.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDestination | Gets the destination line.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

Public Instance Events

ControlChange | ControlChange event
Disposed (inherited from Component) | Occurs when the component is disposed by a call to the Dispose method.

See Also

Mixer Class | Alvas.Audio Namespace


Mixer Constructor

[Visual Basic]
Public Sub New()
[C#]
public Mixer();

See Also

Mixer Class | Alvas.Audio Namespace


Mixer Fields

The fields of the Mixer class are listed below. For a complete list of Mixer class members, see the Mixer Members topic.

Public Static (Shared) Fields

Playback | Playback line
Recording | Recording line

See Also

Mixer Class | Alvas.Audio Namespace


Mixer.Playback Field

Playback line

[Visual Basic]
Public Shared ReadOnly Playback As Integer
[C#]
public static readonly Int32 Playback;

See Also

Mixer Class | Alvas.Audio Namespace


Mixer.Recording Field

Recording line

[Visual Basic]
Public Shared ReadOnly Recording As Integer
[C#]
public static readonly Int32 Recording;

See Also

Mixer Class | Alvas.Audio Namespace


Mixer Properties

The properties of the Mixer class are listed below. For a complete list of Mixer class members, see the Mixer Members topic.

Public Static (Shared) Properties

MixerCount Gets mixer quantity.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
MixerID | Gets the mixer ID.
MixerName | Gets the name of the mixer.
MixerNo | Gets or sets the current mixer number.
Site (inherited from Component) | Gets or sets the ISite of the Component.

See Also

Mixer Class | Alvas.Audio Namespace


MixerCount Property

Alvas.Audio Class Library

Mixer.MixerCount Property

Gets mixer quantity.

[Visual Basic]
Public Shared ReadOnly Property MixerCount As Integer
[C#]
public static Int32 MixerCount {get;}

Property Value

The mixer quantity.

See Also

Mixer Class | Alvas.Audio Namespace


MixerID Property

Alvas.Audio Class Library

Mixer.MixerID Property

Gets the mixer ID.

[Visual Basic]
Public ReadOnly Property MixerID As Integer
[C#]
public Int32 MixerID {get;}

Property Value

The mixer ID.

See Also

Mixer Class | Alvas.Audio Namespace


MixerName Property

Alvas.Audio Class Library

Mixer.MixerName Property

Gets the name of the mixer.

[Visual Basic]
Public ReadOnly Property MixerName As String
[C#]
public String MixerName {get;}

Property Value

The name of the mixer.

See Also

Mixer Class | Alvas.Audio Namespace


MixerNo Property

Alvas.Audio Class Library

Mixer.MixerNo Property

Gets or sets the current mixer number.

[Visual Basic]
Public Property MixerNo As Integer
[C#]
public Int32 MixerNo {get; set;}

Property Value

The mixer number.

See Also

Mixer Class | Alvas.Audio Namespace


Mixer Methods

The methods of the Mixer class are listed below. For a complete list of Mixer class members, see the Mixer Members topic.

Public Static (Shared) Methods

GetMixerName Gets the name of the mixer by index.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDestination | Gets the destination line.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

See Also

Mixer Class | Alvas.Audio Namespace


Mixer.GetDestination Method

Gets the destination line.

[Visual Basic]
Public Function GetDestination( _
ByVal lineType As Integer _
) As DestinationLine
[C#]
public DestinationLine GetDestination(
Int32 lineType
);

Parameters

lineType
Type of the line.

Return Value

See Also

Mixer Class | Alvas.Audio Namespace


Mixer.GetMixerName Method

Gets the name of the mixer by index.

[Visual Basic]
Public Shared Function GetMixerName( _
ByVal index As Integer _
) As String
[C#]
public static string GetMixerName(
Int32 index
);

Parameters

index
The index.

Return Value

Example

This example shows simple using of GetMixerName method.

for (int i = 0; i < Mixer.MixerCount; i++)
{
   Console.WriteLine(Mixer.GetMixerName(i));
}

See Also

Mixer Class | Alvas.Audio Namespace


Mixer Events

The events of the Mixer class are listed below. For a complete list of Mixer class members, see the Mixer Members topic.

Public Instance Events

ControlChange | ControlChange event
Disposed (inherited from Component) | Occurs when the component is disposed by a call to the Dispose method.

See Also

Mixer Class | Alvas.Audio Namespace


Mixer.ControlChange Event

ControlChange event

[Visual Basic]
Public Event ControlChange As Mixer#ControlChangeEventHandler
[C#]
public event Mixer.ControlChangeEventHandler ControlChange;

See Also

Mixer Class | Alvas.Audio Namespace


Mixer.ControlChangeEventHandler Delegate

ControlChange event handler

[Visual Basic]
Public Delegate Sub Mixer.ControlChangeEventHandler( _
ByVal sender As Object, _
ByVal e As ControlChangeEventArgs _
)
[C#]
public delegate void Mixer.ControlChangeEventHandler(
Object sender,
ControlChangeEventArgs e
);

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Alvas.Audio Namespace


MixerBoolControl Class

Mixer boolean control

For a list of all members of this type, see MixerBoolControl Members.

System.Object
MixerControl
MixerBoolControl
MixerMuteControl

[Visual Basic]
Public Class MixerBoolControl
Inherits
[C#]
public class MixerBoolControl : MixerControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

MixerBoolControl Members | Alvas.Audio Namespace


MixerBoolControl Members

MixerBoolControl overview

Public Instance Properties

ControlID (inherited from MixerControl) | Gets the control ID.
MixerID (inherited from MixerControl) | Gets the mixer ID.
MixerLine (inherited from MixerControl) | Gets the mixer line.
Name (inherited from MixerControl) | Gets the control name.
ShortName (inherited from MixerControl) | Gets the short name of the control.
Value (inherited from MixerControl) | Gets or sets the control value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MixerBoolControl Class | Alvas.Audio Namespace


MixerControl Class

Mixer control.

For a list of all members of this type, see MixerControl Members.

System.Object
MixerControl
MixerBoolControl
MixerIntControl
MixerListControl

[Visual Basic]
MustInherit Public Class MixerControl
[C#]
public class MixerControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

MixerControl Members | Alvas.Audio Namespace


MixerControl Members

MixerControl overview

Public Instance Properties

ControlID | Gets the control ID.
MixerID | Gets the mixer ID.
MixerLine | Gets the mixer line.
Name | Gets the control name.
ShortName | Gets the short name of the control.
Value | Gets or sets the control value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MixerControl Class | Alvas.Audio Namespace


MixerControl Properties

The properties of the MixerControl class are listed below. For a complete list of MixerControl class members, see the MixerControl Members topic.

Public Instance Properties

ControlID | Gets the control ID.
MixerID | Gets the mixer ID.
MixerLine | Gets the mixer line.
Name | Gets the control name.
ShortName | Gets the short name of the control.
Value | Gets or sets the control value.

See Also

MixerControl Class | Alvas.Audio Namespace


ControlID Property

Alvas.Audio Class Library

MixerControl.ControlID Property

Gets the control ID.

[Visual Basic]
Public ReadOnly Property ControlID As Integer
[C#]
public Int32 ControlID {get;}

Property Value

The control ID.

See Also

MixerControl Class | Alvas.Audio Namespace


MixerID Property

Alvas.Audio Class Library

MixerControl.MixerID Property

Gets the mixer ID.

[Visual Basic]
Public ReadOnly Property MixerID As Integer
[C#]
public Int32 MixerID {get;}

Property Value

The mixer ID.

See Also

MixerControl Class | Alvas.Audio Namespace


MixerLine Property

Alvas.Audio Class Library

MixerControl.MixerLine Property

Gets the mixer line.

[Visual Basic]
Public ReadOnly Property MixerLine As MixerLine
[C#]
public MixerLine MixerLine {get;}

Property Value

The mixer line.

See Also

MixerControl Class | Alvas.Audio Namespace


Name Property

Alvas.Audio Class Library

MixerControl.Name Property

Gets the control name.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public String Name {get;}

Property Value

The name.

See Also

MixerControl Class | Alvas.Audio Namespace


ShortName Property

Alvas.Audio Class Library

MixerControl.ShortName Property

Gets the short name of the control.

[Visual Basic]
Public ReadOnly Property ShortName As String
[C#]
public String ShortName {get;}

Property Value

The short name.

See Also

MixerControl Class | Alvas.Audio Namespace


Value Property

Alvas.Audio Class Library

MixerControl.Value Property

Gets or sets the control value.

[Visual Basic]
Public Property Value As Integer
[C#]
public Int32 Value {get; set;}

Property Value

The control value.

See Also

MixerControl Class | Alvas.Audio Namespace


MixerException Class

The exception that is thrown when an Mixer error occurs.

For a list of all members of this type, see MixerException Members.

System.Object
Exception
AudioException
MixerException

[Visual Basic]
Public Class MixerException
Inherits
[C#]
public class MixerException : AudioException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

MixerException Members | Alvas.Audio Namespace


MixerException Members

MixerException overview

Public Instance Constructors

MixerException Constructor Initializes a new instance of the MixerException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode | Gets the error code that is associated with this exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from AudioException) |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

See Also

MixerException Class | Alvas.Audio Namespace


MixerException Constructor

Initializes a new instance of the MixerException class.

[Visual Basic]
Public Sub New( _
ByVal errorCode As Integer _
)
[C#]
public MixerException(
Int32 errorCode
);

Parameters

errorCode
The error code.

See Also

MixerException Class | Alvas.Audio Namespace


MixerException Properties

The properties of the MixerException class are listed below. For a complete list of MixerException class members, see the MixerException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode | Gets the error code that is associated with this exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from AudioException) |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

MixerException Class | Alvas.Audio Namespace


ErrorCode Property

Alvas.Audio Class Library

MixerException.ErrorCode Property

Gets the error code that is associated with this exception.

[Visual Basic]
Public ReadOnly Property ErrorCode As Integer
[C#]
public Int32 ErrorCode {get;}

See Also

MixerException Class | Alvas.Audio Namespace


MixerIntControl Class

Mixer integer control

For a list of all members of this type, see MixerIntControl Members.

System.Object
MixerControl
MixerIntControl

[Visual Basic]
Public Class MixerIntControl
Inherits
[C#]
public class MixerIntControl : MixerControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

MixerIntControl Members | Alvas.Audio Namespace


MixerIntControl Members

MixerIntControl overview

Public Instance Properties

ControlID (inherited from MixerControl) | Gets the control ID.
Maximum | Gets the maximum value of the control.
Minimum | Gets the minimum value of the control.
MixerID (inherited from MixerControl) | Gets the mixer ID.
MixerLine (inherited from MixerControl) | Gets the mixer line.
Name (inherited from MixerControl) | Gets the control name.
ShortName (inherited from MixerControl) | Gets the short name of the control.
Steps | Gets the steps.
Value (inherited from MixerControl) | Gets or sets the control value.
Values | Gets or sets the control values.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MixerIntControl Class | Alvas.Audio Namespace


MixerIntControl Properties

The properties of the MixerIntControl class are listed below. For a complete list of MixerIntControl class members, see the MixerIntControl Members topic.

Public Instance Properties

ControlID (inherited from MixerControl) | Gets the control ID.
Maximum | Gets the maximum value of the control.
Minimum | Gets the minimum value of the control.
MixerID (inherited from MixerControl) | Gets the mixer ID.
MixerLine (inherited from MixerControl) | Gets the mixer line.
Name (inherited from MixerControl) | Gets the control name.
ShortName (inherited from MixerControl) | Gets the short name of the control.
Steps | Gets the steps.
Value (inherited from MixerControl) | Gets or sets the control value.
Values | Gets or sets the control values.

See Also

MixerIntControl Class | Alvas.Audio Namespace


Maximum Property

Alvas.Audio Class Library

MixerIntControl.Maximum Property

Gets the maximum value of the control.

[Visual Basic]
Public ReadOnly Property Maximum As Integer
[C#]
public Int32 Maximum {get;}

Property Value

The maximum.

See Also

MixerIntControl Class | Alvas.Audio Namespace


Minimum Property

Alvas.Audio Class Library

MixerIntControl.Minimum Property

Gets the minimum value of the control.

[Visual Basic]
Public ReadOnly Property Minimum As Integer
[C#]
public Int32 Minimum {get;}

Property Value

The minimum.

See Also

MixerIntControl Class | Alvas.Audio Namespace


Steps Property

Alvas.Audio Class Library

MixerIntControl.Steps Property

Gets the steps.

[Visual Basic]
Public ReadOnly Property Steps As Integer
[C#]
public Int32 Steps {get;}

Property Value

The steps.

See Also

MixerIntControl Class | Alvas.Audio Namespace


Values Property

Alvas.Audio Class Library

MixerIntControl.Values Property

Gets or sets the control values.

[Visual Basic]
Public Property Values As Integer()
[C#]
public Int32[] Values {get; set;}

See Also

MixerIntControl Class | Alvas.Audio Namespace


MixerLine Class

Mixer line.

For a list of all members of this type, see MixerLine Members.

System.Object
MixerLine
DestinationLine

[Visual Basic]
Public Class MixerLine
[C#]
public class MixerLine

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

MixerLine Members | Alvas.Audio Namespace


MixerLine Members

MixerLine overview

Public Instance Properties

Channels | Gets quantity of channels for mixer line
Controls | Gets the controls of the mixer line.
MixerID | Gets the mixer ID.
MixerLineID | Gets the mixer line ID.
Name | Gets the mixer line name.
ShortName | Gets the short name of the mixer line.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents the current Object.

See Also

MixerLine Class | Alvas.Audio Namespace


MixerLine Properties

The properties of the MixerLine class are listed below. For a complete list of MixerLine class members, see the MixerLine Members topic.

Public Instance Properties

Channels | Gets quantity of channels for mixer line
Controls | Gets the controls of the mixer line.
MixerID | Gets the mixer ID.
MixerLineID | Gets the mixer line ID.
Name | Gets the mixer line name.
ShortName | Gets the short name of the mixer line.

See Also

MixerLine Class | Alvas.Audio Namespace


Channels Property

Alvas.Audio Class Library

MixerLine.Channels Property

Gets quantity of channels for mixer line

[Visual Basic]
Public ReadOnly Property Channels As Integer
[C#]
public Int32 Channels {get;}

See Also

MixerLine Class | Alvas.Audio Namespace


Controls Property

Alvas.Audio Class Library

MixerLine.Controls Property

Gets the controls of the mixer line.

[Visual Basic]
Public ReadOnly Property Controls As MixerControl()
[C#]
public MixerControl[] Controls {get;}

Property Value

The controls.

See Also

MixerLine Class | Alvas.Audio Namespace


MixerID Property

Alvas.Audio Class Library

MixerLine.MixerID Property

Gets the mixer ID.

[Visual Basic]
Public ReadOnly Property MixerID As Integer
[C#]
public Int32 MixerID {get;}

Property Value

The mixer ID.

See Also

MixerLine Class | Alvas.Audio Namespace


MixerLineID Property

Alvas.Audio Class Library

MixerLine.MixerLineID Property

Gets the mixer line ID.

[Visual Basic]
Public ReadOnly Property MixerLineID As Integer
[C#]
public Int32 MixerLineID {get;}

Property Value

The mixer line ID.

See Also

MixerLine Class | Alvas.Audio Namespace


Name Property

Alvas.Audio Class Library

MixerLine.Name Property

Gets the mixer line name.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public String Name {get;}

Property Value

The name.

See Also

MixerLine Class | Alvas.Audio Namespace


ShortName Property

Alvas.Audio Class Library

MixerLine.ShortName Property

Gets the short name of the mixer line.

[Visual Basic]
Public ReadOnly Property ShortName As String
[C#]
public String ShortName {get;}

Property Value

The short name.

See Also

MixerLine Class | Alvas.Audio Namespace


MixerLine Methods

The methods of the MixerLine class are listed below. For a complete list of MixerLine class members, see the MixerLine Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents the current Object.

See Also

MixerLine Class | Alvas.Audio Namespace


MixerLine.ToString Method

Returns a String that represents the current Object.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

A String that represents the current Object.

See Also

MixerLine Class | Alvas.Audio Namespace


MixerListControl Class

Mixer list control

For a list of all members of this type, see MixerListControl Members.

System.Object
MixerControl
MixerListControl

[Visual Basic]
Public Class MixerListControl
Inherits
[C#]
public class MixerListControl : MixerControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

MixerListControl Members | Alvas.Audio Namespace


MixerListControl Members

MixerListControl overview

Public Instance Properties

ControlID (inherited from MixerControl) | Gets the control ID.
Lines | Gets the mixer lines.
MixerID (inherited from MixerControl) | Gets the mixer ID.
MixerLine (inherited from MixerControl) | Gets the mixer line.
Name (inherited from MixerControl) | Gets the control name.
ShortName (inherited from MixerControl) | Gets the short name of the control.
Value (inherited from MixerControl) | Gets or sets the control value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MixerListControl Class | Alvas.Audio Namespace


MixerListControl Properties

The properties of the MixerListControl class are listed below. For a complete list of MixerListControl class members, see the MixerListControl Members topic.

Public Instance Properties

ControlID (inherited from MixerControl) | Gets the control ID.
Lines | Gets the mixer lines.
MixerID (inherited from MixerControl) | Gets the mixer ID.
MixerLine (inherited from MixerControl) | Gets the mixer line.
Name (inherited from MixerControl) | Gets the control name.
ShortName (inherited from MixerControl) | Gets the short name of the control.
Value (inherited from MixerControl) | Gets or sets the control value.

See Also

MixerListControl Class | Alvas.Audio Namespace


Lines Property

Alvas.Audio Class Library

MixerListControl.Lines Property

Gets the mixer lines.

[Visual Basic]
Public ReadOnly Property Lines As MixerLine()
[C#]
public MixerLine[] Lines {get;}

Property Value

The mixer lines.

See Also

MixerListControl Class | Alvas.Audio Namespace


MixerMuteControl Class

Mixer mute control

For a list of all members of this type, see MixerMuteControl Members.

System.Object
MixerControl
MixerBoolControl
MixerMuteControl

[Visual Basic]
Public Class MixerMuteControl
Inherits
[C#]
public class MixerMuteControl : MixerBoolControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

MixerMuteControl Members | Alvas.Audio Namespace


MixerMuteControl Members

MixerMuteControl overview

Public Instance Properties

ControlID (inherited from MixerControl) | Gets the control ID.
MixerID (inherited from MixerControl) | Gets the mixer ID.
MixerLine (inherited from MixerControl) | Gets the mixer line.
Name (inherited from MixerControl) | Gets the control name.
ShortName (inherited from MixerControl) | Gets the short name of the control.
Value (inherited from MixerControl) | Gets or sets the control value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MixerMuteControl Class | Alvas.Audio Namespace


Mp3Reader Class

Reads audio data from the Mp3 stream.

For a list of all members of this type, see Mp3Reader Members.

System.Object
BinaryReader
AudioReader
Mp3Reader
Mp3ReadWriter

[Visual Basic]
Public Class Mp3Reader
Inherits
[C#]
public class Mp3Reader : AudioReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example shows simple using of Mp3Reader.

Mp3Reader mr = new Mp3Reader(File.OpenRead("123.mp3"));
IntPtr format = mr.ReadFormat();
byte[] data = mr.ReadData();
mr.Close();

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Mp3Reader Members | Alvas.Audio Namespace


Mp3Reader Members

Mp3Reader overview

Public Instance Constructors

Mp3Reader Constructor Initializes a new instance of the Mp3Reader class for the specified stream.

Public Instance Properties

BaseStream (inherited from BinaryReader) Exposes access to the underlying stream of the BinaryReader.

Public Instance Methods

Close (inherited from BinaryReader) | Closes the current reader and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS | Gets audio stream duration in milliseconds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeWave | Changes MP3 stream to Wave stream.
Milliseconds2Bytes (inherited from AudioReader) | Converts from milliseconds to bytes for current stream.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadData | Overloaded. Reads audio data from the stream.
ReadDataInBytes | Overloaded. Reads audio data from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadFormat | Reads an audio format.
ReadID3v1Tag | Reads ID3 tag version 1
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Mp3Reader Class | Alvas.Audio Namespace


Mp3Reader Constructor

Initializes a new instance of the Mp3Reader class for the specified stream.

[Visual Basic]
Public Sub New( _
ByVal input As Stream _
)
[C#]
public Mp3Reader(
Stream input
);

Parameters

input
The stream to be read.

See Also

Mp3Reader Class | Alvas.Audio Namespace


Mp3Reader Methods

The methods of the Mp3Reader class are listed below. For a complete list of Mp3Reader class members, see the Mp3Reader Members topic.

Public Instance Methods

Close (inherited from BinaryReader) | Closes the current reader and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS | Gets audio stream duration in milliseconds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeWave | Changes MP3 stream to Wave stream.
Milliseconds2Bytes (inherited from AudioReader) | Converts from milliseconds to bytes for current stream.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadData | Overloaded. Reads audio data from the stream.
ReadDataInBytes | Overloaded. Reads audio data from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadFormat | Reads an audio format.
ReadID3v1Tag | Reads ID3 tag version 1
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Mp3Reader Class | Alvas.Audio Namespace


Mp3Reader.GetDurationInMS Method

Gets audio stream duration in milliseconds.

[Visual Basic]
Overrides Public Function GetDurationInMS() As Integer _
Implements IAudioReader.GetDurationInMS
[C#]
public override int GetDurationInMS();

Return Value

Implements

IAudioReader.GetDurationInMS

See Also

Mp3Reader Class | Alvas.Audio Namespace


Mp3Reader.GetLengthInBytes Method

Gets audio stream length in bytes.

[Visual Basic]
Overrides Public Function GetLengthInBytes() As Integer _
Implements IAudioReader.GetLengthInBytes
[C#]
public override int GetLengthInBytes();

Return Value

Implements

IAudioReader.GetLengthInBytes

See Also

Mp3Reader Class | Alvas.Audio Namespace


Mp3Reader.MakeWave Method

Changes MP3 stream to Wave stream.

[Visual Basic]
Public Sub MakeWave( _
ByVal stream As Stream _
)
[C#]
public void MakeWave(
Stream stream
);

Parameters

stream
stream with resulting wave header and data

Example

This example shows simple using of MakeWave method.

string mp3File = "in.mp3";
using (Mp3Reader mr = new Mp3Reader(File.OpenRead(mp3File)))
{
    string wavFile = "out.wav";
    using (FileStream fs = File.Create(wavFile))
    {
        mr.MakeWave(fs);
    }
}

See Also

Mp3Reader Class | Alvas.Audio Namespace


ReadData Method

Alvas.Audio Class Library

Mp3Reader.ReadData Method

Reads all audio data from the stream.

Overload List

Reads all audio data from the stream.

public override byte[] ReadData();

Reads audio data from the stream.

public override byte[] ReadData(Int32);

Reads audio data from the stream.

public override byte[] ReadData(Int32,Int32);

See Also

Mp3Reader Class | Alvas.Audio Namespace


Mp3Reader.ReadData Method ()

Reads all audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadData() As Byte() _
Implements IAudioReader.ReadData
[C#]
public override byte[] ReadData();

Return Value

audio data array

Implements

IAudioReader.ReadData

See Also

Mp3Reader Class | Alvas.Audio Namespace | Mp3Reader.ReadData Overload List


Mp3Reader.ReadData Method (Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadData( _
ByVal skipSeconds As Integer _
) As Byte() _
Implements IAudioReader.ReadData
[C#]
public override byte[] ReadData(
Int32 skipSeconds
);

Parameters

skipSeconds
skip seconds

Return Value

Implements

IAudioReader.ReadData

See Also

Mp3Reader Class | Alvas.Audio Namespace | Mp3Reader.ReadData Overload List


Mp3Reader.ReadData Method (Int32, Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadData( _
ByVal skipSeconds As Integer, _
ByVal readSeconds As Integer _
) As Byte() _
Implements IAudioReader.ReadData
[C#]
public override byte[] ReadData(
Int32 skipSeconds,
Int32 readSeconds
);

Parameters

skipSeconds
skip seconds
readSeconds
read seconds

Return Value

Implements

IAudioReader.ReadData

See Also

Mp3Reader Class | Alvas.Audio Namespace | Mp3Reader.ReadData Overload List


ReadDataInBytes Method

Alvas.Audio Class Library

Mp3Reader.ReadDataInBytes Method

Reads audio data from the stream.

Overload List

Reads audio data from the stream.

public override byte[] ReadDataInBytes(Int32);

Reads audio data from the stream.

public override byte[] ReadDataInBytes(Int32,Int32);

See Also

Mp3Reader Class | Alvas.Audio Namespace


Mp3Reader.ReadDataInBytes Method (Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadDataInBytes( _
ByVal skipBytes As Integer _
) As Byte() _
Implements IAudioReader.ReadDataInBytes
[C#]
public override byte[] ReadDataInBytes(
Int32 skipBytes
);

Parameters

skipBytes
Skips length of bytes. Use Milliseconds2Bytes for this parameter.

Return Value

Implements

IAudioReader.ReadDataInBytes

See Also

Mp3Reader Class | Alvas.Audio Namespace | Mp3Reader.ReadDataInBytes Overload List


Mp3Reader.ReadDataInBytes Method (Int32, Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadDataInBytes( _
ByVal skipBytes As Integer, _
ByVal readBytes As Integer _
) As Byte() _
Implements IAudioReader.ReadDataInBytes
[C#]
public override byte[] ReadDataInBytes(
Int32 skipBytes,
Int32 readBytes
);

Parameters

skipBytes
Skips length of bytes. Use Milliseconds2Bytes for this parameter.
readBytes
Reads length of bytes. Use Milliseconds2Bytes for this parameter.

Return Value

Implements

IAudioReader.ReadDataInBytes

See Also

Mp3Reader Class | Alvas.Audio Namespace | Mp3Reader.ReadDataInBytes Overload List


Mp3Reader.ReadFormat Method

Reads an audio format.

[Visual Basic]
Overrides Public Function ReadFormat() As IntPtr _
Implements IAudioReader.ReadFormat
[C#]
public override IntPtr ReadFormat();

Return Value

Implements

IAudioReader.ReadFormat

See Also

Mp3Reader Class | Alvas.Audio Namespace


Mp3Reader.ReadID3v1Tag Method

Reads ID3 tag version 1

[Visual Basic]
Public Function ReadID3v1Tag() As ID3v1
[C#]
public ID3v1 ReadID3v1Tag();

Return Value

Example

This example shows simple using of ReadID3v1Tag method.

Mp3Reader br = new Mp3Reader(File.OpenRead(fileName));
ID3v1 id3v1 = br.ReadID3v1Tag();
br.Close();
if (id3v1 != null)
{
    Console.WriteLine(id3v1.Title);
}

See Also

Mp3Reader Class | Alvas.Audio Namespace


Mp3ReaderException Class

The exception that is thrown when a mp3 reader error occurs.

For a list of all members of this type, see Mp3ReaderException Members.

System.Object
Exception
AudioException
Mp3ReaderException

[Visual Basic]
Public Class Mp3ReaderException
Inherits
[C#]
public class Mp3ReaderException : AudioException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Mp3ReaderException Members | Alvas.Audio Namespace


Mp3ReaderException Members

Mp3ReaderException overview

Public Instance Constructors

Mp3ReaderException Overloaded. Initializes a new instance of the Mp3ReaderException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

See Also

Mp3ReaderException Class | Alvas.Audio Namespace


Mp3ReaderException Constructor

Overload List

public Mp3ReaderException();

public Mp3ReaderException(String);

See Also

Mp3ReaderException Class | Alvas.Audio Namespace


Mp3ReaderException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public Mp3ReaderException(
String message
);

Parameters

message

See Also

Mp3ReaderException Class | Alvas.Audio Namespace | Mp3ReaderException Constructor Overload List


Mp3ReaderException Constructor ()

[Visual Basic]
Overloads Public Sub New()
[C#]
public Mp3ReaderException();

See Also

Mp3ReaderException Class | Alvas.Audio Namespace | Mp3ReaderException Constructor Overload List


Mp3ReaderException Properties

The properties of the Mp3ReaderException class are listed below. For a complete list of Mp3ReaderException class members, see the Mp3ReaderException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

Mp3ReaderException Class | Alvas.Audio Namespace


Message Property

Alvas.Audio Class Library

Mp3ReaderException.Message Property

[Visual Basic]
Overrides Public ReadOnly Property Message As String
[C#]
public override String Message {get;}

See Also

Mp3ReaderException Class | Alvas.Audio Namespace


Mp3ReadWriter Class

Reads/writes audio data from/to the Mp3 stream.

For a list of all members of this type, see Mp3ReadWriter Members.

System.Object
BinaryReader
AudioReader
Mp3Reader
Mp3ReadWriter

[Visual Basic]
Public Class Mp3ReadWriter
Inherits
Implements IAudioReadWriter, IAudioWriter
[C#]
public class Mp3ReadWriter : Mp3Reader, IAudioReadWriter, IAudioWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Mp3ReadWriter Members | Alvas.Audio Namespace


Mp3ReadWriter Members

Mp3ReadWriter overview

Public Instance Constructors

Mp3ReadWriter Overloaded. Initializes a new instance of the Mp3ReadWriter class.

Public Instance Properties

BaseStream (inherited from BinaryReader) Exposes access to the underlying stream of the BinaryReader.

Public Instance Methods

Close | Closes the current reader and writer and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS (inherited from Mp3Reader) | Gets audio stream duration in milliseconds.
GetFormat | Returns pointer to audio format.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes (inherited from Mp3Reader) | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeWave (inherited from Mp3Reader) | Changes MP3 stream to Wave stream.
Milliseconds2Bytes (inherited from AudioReader) | Converts from milliseconds to bytes for current stream.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadData (inherited from Mp3Reader) | Overloaded. Reads audio data from the stream.
ReadDataInBytes (inherited from Mp3Reader) | Overloaded. Reads audio data from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadFormat (inherited from Mp3Reader) | Reads an audio format.
ReadID3v1Tag (inherited from Mp3Reader) | Reads ID3 tag version 1
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteData | Overloaded. Writes an audio byte array to the underlying stream.
WriteID3v1Tag | Writes ID3 tag version 1

See Also

Mp3ReadWriter Class | Alvas.Audio Namespace


Mp3ReadWriter Constructor

Initializes a new instance of the Mp3ReadWriter class based on the supplied stream and a specific audio format.

Overload List

public Mp3ReadWriter(Stream);

Initializes a new instance of the Mp3ReadWriter class based on the supplied stream and a specific audio format.

public Mp3ReadWriter(Stream,IntPtr);

See Also

Mp3ReadWriter Class | Alvas.Audio Namespace


Mp3ReadWriter Constructor (Stream, IntPtr)

Initializes a new instance of the Mp3ReadWriter class based on the supplied stream and a specific audio format.

[Visual Basic]
Overloads Public Sub New( _
ByVal input As Stream, _
ByVal format As IntPtr _
)
[C#]
public Mp3ReadWriter(
Stream input,
IntPtr format
);

Parameters

input
The supplied stream.
format
The audio format.

See Also

Mp3ReadWriter Class | Alvas.Audio Namespace | Mp3ReadWriter Constructor Overload List


Mp3ReadWriter Constructor (Stream)

[Visual Basic]
Overloads Public Sub New( _
ByVal input As Stream _
)
[C#]
public Mp3ReadWriter(
Stream input
);

Parameters

input

See Also

Mp3ReadWriter Class | Alvas.Audio Namespace | Mp3ReadWriter Constructor Overload List


Mp3ReadWriter Methods

The methods of the Mp3ReadWriter class are listed below. For a complete list of Mp3ReadWriter class members, see the Mp3ReadWriter Members topic.

Public Instance Methods

Close | Closes the current reader and writer and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS (inherited from Mp3Reader) | Gets audio stream duration in milliseconds.
GetFormat | Returns pointer to audio format.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes (inherited from Mp3Reader) | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeWave (inherited from Mp3Reader) | Changes MP3 stream to Wave stream.
Milliseconds2Bytes (inherited from AudioReader) | Converts from milliseconds to bytes for current stream.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadData (inherited from Mp3Reader) | Overloaded. Reads audio data from the stream.
ReadDataInBytes (inherited from Mp3Reader) | Overloaded. Reads audio data from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadFormat (inherited from Mp3Reader) | Reads an audio format.
ReadID3v1Tag (inherited from Mp3Reader) | Reads ID3 tag version 1
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteData | Overloaded. Writes an audio byte array to the underlying stream.
WriteID3v1Tag | Writes ID3 tag version 1

See Also

Mp3ReadWriter Class | Alvas.Audio Namespace


Mp3ReadWriter.Close Method

Closes the current reader and writer and the underlying stream.

[Visual Basic]
Overrides Public Sub Close() _
Implements IAudioReader.Close
[C#]
public override void Close();

Implements

IAudioReader.Close

See Also

Mp3ReadWriter Class | Alvas.Audio Namespace


Mp3ReadWriter.GetFormat Method

Returns pointer to audio format.

[Visual Basic]
Public Function GetFormat() As IntPtr
[C#]
public IntPtr GetFormat();

Return Value

See Also

Mp3ReadWriter Class | Alvas.Audio Namespace


WriteData Method

Alvas.Audio Class Library

Mp3ReadWriter.WriteData Method

Writes an audio byte array to the underlying stream.

Overload List

Writes an audio byte array to the underlying stream.

public void WriteData(Byte[]);

Writes an audio byte array to the underlying stream from specified position.

public long WriteData(Byte[],Int64);

Writes an audio byte array to the underlying stream from specified position in specified mode.

public long WriteData(Byte[],Int64,WriteMode);

See Also

Mp3ReadWriter Class | Alvas.Audio Namespace


Mp3ReadWriter.WriteData Method (Byte[])

Writes an audio byte array to the underlying stream.

[Visual Basic]
NotOverridable Overloads Public Sub WriteData( _
ByVal buffer As Byte() _
) _
Implements IAudioWriter.WriteData
[C#]
public void WriteData(
Byte[] buffer
);

Parameters

buffer
A byte array containing the data to write.

Implements

IAudioWriter.WriteData

See Also

Mp3ReadWriter Class | Alvas.Audio Namespace | Mp3ReadWriter.WriteData Overload List


Mp3ReadWriter.WriteData Method (Byte[], Int64)

Writes an audio byte array to the underlying stream from specified position.

[Visual Basic]
NotOverridable Overloads Public Function WriteData( _
ByVal buffer As Byte(), _
ByVal position As Long _
) As Long _
Implements IAudioWriter.WriteData
[C#]
public long WriteData(
Byte[] buffer,
Int64 position
);

Parameters

buffer
A byte array containing the data to write.
position
Data position in bytes

Return Value

Returns new data position in bytes

Implements

IAudioWriter.WriteData

See Also

Mp3ReadWriter Class | Alvas.Audio Namespace | Mp3ReadWriter.WriteData Overload List


Mp3ReadWriter.WriteData Method (Byte[], Int64, WriteMode)

Writes an audio byte array to the underlying stream from specified position in specified mode.

[Visual Basic]
NotOverridable Overloads Public Function WriteData( _
ByVal buffer As Byte(), _
ByVal position As Long, _
ByVal mode As WriteMode _
) As Long _
Implements IAudioWriter.WriteData
[C#]
public long WriteData(
Byte[] buffer,
Int64 position,
WriteMode mode
);

Parameters

buffer
A byte array containing the data to write.
position
Data position in bytes
mode
mode

Return Value

Returns new data position in bytes

Implements

IAudioWriter.WriteData

See Also

Mp3ReadWriter Class | Alvas.Audio Namespace | Mp3ReadWriter.WriteData Overload List


Mp3ReadWriter.WriteID3v1Tag Method

Writes ID3 tag version 1

[Visual Basic]
Public Sub WriteID3v1Tag( _
ByVal tag As ID3v1 _
)
[C#]
public void WriteID3v1Tag(
ID3v1 tag
);

Parameters

tag

Example

This example shows simple using of WriteID3v1Tag method.

 //removes ID3v1 tags from audio stream
Mp3ReadWriter mrw1 = new Mp3ReadWriter(File.Open("in1.mp3", FileMode.Open, FileAccess.ReadWrite));
mrw1.WriteID3v1Tag(null);
mrw1.Close();

 //writes ID3v1 tags into audio stream
Mp3ReadWriter mrw2 = new Mp3ReadWriter(File.Open("in2.mp3", FileMode.Open, FileAccess.ReadWrite));
ID3v1 tag = new ID3v1();
tag.Comment = "Comment...";
mrw2.WriteID3v1Tag(tag);
mrw2.Close();

See Also

Mp3ReadWriter Class | Alvas.Audio Namespace


Mp3Writer Class

Writes MP3 data to the stream.

For a list of all members of this type, see Mp3Writer Members.

System.Object
BinaryWriter
AudioWriter
Mp3Writer

[Visual Basic]
Public Class Mp3Writer
Inherits
[C#]
public class Mp3Writer : AudioWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example shows simple using of Mp3Writer class.

Mp3Writer mw = new Mp3Writer(File.Create("new.mp3"));
mw.WriteData(dataMp3);
mw.Close();

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Mp3Writer Members | Alvas.Audio Namespace


Mp3Writer Members

Mp3Writer overview

Public Instance Constructors

Mp3Writer Constructor Initializes a new instance of the Mp3Writer class based on the supplied stream.

Public Instance Properties

BaseStream (inherited from BinaryWriter) Gets the underlying stream of the BinaryWriter.

Public Instance Methods

Close (inherited from BinaryWriter) | Closes the current BinaryWriter and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from BinaryWriter) | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Seek (inherited from BinaryWriter) | Sets the position within the current stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from BinaryWriter) | Overloaded. Writes a one-byte Boolean value to the current stream, with 0 representing false and 1 representing true.
WriteData | Overloaded. Writes an audio byte array to the underlying stream.

See Also

Mp3Writer Class | Alvas.Audio Namespace


Mp3Writer Constructor

Initializes a new instance of the Mp3Writer class based on the supplied stream.

[Visual Basic]
Public Sub New( _
ByVal output As Stream _
)
[C#]
public Mp3Writer(
Stream output
);

Parameters

output
The supplied stream.

See Also

Mp3Writer Class | Alvas.Audio Namespace


Mp3Writer Methods

The methods of the Mp3Writer class are listed below. For a complete list of Mp3Writer class members, see the Mp3Writer Members topic.

Public Instance Methods

Close (inherited from BinaryWriter) | Closes the current BinaryWriter and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from BinaryWriter) | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Seek (inherited from BinaryWriter) | Sets the position within the current stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from BinaryWriter) | Overloaded. Writes a one-byte Boolean value to the current stream, with 0 representing false and 1 representing true.
WriteData | Overloaded. Writes an audio byte array to the underlying stream.

See Also

Mp3Writer Class | Alvas.Audio Namespace


WriteData Method

Alvas.Audio Class Library

Mp3Writer.WriteData Method

Writes an audio byte array to the underlying stream.

Overload List

Writes an audio byte array to the underlying stream.

public override void WriteData(Byte[]);

Writes an audio byte array to the underlying stream from specified position.

public override long WriteData(Byte[],Int64);

Writes an audio byte array to the underlying stream from specified position in specified mode.

public override long WriteData(Byte[],Int64,WriteMode);

See Also

Mp3Writer Class | Alvas.Audio Namespace


Mp3Writer.WriteData Method (Byte[])

Writes an audio byte array to the underlying stream.

[Visual Basic]
Overrides Overloads Public Sub WriteData( _
ByVal buffer As Byte() _
) _
Implements IAudioWriter.WriteData
[C#]
public override void WriteData(
Byte[] buffer
);

Parameters

buffer
A byte array containing the data to write.

Implements

IAudioWriter.WriteData

See Also

Mp3Writer Class | Alvas.Audio Namespace | Mp3Writer.WriteData Overload List


Mp3Writer.WriteData Method (Byte[], Int64)

Writes an audio byte array to the underlying stream from specified position.

[Visual Basic]
Overrides Overloads Public Function WriteData( _
ByVal buffer As Byte(), _
ByVal position As Long _
) As Long _
Implements IAudioWriter.WriteData
[C#]
public override long WriteData(
Byte[] buffer,
Int64 position
);

Parameters

buffer
A byte array containing the data to write.
position
Data position in bytes

Return Value

Returns new data position in bytes

Implements

IAudioWriter.WriteData

See Also

Mp3Writer Class | Alvas.Audio Namespace | Mp3Writer.WriteData Overload List


Mp3Writer.WriteData Method (Byte[], Int64, WriteMode)

Writes an audio byte array to the underlying stream from specified position in specified mode.

[Visual Basic]
Overrides Overloads Public Function WriteData( _
ByVal buffer As Byte(), _
ByVal position As Long, _
ByVal mode As WriteMode _
) As Long _
Implements IAudioWriter.WriteData
[C#]
public override long WriteData(
Byte[] buffer,
Int64 position,
WriteMode mode
);

Parameters

buffer
A byte array containing the data to write.
position
Data position in bytes
mode
mode

Return Value

Returns new data position in bytes

Implements

IAudioWriter.WriteData

See Also

Mp3Writer Class | Alvas.Audio Namespace | Mp3Writer.WriteData Overload List


ParamEqAudioEffect Class

A parametric equalizer amplifies or attenuates signals of a given frequency.

For a list of all members of this type, see ParamEqAudioEffect Members.

System.Object
AudioEffect
ParamEqAudioEffect

[Visual Basic]
Public Class ParamEqAudioEffect
Inherits
[C#]
public class ParamEqAudioEffect : AudioEffect

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

ParamEqAudioEffect Members | Alvas.Audio Namespace


ParamEqAudioEffect Members

ParamEqAudioEffect overview

Public Instance Properties

HasProcessInPlace (inherited from AudioEffect) Checks can whether process in place

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessInPlace (inherited from AudioEffect) | Process in place audio data and put the resulting audio data into data array
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ParamEqAudioEffect Class | Alvas.Audio Namespace


Player Class

Player is a component for audio files playing.

For a list of all members of this type, see Player Members.

System.Object
MarshalByRefObject
Component
Player

[Visual Basic]
Public Class Player
Inherits
[C#]
public class Player : Component

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example shows how simple use Player.

player.FileName = "123.mp3";
player.Play();

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Player Members | Alvas.Audio Namespace


Player Members

Player overview

Public Static (Shared) Methods

GetErrorString Returns string that describes the specified error code.

Public Instance Constructors

Player Constructor

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
DeviceName | Gets the current device name being used to play.
DurationInMS | Gets audio file duration in milliseconds.
FileName | Gets or sets file name for playing.
IsPlaying | Returns true if playing or false otherwise.
LeftVolume | Gets or sets the average volume to the left speaker.
PositionInMS | Gets the current position in milliseconds.
RightVolume | Gets or sets the average volume to the right speaker.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Speed | Gets or Sets the current speed of the device in frames per second.
Status | Gets current device status.
Volume | Gets or sets the average volume to the left and right speaker.

Public Instance Methods

ChangePosition | Changes the current position in milliseconds.
Close | To close playing.
CloseAudioDevices | Closes all audio devices.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Pause | To pause playing.
Play | Overloaded. Plays Wave file data from array
Resume | Resumes playing that has been paused.
Stop | To stop playing.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

Public Instance Events

Disposed (inherited from Component) Occurs when the component is disposed by a call to the Dispose method.

See Also

Player Class | Alvas.Audio Namespace


Player Constructor

[Visual Basic]
Public Sub New()
[C#]
public Player();

See Also

Player Class | Alvas.Audio Namespace


Player Properties

The properties of the Player class are listed below. For a complete list of Player class members, see the Player Members topic.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
DeviceName | Gets the current device name being used to play.
DurationInMS | Gets audio file duration in milliseconds.
FileName | Gets or sets file name for playing.
IsPlaying | Returns true if playing or false otherwise.
LeftVolume | Gets or sets the average volume to the left speaker.
PositionInMS | Gets the current position in milliseconds.
RightVolume | Gets or sets the average volume to the right speaker.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Speed | Gets or Sets the current speed of the device in frames per second.
Status | Gets current device status.
Volume | Gets or sets the average volume to the left and right speaker.

See Also

Player Class | Alvas.Audio Namespace


DeviceName Property

Alvas.Audio Class Library

Player.DeviceName Property

Gets the current device name being used to play.

[Visual Basic]
Public ReadOnly Property DeviceName As String
[C#]
public String DeviceName {get;}

See Also

Player Class | Alvas.Audio Namespace


DurationInMS Property

Alvas.Audio Class Library

Player.DurationInMS Property

Gets audio file duration in milliseconds.

[Visual Basic]
Public ReadOnly Property DurationInMS As Integer
[C#]
public Int32 DurationInMS {get;}

See Also

Player Class | Alvas.Audio Namespace


FileName Property

Alvas.Audio Class Library

Player.FileName Property

Gets or sets file name for playing.

[Visual Basic]
Public Property FileName As String
[C#]
public String FileName {get; set;}

See Also

Player Class | Alvas.Audio Namespace


IsPlaying Property

Alvas.Audio Class Library

Player.IsPlaying Property

Returns true if playing or false otherwise.

[Visual Basic]
Public ReadOnly Property IsPlaying As Boolean
[C#]
public Boolean IsPlaying {get;}

See Also

Player Class | Alvas.Audio Namespace


LeftVolume Property

Alvas.Audio Class Library

Player.LeftVolume Property

Gets or sets the average volume to the left speaker.

[Visual Basic]
Public Property LeftVolume As Integer
[C#]
public Int32 LeftVolume {get; set;}

See Also

Player Class | Alvas.Audio Namespace


PositionInMS Property

Alvas.Audio Class Library

Player.PositionInMS Property

Gets the current position in milliseconds.

[Visual Basic]
Public ReadOnly Property PositionInMS As Integer
[C#]
public Int32 PositionInMS {get;}

See Also

Player Class | Alvas.Audio Namespace


RightVolume Property

Alvas.Audio Class Library

Player.RightVolume Property

Gets or sets the average volume to the right speaker.

[Visual Basic]
Public Property RightVolume As Integer
[C#]
public Int32 RightVolume {get; set;}

See Also

Player Class | Alvas.Audio Namespace


Speed Property

Alvas.Audio Class Library

Player.Speed Property

Gets or Sets the current speed of the device in frames per second.

[Visual Basic]
Public Property Speed As Integer
[C#]
public Int32 Speed {get; set;}

See Also

Player Class | Alvas.Audio Namespace


Status Property

Alvas.Audio Class Library

Player.Status Property

Gets current device status.

[Visual Basic]
Public ReadOnly Property Status As String
[C#]
public String Status {get;}

See Also

Player Class | Alvas.Audio Namespace


Volume Property

Alvas.Audio Class Library

Player.Volume Property

Gets or sets the average volume to the left and right speaker.

[Visual Basic]
Public Property Volume As Integer
[C#]
public Int32 Volume {get; set;}

See Also

Player Class | Alvas.Audio Namespace


Player Methods

The methods of the Player class are listed below. For a complete list of Player class members, see the Player Members topic.

Public Static (Shared) Methods

GetErrorString Returns string that describes the specified error code.

Public Instance Methods

ChangePosition | Changes the current position in milliseconds.
Close | To close playing.
CloseAudioDevices | Closes all audio devices.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Pause | To pause playing.
Play | Overloaded. Plays Wave file data from array
Resume | Resumes playing that has been paused.
Stop | To stop playing.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

See Also

Player Class | Alvas.Audio Namespace


Player.ChangePosition Method

Changes the current position in milliseconds.

[Visual Basic]
Public Function ChangePosition( _
ByVal mS As Integer _
) As Integer
[C#]
public int ChangePosition(
Int32 mS
);

Parameters

mS

Return Value

Returns 0 if successful or error number otherwise. Use GetErrorString static function to describe error number.

See Also

Player Class | Alvas.Audio Namespace


Player.Close Method

To close playing.

[Visual Basic]
Public Function Close() As Integer
[C#]
public int Close();

Return Value

Returns 0 if successful or error number otherwise. Use GetErrorString static function to describe error number.

See Also

Player Class | Alvas.Audio Namespace


Player.CloseAudioDevices Method

Closes all audio devices.

[Visual Basic]
Public Function CloseAudioDevices() As Integer
[C#]
public int CloseAudioDevices();

Return Value

Returns 0 if successful or error number otherwise. Use GetErrorString static function to describe error number.

See Also

Player Class | Alvas.Audio Namespace


Player.GetErrorString Method

Returns string that describes the specified error code.

[Visual Basic]
Public Shared Function GetErrorString( _
ByVal err As Integer _
) As String
[C#]
public static string GetErrorString(
Int32 err
);

Parameters

err
Error code number

Return Value

See Also

Player Class | Alvas.Audio Namespace


Player.Pause Method

To pause playing.

[Visual Basic]
Public Function Pause() As Integer
[C#]
public int Pause();

Return Value

Returns 0 if successful or error number otherwise. Use GetErrorString static function to describe error number.

See Also

Player Class | Alvas.Audio Namespace


Play Method

Alvas.Audio Class Library

Player.Play Method

Plays sound.

Overload List

Plays sound.

public int Play();

Plays Wave file data from array

public int Play(Byte[]);

See Also

Player Class | Alvas.Audio Namespace


Player.Play Method ()

Plays sound.

[Visual Basic]
Overloads Public Function Play() As Integer
[C#]
public int Play();

Return Value

Returns 0 if successful or error number otherwise. Use GetErrorString static function to describe error number.

See Also

Player Class | Alvas.Audio Namespace | Player.Play Overload List


Player.Play Method (Byte[])

Plays Wave file data from array

[Visual Basic]
Overloads Public Function Play( _
ByVal waveData As Byte() _
) As Integer
[C#]
public int Play(
Byte[] waveData
);

Parameters

waveData
Wave file data

Return Value

Example

This example shows simple using of Play method.

Player pl = new Player();
byte[] arr = File.ReadAllBytes(@"in.wav");
pl.Play(arr);

See Also

Player Class | Alvas.Audio Namespace | Player.Play Overload List


Player.Resume Method

Resumes playing that has been paused.

[Visual Basic]
Public Function Resume() As Integer
[C#]
public int Resume();

Return Value

Returns 0 if successful or error number otherwise. Use GetErrorString static function to describe error number.

See Also

Player Class | Alvas.Audio Namespace


Player.Stop Method

To stop playing.

[Visual Basic]
Public Function Stop() As Integer
[C#]
public int Stop();

Return Value

Returns 0 if successful or error number otherwise. Use GetErrorString static function to describe error number.

See Also

Player Class | Alvas.Audio Namespace


PlayerEx Class

PlayerEx is a component for playing sound in PCM, IMA ADPCM, Microsoft ADPCM, CCITT A-Law, CCITT u-Law, GSM 6.10, Windows Media Audio V2, MPEG Layer-3 (mp3) and other wave file format.

For a list of all members of this type, see PlayerEx Members.

System.Object
MarshalByRefObject
Component
PlayerEx

[Visual Basic]
Public Class PlayerEx
Inherits
[C#]
public class PlayerEx : Component

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example shows simple using of PlayerEx class.

public static void TestPlayerEx()
{
    PlayerEx plex = new PlayerEx();
    plex.Done += new PlayerEx.DoneEventHandler(plex_Done);
    Mp3Reader mr = new Mp3Reader(File.OpenRead("in.mp3"));
    IntPtr format = mr.ReadFormat();
    byte[] data = mr.ReadData();
    mr.Close();
    plex.OpenPlayer(format);
    plex.AddData(data);
    plex.StartPlay();
}

static void plex_Done(object sender, DoneEventArgs e)
{
    if (e.IsEndPlaying)
    {
        ((PlayerEx)sender).ClosePlayer();
    }
}

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

PlayerEx Members | Alvas.Audio Namespace


PlayerEx Members

PlayerEx overview

Public Static (Shared) Properties

PlayerCount Gets the number of audio players installed in system.

Public Static (Shared) Methods

GetPlayerName Returns player name by index.

Public Instance Constructors

PlayerEx Overloaded. Initializes a new instance of the PlayerEx class.

Public Instance Properties

BufferSizeInMS | Gets or sets the player buffer size in milliseconds. By default 500 ms.
Container (inherited from Component) | Gets the IContainer that contains the Component.
Format | Gets pointer to audio format.
PlayerID | Gets or sets the current player. If -1 the system uses suitable player.
Site (inherited from Component) | Gets or sets the ISite of the Component.
State | Gets the player state.
VolumeScale | Scales the volume of audio data. 100 is normal volume, 50 is reduced by half, 200 is increased in 2 times

Public Instance Methods

AddData | Adds the audio data for playing.
AddMixData | Adds and mixes the audio data for playing.
ClosePlayer | Closes the player.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetMixerNo | Returns mixer number
GetPosition | Gets the current sound position.
GetQueueLength | Gets audio data queue length
GetType (inherited from Object) | Gets the Type of the current instance.
GetVolume |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
OpenPlayer | Opens the player.
PausePlay | Pauses the play.
QueueClear | Clears audio data queue
ResumePlay | Resumes the play.
SetVolume | Sets the volume.
StartPlay | Plays the audio data.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

Public Instance Events

Close | Occurs when the player is closed after playing.
Disposed (inherited from Component) | Occurs when the component is disposed by a call to the Dispose method.
Done | Occurs when the player returns next portion of the played data.
Open | Occurs when the player is opened for playing.

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx Constructor

Overload List

public PlayerEx();

public PlayerEx(Boolean);

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx Constructor ()

[Visual Basic]
Overloads Public Sub New()
[C#]
public PlayerEx();

See Also

PlayerEx Class | Alvas.Audio Namespace | PlayerEx Constructor Overload List


PlayerEx Constructor (Boolean)

[Visual Basic]
Overloads Public Sub New( _
ByVal isConsole As Boolean _
)
[C#]
public PlayerEx(
Boolean isConsole
);

Parameters

isConsole
true if used in console application or Windows service; otherwise, false.

See Also

PlayerEx Class | Alvas.Audio Namespace | PlayerEx Constructor Overload List


PlayerEx Properties

The properties of the PlayerEx class are listed below. For a complete list of PlayerEx class members, see the PlayerEx Members topic.

Public Static (Shared) Properties

PlayerCount Gets the number of audio players installed in system.

Public Instance Properties

BufferSizeInMS | Gets or sets the player buffer size in milliseconds. By default 500 ms.
Container (inherited from Component) | Gets the IContainer that contains the Component.
Format | Gets pointer to audio format.
PlayerID | Gets or sets the current player. If -1 the system uses suitable player.
Site (inherited from Component) | Gets or sets the ISite of the Component.
State | Gets the player state.
VolumeScale | Scales the volume of audio data. 100 is normal volume, 50 is reduced by half, 200 is increased in 2 times

See Also

PlayerEx Class | Alvas.Audio Namespace


BufferSizeInMS Property

Alvas.Audio Class Library

PlayerEx.BufferSizeInMS Property

Gets or sets the player buffer size in milliseconds. By default 500 ms.

[Visual Basic]
Public Property BufferSizeInMS As Integer
[C#]
public Int32 BufferSizeInMS {get; set;}

See Also

PlayerEx Class | Alvas.Audio Namespace


Format Property

Alvas.Audio Class Library

PlayerEx.Format Property

Gets pointer to audio format.

[Visual Basic]
Public ReadOnly Property Format As IntPtr
[C#]
public IntPtr Format {get;}

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerCount Property

Alvas.Audio Class Library

PlayerEx.PlayerCount Property

Gets the number of audio players installed in system.

[Visual Basic]
Public Shared ReadOnly Property PlayerCount As Integer
[C#]
public static Int32 PlayerCount {get;}

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerID Property

Alvas.Audio Class Library

PlayerEx.PlayerID Property

Gets or sets the current player. If -1 the system uses suitable player.

[Visual Basic]
Public Property PlayerID As Integer
[C#]
public Int32 PlayerID {get; set;}

See Also

PlayerEx Class | Alvas.Audio Namespace


State Property

Alvas.Audio Class Library

PlayerEx.State Property

Gets the player state.

[Visual Basic]
Public ReadOnly Property State As DeviceState
[C#]
public DeviceState State {get;}

See Also

PlayerEx Class | Alvas.Audio Namespace


VolumeScale Property

Alvas.Audio Class Library

PlayerEx.VolumeScale Property

Scales the volume of audio data. 100 is normal volume, 50 is reduced by half, 200 is increased in 2 times

[Visual Basic]
Public Property VolumeScale As Integer
[C#]
public Int32 VolumeScale {get; set;}

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx Methods

The methods of the PlayerEx class are listed below. For a complete list of PlayerEx class members, see the PlayerEx Members topic.

Public Static (Shared) Methods

GetPlayerName Returns player name by index.

Public Instance Methods

AddData | Adds the audio data for playing.
AddMixData | Adds and mixes the audio data for playing.
ClosePlayer | Closes the player.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetMixerNo | Returns mixer number
GetPosition | Gets the current sound position.
GetQueueLength | Gets audio data queue length
GetType (inherited from Object) | Gets the Type of the current instance.
GetVolume |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
OpenPlayer | Opens the player.
PausePlay | Pauses the play.
QueueClear | Clears audio data queue
ResumePlay | Resumes the play.
SetVolume | Sets the volume.
StartPlay | Plays the audio data.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx.AddData Method

Adds the audio data for playing.

[Visual Basic]
Public Sub AddData( _
ByVal data As Byte() _
)
[C#]
public void AddData(
Byte[] data
);

Parameters

data
The audio data.

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx.AddMixData Method

Adds and mixes the audio data for playing.

[Visual Basic]
Public Sub AddMixData( _
ParamArray data As Byte()[) _
)
[C#]
public void AddMixData(
params Byte[][] data
);

Parameters

data
The audio data.

Example

This example shows how mixed audio data plays.

public void PlayMix()
{
        string dir = Path.GetDirectoryName(Application.ExecutablePath);
        string path1 = dir + @"\1.wav";
        WaveReader wr1 = new WaveReader(File.OpenRead(path1));
        IntPtr format = wr1.ReadFormat();
        WaveFormat wf = AudioCompressionManager.GetWaveFormat(format);
        playEx.OpenPlayer(format);//validFormat
        byte[] data1 = wr1.ReadData();
        wr1.Close();
        //----------
        string path2 = dir + @"\2.wav";
        WaveReader wr2 = new WaveReader(File.OpenRead(path2));
        byte[] data2 = wr2.ReadData();
        wr2.Close();
        playEx.AddMixData(data1, data2);
        playEx.StartPlay();
}

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx.ClosePlayer Method

Closes the player.

[Visual Basic]
Public Sub ClosePlayer()
[C#]
public void ClosePlayer();

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx.GetMixerNo Method

Returns mixer number

[Visual Basic]
Public Function GetMixerNo() As Integer
[C#]
public int GetMixerNo();

Return Value

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx.GetPlayerName Method

Returns player name by index.

[Visual Basic]
Public Shared Function GetPlayerName( _
ByVal index As Integer _
) As String
[C#]
public static string GetPlayerName(
Int32 index
);

Parameters

index

Return Value

Example

This example shows simple using of GetPlayerName method.

for (int i = 0; i < PlayerEx.PlayerCount; i++)
{
    Console.WriteLine(PlayerEx.GetPlayerName(i));
}

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx.GetPosition Method

Gets the current sound position.

[Visual Basic]
Public Function GetPosition( _
ByVal time As TimeFormat _
) As Long
[C#]
public long GetPosition(
TimeFormat time
);

Parameters

time
The time parameter specifies the sound position in milliseconds, bytes or samples.

Return Value

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx.GetQueueLength Method

Gets audio data queue length

[Visual Basic]
Public Function GetQueueLength() As Integer
[C#]
public int GetQueueLength();

Return Value

Returns audio data queue length

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx.GetVolume Method

[Visual Basic]
Public Sub GetVolume( _
ByRef leftVolume As Integer, _
ByRef rightVolume As Integer _
)
[C#]
public void GetVolume(
ref Int32& leftVolume,
ref Int32& rightVolume
);

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx.OpenPlayer Method

Opens the player.

[Visual Basic]
Public Sub OpenPlayer( _
ByVal format As IntPtr _
)
[C#]
public void OpenPlayer(
IntPtr format
);

Parameters

format
The format.

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx.PausePlay Method

Pauses the play.

[Visual Basic]
Public Sub PausePlay()
[C#]
public void PausePlay();

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx.QueueClear Method

Clears audio data queue

[Visual Basic]
Public Sub QueueClear()
[C#]
public void QueueClear();

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx.ResumePlay Method

Resumes the play.

[Visual Basic]
Public Sub ResumePlay()
[C#]
public void ResumePlay();

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx.SetVolume Method

Sets the volume.

[Visual Basic]
Public Sub SetVolume( _
ByVal leftVolume As Integer, _
ByVal rightVolume As Integer _
)
[C#]
public void SetVolume(
Int32 leftVolume,
Int32 rightVolume
);

Parameters

leftVolume
The left volume. Value between 0 and ushort.MaxValue.
rightVolume
The right volume. Value between 0 and ushort.MaxValue.

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx.StartPlay Method

Plays the audio data.

[Visual Basic]
Public Sub StartPlay()
[C#]
public void StartPlay();

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx Events

The events of the PlayerEx class are listed below. For a complete list of PlayerEx class members, see the PlayerEx Members topic.

Public Instance Events

Close | Occurs when the player is closed after playing.
Disposed (inherited from Component) | Occurs when the component is disposed by a call to the Dispose method.
Done | Occurs when the player returns next portion of the played data.
Open | Occurs when the player is opened for playing.

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx.Close Event

Occurs when the player is closed after playing.

[Visual Basic]
Public Event Close As EventHandler
[C#]
public event EventHandler Close;

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx.Done Event

Occurs when the player returns next portion of the played data.

[Visual Basic]
Public Event Done As PlayerEx#DoneEventHandler
[C#]
public event PlayerEx.DoneEventHandler Done;

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx.Open Event

Occurs when the player is opened for playing.

[Visual Basic]
Public Event Open As EventHandler
[C#]
public event EventHandler Open;

See Also

PlayerEx Class | Alvas.Audio Namespace


PlayerEx.DoneEventHandler Delegate

Represents the method that will handle the Done event of the PlayerEx.

[Visual Basic]
Public Delegate Sub PlayerEx.DoneEventHandler( _
ByVal sender As Object, _
ByVal e As DoneEventArgs _
)
[C#]
public delegate void PlayerEx.DoneEventHandler(
Object sender,
DoneEventArgs e
);

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Alvas.Audio Namespace


RawReader Class

Reads an audio data from the headerless stream. Slinear, Gsm, A-law, mu-law etc.

For a list of all members of this type, see RawReader Members.

System.Object
BinaryReader
AudioReader
RawReader
RawReadWriter

[Visual Basic]
Public Class RawReader
Inherits
[C#]
public class RawReader : AudioReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example shows simple using of RawReader.

WaveFormat wfAlaw = new WaveFormat();
wfAlaw.wFormatTag = AudioCompressionManager.ALawFormatTag;
wfAlaw.nChannels = 1;
wfAlaw.nSamplesPerSec = 8000;
FormatDetails[] fdArr = AudioCompressionManager.GetFormatList(wfAlaw);
RawReader rr = new RawReader(File.OpenRead("123.alaw"),
    fdArr[0].FormatHandle);
IntPtr format = rr.ReadFormat();
byte[] data = rr.ReadData();
rr.Close();

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

RawReader Members | Alvas.Audio Namespace


RawReader Members

RawReader overview

Public Instance Constructors

RawReader Constructor Initializes a new instance of the RawReader class for the specified stream.

Public Instance Properties

BaseStream (inherited from BinaryReader) Exposes access to the underlying stream of the BinaryReader.

Public Instance Methods

Close (inherited from BinaryReader) | Closes the current reader and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS | Gets audio stream duration in milliseconds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
Milliseconds2Bytes (inherited from AudioReader) | Converts from milliseconds to bytes for current stream.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadData | Overloaded. Reads all audio data from the stream.
ReadDataInBytes | Overloaded. Reads audio data from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadFormat | Reads an audio format.
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RawReader Class | Alvas.Audio Namespace


RawReader Constructor

Initializes a new instance of the RawReader class for the specified stream.

[Visual Basic]
Public Sub New( _
ByVal input As Stream, _
ByVal format As IntPtr _
)
[C#]
public RawReader(
Stream input,
IntPtr format
);

Parameters

input
The stream to be read.
format
Audio format

See Also

RawReader Class | Alvas.Audio Namespace


RawReader Methods

The methods of the RawReader class are listed below. For a complete list of RawReader class members, see the RawReader Members topic.

Public Instance Methods

Close (inherited from BinaryReader) | Closes the current reader and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS | Gets audio stream duration in milliseconds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
Milliseconds2Bytes (inherited from AudioReader) | Converts from milliseconds to bytes for current stream.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadData | Overloaded. Reads all audio data from the stream.
ReadDataInBytes | Overloaded. Reads audio data from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadFormat | Reads an audio format.
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RawReader Class | Alvas.Audio Namespace


RawReader.GetDurationInMS Method

Gets audio stream duration in milliseconds.

[Visual Basic]
Overrides Public Function GetDurationInMS() As Integer _
Implements IAudioReader.GetDurationInMS
[C#]
public override int GetDurationInMS();

Return Value

Implements

IAudioReader.GetDurationInMS

See Also

RawReader Class | Alvas.Audio Namespace


RawReader.GetLengthInBytes Method

Gets audio stream length in bytes.

[Visual Basic]
Overrides Public Function GetLengthInBytes() As Integer _
Implements IAudioReader.GetLengthInBytes
[C#]
public override int GetLengthInBytes();

Return Value

Implements

IAudioReader.GetLengthInBytes

See Also

RawReader Class | Alvas.Audio Namespace


ReadData Method

Alvas.Audio Class Library

RawReader.ReadData Method

Reads all audio data from the stream.

Overload List

Reads all audio data from the stream.

public override byte[] ReadData();

Reads audio data from the stream.

public override byte[] ReadData(Int32);

Reads audio data from the stream.

public override byte[] ReadData(Int32,Int32);

See Also

RawReader Class | Alvas.Audio Namespace


RawReader.ReadData Method ()

Reads all audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadData() As Byte() _
Implements IAudioReader.ReadData
[C#]
public override byte[] ReadData();

Return Value

audio data array

Implements

IAudioReader.ReadData

See Also

RawReader Class | Alvas.Audio Namespace | RawReader.ReadData Overload List


RawReader.ReadData Method (Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadData( _
ByVal skipSeconds As Integer _
) As Byte() _
Implements IAudioReader.ReadData
[C#]
public override byte[] ReadData(
Int32 skipSeconds
);

Parameters

skipSeconds
skip seconds

Return Value

Implements

IAudioReader.ReadData

See Also

RawReader Class | Alvas.Audio Namespace | RawReader.ReadData Overload List


RawReader.ReadData Method (Int32, Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadData( _
ByVal skipSeconds As Integer, _
ByVal readSeconds As Integer _
) As Byte() _
Implements IAudioReader.ReadData
[C#]
public override byte[] ReadData(
Int32 skipSeconds,
Int32 readSeconds
);

Parameters

skipSeconds
skip seconds
readSeconds
read seconds

Return Value

Implements

IAudioReader.ReadData

See Also

RawReader Class | Alvas.Audio Namespace | RawReader.ReadData Overload List


ReadDataInBytes Method

Alvas.Audio Class Library

RawReader.ReadDataInBytes Method

Reads audio data from the stream.

Overload List

Reads audio data from the stream.

public override byte[] ReadDataInBytes(Int32);

Reads audio data from the stream.

public override byte[] ReadDataInBytes(Int32,Int32);

See Also

RawReader Class | Alvas.Audio Namespace


RawReader.ReadDataInBytes Method (Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadDataInBytes( _
ByVal skipBytes As Integer _
) As Byte() _
Implements IAudioReader.ReadDataInBytes
[C#]
public override byte[] ReadDataInBytes(
Int32 skipBytes
);

Parameters

skipBytes
Skips length of bytes. Use Milliseconds2Bytes for this parameter.

Return Value

Implements

IAudioReader.ReadDataInBytes

See Also

RawReader Class | Alvas.Audio Namespace | RawReader.ReadDataInBytes Overload List


RawReader.ReadDataInBytes Method (Int32, Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadDataInBytes( _
ByVal skipBytes As Integer, _
ByVal readBytes As Integer _
) As Byte() _
Implements IAudioReader.ReadDataInBytes
[C#]
public override byte[] ReadDataInBytes(
Int32 skipBytes,
Int32 readBytes
);

Parameters

skipBytes
Skips length of bytes. Use Milliseconds2Bytes for this parameter.
readBytes
Reads length of bytes. Use Milliseconds2Bytes for this parameter.

Return Value

Implements

IAudioReader.ReadDataInBytes

See Also

RawReader Class | Alvas.Audio Namespace | RawReader.ReadDataInBytes Overload List


RawReader.ReadFormat Method

Reads an audio format.

[Visual Basic]
Overrides Public Function ReadFormat() As IntPtr _
Implements IAudioReader.ReadFormat
[C#]
public override IntPtr ReadFormat();

Return Value

Implements

IAudioReader.ReadFormat

See Also

RawReader Class | Alvas.Audio Namespace


RawReadWriter Class

Reads/writes an audio data from/to the headerless stream. Slinear, Gsm, A-law, mu-law etc.

For a list of all members of this type, see RawReadWriter Members.

System.Object
BinaryReader
AudioReader
RawReader
RawReadWriter

[Visual Basic]
Public Class RawReadWriter
Inherits
Implements IAudioReadWriter, IAudioWriter
[C#]
public class RawReadWriter : RawReader, IAudioReadWriter, IAudioWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

RawReadWriter Members | Alvas.Audio Namespace


RawReadWriter Members

RawReadWriter overview

Public Instance Constructors

RawReadWriter Constructor Initializes a new instance of the RawReadWriter class based on the supplied stream and a specific audio format.

Public Instance Properties

BaseStream (inherited from BinaryReader) Exposes access to the underlying stream of the BinaryReader.

Public Instance Methods

Close | Closes the current reader and writer and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS (inherited from RawReader) | Gets audio stream duration in milliseconds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes (inherited from RawReader) | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
Milliseconds2Bytes (inherited from AudioReader) | Converts from milliseconds to bytes for current stream.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadData (inherited from RawReader) | Overloaded. Reads all audio data from the stream.
ReadDataInBytes (inherited from RawReader) | Overloaded. Reads audio data from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadFormat (inherited from RawReader) | Reads an audio format.
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteData | Overloaded. Writes an audio byte array to the underlying stream.

See Also

RawReadWriter Class | Alvas.Audio Namespace


RawReadWriter Constructor

Initializes a new instance of the RawReadWriter class based on the supplied stream and a specific audio format.

[Visual Basic]
Public Sub New( _
ByVal input As Stream, _
ByVal format As IntPtr _
)
[C#]
public RawReadWriter(
Stream input,
IntPtr format
);

Parameters

input
The supplied stream.
format
The audio format.

See Also

RawReadWriter Class | Alvas.Audio Namespace


RawReadWriter Methods

The methods of the RawReadWriter class are listed below. For a complete list of RawReadWriter class members, see the RawReadWriter Members topic.

Public Instance Methods

Close | Closes the current reader and writer and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS (inherited from RawReader) | Gets audio stream duration in milliseconds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes (inherited from RawReader) | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
Milliseconds2Bytes (inherited from AudioReader) | Converts from milliseconds to bytes for current stream.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadData (inherited from RawReader) | Overloaded. Reads all audio data from the stream.
ReadDataInBytes (inherited from RawReader) | Overloaded. Reads audio data from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadFormat (inherited from RawReader) | Reads an audio format.
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteData | Overloaded. Writes an audio byte array to the underlying stream.

See Also

RawReadWriter Class | Alvas.Audio Namespace


RawReadWriter.Close Method

Closes the current reader and writer and the underlying stream.

[Visual Basic]
Overrides Public Sub Close() _
Implements IAudioReader.Close
[C#]
public override void Close();

Implements

IAudioReader.Close

See Also

RawReadWriter Class | Alvas.Audio Namespace


WriteData Method

Alvas.Audio Class Library

RawReadWriter.WriteData Method

Writes an audio byte array to the underlying stream.

Overload List

Writes an audio byte array to the underlying stream.

public void WriteData(Byte[]);

Writes an audio byte array to the underlying stream from specified position.

public long WriteData(Byte[],Int64);

Writes an audio byte array to the underlying stream from specified position in specified mode.

public long WriteData(Byte[],Int64,WriteMode);

See Also

RawReadWriter Class | Alvas.Audio Namespace


RawReadWriter.WriteData Method (Byte[])

Writes an audio byte array to the underlying stream.

[Visual Basic]
NotOverridable Overloads Public Sub WriteData( _
ByVal buffer As Byte() _
) _
Implements IAudioWriter.WriteData
[C#]
public void WriteData(
Byte[] buffer
);

Parameters

buffer
A byte array containing the data to write.

Implements

IAudioWriter.WriteData

See Also

RawReadWriter Class | Alvas.Audio Namespace | RawReadWriter.WriteData Overload List


RawReadWriter.WriteData Method (Byte[], Int64)

Writes an audio byte array to the underlying stream from specified position.

[Visual Basic]
NotOverridable Overloads Public Function WriteData( _
ByVal buffer As Byte(), _
ByVal position As Long _
) As Long _
Implements IAudioWriter.WriteData
[C#]
public long WriteData(
Byte[] buffer,
Int64 position
);

Parameters

buffer
A byte array containing the data to write.
position
Data position in bytes

Return Value

Returns new data position in bytes

Implements

IAudioWriter.WriteData

See Also

RawReadWriter Class | Alvas.Audio Namespace | RawReadWriter.WriteData Overload List


RawReadWriter.WriteData Method (Byte[], Int64, WriteMode)

Writes an audio byte array to the underlying stream from specified position in specified mode.

[Visual Basic]
NotOverridable Overloads Public Function WriteData( _
ByVal buffer As Byte(), _
ByVal position As Long, _
ByVal mode As WriteMode _
) As Long _
Implements IAudioWriter.WriteData
[C#]
public long WriteData(
Byte[] buffer,
Int64 position,
WriteMode mode
);

Parameters

buffer
A byte array containing the data to write.
position
Data position in bytes
mode
mode

Return Value

Returns new data position in bytes

Implements

IAudioWriter.WriteData

See Also

RawReadWriter Class | Alvas.Audio Namespace | RawReadWriter.WriteData Overload List


RawWriter Class

Writes an audio data to the headerless stream. Slinear, Gsm, A-law, mu-law etc.

For a list of all members of this type, see RawWriter Members.

System.Object
BinaryWriter
AudioWriter
RawWriter

[Visual Basic]
Public Class RawWriter
Inherits
[C#]
public class RawWriter : AudioWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example shows simple using of RawWriter class.

RawWriter rw = new RawWriter(File.Create("out.pcm"));
rw.WriteData(new byte[16000]);
rw.Close();

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

RawWriter Members | Alvas.Audio Namespace


RawWriter Members

RawWriter overview

Public Instance Constructors

RawWriter Constructor Initializes a new instance of the RawWriter class based on the supplied stream.

Public Instance Properties

BaseStream (inherited from BinaryWriter) Gets the underlying stream of the BinaryWriter.

Public Instance Methods

Close (inherited from BinaryWriter) | Closes the current BinaryWriter and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from BinaryWriter) | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Seek (inherited from BinaryWriter) | Sets the position within the current stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from BinaryWriter) | Overloaded. Writes a one-byte Boolean value to the current stream, with 0 representing false and 1 representing true.
WriteData | Overloaded. Writes an audio byte array to the underlying stream.

See Also

RawWriter Class | Alvas.Audio Namespace


RawWriter Constructor

Initializes a new instance of the RawWriter class based on the supplied stream.

[Visual Basic]
Public Sub New( _
ByVal output As Stream _
)
[C#]
public RawWriter(
Stream output
);

Parameters

output
The supplied stream.

See Also

RawWriter Class | Alvas.Audio Namespace


RawWriter Methods

The methods of the RawWriter class are listed below. For a complete list of RawWriter class members, see the RawWriter Members topic.

Public Instance Methods

Close (inherited from BinaryWriter) | Closes the current BinaryWriter and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from BinaryWriter) | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Seek (inherited from BinaryWriter) | Sets the position within the current stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from BinaryWriter) | Overloaded. Writes a one-byte Boolean value to the current stream, with 0 representing false and 1 representing true.
WriteData | Overloaded. Writes an audio byte array to the underlying stream.

See Also

RawWriter Class | Alvas.Audio Namespace


WriteData Method

Alvas.Audio Class Library

RawWriter.WriteData Method

Writes an audio byte array to the underlying stream.

Overload List

Writes an audio byte array to the underlying stream.

public override void WriteData(Byte[]);

Writes an audio byte array to the underlying stream from specified position.

public override long WriteData(Byte[],Int64);

Writes an audio byte array to the underlying stream from specified position in specified mode.

public override long WriteData(Byte[],Int64,WriteMode);

See Also

RawWriter Class | Alvas.Audio Namespace


RawWriter.WriteData Method (Byte[])

Writes an audio byte array to the underlying stream.

[Visual Basic]
Overrides Overloads Public Sub WriteData( _
ByVal buffer As Byte() _
) _
Implements IAudioWriter.WriteData
[C#]
public override void WriteData(
Byte[] buffer
);

Parameters

buffer
A byte array containing the data to write.

Implements

IAudioWriter.WriteData

See Also

RawWriter Class | Alvas.Audio Namespace | RawWriter.WriteData Overload List


RawWriter.WriteData Method (Byte[], Int64)

Writes an audio byte array to the underlying stream from specified position.

[Visual Basic]
Overrides Overloads Public Function WriteData( _
ByVal buffer As Byte(), _
ByVal position As Long _
) As Long _
Implements IAudioWriter.WriteData
[C#]
public override long WriteData(
Byte[] buffer,
Int64 position
);

Parameters

buffer
A byte array containing the data to write.
position
Data position in bytes

Return Value

Returns new data position in bytes

Implements

IAudioWriter.WriteData

See Also

RawWriter Class | Alvas.Audio Namespace | RawWriter.WriteData Overload List


RawWriter.WriteData Method (Byte[], Int64, WriteMode)

Writes an audio byte array to the underlying stream from specified position in specified mode.

[Visual Basic]
Overrides Overloads Public Function WriteData( _
ByVal buffer As Byte(), _
ByVal position As Long, _
ByVal mode As WriteMode _
) As Long _
Implements IAudioWriter.WriteData
[C#]
public override long WriteData(
Byte[] buffer,
Int64 position,
WriteMode mode
);

Parameters

buffer
A byte array containing the data to write.
position
Data position in bytes
mode
mode

Return Value

Returns new data position in bytes

Implements

IAudioWriter.WriteData

See Also

RawWriter Class | Alvas.Audio Namespace | RawWriter.WriteData Overload List


Recorder Class

Recorder is a component for sound recording in pulse code modulation (PCM) wave file format.

For a list of all members of this type, see Recorder Members.

System.Object
MarshalByRefObject
Component
Recorder

[Visual Basic]
Public Class Recorder
Inherits
[C#]
public class Recorder : Component

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example shows how simple use Recorder.

rec.Open();
Recorder.Channel rc = Recorder.Channel.Stereo;
Recorder.BitsPerSample rbps = Recorder.BitsPerSample.Bps16;
Recorder.SamplesPerSec rsps = Recorder.SamplesPerSec.Sps8000;
rec.Configure(rc, rbps, rsps);
rec.Record();

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Recorder Members | Alvas.Audio Namespace


Recorder Members

Recorder overview

Public Static (Shared) Methods

GetErrorString Returns string that describes the specified error code.

Public Instance Constructors

Recorder Constructor

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
IsRecording | Returns true if recording or false otherwise.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Status | Gets current device status.

Public Instance Methods

Close | Closes opened recording device.
Configure |
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Open | Opens device for recording.
Record | Records sound.
Save | Saves recorded sound into file.
Stop | Stops recording.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

Public Instance Events

Disposed (inherited from Component) Occurs when the component is disposed by a call to the Dispose method.

See Also

Recorder Class | Alvas.Audio Namespace


Recorder Constructor

[Visual Basic]
Public Sub New()
[C#]
public Recorder();

See Also

Recorder Class | Alvas.Audio Namespace


Recorder Properties

The properties of the Recorder class are listed below. For a complete list of Recorder class members, see the Recorder Members topic.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
IsRecording | Returns true if recording or false otherwise.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Status | Gets current device status.

See Also

Recorder Class | Alvas.Audio Namespace


IsRecording Property

Alvas.Audio Class Library

Recorder.IsRecording Property

Returns true if recording or false otherwise.

[Visual Basic]
Public ReadOnly Property IsRecording As Boolean
[C#]
public Boolean IsRecording {get;}

See Also

Recorder Class | Alvas.Audio Namespace


Status Property

Alvas.Audio Class Library

Recorder.Status Property

Gets current device status.

[Visual Basic]
Public ReadOnly Property Status As String
[C#]
public String Status {get;}

See Also

Recorder Class | Alvas.Audio Namespace


Recorder Methods

The methods of the Recorder class are listed below. For a complete list of Recorder class members, see the Recorder Members topic.

Public Static (Shared) Methods

GetErrorString Returns string that describes the specified error code.

Public Instance Methods

Close | Closes opened recording device.
Configure |
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Open | Opens device for recording.
Record | Records sound.
Save | Saves recorded sound into file.
Stop | Stops recording.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

See Also

Recorder Class | Alvas.Audio Namespace


Recorder.Close Method

Closes opened recording device.

[Visual Basic]
Public Function Close() As Integer
[C#]
public int Close();

Return Value

Returns 0 if successful or error number otherwise. Use GetErrorString static function to describe error number.

See Also

Recorder Class | Alvas.Audio Namespace


Recorder.Configure Method

[Visual Basic]
Public Function Configure( _
ByVal channel As Recorder#Channel, _
ByVal bitsPerSample As Recorder#BitsPerSample, _
ByVal samplesPerSec As Recorder#SamplesPerSec _
) As Integer
[C#]
public int Configure(
Recorder.Channel channel,
Recorder.BitsPerSample bitsPerSample,
Recorder.SamplesPerSec samplesPerSec
);

See Also

Recorder Class | Alvas.Audio Namespace


Recorder.GetErrorString Method

Returns string that describes the specified error code.

[Visual Basic]
Public Shared Function GetErrorString( _
ByVal err As Integer _
) As String
[C#]
public static string GetErrorString(
Int32 err
);

Parameters

err
Error code number

Return Value

See Also

Recorder Class | Alvas.Audio Namespace


Recorder.Open Method

Opens device for recording.

[Visual Basic]
Public Function Open() As Integer
[C#]
public int Open();

Return Value

Returns 0 if successful or error number otherwise. Use GetErrorString static function to describe error number.

See Also

Recorder Class | Alvas.Audio Namespace


Recorder.Record Method

Records sound.

[Visual Basic]
Public Function Record() As Integer
[C#]
public int Record();

Return Value

Returns 0 if successful or error number otherwise. Use GetErrorString static function to describe error number.

See Also

Recorder Class | Alvas.Audio Namespace


Recorder.Save Method

Saves recorded sound into file.

[Visual Basic]
Public Function Save( _
ByVal fileName As String _
) As Integer
[C#]
public int Save(
String fileName
);

Parameters

fileName
File name for saving.

Return Value

Returns 0 if successful or error number otherwise. Use GetErrorString static function to describe error number.

See Also

Recorder Class | Alvas.Audio Namespace


Recorder.Stop Method

Stops recording.

[Visual Basic]
Public Function Stop() As Integer
[C#]
public int Stop();

Return Value

Returns 0 if successful or error number otherwise. Use GetErrorString static function to describe error number.

See Also

Recorder Class | Alvas.Audio Namespace


Recorder.BitsPerSample Enumeration

Bits per sample enumeration.

[Visual Basic]
Public Enum Recorder.BitsPerSample
[C#]
public enum Recorder.BitsPerSample

Members

Member Name | Description
Bps8 | 8 bits per sample
Bps16 | 16 bits per sample

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Alvas.Audio Namespace


Recorder.Channel Enumeration

Channels enumeration.

[Visual Basic]
Public Enum Recorder.Channel
[C#]
public enum Recorder.Channel

Members

Member Name | Description
Mono | Mono
Stereo | Stereo

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Alvas.Audio Namespace


Recorder.SamplesPerSec Enumeration

Samples per second enumeration.

[Visual Basic]
Public Enum Recorder.SamplesPerSec
[C#]
public enum Recorder.SamplesPerSec

Members

Member Name | Description
Sps8000 | 8000 samples per second
Sps11025 | 11025 samples per second
Sps22050 | 22050 samples per second
Sps44100 | 44100 samples per second
Sps48000 | 48000 samples per second
Sps96000 | 96000 samples per second

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Alvas.Audio Namespace


RecorderEx Class

RecorderEx is a component for sound recording in PCM, IMA ADPCM, Microsoft ADPCM, CCITT A-Law, CCITT u-Law, GSM 6.10, Windows Media Audio V2, MPEG Layer-3 (mp3) and other wave file format.

For a list of all members of this type, see RecorderEx Members.

System.Object
MarshalByRefObject
Component
RecorderEx

[Visual Basic]
Public Class RecorderEx
Inherits
[C#]
public class RecorderEx : Component

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example shows simple using of RecorderEx class.

public static void TestRecorderEx()
{
    RecorderEx rex = new RecorderEx();
    rex.Open += new EventHandler(rex_Open);
    rex.Data += new RecorderEx.DataEventHandler(rex_Data);
    rex.Close += new EventHandler(rex_Close);
    rex.Format = AudioCompressionManager.GetPcmFormat(1, 16, 44100);
    rex.StartRecord();
}

static WaveWriter ww;
static int i = 0;

static void rex_Close(object sender, EventArgs e)
{
    ww.Close();
    ww = null;
}

static void rex_Data(object sender, DataEventArgs e)
{
    ww.WriteData(e.Data);
    i += 1;
    if (i == 10)
    {
        ((RecorderEx)sender).StopRecord();
    }
}

static void rex_Open(object sender, EventArgs e)
{
    if (ww == null)
    {
        ww = new WaveWriter(File.Create("rec.wav"), AudioCompressionManager.FormatBytes(((RecorderEx)sender).Format));
    }
}

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

RecorderEx Members | Alvas.Audio Namespace


RecorderEx Members

RecorderEx overview

Public Static (Shared) Properties

RecorderCount Gets the number of audio recorders installed in system.

Public Static (Shared) Methods

GetRecorderName Returns recorder name by index.

Public Instance Constructors

RecorderEx Overloaded. Initializes a new instance of the RecorderEx class.

Public Instance Properties

BufferSizeInMS | Gets or sets the recorder buffer size in milliseconds. By default 500 ms.
Container (inherited from Component) | Gets the IContainer that contains the Component.
Format | Gets and sets pointer to audio format.
RecorderID | Gets or sets the current recorder. If -1 the system uses suitable recorder.
Site (inherited from Component) | Gets or sets the ISite of the Component.
State | Gets the recorder state.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FormatBytes | Returns audio format byte array.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetMixerNo | Return mixer number
GetPosition | Gets the current sound position.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
PauseRecord | Pauses recording. Use StartRecord method to resume recording.
StartRecord | Starts recording.
StopRecord | Stops recording.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

Public Instance Events

Close | Occurs when the recorder is closed after recording.
Data | Occurs when the Recorder returns next portion of the recorded data.
Disposed (inherited from Component) | Occurs when the component is disposed by a call to the Dispose method.
Open | Occurs when the recorder is opened for recording.

See Also

RecorderEx Class | Alvas.Audio Namespace


RecorderEx Constructor

Overload List

public RecorderEx();

public RecorderEx(Boolean);

See Also

RecorderEx Class | Alvas.Audio Namespace


RecorderEx Constructor ()

[Visual Basic]
Overloads Public Sub New()
[C#]
public RecorderEx();

See Also

RecorderEx Class | Alvas.Audio Namespace | RecorderEx Constructor Overload List


RecorderEx Constructor (Boolean)

[Visual Basic]
Overloads Public Sub New( _
ByVal isConsole As Boolean _
)
[C#]
public RecorderEx(
Boolean isConsole
);

Parameters

isConsole
true if used in console application or Windows service; otherwise, false.

See Also

RecorderEx Class | Alvas.Audio Namespace | RecorderEx Constructor Overload List


RecorderEx Properties

The properties of the RecorderEx class are listed below. For a complete list of RecorderEx class members, see the RecorderEx Members topic.

Public Static (Shared) Properties

RecorderCount Gets the number of audio recorders installed in system.

Public Instance Properties

BufferSizeInMS | Gets or sets the recorder buffer size in milliseconds. By default 500 ms.
Container (inherited from Component) | Gets the IContainer that contains the Component.
Format | Gets and sets pointer to audio format.
RecorderID | Gets or sets the current recorder. If -1 the system uses suitable recorder.
Site (inherited from Component) | Gets or sets the ISite of the Component.
State | Gets the recorder state.

See Also

RecorderEx Class | Alvas.Audio Namespace


BufferSizeInMS Property

Alvas.Audio Class Library

RecorderEx.BufferSizeInMS Property

Gets or sets the recorder buffer size in milliseconds. By default 500 ms.

[Visual Basic]
Public Property BufferSizeInMS As Integer
[C#]
public Int32 BufferSizeInMS {get; set;}

See Also

RecorderEx Class | Alvas.Audio Namespace


Format Property

Alvas.Audio Class Library

RecorderEx.Format Property

Gets and sets pointer to audio format.

[Visual Basic]
Public Property Format As IntPtr
[C#]
public IntPtr Format {get; set;}

See Also

RecorderEx Class | Alvas.Audio Namespace


RecorderCount Property

Alvas.Audio Class Library

RecorderEx.RecorderCount Property

Gets the number of audio recorders installed in system.

[Visual Basic]
Public Shared ReadOnly Property RecorderCount As Integer
[C#]
public static Int32 RecorderCount {get;}

See Also

RecorderEx Class | Alvas.Audio Namespace


RecorderID Property

Alvas.Audio Class Library

RecorderEx.RecorderID Property

Gets or sets the current recorder. If -1 the system uses suitable recorder.

[Visual Basic]
Public Property RecorderID As Integer
[C#]
public Int32 RecorderID {get; set;}

See Also

RecorderEx Class | Alvas.Audio Namespace


State Property

Alvas.Audio Class Library

RecorderEx.State Property

Gets the recorder state.

[Visual Basic]
Public ReadOnly Property State As DeviceState
[C#]
public DeviceState State {get;}

See Also

RecorderEx Class | Alvas.Audio Namespace


RecorderEx Methods

The methods of the RecorderEx class are listed below. For a complete list of RecorderEx class members, see the RecorderEx Members topic.

Public Static (Shared) Methods

GetRecorderName Returns recorder name by index.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FormatBytes | Returns audio format byte array.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetMixerNo | Return mixer number
GetPosition | Gets the current sound position.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
PauseRecord | Pauses recording. Use StartRecord method to resume recording.
StartRecord | Starts recording.
StopRecord | Stops recording.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

See Also

RecorderEx Class | Alvas.Audio Namespace


RecorderEx.FormatBytes Method

Returns audio format byte array.

[Visual Basic]
Public Function FormatBytes() As Byte()
[C#]
public byte[] FormatBytes();

Return Value

See Also

RecorderEx Class | Alvas.Audio Namespace


RecorderEx.GetMixerNo Method

Return mixer number

[Visual Basic]
Public Function GetMixerNo() As Integer
[C#]
public int GetMixerNo();

Return Value

See Also

RecorderEx Class | Alvas.Audio Namespace


RecorderEx.GetPosition Method

Gets the current sound position.

[Visual Basic]
Public Function GetPosition( _
ByVal time As TimeFormat _
) As Long
[C#]
public long GetPosition(
TimeFormat time
);

Parameters

time
The time parameter specifies the sound position in milliseconds, bytes or samples.

Return Value

See Also

RecorderEx Class | Alvas.Audio Namespace


RecorderEx.GetRecorderName Method

Returns recorder name by index.

[Visual Basic]
Public Shared Function GetRecorderName( _
ByVal index As Integer _
) As String
[C#]
public static string GetRecorderName(
Int32 index
);

Parameters

index

Return Value

Example

This example shows simple using of GetRecorderName method.

for (int i = 0; i < RecorderEx.RecorderCount; i++)
{
    Console.WriteLine(RecorderEx.GetRecorderName(i));
}

See Also

RecorderEx Class | Alvas.Audio Namespace


RecorderEx.PauseRecord Method

Pauses recording. Use StartRecord method to resume recording.

[Visual Basic]
Public Sub PauseRecord()
[C#]
public void PauseRecord();

See Also

RecorderEx Class | Alvas.Audio Namespace


RecorderEx.StartRecord Method

Starts recording.

[Visual Basic]
Public Sub StartRecord()
[C#]
public void StartRecord();

See Also

RecorderEx Class | Alvas.Audio Namespace


RecorderEx.StopRecord Method

Stops recording.

[Visual Basic]
Public Sub StopRecord()
[C#]
public void StopRecord();

See Also

RecorderEx Class | Alvas.Audio Namespace


RecorderEx Events

The events of the RecorderEx class are listed below. For a complete list of RecorderEx class members, see the RecorderEx Members topic.

Public Instance Events

Close | Occurs when the recorder is closed after recording.
Data | Occurs when the Recorder returns next portion of the recorded data.
Disposed (inherited from Component) | Occurs when the component is disposed by a call to the Dispose method.
Open | Occurs when the recorder is opened for recording.

See Also

RecorderEx Class | Alvas.Audio Namespace


RecorderEx.Close Event

Occurs when the recorder is closed after recording.

[Visual Basic]
Public Event Close As EventHandler
[C#]
public event EventHandler Close;

See Also

RecorderEx Class | Alvas.Audio Namespace


RecorderEx.Data Event

Occurs when the Recorder returns next portion of the recorded data.

[Visual Basic]
Public Event Data As RecorderEx#DataEventHandler
[C#]
public event RecorderEx.DataEventHandler Data;

See Also

RecorderEx Class | Alvas.Audio Namespace


RecorderEx.Open Event

Occurs when the recorder is opened for recording.

[Visual Basic]
Public Event Open As EventHandler
[C#]
public event EventHandler Open;

See Also

RecorderEx Class | Alvas.Audio Namespace


RecorderEx.DataEventHandler Delegate

Represents the method that will handle the Data event of the RecorderEx.

[Visual Basic]
Public Delegate Sub RecorderEx.DataEventHandler( _
ByVal sender As Object, _
ByVal e As DataEventArgs _
)
[C#]
public delegate void RecorderEx.DataEventHandler(
Object sender,
DataEventArgs e
);

Parameters

sender
e

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Alvas.Audio Namespace


RecordPlayer Class

Class for recording and playback

For a list of all members of this type, see RecordPlayer Members.

System.Object
RecordPlayer

[Visual Basic]
Public Class RecordPlayer
Implements INotifyPropertyChanged
[C#]
public class RecordPlayer : INotifyPropertyChanged

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example shows simple using of RecordPlayer class.

public static void TestRecordPlayer()
{
    RecordPlayer rp = new RecordPlayer();
    rp.PropertyChanged += new PropertyChangedEventHandler(rp_PropertyChanged);
    rp.Open(new Mp3Reader(File.OpenRead("in.mp3")));
    rp.Play();
}

static void rp_PropertyChanged(object sender, PropertyChangedEventArgs e)
{
    switch (e.PropertyName)
    {
        case RecordPlayer.StateProperty:
            RecordPlayer rp = ((RecordPlayer)sender);
            if (rp.State == DeviceState.Stopped)
            {
                rp.Close();
            }
            break;
    }
}

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

RecordPlayer Members | Alvas.Audio Namespace


RecordPlayer Members

RecordPlayer overview

Public Static (Shared) Fields

BufferSizeInMSProperty | BufferSizeInMS property name
DurationProperty | Duration property name
PlayerVolumeMuteProperty | PlayerVolumeMute property name
PlayerVolumeProperty | PlayerVolume property name
PositionProperty | Position property name
RecorderLinesIndexProperty | RecorderLinesIndex property name
RecorderLinesProperty | RecorderLines property name
RecorderVolumeProperty | RecorderVolume property name
SilentLevelProperty | SilentLevel property name
SkipSilentProperty | SkipSilent property name
StateProperty | State property name
VolumeLevelProperty | VolumeLevel property name
VolumeScaleProperty | VolumeScale property name

Public Instance Constructors

RecordPlayer Constructor

Public Instance Properties

BufferSizeInMS | Gets or sets the audio buffer size in milliseconds. By default 500 ms.
CanRecord | Indicates whether the stream can be recorded.
Duration | Returns audio stream duration in ms
FormatDetails | Gets format details for current audio stream
PlayerID | Gets or sets the current player. If -1 the system uses suitable player.
PlayerVolume | Sets and gets playback volume
PlayerVolumeMute | Sets and gets playback mute
Position | Gets current position for audio stream
RecorderID | Gets or sets the current recorder. If -1 the system uses suitable recorder.
RecorderLines | Gets recorder lines
RecorderLinesIndex | Gets and sets selected recorder lines index
RecorderVolume | Sets and gets recording volume
SilentLevel | Sets and gets sound level, which will be silence
SkipSilent | Skip silence during recording
State | Current device state
VolumeData | Volume audio data array for current audio operation.
VolumeDataLength | Length of volume audio data array
VolumeLevel | Volume level for current audio operation
VolumeScale | Scales the volume of audio data. 100 is normal volume, 50 is reduced by half, 200 is increased in 2 times

Public Instance Methods

Backward | Backwards current stream position
Close | Closes audio stream
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Forward | Forwards current stream position
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Open | Open existing audio file for recording and playback
Pause | Pauses recording or playback
Play | Overloaded. Plays audio stream
Record | Overloaded. Records audio stream
Stop | Stops recording or playback
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

PropertyChanged Occurs when a property changes values.

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer Constructor

[Visual Basic]
Public Sub New()
[C#]
public RecordPlayer();

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer Fields

The fields of the RecordPlayer class are listed below. For a complete list of RecordPlayer class members, see the RecordPlayer Members topic.

Public Static (Shared) Fields

BufferSizeInMSProperty | BufferSizeInMS property name
DurationProperty | Duration property name
PlayerVolumeMuteProperty | PlayerVolumeMute property name
PlayerVolumeProperty | PlayerVolume property name
PositionProperty | Position property name
RecorderLinesIndexProperty | RecorderLinesIndex property name
RecorderLinesProperty | RecorderLines property name
RecorderVolumeProperty | RecorderVolume property name
SilentLevelProperty | SilentLevel property name
SkipSilentProperty | SkipSilent property name
StateProperty | State property name
VolumeLevelProperty | VolumeLevel property name
VolumeScaleProperty | VolumeScale property name

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.BufferSizeInMSProperty Field

BufferSizeInMS property name

[Visual Basic]
Public Const BufferSizeInMSProperty As String = "BufferSizeInMS"
[C#]
public const String BufferSizeInMSProperty = "BufferSizeInMS";

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.DurationProperty Field

Duration property name

[Visual Basic]
Public Const DurationProperty As String = "Duration"
[C#]
public const String DurationProperty = "Duration";

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.PlayerVolumeMuteProperty Field

PlayerVolumeMute property name

[Visual Basic]
Public Const PlayerVolumeMuteProperty As String = "PlayerVolumeMute"
[C#]
public const String PlayerVolumeMuteProperty = "PlayerVolumeMute";

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.PlayerVolumeProperty Field

PlayerVolume property name

[Visual Basic]
Public Const PlayerVolumeProperty As String = "PlayerVolume"
[C#]
public const String PlayerVolumeProperty = "PlayerVolume";

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.PositionProperty Field

Position property name

[Visual Basic]
Public Const PositionProperty As String = "Position"
[C#]
public const String PositionProperty = "Position";

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.RecorderLinesIndexProperty Field

RecorderLinesIndex property name

[Visual Basic]
Public Const RecorderLinesIndexProperty As String = "RecorderLinesIndex"
[C#]
public const String RecorderLinesIndexProperty = "RecorderLinesIndex";

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.RecorderLinesProperty Field

RecorderLines property name

[Visual Basic]
Public Const RecorderLinesProperty As String = "RecorderLines"
[C#]
public const String RecorderLinesProperty = "RecorderLines";

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.RecorderVolumeProperty Field

RecorderVolume property name

[Visual Basic]
Public Const RecorderVolumeProperty As String = "RecorderVolume"
[C#]
public const String RecorderVolumeProperty = "RecorderVolume";

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.SilentLevelProperty Field

SilentLevel property name

[Visual Basic]
Public Const SilentLevelProperty As String = "SilentLevel"
[C#]
public const String SilentLevelProperty = "SilentLevel";

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.SkipSilentProperty Field

SkipSilent property name

[Visual Basic]
Public Const SkipSilentProperty As String = "SkipSilent"
[C#]
public const String SkipSilentProperty = "SkipSilent";

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.StateProperty Field

State property name

[Visual Basic]
Public Const StateProperty As String = "State"
[C#]
public const String StateProperty = "State";

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.VolumeLevelProperty Field

VolumeLevel property name

[Visual Basic]
Public Const VolumeLevelProperty As String = "VolumeLevel"
[C#]
public const String VolumeLevelProperty = "VolumeLevel";

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.VolumeScaleProperty Field

VolumeScale property name

[Visual Basic]
Public Const VolumeScaleProperty As String = "VolumeScale"
[C#]
public const String VolumeScaleProperty = "VolumeScale";

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer Properties

The properties of the RecordPlayer class are listed below. For a complete list of RecordPlayer class members, see the RecordPlayer Members topic.

Public Instance Properties

BufferSizeInMS | Gets or sets the audio buffer size in milliseconds. By default 500 ms.
CanRecord | Indicates whether the stream can be recorded.
Duration | Returns audio stream duration in ms
FormatDetails | Gets format details for current audio stream
PlayerID | Gets or sets the current player. If -1 the system uses suitable player.
PlayerVolume | Sets and gets playback volume
PlayerVolumeMute | Sets and gets playback mute
Position | Gets current position for audio stream
RecorderID | Gets or sets the current recorder. If -1 the system uses suitable recorder.
RecorderLines | Gets recorder lines
RecorderLinesIndex | Gets and sets selected recorder lines index
RecorderVolume | Sets and gets recording volume
SilentLevel | Sets and gets sound level, which will be silence
SkipSilent | Skip silence during recording
State | Current device state
VolumeData | Volume audio data array for current audio operation.
VolumeDataLength | Length of volume audio data array
VolumeLevel | Volume level for current audio operation
VolumeScale | Scales the volume of audio data. 100 is normal volume, 50 is reduced by half, 200 is increased in 2 times

See Also

RecordPlayer Class | Alvas.Audio Namespace


BufferSizeInMS Property

Alvas.Audio Class Library

RecordPlayer.BufferSizeInMS Property

Gets or sets the audio buffer size in milliseconds. By default 500 ms.

[Visual Basic]
Public Property BufferSizeInMS As Integer
[C#]
public Int32 BufferSizeInMS {get; set;}

See Also

RecordPlayer Class | Alvas.Audio Namespace


CanRecord Property

Alvas.Audio Class Library

RecordPlayer.CanRecord Property

Indicates whether the stream can be recorded.

[Visual Basic]
Public ReadOnly Property CanRecord As Boolean
[C#]
public Boolean CanRecord {get;}

See Also

RecordPlayer Class | Alvas.Audio Namespace


Duration Property

Alvas.Audio Class Library

RecordPlayer.Duration Property

Returns audio stream duration in ms

[Visual Basic]
Public ReadOnly Property Duration As Integer
[C#]
public Int32 Duration {get;}

See Also

RecordPlayer Class | Alvas.Audio Namespace


FormatDetails Property

Alvas.Audio Class Library

RecordPlayer.FormatDetails Property

Gets format details for current audio stream

[Visual Basic]
Public ReadOnly Property FormatDetails As FormatDetails
[C#]
public FormatDetails FormatDetails {get;}

See Also

RecordPlayer Class | Alvas.Audio Namespace


PlayerID Property

Alvas.Audio Class Library

RecordPlayer.PlayerID Property

Gets or sets the current player. If -1 the system uses suitable player.

[Visual Basic]
Public Property PlayerID As Integer
[C#]
public Int32 PlayerID {get; set;}

See Also

RecordPlayer Class | Alvas.Audio Namespace


PlayerVolume Property

Alvas.Audio Class Library

RecordPlayer.PlayerVolume Property

Sets and gets playback volume

[Visual Basic]
Public Property PlayerVolume As Integer
[C#]
public Int32 PlayerVolume {get; set;}

See Also

RecordPlayer Class | Alvas.Audio Namespace


PlayerVolumeMute Property

Alvas.Audio Class Library

RecordPlayer.PlayerVolumeMute Property

Sets and gets playback mute

[Visual Basic]
Public Property PlayerVolumeMute As Boolean
[C#]
public Boolean PlayerVolumeMute {get; set;}

See Also

RecordPlayer Class | Alvas.Audio Namespace


Position Property

Alvas.Audio Class Library

RecordPlayer.Position Property

Gets current position for audio stream

[Visual Basic]
Public Property Position As Integer
[C#]
public Int32 Position {get; set;}

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecorderID Property

Alvas.Audio Class Library

RecordPlayer.RecorderID Property

Gets or sets the current recorder. If -1 the system uses suitable recorder.

[Visual Basic]
Public Property RecorderID As Integer
[C#]
public Int32 RecorderID {get; set;}

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecorderLines Property

Alvas.Audio Class Library

RecordPlayer.RecorderLines Property

Gets recorder lines

[Visual Basic]
Public ReadOnly Property RecorderLines As MixerLine()
[C#]
public MixerLine[] RecorderLines {get;}

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecorderLinesIndex Property

Alvas.Audio Class Library

RecordPlayer.RecorderLinesIndex Property

Gets and sets selected recorder lines index

[Visual Basic]
Public Property RecorderLinesIndex As Integer
[C#]
public Int32 RecorderLinesIndex {get; set;}

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecorderVolume Property

Alvas.Audio Class Library

RecordPlayer.RecorderVolume Property

Sets and gets recording volume

[Visual Basic]
Public Property RecorderVolume As Integer
[C#]
public Int32 RecorderVolume {get; set;}

See Also

RecordPlayer Class | Alvas.Audio Namespace


SilentLevel Property

Alvas.Audio Class Library

RecordPlayer.SilentLevel Property

Sets and gets sound level, which will be silence

[Visual Basic]
Public Property SilentLevel As Integer
[C#]
public Int32 SilentLevel {get; set;}

See Also

RecordPlayer Class | Alvas.Audio Namespace


SkipSilent Property

Alvas.Audio Class Library

RecordPlayer.SkipSilent Property

Skip silence during recording

[Visual Basic]
Public Property SkipSilent As Boolean
[C#]
public Boolean SkipSilent {get; set;}

See Also

RecordPlayer Class | Alvas.Audio Namespace


State Property

Alvas.Audio Class Library

RecordPlayer.State Property

Current device state

[Visual Basic]
Public ReadOnly Property State As DeviceState
[C#]
public DeviceState State {get;}

See Also

RecordPlayer Class | Alvas.Audio Namespace


VolumeData Property

Alvas.Audio Class Library

RecordPlayer.VolumeData Property

Volume audio data array for current audio operation.

[Visual Basic]
Public ReadOnly Property VolumeData As Short()
[C#]
public Int16[] VolumeData {get;}

Example

This example shows simple using of VolumeData property.

private void Init()
{
    slm = new SoundLevelMeter();
    slm.Dock = DockStyle.Fill;
    this.Controls.Add(slm);
    IntPtr pcmFormat = AudioCompressionManager.GetPcmFormat(2, 16, 44100);
    rp.VolumeDataLength = slm.ClientSize.Width;
    rp.PropertyChanged += new PropertyChangedEventHandler(rp_PropertyChanged);
    rp.Open(new WaveReadWriter(new MemoryStream(), AudioCompressionManager.FormatBytes(pcmFormat)));
    rp.Record();
}

SoundLevelMeter slm;
RecordPlayer rp = new RecordPlayer();

void rp_PropertyChanged(object sender, PropertyChangedEventArgs e)
{
    if (e.PropertyName == RecordPlayer.VolumeLevelProperty)
    {
        slm.Data = rp.VolumeData;
    };
}

See Also

RecordPlayer Class | Alvas.Audio Namespace


VolumeDataLength Property

Alvas.Audio Class Library

RecordPlayer.VolumeDataLength Property

Length of volume audio data array

[Visual Basic]
Public Property VolumeDataLength As Integer
[C#]
public Int32 VolumeDataLength {get; set;}

See Also

RecordPlayer Class | Alvas.Audio Namespace


VolumeLevel Property

Alvas.Audio Class Library

RecordPlayer.VolumeLevel Property

Volume level for current audio operation

[Visual Basic]
Public ReadOnly Property VolumeLevel As Integer
[C#]
public Int32 VolumeLevel {get;}

See Also

RecordPlayer Class | Alvas.Audio Namespace


VolumeScale Property

Alvas.Audio Class Library

RecordPlayer.VolumeScale Property

Scales the volume of audio data. 100 is normal volume, 50 is reduced by half, 200 is increased in 2 times

[Visual Basic]
Public Property VolumeScale As Integer
[C#]
public Int32 VolumeScale {get; set;}

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer Methods

The methods of the RecordPlayer class are listed below. For a complete list of RecordPlayer class members, see the RecordPlayer Members topic.

Public Instance Methods

Backward | Backwards current stream position
Close | Closes audio stream
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Forward | Forwards current stream position
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Open | Open existing audio file for recording and playback
Pause | Pauses recording or playback
Play | Overloaded. Plays audio stream
Record | Overloaded. Records audio stream
Stop | Stops recording or playback
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.Backward Method

Backwards current stream position

[Visual Basic]
Public Sub Backward( _
ByVal ms As Integer _
)
[C#]
public void Backward(
Int32 ms
);

Parameters

ms

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.Close Method

Closes audio stream

[Visual Basic]
Public Sub Close()
[C#]
public void Close();

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.Forward Method

Forwards current stream position

[Visual Basic]
Public Sub Forward( _
ByVal ms As Integer _
)
[C#]
public void Forward(
Int32 ms
);

Parameters

ms

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.Open Method

Open existing audio file for recording and playback

[Visual Basic]
Public Sub Open( _
ByVal readWriter As IAudioReader _
)
[C#]
public void Open(
IAudioReader readWriter
);

Parameters

readWriter

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.Pause Method

Pauses recording or playback

[Visual Basic]
Public Sub Pause()
[C#]
public void Pause();

See Also

RecordPlayer Class | Alvas.Audio Namespace


Play Method

Alvas.Audio Class Library

RecordPlayer.Play Method

Plays audio stream

Overload List

Plays audio stream

public void Play();

Plays audio stream from stated position

public void Play(Int32);

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.Play Method ()

Plays audio stream

[Visual Basic]
Overloads Public Sub Play()
[C#]
public void Play();

See Also

RecordPlayer Class | Alvas.Audio Namespace | RecordPlayer.Play Overload List


RecordPlayer.Play Method (Int32)

Plays audio stream from stated position

[Visual Basic]
Overloads Public Sub Play( _
ByVal positionInMS As Integer _
)
[C#]
public void Play(
Int32 positionInMS
);

Parameters

positionInMS
position in milliseconds

See Also

RecordPlayer Class | Alvas.Audio Namespace | RecordPlayer.Play Overload List


Record Method

Alvas.Audio Class Library

RecordPlayer.Record Method

Records audio stream

Overload List

Records audio stream

public void Record();

Records audio stream from specified position in milliseconds.

public void Record(Int32);

Records audio stream from specified position in milliseconds with specified mode.

public void Record(Int32,WriteMode);

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.Record Method ()

Records audio stream

[Visual Basic]
Overloads Public Sub Record()
[C#]
public void Record();

See Also

RecordPlayer Class | Alvas.Audio Namespace | RecordPlayer.Record Overload List


RecordPlayer.Record Method (Int32)

Records audio stream from specified position in milliseconds.

[Visual Basic]
Overloads Public Sub Record( _
ByVal positionInMS As Integer _
)
[C#]
public void Record(
Int32 positionInMS
);

See Also

RecordPlayer Class | Alvas.Audio Namespace | RecordPlayer.Record Overload List


RecordPlayer.Record Method (Int32, WriteMode)

Records audio stream from specified position in milliseconds with specified mode.

[Visual Basic]
Overloads Public Sub Record( _
ByVal positionInMS As Integer, _
ByVal mode As WriteMode _
)
[C#]
public void Record(
Int32 positionInMS,
WriteMode mode
);

Parameters

positionInMS
position in milliseconds
mode
specified mode

See Also

RecordPlayer Class | Alvas.Audio Namespace | RecordPlayer.Record Overload List


RecordPlayer.Stop Method

Stops recording or playback

[Visual Basic]
Public Sub Stop()
[C#]
public void Stop();

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer Events

The events of the RecordPlayer class are listed below. For a complete list of RecordPlayer class members, see the RecordPlayer Members topic.

Public Instance Events

PropertyChanged Occurs when a property changes values.

See Also

RecordPlayer Class | Alvas.Audio Namespace


RecordPlayer.PropertyChanged Event

Occurs when a property changes values.

[Visual Basic]
Public Event PropertyChanged As PropertyChangedEventHandler
[C#]
public event PropertyChangedEventHandler PropertyChanged;

Implements

INotifyPropertyChanged.PropertyChanged

See Also

RecordPlayer Class | Alvas.Audio Namespace


SoundLevelMeter Class

Sound level meter is a component that allows audio signal level to be viewed. The sound level meter draws a horizontal line across the middle of the screen from left to right. If the input sound level departs from zero, the line is deflected either upwards or downwards.

For a list of all members of this type, see SoundLevelMeter Members.

System.Object
MarshalByRefObject
Component
Control
SoundLevelMeter

[Visual Basic]
Public Class SoundLevelMeter
Inherits
[C#]
public class SoundLevelMeter : Control

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example shows simple using of SoundLevelMeter class.

SoundLevelMeter vum = new SoundLevelMeter();
WaveReader wr = new WaveReader(File.OpenRead("in.wav"));
IntPtr format = wr.ReadFormat();
byte[] data = wr.ReadData();
wr.Close();
short[] buffer = AudioCompressionManager.RecalculateData(format, data, vum.ClientRectangle.Width);
vum.Data = buffer;

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

SoundLevelMeter Members | Alvas.Audio Namespace


SoundLevelMeter Members

SoundLevelMeter overview

Public Instance Constructors

SoundLevelMeter Constructor

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoSize (inherited from Control) | This property is not relevant for this class.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle | Gets or sets the border style for the control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Data | Audio data array for the SoundLevelMeter.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
OwnerDraw | Gets or sets a value indicating whether the control is drawn by itself or by the code that you provide.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control and all its parent controls are displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) | This property is not relevant for this class.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) |
PreProcessMessage (inherited from Control) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Font property to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AutoSizeChanged (inherited from Control) | This event is not relevant for this class.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Occurs when the component is disposed by a call to the Dispose method.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses or gains mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

SoundLevelMeter Class | Alvas.Audio Namespace


SoundLevelMeter Constructor

[Visual Basic]
Public Sub New()
[C#]
public SoundLevelMeter();

See Also

SoundLevelMeter Class | Alvas.Audio Namespace


SoundLevelMeter Properties

The properties of the SoundLevelMeter class are listed below. For a complete list of SoundLevelMeter class members, see the SoundLevelMeter Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoSize (inherited from Control) | This property is not relevant for this class.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle | Gets or sets the border style for the control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Data | Audio data array for the SoundLevelMeter.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
OwnerDraw | Gets or sets a value indicating whether the control is drawn by itself or by the code that you provide.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control and all its parent controls are displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) | This property is not relevant for this class.

See Also

SoundLevelMeter Class | Alvas.Audio Namespace


BorderStyle Property

Alvas.Audio Class Library

SoundLevelMeter.BorderStyle Property

Gets or sets the border style for the control.

[Visual Basic]
Public Property BorderStyle As BorderStyle
[C#]
public BorderStyle BorderStyle {get; set;}

See Also

SoundLevelMeter Class | Alvas.Audio Namespace


Data Property

Alvas.Audio Class Library

SoundLevelMeter.Data Property

Audio data array for the SoundLevelMeter.

[Visual Basic]
Public Property Data As Short()
[C#]
public Int16[] Data {get; set;}

See Also

SoundLevelMeter Class | Alvas.Audio Namespace


OwnerDraw Property

Alvas.Audio Class Library

SoundLevelMeter.OwnerDraw Property

Gets or sets a value indicating whether the control is drawn by itself or by the code that you provide.

[Visual Basic]
Public Property OwnerDraw As Boolean
[C#]
public Boolean OwnerDraw {get; set;}

See Also

SoundLevelMeter Class | Alvas.Audio Namespace


TimeFormat Enumeration

TimeFormat specifies the sound position in milliseconds, bytes or samples.

[Visual Basic]
Public Enum TimeFormat
[C#]
public enum TimeFormat

Members

Member Name | Description
Milliseconds | Time in milliseconds
Samples | Number of wave samples
Bytes | Current byte offset

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Alvas.Audio Namespace


Vox Class

Class for encoding and decoding Dialogic .vox (adpcm) format data

For a list of all members of this type, see Vox Members.

System.Object
Vox

[Visual Basic]
Public Class Vox
[C#]
public class Vox

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Vox Members | Alvas.Audio Namespace


Vox Members

Vox overview

Public Static (Shared) Methods

Raw2Vox | Encode raw PCM-data to Dialogic .vox (adpcm) format data
Vox2Mp3 | Overloaded. Converts Dialogic .vox (adpcm) file to Mp3 file.
Vox2Wav | Overloaded. Decodes Dialogic .vox (adpcm) format data to wave PCM-data format

Public Instance Constructors

Vox Constructor Initializes a new instance of the Vox class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Vox Class | Alvas.Audio Namespace


Vox Constructor

Initializes a new instance of the Vox class.

[Visual Basic]
Public Sub New()
[C#]
public Vox();

See Also

Vox Class | Alvas.Audio Namespace


Vox Methods

The methods of the Vox class are listed below. For a complete list of Vox class members, see the Vox Members topic.

Public Static (Shared) Methods

Raw2Vox | Encode raw PCM-data to Dialogic .vox (adpcm) format data
Vox2Mp3 | Overloaded. Converts Dialogic .vox (adpcm) file to Mp3 file.
Vox2Wav | Overloaded. Decodes Dialogic .vox (adpcm) format data to wave PCM-data format

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Vox Class | Alvas.Audio Namespace


Vox.Raw2Vox Method

Encode raw PCM-data to Dialogic .vox (adpcm) format data

[Visual Basic]
Public Shared Sub Raw2Vox( _
ByVal br As BinaryReader, _
ByVal bw As BinaryWriter, _
ByVal bitsPerSample As Short _
)
[C#]
public static void Raw2Vox(
BinaryReader br,
BinaryWriter bw,
Int16 bitsPerSample
);

Parameters

br
bw
bitsPerSample

Example

This example shows simple using of Raw2Vox method.

private static void Decode2Pcm(ref IntPtr format, ref byte[] data, ref WaveFormat wf)
{
    IntPtr newFormat = AudioCompressionManager.GetCompatibleFormat(format, AudioCompressionManager.PcmFormatTag);
    byte[] buffer = AudioCompressionManager.Convert(format, newFormat, data, false);
    wf = AudioCompressionManager.GetWaveFormat(newFormat);
    format = newFormat;
    data = buffer;
}

public static void Raw2VoxTest()
{
    string inFile = "in.wav";
    string outFile = "out.vox";
    WaveReader wr = new WaveReader(File.OpenRead(inFile));
    IntPtr format = wr.ReadFormat();
    byte[] data = wr.ReadData();
    wr.Close();
    WaveFormat wf = AudioCompressionManager.GetWaveFormat(format);
    if (wf.wFormatTag != AudioCompressionManager.PcmFormatTag)//Decode if not PCM data
    {
        Decode2Pcm(ref format, ref data, ref wf);
    }
    BinaryWriter bw = new BinaryWriter(File.OpenWrite(outFile));
    BinaryReader br = new BinaryReader(new MemoryStream(data));
    Vox.Raw2Vox(br, bw, wf.wBitsPerSample);
    br.Close();
    bw.Close();
}

See Also

Vox Class | Alvas.Audio Namespace


Vox2Mp3 Method

Alvas.Audio Class Library

Vox.Vox2Mp3 Method

Converts Dialogic .vox (adpcm) data to Mp3 audio data.

Overload List

Converts Dialogic .vox (adpcm) data to Mp3 audio data.

public static void Vox2Mp3(BinaryReader,BinaryWriter,Int32);

public static void Vox2Mp3(BinaryReader,BinaryWriter,Int32,ref AdpcmStatus&);

Converts Dialogic .vox (adpcm) stream to Mp3 stream.

public static void Vox2Mp3(Stream,Stream,Int32);

public static void Vox2Mp3(Stream,Stream,Int32,ref AdpcmStatus&);

Converts Dialogic .vox (adpcm) file to Mp3 file.

public static void Vox2Mp3(String,String,Int32);

See Also

Vox Class | Alvas.Audio Namespace


Vox.Vox2Mp3 Method (BinaryReader, BinaryWriter, Int32)

Converts Dialogic .vox (adpcm) data to Mp3 audio data.

[Visual Basic]
Overloads Public Shared Sub Vox2Mp3( _
ByVal br As BinaryReader, _
ByVal bw As BinaryWriter, _
ByVal samplesPerSec As Integer _
)
[C#]
public static void Vox2Mp3(
BinaryReader br,
BinaryWriter bw,
Int32 samplesPerSec
);

Parameters

br
bw
samplesPerSec

Example

This example shows simple using of Vox2Mp3 method.

string voxFile = "in.vox";
string mp3File = "out.mp3";
int samplesPerSec = 8000;
BinaryReader br = new BinaryReader(File.OpenRead(voxFile));
Mp3Writer mw = new Mp3Writer(File.Create(mp3File));
Vox.Vox2Mp3(br, mw, samplesPerSec);
mw.Close();
br.Close();

See Also

Vox Class | Alvas.Audio Namespace | Vox.Vox2Mp3 Overload List


Vox.Vox2Mp3 Method (BinaryReader, BinaryWriter, Int32, Vox#AdpcmStatus)

[Visual Basic]
Overloads Public Shared Sub Vox2Mp3( _
ByVal br As BinaryReader, _
ByVal bw As BinaryWriter, _
ByVal samplesPerSec As Integer, _
ByRef coder_stat As Vox#AdpcmStatus _
)
[C#]
public static void Vox2Mp3(
BinaryReader br,
BinaryWriter bw,
Int32 samplesPerSec,
ref AdpcmStatus& coder_stat
);

See Also

Vox Class | Alvas.Audio Namespace | Vox.Vox2Mp3 Overload List


Vox.Vox2Mp3 Method (Stream, Stream, Int32)

Converts Dialogic .vox (adpcm) stream to Mp3 stream.

[Visual Basic]
Overloads Public Shared Sub Vox2Mp3( _
ByVal voxStream As Stream, _
ByVal mp3Stream As Stream, _
ByVal samplesPerSec As Integer _
)
[C#]
public static void Vox2Mp3(
Stream voxStream,
Stream mp3Stream,
Int32 samplesPerSec
);

Parameters

voxStream
input Vox stream
mp3Stream
output Mp3 stream
samplesPerSec
samples per second

Example

This example shows simple using of Vox2Mp3 method.

string voxFile = "in.vox";
string mp3File = "out.mp3";
int samplesPerSec = 8000;
Vox.Vox2Mp3(File.OpenRead(voxFile), File.Create(mp3File), samplesPerSec);

See Also

Vox Class | Alvas.Audio Namespace | Vox.Vox2Mp3 Overload List


Vox.Vox2Mp3 Method (Stream, Stream, Int32, Vox#AdpcmStatus)

[Visual Basic]
Overloads Public Shared Sub Vox2Mp3( _
ByVal voxStream As Stream, _
ByVal mp3Stream As Stream, _
ByVal samplesPerSec As Integer, _
ByRef coder_stat As Vox#AdpcmStatus _
)
[C#]
public static void Vox2Mp3(
Stream voxStream,
Stream mp3Stream,
Int32 samplesPerSec,
ref AdpcmStatus& coder_stat
);

See Also

Vox Class | Alvas.Audio Namespace | Vox.Vox2Mp3 Overload List


Vox.Vox2Mp3 Method (String, String, Int32)

Converts Dialogic .vox (adpcm) file to Mp3 file.

[Visual Basic]
Overloads Public Shared Sub Vox2Mp3( _
ByVal voxFile As String, _
ByVal mp3File As String, _
ByVal samplesPerSec As Integer _
)
[C#]
public static void Vox2Mp3(
String voxFile,
String mp3File,
Int32 samplesPerSec
);

Parameters

voxFile
input Vox file
mp3File
output Mp3 file
samplesPerSec
samples per second

Example

This example shows simple using of Vox2Mp3 method.

string voxFile = "in.vox";
string mp3File = "out.mp3";
int samplesPerSec = 8000;
Vox.Vox2Mp3(voxFile, mp3File, samplesPerSec);

See Also

Vox Class | Alvas.Audio Namespace | Vox.Vox2Mp3 Overload List


Vox2Wav Method

Alvas.Audio Class Library

Vox.Vox2Wav Method

Decodes Dialogic .vox (adpcm) format data to wave PCM-data format

Overload List

Decodes Dialogic .vox (adpcm) format data to wave PCM-data format

public static void Vox2Wav(BinaryReader,WaveWriter);

public static void Vox2Wav(BinaryReader,WaveWriter,ref AdpcmStatus&);

See Also

Vox Class | Alvas.Audio Namespace


Vox.Vox2Wav Method (BinaryReader, WaveWriter)

Decodes Dialogic .vox (adpcm) format data to wave PCM-data format

[Visual Basic]
Overloads Public Shared Sub Vox2Wav( _
ByVal br As BinaryReader, _
ByVal ww As WaveWriter _
)
[C#]
public static void Vox2Wav(
BinaryReader br,
WaveWriter ww
);

Parameters

br
ww

Example

This example shows simple using of Vox2Wav method.

string voxFile = "in.vox";
int samplesPerSec = 8000;
string wavFile = "out.wav";
BinaryReader br = new BinaryReader(File.OpenRead(voxFile));
IntPtr format = AudioCompressionManager.GetPcmFormat(1, 16, samplesPerSec);
WaveWriter ww = new WaveWriter(File.Create(wavFile), AudioCompressionManager.FormatBytes(format));
Vox.Vox2Wav(br, ww);
br.Close();
ww.Close();

See Also

Vox Class | Alvas.Audio Namespace | Vox.Vox2Wav Overload List


Vox.Vox2Wav Method (BinaryReader, WaveWriter, Vox#AdpcmStatus)

[Visual Basic]
Overloads Public Shared Sub Vox2Wav( _
ByVal br As BinaryReader, _
ByVal ww As WaveWriter, _
ByRef coder_stat As Vox#AdpcmStatus _
)
[C#]
public static void Vox2Wav(
BinaryReader br,
WaveWriter ww,
ref AdpcmStatus& coder_stat
);

See Also

Vox Class | Alvas.Audio Namespace | Vox.Vox2Wav Overload List


Vox.AdpcmStatus Structure

Coder status strucrure

For a list of all members of this type, see Vox.AdpcmStatus Members.

System.Object
ValueType
Vox.AdpcmStatus

[Visual Basic]
Public Structure Vox.AdpcmStatus
[C#]
public struct Vox.AdpcmStatus

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Vox.AdpcmStatus Members | Alvas.Audio Namespace


Vox.AdpcmStatus Members

Vox.AdpcmStatus overview

Public Instance Fields

Last | Last
StepIndex | StepIndex

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Vox.AdpcmStatus Class | Alvas.Audio Namespace


Vox.AdpcmStatus Fields

The fields of the Vox.AdpcmStatus structure are listed below. For a complete list of Vox.AdpcmStatus structure members, see the Vox.AdpcmStatus Members topic.

Public Instance Fields

Last | Last
StepIndex | StepIndex

See Also

Vox.AdpcmStatus Class | Alvas.Audio Namespace


Vox.AdpcmStatus.Last Field

Last

[Visual Basic]
Public Last As Short
[C#]
public Int16 Last;

See Also

Vox.AdpcmStatus Class | Alvas.Audio Namespace


Vox.AdpcmStatus.StepIndex Field

StepIndex

[Visual Basic]
Public StepIndex As Short
[C#]
public Int16 StepIndex;

See Also

Vox.AdpcmStatus Class | Alvas.Audio Namespace


WaveFormat Class

Describes the format of the waveform-audio data.

For a list of all members of this type, see WaveFormat Members.

System.Object
WaveFormat

[Visual Basic]
Public Class WaveFormat
[C#]
public class WaveFormat

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

WaveFormat Members | Alvas.Audio Namespace


WaveFormat Members

WaveFormat overview

Public Instance Constructors

WaveFormat Constructor Initializes a new instance of the WaveFormat class.

Public Instance Fields

nAvgBytesPerSec | Required average data transfer rate, in bytes per second. For example, 16-bit stereo at 44.1 kHz has an average data rate of 176,400 bytes per second (2 channels — 2 bytes per sample per channel — 44,100 samples per second).
nBlockAlign | Block alignment, in bytes. The block alignment is the minimum atomic unit of data. For PCM data, the block alignment is the number of bytes used by a single sample, including data for both channels if the data is stereo. For example, the block alignment for 16-bit stereo PCM is 4 bytes (2 channels — 2 bytes per sample).
nChannels | Number of channels in the waveform-audio data. Mono data uses one channel and stereo data uses two channels.
nSamplesPerSec | Sample rate, in samples per second.
wBitsPerSample | Bits per sample for the wFormatTag format type. If wFormatTag is PCM, then wBitsPerSample should be equal to 8 or 16. For non-PCM formats, this member must be set according to the manufacturer's specification of the format tag. Note that some compression schemes cannot define a value for wBitsPerSample, so this member can be zero.
wFormatTag | Format tag.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WaveFormat Class | Alvas.Audio Namespace


WaveFormat Constructor

Initializes a new instance of the WaveFormat class.

[Visual Basic]
Public Sub New()
[C#]
public WaveFormat();

See Also

WaveFormat Class | Alvas.Audio Namespace


WaveFormat Fields

The fields of the WaveFormat class are listed below. For a complete list of WaveFormat class members, see the WaveFormat Members topic.

Public Instance Fields

nAvgBytesPerSec | Required average data transfer rate, in bytes per second. For example, 16-bit stereo at 44.1 kHz has an average data rate of 176,400 bytes per second (2 channels — 2 bytes per sample per channel — 44,100 samples per second).
nBlockAlign | Block alignment, in bytes. The block alignment is the minimum atomic unit of data. For PCM data, the block alignment is the number of bytes used by a single sample, including data for both channels if the data is stereo. For example, the block alignment for 16-bit stereo PCM is 4 bytes (2 channels — 2 bytes per sample).
nChannels | Number of channels in the waveform-audio data. Mono data uses one channel and stereo data uses two channels.
nSamplesPerSec | Sample rate, in samples per second.
wBitsPerSample | Bits per sample for the wFormatTag format type. If wFormatTag is PCM, then wBitsPerSample should be equal to 8 or 16. For non-PCM formats, this member must be set according to the manufacturer's specification of the format tag. Note that some compression schemes cannot define a value for wBitsPerSample, so this member can be zero.
wFormatTag | Format tag.

See Also

WaveFormat Class | Alvas.Audio Namespace


WaveFormat.nAvgBytesPerSec Field

Required average data transfer rate, in bytes per second. For example, 16-bit stereo at 44.1 kHz has an average data rate of 176,400 bytes per second (2 channels — 2 bytes per sample per channel — 44,100 samples per second).

[Visual Basic]
Public nAvgBytesPerSec As Integer
[C#]
public Int32 nAvgBytesPerSec;

See Also

WaveFormat Class | Alvas.Audio Namespace


WaveFormat.nBlockAlign Field

Block alignment, in bytes. The block alignment is the minimum atomic unit of data. For PCM data, the block alignment is the number of bytes used by a single sample, including data for both channels if the data is stereo. For example, the block alignment for 16-bit stereo PCM is 4 bytes (2 channels — 2 bytes per sample).

[Visual Basic]
Public nBlockAlign As Short
[C#]
public Int16 nBlockAlign;

See Also

WaveFormat Class | Alvas.Audio Namespace


WaveFormat.nChannels Field

Number of channels in the waveform-audio data. Mono data uses one channel and stereo data uses two channels.

[Visual Basic]
Public nChannels As Short
[C#]
public Int16 nChannels;

See Also

WaveFormat Class | Alvas.Audio Namespace


WaveFormat.nSamplesPerSec Field

Sample rate, in samples per second.

[Visual Basic]
Public nSamplesPerSec As Integer
[C#]
public Int32 nSamplesPerSec;

See Also

WaveFormat Class | Alvas.Audio Namespace


WaveFormat.wBitsPerSample Field

Bits per sample for the wFormatTag format type. If wFormatTag is PCM, then wBitsPerSample should be equal to 8 or 16. For non-PCM formats, this member must be set according to the manufacturer's specification of the format tag. Note that some compression schemes cannot define a value for wBitsPerSample, so this member can be zero.

[Visual Basic]
Public wBitsPerSample As Short
[C#]
public Int16 wBitsPerSample;

See Also

WaveFormat Class | Alvas.Audio Namespace


WaveFormat.wFormatTag Field

Format tag.

[Visual Basic]
Public wFormatTag As Short
[C#]
public Int16 wFormatTag;

See Also

WaveFormat Class | Alvas.Audio Namespace


WaveFormat Methods

The methods of the WaveFormat class are listed below. For a complete list of WaveFormat class members, see the WaveFormat Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WaveFormat Class | Alvas.Audio Namespace


WaveFormat.Equals Method

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
Object obj
);

Parameters

obj

Return Value

See Also

WaveFormat Class | Alvas.Audio Namespace


WaveFormat.GetHashCode Method

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

See Also

WaveFormat Class | Alvas.Audio Namespace


WaveformVisualizer Class

WaveformVisualizer draws picture of the sound amplitude-time representation (Waveform).

For a list of all members of this type, see WaveformVisualizer Members.

System.Object
MarshalByRefObject
Component
Control
WaveformVisualizer

[Visual Basic]
Public Class WaveformVisualizer
Inherits
[C#]
public class WaveformVisualizer : Control

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

WaveformVisualizer Members | Alvas.Audio Namespace


WaveformVisualizer Members

WaveformVisualizer overview

Public Instance Constructors

WaveformVisualizer Constructor

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoSize (inherited from Control) | This property is not relevant for this class.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle | Gets or sets the border style for the control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Data | Gets audio data.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DurationInMS | Gets audio data duration in milliseconds.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format | Gets audio format.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
Position | Gets or sets the current audio position.
PositionColor | Gets or sets the color of the current position indicator.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowPosition | Gets or sets a value indicating whether the position indicator is displayed.
ShowTimeline | Gets or sets a value indicating whether the timeline is displayed.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TimeLineColor | Gets or sets the timeline font color.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control and all its parent controls are displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) | This property is not relevant for this class.

Public Instance Methods

Assign | Sets the audio format and audio data
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) |
PreProcessMessage (inherited from Control) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Font property to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AutoSizeChanged (inherited from Control) | This event is not relevant for this class.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Occurs when the component is disposed by a call to the Dispose method.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses or gains mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
PaintBackground | Occurs when the control background is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

WaveformVisualizer Class | Alvas.Audio Namespace


WaveformVisualizer Constructor

[Visual Basic]
Public Sub New()
[C#]
public WaveformVisualizer();

See Also

WaveformVisualizer Class | Alvas.Audio Namespace


WaveformVisualizer Properties

The properties of the WaveformVisualizer class are listed below. For a complete list of WaveformVisualizer class members, see the WaveformVisualizer Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoSize (inherited from Control) | This property is not relevant for this class.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle | Gets or sets the border style for the control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Data | Gets audio data.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DurationInMS | Gets audio data duration in milliseconds.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format | Gets audio format.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
Position | Gets or sets the current audio position.
PositionColor | Gets or sets the color of the current position indicator.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowPosition | Gets or sets a value indicating whether the position indicator is displayed.
ShowTimeline | Gets or sets a value indicating whether the timeline is displayed.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TimeLineColor | Gets or sets the timeline font color.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control and all its parent controls are displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) | This property is not relevant for this class.

See Also

WaveformVisualizer Class | Alvas.Audio Namespace


BorderStyle Property

Alvas.Audio Class Library

WaveformVisualizer.BorderStyle Property

Gets or sets the border style for the control.

[Visual Basic]
Public Property BorderStyle As BorderStyle
[C#]
public BorderStyle BorderStyle {get; set;}

See Also

WaveformVisualizer Class | Alvas.Audio Namespace


Data Property

Alvas.Audio Class Library

WaveformVisualizer.Data Property

Gets audio data.

[Visual Basic]
Public ReadOnly Property Data As Byte()
[C#]
public Byte[] Data {get;}

See Also

WaveformVisualizer Class | Alvas.Audio Namespace


DurationInMS Property

Alvas.Audio Class Library

WaveformVisualizer.DurationInMS Property

Gets audio data duration in milliseconds.

[Visual Basic]
Public ReadOnly Property DurationInMS As Integer
[C#]
public Int32 DurationInMS {get;}

See Also

WaveformVisualizer Class | Alvas.Audio Namespace


Format Property

Alvas.Audio Class Library

WaveformVisualizer.Format Property

Gets audio format.

[Visual Basic]
Public ReadOnly Property Format As IntPtr
[C#]
public IntPtr Format {get;}

See Also

WaveformVisualizer Class | Alvas.Audio Namespace


Position Property

Alvas.Audio Class Library

WaveformVisualizer.Position Property

Gets or sets the current audio position.

[Visual Basic]
Public Property Position As Integer
[C#]
public Int32 Position {get; set;}

See Also

WaveformVisualizer Class | Alvas.Audio Namespace


PositionColor Property

Alvas.Audio Class Library

WaveformVisualizer.PositionColor Property

Gets or sets the color of the current position indicator.

[Visual Basic]
Public Property PositionColor As Color
[C#]
public Color PositionColor {get; set;}

See Also

WaveformVisualizer Class | Alvas.Audio Namespace


ShowPosition Property

Alvas.Audio Class Library

WaveformVisualizer.ShowPosition Property

Gets or sets a value indicating whether the position indicator is displayed.

[Visual Basic]
Public Property ShowPosition As Boolean
[C#]
public Boolean ShowPosition {get; set;}

See Also

WaveformVisualizer Class | Alvas.Audio Namespace


ShowTimeline Property

Alvas.Audio Class Library

WaveformVisualizer.ShowTimeline Property

Gets or sets a value indicating whether the timeline is displayed.

[Visual Basic]
Public Property ShowTimeline As Boolean
[C#]
public Boolean ShowTimeline {get; set;}

See Also

WaveformVisualizer Class | Alvas.Audio Namespace


TimeLineColor Property

Alvas.Audio Class Library

WaveformVisualizer.TimeLineColor Property

Gets or sets the timeline font color.

[Visual Basic]
Public Property TimeLineColor As Color
[C#]
public Color TimeLineColor {get; set;}

See Also

WaveformVisualizer Class | Alvas.Audio Namespace


WaveformVisualizer Methods

The methods of the WaveformVisualizer class are listed below. For a complete list of WaveformVisualizer class members, see the WaveformVisualizer Members topic.

Public Instance Methods

Assign | Sets the audio format and audio data
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) |
PreProcessMessage (inherited from Control) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Font property to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

See Also

WaveformVisualizer Class | Alvas.Audio Namespace


WaveformVisualizer.Assign Method

Sets the audio format and audio data

[Visual Basic]
Public Sub Assign( _
ByVal format As IntPtr, _
ByVal data As Byte() _
)
[C#]
public void Assign(
IntPtr format,
Byte[] data
);

Parameters

format
audio format
data
audio data array

See Also

WaveformVisualizer Class | Alvas.Audio Namespace


WaveformVisualizer Events

The events of the WaveformVisualizer class are listed below. For a complete list of WaveformVisualizer class members, see the WaveformVisualizer Members topic.

Public Instance Events

AutoSizeChanged (inherited from Control) | This event is not relevant for this class.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Occurs when the component is disposed by a call to the Dispose method.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses or gains mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
PaintBackground | Occurs when the control background is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

WaveformVisualizer Class | Alvas.Audio Namespace


WaveformVisualizer.PaintBackground Event

Occurs when the control background is redrawn.

[Visual Basic]
Public Event PaintBackground As PaintEventHandler
[C#]
public event PaintEventHandler PaintBackground;

See Also

WaveformVisualizer Class | Alvas.Audio Namespace


WaveInException Class

The exception that is thrown when a WaveIn error occurs.

For a list of all members of this type, see WaveInException Members.

System.Object
Exception
AudioException
WaveInException

[Visual Basic]
Public Class WaveInException
Inherits
[C#]
public class WaveInException : AudioException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

WaveInException Members | Alvas.Audio Namespace


WaveInException Members

WaveInException overview

Public Instance Constructors

WaveInException Constructor

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode | Gets the error code associated with this exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

See Also

WaveInException Class | Alvas.Audio Namespace


WaveInException Constructor

[Visual Basic]
Public Sub New( _
ByVal errorCode As Integer _
)
[C#]
public WaveInException(
Int32 errorCode
);

Parameters

errorCode

See Also

WaveInException Class | Alvas.Audio Namespace


WaveInException Properties

The properties of the WaveInException class are listed below. For a complete list of WaveInException class members, see the WaveInException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode | Gets the error code associated with this exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

WaveInException Class | Alvas.Audio Namespace


ErrorCode Property

Alvas.Audio Class Library

WaveInException.ErrorCode Property

Gets the error code associated with this exception.

[Visual Basic]
Public ReadOnly Property ErrorCode As Integer
[C#]
public Int32 ErrorCode {get;}

See Also

WaveInException Class | Alvas.Audio Namespace


Message Property

Alvas.Audio Class Library

WaveInException.Message Property

[Visual Basic]
Overrides Public ReadOnly Property Message As String
[C#]
public override String Message {get;}

See Also

WaveInException Class | Alvas.Audio Namespace


WaveInfo Enumeration

Wave Info tag list

[Visual Basic]
Public Enum WaveInfo
[C#]
public enum WaveInfo

Members

Member Name | Description
ArchivalLocation | Archival Location
Artist | Artist
Commissioned | Commissioned
Comments | Comments
Copyright | Copyright
CreationDate | Creation date
Cropped | Cropped
Dimensions | Dimensions
DotsPerInch | Dots Per Inch
Engineer | Engineer
Genre | Genre
Keywords | Keywords
Lightness | Lightness
Medium | Medium
Name | Name
PaletteSetting | Palette Setting
Product | Product
Subject | Subject
Software | Software
Sharpness | Sharpness
Source | Source
SourceForm | Source Form
Technician | Technician

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Alvas.Audio Namespace


WaveOutException Class

The exception that is thrown when a WaveOut error occurs.

For a list of all members of this type, see WaveOutException Members.

System.Object
Exception
AudioException
WaveOutException

[Visual Basic]
Public Class WaveOutException
Inherits
[C#]
public class WaveOutException : AudioException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

WaveOutException Members | Alvas.Audio Namespace


WaveOutException Members

WaveOutException overview

Public Instance Constructors

WaveOutException Constructor

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode | Gets the error code associated with this exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

See Also

WaveOutException Class | Alvas.Audio Namespace


WaveOutException Constructor

[Visual Basic]
Public Sub New( _
ByVal errorCode As Integer _
)
[C#]
public WaveOutException(
Int32 errorCode
);

Parameters

errorCode

See Also

WaveOutException Class | Alvas.Audio Namespace


WaveOutException Properties

The properties of the WaveOutException class are listed below. For a complete list of WaveOutException class members, see the WaveOutException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode | Gets the error code associated with this exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

WaveOutException Class | Alvas.Audio Namespace


ErrorCode Property

Alvas.Audio Class Library

WaveOutException.ErrorCode Property

Gets the error code associated with this exception.

[Visual Basic]
Public ReadOnly Property ErrorCode As Integer
[C#]
public Int32 ErrorCode {get;}

See Also

WaveOutException Class | Alvas.Audio Namespace


Message Property

Alvas.Audio Class Library

WaveOutException.Message Property

[Visual Basic]
Overrides Public ReadOnly Property Message As String
[C#]
public override String Message {get;}

See Also

WaveOutException Class | Alvas.Audio Namespace


WaveReader Class

Reads WAVE (waveform audio format) data from the stream.

For a list of all members of this type, see WaveReader Members.

System.Object
BinaryReader
AudioReader
WaveReader
WaveReadWriter

[Visual Basic]
Public Class WaveReader
Inherits
[C#]
public class WaveReader : AudioReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example shows how simple use WaveReader.

WaveReader wr = new WaveReader(File.OpenRead("123.wav"));
IntPtr format = wr.ReadFormat();
byte[] data = wr.ReadData();
wr.Close();

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

WaveReader Members | Alvas.Audio Namespace


WaveReader Members

WaveReader overview

Public Instance Constructors

WaveReader Constructor Initializes a new instance of the WaveReader class for the specified stream.

Public Instance Properties

BaseStream (inherited from BinaryReader) Exposes access to the underlying stream of the BinaryReader.

Public Instance Methods

Close (inherited from BinaryReader) | Closes the current reader and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS | Gets audio stream duration in milliseconds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeMP3 | Changes Wave stream to MP3 stream if Wave stream contains MPEG Layer 3 data.
Milliseconds2Bytes (inherited from AudioReader) | Converts from milliseconds to bytes for current stream.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadData | Overloaded. Reads all audio data from the stream.
ReadDataInBytes | Overloaded. Reads audio data from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadFormat | Reads an audio format.
ReadInfoTag | Reads INFO metadata(similar mp3 tags) from Wave stream.
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WaveReader Class | Alvas.Audio Namespace


WaveReader Constructor

Initializes a new instance of the WaveReader class for the specified stream.

[Visual Basic]
Public Sub New( _
ByVal input As Stream _
)
[C#]
public WaveReader(
Stream input
);

Parameters

input
The stream to be read.

See Also

WaveReader Class | Alvas.Audio Namespace


WaveReader Methods

The methods of the WaveReader class are listed below. For a complete list of WaveReader class members, see the WaveReader Members topic.

Public Instance Methods

Close (inherited from BinaryReader) | Closes the current reader and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS | Gets audio stream duration in milliseconds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeMP3 | Changes Wave stream to MP3 stream if Wave stream contains MPEG Layer 3 data.
Milliseconds2Bytes (inherited from AudioReader) | Converts from milliseconds to bytes for current stream.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadData | Overloaded. Reads all audio data from the stream.
ReadDataInBytes | Overloaded. Reads audio data from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadFormat | Reads an audio format.
ReadInfoTag | Reads INFO metadata(similar mp3 tags) from Wave stream.
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WaveReader Class | Alvas.Audio Namespace


WaveReader.GetDurationInMS Method

Gets audio stream duration in milliseconds.

[Visual Basic]
Overrides Public Function GetDurationInMS() As Integer _
Implements IAudioReader.GetDurationInMS
[C#]
public override int GetDurationInMS();

Return Value

Implements

IAudioReader.GetDurationInMS

See Also

WaveReader Class | Alvas.Audio Namespace


WaveReader.GetLengthInBytes Method

Gets audio stream length in bytes.

[Visual Basic]
Overrides Public Function GetLengthInBytes() As Integer _
Implements IAudioReader.GetLengthInBytes
[C#]
public override int GetLengthInBytes();

Return Value

Implements

IAudioReader.GetLengthInBytes

See Also

WaveReader Class | Alvas.Audio Namespace


WaveReader.MakeMP3 Method

Changes Wave stream to MP3 stream if Wave stream contains MPEG Layer 3 data.

[Visual Basic]
Public Sub MakeMP3( _
ByVal stream As Stream _
)
[C#]
public void MakeMP3(
Stream stream
);

Parameters

stream
stream with resulting mp3 header and data

Example

This example shows simple using of MakeMP3 method.

string wavFile = "in.wav";
using (WaveReader wr = new WaveReader(File.OpenRead(wavFile)))
{
    string mp3File = "out.mp3";
    using (FileStream fs = File.Create(mp3File))
    {
        wr.MakeMP3(fs);
    }
}

See Also

WaveReader Class | Alvas.Audio Namespace


ReadData Method

Alvas.Audio Class Library

WaveReader.ReadData Method

Reads all audio data from the stream.

Overload List

Reads all audio data from the stream.

public override byte[] ReadData();

Reads audio data from the stream.

public override byte[] ReadData(Int32);

Reads audio data from the stream.

public override byte[] ReadData(Int32,Int32);

See Also

WaveReader Class | Alvas.Audio Namespace


WaveReader.ReadData Method ()

Reads all audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadData() As Byte() _
Implements IAudioReader.ReadData
[C#]
public override byte[] ReadData();

Return Value

audio data array

Implements

IAudioReader.ReadData

See Also

WaveReader Class | Alvas.Audio Namespace | WaveReader.ReadData Overload List


WaveReader.ReadData Method (Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadData( _
ByVal skipSeconds As Integer _
) As Byte() _
Implements IAudioReader.ReadData
[C#]
public override byte[] ReadData(
Int32 skipSeconds
);

Parameters

skipSeconds
skips seconds

Return Value

Implements

IAudioReader.ReadData

See Also

WaveReader Class | Alvas.Audio Namespace | WaveReader.ReadData Overload List


WaveReader.ReadData Method (Int32, Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadData( _
ByVal skipSeconds As Integer, _
ByVal readSeconds As Integer _
) As Byte() _
Implements IAudioReader.ReadData
[C#]
public override byte[] ReadData(
Int32 skipSeconds,
Int32 readSeconds
);

Parameters

skipSeconds
skip seconds
readSeconds
read seconds

Return Value

Implements

IAudioReader.ReadData

See Also

WaveReader Class | Alvas.Audio Namespace | WaveReader.ReadData Overload List


ReadDataInBytes Method

Alvas.Audio Class Library

WaveReader.ReadDataInBytes Method

Reads audio data from the stream.

Overload List

Reads audio data from the stream.

public override byte[] ReadDataInBytes(Int32);

Reads audio data from the stream.

public override byte[] ReadDataInBytes(Int32,Int32);

See Also

WaveReader Class | Alvas.Audio Namespace


WaveReader.ReadDataInBytes Method (Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadDataInBytes( _
ByVal skipBytes As Integer _
) As Byte() _
Implements IAudioReader.ReadDataInBytes
[C#]
public override byte[] ReadDataInBytes(
Int32 skipBytes
);

Parameters

skipBytes
Skips length of bytes. Use Milliseconds2Bytes for this parameter.

Return Value

Implements

IAudioReader.ReadDataInBytes

See Also

WaveReader Class | Alvas.Audio Namespace | WaveReader.ReadDataInBytes Overload List


WaveReader.ReadDataInBytes Method (Int32, Int32)

Reads audio data from the stream.

[Visual Basic]
Overrides Overloads Public Function ReadDataInBytes( _
ByVal skipBytes As Integer, _
ByVal readBytes As Integer _
) As Byte() _
Implements IAudioReader.ReadDataInBytes
[C#]
public override byte[] ReadDataInBytes(
Int32 skipBytes,
Int32 readBytes
);

Parameters

skipBytes
Skips length of bytes. Use Milliseconds2Bytes for this parameter.
readBytes
Reads length of bytes. Use Milliseconds2Bytes for this parameter.

Return Value

Implements

IAudioReader.ReadDataInBytes

See Also

WaveReader Class | Alvas.Audio Namespace | WaveReader.ReadDataInBytes Overload List


WaveReader.ReadFormat Method

Reads an audio format.

[Visual Basic]
Overrides Public Function ReadFormat() As IntPtr _
Implements IAudioReader.ReadFormat
[C#]
public override IntPtr ReadFormat();

Return Value

Implements

IAudioReader.ReadFormat

See Also

WaveReader Class | Alvas.Audio Namespace


WaveReader.ReadInfoTag Method

Reads INFO metadata(similar mp3 tags) from Wave stream.

[Visual Basic]
Public Function ReadInfoTag() As String}
[C#]
public Dictionary<TKey,TValue> ReadInfoTag();

Return Value

Example

This example shows simple using of ReadInfoTag method.

WaveReader br = new WaveReader(File.OpenRead(fileName));
var dir = br.ReadInfoTag();
br.Close();
if (dir.Count > 0)
{
    foreach (string val in dir.Values)
    {
        Console.WriteLine(val);
    }
}

See Also

WaveReader Class | Alvas.Audio Namespace


WaveReaderException Class

The exception that is thrown when a wave reader error occurs.

For a list of all members of this type, see WaveReaderException Members.

System.Object
Exception
AudioException
WaveReaderException

[Visual Basic]
Public Class WaveReaderException
Inherits
[C#]
public class WaveReaderException : AudioException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

WaveReaderException Members | Alvas.Audio Namespace


WaveReaderException Members

WaveReaderException overview

Public Instance Constructors

WaveReaderException Overloaded. Initializes a new instance of the WaveReaderException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

See Also

WaveReaderException Class | Alvas.Audio Namespace


WaveReaderException Constructor

Overload List

public WaveReaderException();

public WaveReaderException(String);

See Also

WaveReaderException Class | Alvas.Audio Namespace


WaveReaderException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public WaveReaderException(
String message
);

Parameters

message

See Also

WaveReaderException Class | Alvas.Audio Namespace | WaveReaderException Constructor Overload List


WaveReaderException Constructor ()

[Visual Basic]
Overloads Public Sub New()
[C#]
public WaveReaderException();

See Also

WaveReaderException Class | Alvas.Audio Namespace | WaveReaderException Constructor Overload List


WaveReaderException Properties

The properties of the WaveReaderException class are listed below. For a complete list of WaveReaderException class members, see the WaveReaderException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

WaveReaderException Class | Alvas.Audio Namespace


Message Property

Alvas.Audio Class Library

WaveReaderException.Message Property

[Visual Basic]
Overrides Public ReadOnly Property Message As String
[C#]
public override String Message {get;}

See Also

WaveReaderException Class | Alvas.Audio Namespace


WaveReadWriter Class

Reads/writes audio data from/to the Wave stream.

For a list of all members of this type, see WaveReadWriter Members.

System.Object
BinaryReader
AudioReader
WaveReader
WaveReadWriter

[Visual Basic]
Public Class WaveReadWriter
Inherits
Implements IAudioReadWriter, IAudioWriter
[C#]
public class WaveReadWriter : WaveReader, IAudioReadWriter, IAudioWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

WaveReadWriter Members | Alvas.Audio Namespace


WaveReadWriter Members

WaveReadWriter overview

Public Instance Constructors

WaveReadWriter Overloaded. Initializes a new instance of the WaveReadWriter class.

Public Instance Properties

BaseStream (inherited from BinaryReader) Exposes access to the underlying stream of the BinaryReader.

Public Instance Methods

Close | Closes the current reader, writer and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS (inherited from WaveReader) | Gets audio stream duration in milliseconds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes (inherited from WaveReader) | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeMP3 (inherited from WaveReader) | Changes Wave stream to MP3 stream if Wave stream contains MPEG Layer 3 data.
Milliseconds2Bytes (inherited from AudioReader) | Converts from milliseconds to bytes for current stream.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadData (inherited from WaveReader) | Overloaded. Reads all audio data from the stream.
ReadDataInBytes (inherited from WaveReader) | Overloaded. Reads audio data from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadFormat (inherited from WaveReader) | Reads an audio format.
ReadInfoTag (inherited from WaveReader) | Reads INFO metadata(similar mp3 tags) from Wave stream.
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteData | Overloaded. Writes an audio byte array to the underlying stream.
WriteInfoTag | Writes INFO metadata(similar mp3 tags) into Wave stream.

See Also

WaveReadWriter Class | Alvas.Audio Namespace


WaveReadWriter Constructor

Overload List

public WaveReadWriter(Stream);

public WaveReadWriter(Stream,Byte[]);

See Also

WaveReadWriter Class | Alvas.Audio Namespace


WaveReadWriter Constructor (Stream, Byte[])

[Visual Basic]
Overloads Public Sub New( _
ByVal input As Stream, _
ByVal formatHeader As Byte() _
)
[C#]
public WaveReadWriter(
Stream input,
Byte[] formatHeader
);

Parameters

input
formatHeader

See Also

WaveReadWriter Class | Alvas.Audio Namespace | WaveReadWriter Constructor Overload List


WaveReadWriter Constructor (Stream)

[Visual Basic]
Overloads Public Sub New( _
ByVal input As Stream _
)
[C#]
public WaveReadWriter(
Stream input
);

Parameters

input

See Also

WaveReadWriter Class | Alvas.Audio Namespace | WaveReadWriter Constructor Overload List


WaveReadWriter Methods

The methods of the WaveReadWriter class are listed below. For a complete list of WaveReadWriter class members, see the WaveReadWriter Members topic.

Public Instance Methods

Close | Closes the current reader, writer and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDurationInMS (inherited from WaveReader) | Gets audio stream duration in milliseconds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLengthInBytes (inherited from WaveReader) | Gets audio stream length in bytes.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeMP3 (inherited from WaveReader) | Changes Wave stream to MP3 stream if Wave stream contains MPEG Layer 3 data.
Milliseconds2Bytes (inherited from AudioReader) | Converts from milliseconds to bytes for current stream.
PeekChar (inherited from BinaryReader) | Returns the next available character and does not advance the byte or character position.
Read (inherited from BinaryReader) | Overloaded. Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadBoolean (inherited from BinaryReader) | Reads a Boolean value from the current stream and advances the current position of the stream by one byte.
ReadByte (inherited from BinaryReader) | Reads the next byte from the current stream and advances the current position of the stream by one byte.
ReadBytes (inherited from BinaryReader) | Reads count bytes from the current stream into a byte array and advances the current position by count bytes.
ReadChar (inherited from BinaryReader) | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream.
ReadChars (inherited from BinaryReader) | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream.
ReadData (inherited from WaveReader) | Overloaded. Reads all audio data from the stream.
ReadDataInBytes (inherited from WaveReader) | Overloaded. Reads audio data from the stream.
ReadDecimal (inherited from BinaryReader) | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes.
ReadDouble (inherited from BinaryReader) | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes.
ReadFormat (inherited from WaveReader) | Reads an audio format.
ReadInfoTag (inherited from WaveReader) | Reads INFO metadata(similar mp3 tags) from Wave stream.
ReadInt16 (inherited from BinaryReader) | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes.
ReadInt32 (inherited from BinaryReader) | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes.
ReadInt64 (inherited from BinaryReader) | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes.
ReadSByte (inherited from BinaryReader) | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle (inherited from BinaryReader) | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes.
ReadString (inherited from BinaryReader) | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time.
ReadUInt16 (inherited from BinaryReader) | Reads a 2-byte unsigned integer from the current stream using little endian encoding and advances the position of the stream by two bytes.
ReadUInt32 (inherited from BinaryReader) | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 (inherited from BinaryReader) | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteData | Overloaded. Writes an audio byte array to the underlying stream.
WriteInfoTag | Writes INFO metadata(similar mp3 tags) into Wave stream.

See Also

WaveReadWriter Class | Alvas.Audio Namespace


WaveReadWriter.Close Method

Closes the current reader, writer and the underlying stream.

[Visual Basic]
Overrides Public Sub Close() _
Implements IAudioReader.Close
[C#]
public override void Close();

Implements

IAudioReader.Close

See Also

WaveReadWriter Class | Alvas.Audio Namespace


WriteData Method

Alvas.Audio Class Library

WaveReadWriter.WriteData Method

Writes an audio byte array to the underlying stream.

Overload List

Writes an audio byte array to the underlying stream.

public void WriteData(Byte[]);

Writes an audio byte array to the underlying stream from specified position.

public long WriteData(Byte[],Int64);

Writes an audio byte array to the underlying stream from specified position in specified mode.

public long WriteData(Byte[],Int64,WriteMode);

See Also

WaveReadWriter Class | Alvas.Audio Namespace


WaveReadWriter.WriteData Method (Byte[])

Writes an audio byte array to the underlying stream.

[Visual Basic]
NotOverridable Overloads Public Sub WriteData( _
ByVal buffer As Byte() _
) _
Implements IAudioWriter.WriteData
[C#]
public void WriteData(
Byte[] buffer
);

Parameters

buffer
A byte array containing the data to write.

Implements

IAudioWriter.WriteData

See Also

WaveReadWriter Class | Alvas.Audio Namespace | WaveReadWriter.WriteData Overload List


WaveReadWriter.WriteData Method (Byte[], Int64)

Writes an audio byte array to the underlying stream from specified position.

[Visual Basic]
NotOverridable Overloads Public Function WriteData( _
ByVal buffer As Byte(), _
ByVal position As Long _
) As Long _
Implements IAudioWriter.WriteData
[C#]
public long WriteData(
Byte[] buffer,
Int64 position
);

Parameters

buffer
A byte array containing the data to write.
position
Data position in bytes

Return Value

Returns new data position in bytes

Implements

IAudioWriter.WriteData

See Also

WaveReadWriter Class | Alvas.Audio Namespace | WaveReadWriter.WriteData Overload List


WaveReadWriter.WriteData Method (Byte[], Int64, WriteMode)

Writes an audio byte array to the underlying stream from specified position in specified mode.

[Visual Basic]
NotOverridable Overloads Public Function WriteData( _
ByVal buffer As Byte(), _
ByVal position As Long, _
ByVal mode As WriteMode _
) As Long _
Implements IAudioWriter.WriteData
[C#]
public long WriteData(
Byte[] buffer,
Int64 position,
WriteMode mode
);

Parameters

buffer
A byte array containing the data to write.
position
Data position in bytes
mode
mode

Return Value

Returns new data position in bytes

Implements

IAudioWriter.WriteData

See Also

WaveReadWriter Class | Alvas.Audio Namespace | WaveReadWriter.WriteData Overload List


WaveReadWriter.WriteInfoTag Method

Writes INFO metadata(similar mp3 tags) into Wave stream.

[Visual Basic]
Public Sub WriteInfoTag( _
ByVal tag As String} _
)
[C#]
public void WriteInfoTag(
Dictionary<TKey,TValue> tag
);

Parameters

tag

Example

This example shows simple using of WriteInfoTag method.

 //removes INFO tags from audio stream
WaveReadWriter wrw1 = new WaveReadWriter(File.Open("in1.wav", FileMode.Open, FileAccess.ReadWrite));
wrw1.WriteInfoTag(null);
wrw1.Close();

 //writes INFO tags into audio stream
WaveReadWriter wrw2 = new WaveReadWriter(File.Open("in2.wav", FileMode.Open, FileAccess.ReadWrite));
var tag = new Dictionary<WaveInfo, string>();
tag[WaveInfo.Comments] = "Comments...";
wrw2.WriteInfoTag(tag);
wrw2.Close();

See Also

WaveReadWriter Class | Alvas.Audio Namespace


WavesReverbAudioEffect Class

The Waves reverberation effect is intended for use with music.

For a list of all members of this type, see WavesReverbAudioEffect Members.

System.Object
AudioEffect
WavesReverbAudioEffect

[Visual Basic]
Public Class WavesReverbAudioEffect
Inherits
[C#]
public class WavesReverbAudioEffect : AudioEffect

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

WavesReverbAudioEffect Members | Alvas.Audio Namespace


WavesReverbAudioEffect Members

WavesReverbAudioEffect overview

Public Instance Properties

HasProcessInPlace (inherited from AudioEffect) Checks can whether process in place

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessInPlace (inherited from AudioEffect) | Process in place audio data and put the resulting audio data into data array
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WavesReverbAudioEffect Class | Alvas.Audio Namespace


WaveWriter Class

Writes WAVE (waveform audio format) data to the stream.

For a list of all members of this type, see WaveWriter Members.

System.Object
BinaryWriter
AudioWriter
WaveWriter

[Visual Basic]
Public Class WaveWriter
Inherits
[C#]
public class WaveWriter : AudioWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example shows how simple use WaveWriter.

string fileName = "123.wav";
RecorderEx recEx = new RecorderEx();
Stream stream = new FileStream(fileName, FileMode.Create);
WaveWriter wr = new WaveWriter(stream, recEx.FormatBytes());

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

WaveWriter Members | Alvas.Audio Namespace


WaveWriter Members

WaveWriter overview

Public Instance Constructors

WaveWriter Constructor Initializes a new instance of the WaveWriter class based on the supplied stream and a specific audio format header.

Public Instance Properties

BaseStream (inherited from BinaryWriter) Gets the underlying stream of the BinaryWriter.

Public Instance Methods

Close (inherited from BinaryWriter) | Closes the current BinaryWriter and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from BinaryWriter) | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.
GetFormat | Returns pointer to audio format.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Seek (inherited from BinaryWriter) | Sets the position within the current stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from BinaryWriter) | Overloaded. Writes a one-byte Boolean value to the current stream, with 0 representing false and 1 representing true.
WriteData | Overloaded. Writes an audio byte array to the underlying stream.

See Also

WaveWriter Class | Alvas.Audio Namespace


WaveWriter Constructor

Initializes a new instance of the WaveWriter class based on the supplied stream and a specific audio format header.

[Visual Basic]
Overloads Public Sub New( _
ByVal output As Stream, _
ByVal formatHeader As Byte() _
)
[C#]
public WaveWriter(
Stream output,
Byte[] formatHeader
);

Parameters

output
The supplied stream.
formatHeader
The audio format header.

See Also

WaveWriter Class | Alvas.Audio Namespace


WaveWriter Methods

The methods of the WaveWriter class are listed below. For a complete list of WaveWriter class members, see the WaveWriter Members topic.

Public Instance Methods

Close (inherited from BinaryWriter) | Closes the current BinaryWriter and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from BinaryWriter) | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.
GetFormat | Returns pointer to audio format.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Seek (inherited from BinaryWriter) | Sets the position within the current stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from BinaryWriter) | Overloaded. Writes a one-byte Boolean value to the current stream, with 0 representing false and 1 representing true.
WriteData | Overloaded. Writes an audio byte array to the underlying stream.

See Also

WaveWriter Class | Alvas.Audio Namespace


WaveWriter.GetFormat Method

Returns pointer to audio format.

[Visual Basic]
Public Function GetFormat() As IntPtr
[C#]
public IntPtr GetFormat();

Return Value

See Also

WaveWriter Class | Alvas.Audio Namespace


WriteData Method

Alvas.Audio Class Library

WaveWriter.WriteData Method

Writes an audio byte array to the underlying stream.

Overload List

Writes an audio byte array to the underlying stream.

public override void WriteData(Byte[]);

Writes an audio byte array to the underlying stream from specified position.

public override long WriteData(Byte[],Int64);

Writes an audio byte array to the underlying stream from specified position in specified mode.

public override long WriteData(Byte[],Int64,WriteMode);

See Also

WaveWriter Class | Alvas.Audio Namespace


WaveWriter.WriteData Method (Byte[])

Writes an audio byte array to the underlying stream.

[Visual Basic]
Overrides Overloads Public Sub WriteData( _
ByVal buffer As Byte() _
) _
Implements IAudioWriter.WriteData
[C#]
public override void WriteData(
Byte[] buffer
);

Parameters

buffer
A byte array containing the data to write.

Implements

IAudioWriter.WriteData

See Also

WaveWriter Class | Alvas.Audio Namespace | WaveWriter.WriteData Overload List


WaveWriter.WriteData Method (Byte[], Int64)

Writes an audio byte array to the underlying stream from specified position.

[Visual Basic]
Overrides Overloads Public Function WriteData( _
ByVal buffer As Byte(), _
ByVal position As Long _
) As Long _
Implements IAudioWriter.WriteData
[C#]
public override long WriteData(
Byte[] buffer,
Int64 position
);

Parameters

buffer
A byte array containing the data to write.
position
Data position in bytes

Return Value

Returns new data position in bytes

Implements

IAudioWriter.WriteData

See Also

WaveWriter Class | Alvas.Audio Namespace | WaveWriter.WriteData Overload List


WaveWriter.WriteData Method (Byte[], Int64, WriteMode)

Writes an audio byte array to the underlying stream from specified position in specified mode.

[Visual Basic]
Overrides Overloads Public Function WriteData( _
ByVal buffer As Byte(), _
ByVal position As Long, _
ByVal mode As WriteMode _
) As Long _
Implements IAudioWriter.WriteData
[C#]
public override long WriteData(
Byte[] buffer,
Int64 position,
WriteMode mode
);

Parameters

buffer
A byte array containing the data to write.
position
Data position in bytes
mode
mode

Return Value

Returns new data position in bytes

Implements

IAudioWriter.WriteData

See Also

WaveWriter Class | Alvas.Audio Namespace | WaveWriter.WriteData Overload List


WriteMode Enumeration

Write mode

[Visual Basic]
Public Enum WriteMode
[C#]
public enum WriteMode

Members

Member Name | Description
Overwrite | Overwrite mode
Insert | Insert mode

Requirements

Namespace: Alvas.Audio

Assembly: Alvas.Audio (in Alvas.Audio.dll)

See Also

Alvas.Audio Namespace


AudioEffect Hierarchy

System.Object
AudioEffect
ChorusAudioEffect
CompressorAudioEffect
DistortionAudioEffect
EchoAudioEffect
FlangerAudioEffect
GargleAudioEffect
I3DL2ReverbAudioEffect
ParamEqAudioEffect
WavesReverbAudioEffect

See Also

AudioEffect Class | AudioEffect Members | Alvas.Audio Namespace


AudioException Hierarchy

System.Object
Exception
AudioException
AviReaderException
DsReaderException
MixerException
Mp3ReaderException
WaveInException
WaveOutException
WaveReaderException

See Also

AudioException Class | AudioException Members | Alvas.Audio Namespace


Alvas.AudioHierarchy

Alvas.Audio Class Library

Alvas.Audio Hierarchy

System.Object
Alvas.Audio.AcmConverter
Alvas.Audio.AudioEffect
Alvas.Audio.ChorusAudioEffect
Alvas.Audio.CompressorAudioEffect
Alvas.Audio.DistortionAudioEffect
Alvas.Audio.EchoAudioEffect
Alvas.Audio.FlangerAudioEffect
Alvas.Audio.GargleAudioEffect
Alvas.Audio.I3DL2ReverbAudioEffect
Alvas.Audio.ParamEqAudioEffect
Alvas.Audio.WavesReverbAudioEffect
Alvas.Audio.DsReader ---- Alvas.Audio.IAudioReader, System.IDisposable
Alvas.Audio.FormatChooseResult
Alvas.Audio.HResult
Alvas.Audio.IAudioReader
Alvas.Audio.IAudioReadWriter ---- Alvas.Audio.IAudioReader, Alvas.Audio.IAudioWriter
Alvas.Audio.IAudioWriter
Alvas.Audio.ID3v1
Alvas.Audio.MediaBuffer ---- System.IDisposable
Alvas.Audio.MixerControl
Alvas.Audio.MixerBoolControl
Alvas.Audio.MixerMuteControl
Alvas.Audio.MixerIntControl
Alvas.Audio.MixerListControl
Alvas.Audio.MixerLine
Alvas.Audio.DestinationLine
Alvas.Audio.RecordPlayer ---- System.ComponentModel.INotifyPropertyChanged
Alvas.Audio.Vox
Alvas.Audio.WaveFormat
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Alvas.Audio.Mixer.ControlChangeEventHandler
Alvas.Audio.PlayerEx.DoneEventHandler
Alvas.Audio.RecorderEx.DataEventHandler
System.EventArgs
Alvas.Audio.ControlChangeEventArgs
Alvas.Audio.DataEventArgs
Alvas.Audio.DoneEventArgs
System.Exception ---- System.Runtime.Serialization.ISerializable
Alvas.Audio.AudioException
Alvas.Audio.AviReaderException
Alvas.Audio.DsReaderException
Alvas.Audio.MixerException
Alvas.Audio.Mp3ReaderException
Alvas.Audio.WaveInException
Alvas.Audio.WaveOutException
Alvas.Audio.WaveReaderException
System.IO.BinaryReader ---- System.IDisposable
Alvas.Audio.AudioReader ---- Alvas.Audio.IAudioReader
Alvas.Audio.AuReader
Alvas.Audio.AviReader
Alvas.Audio.Mp3Reader
Alvas.Audio.Mp3ReadWriter ---- Alvas.Audio.IAudioReadWriter, Alvas.Audio.IAudioWriter
Alvas.Audio.RawReader
Alvas.Audio.RawReadWriter ---- Alvas.Audio.IAudioReadWriter, Alvas.Audio.IAudioWriter
Alvas.Audio.WaveReader
Alvas.Audio.WaveReadWriter ---- Alvas.Audio.IAudioReadWriter, Alvas.Audio.IAudioWriter
System.IO.BinaryWriter ---- System.IDisposable
Alvas.Audio.AudioWriter ---- Alvas.Audio.IAudioWriter
Alvas.Audio.Mp3Writer
Alvas.Audio.RawWriter
Alvas.Audio.WaveWriter
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
Alvas.Audio.AudioCompressionManager
Alvas.Audio.Mixer
Alvas.Audio.Player
Alvas.Audio.PlayerEx
Alvas.Audio.Recorder
Alvas.Audio.RecorderEx
System.Windows.Forms.Control ---- System.ComponentModel.ISynchronizeInvoke, System.Windows.Forms.IBindableComponent, System.Windows.Forms.IDropTarget, System.Windows.Forms.IWin32Window
Alvas.Audio.SoundLevelMeter
Alvas.Audio.WaveformVisualizer
System.ValueType
Alvas.Audio.DriverDetails ---- System.IComparable
Alvas.Audio.FormatDetails ---- System.IComparable
Alvas.Audio.FormatTagDetails ---- System.IComparable
Alvas.Audio.Vox.AdpcmStatus
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Alvas.Audio.DeviceState
Alvas.Audio.Genre
Alvas.Audio.Recorder.BitsPerSample
Alvas.Audio.Recorder.Channel
Alvas.Audio.Recorder.SamplesPerSec
Alvas.Audio.TimeFormat
Alvas.Audio.WaveInfo
Alvas.Audio.WriteMode

See Also

Alvas.Audio Namespace